Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a Lenovo IdeaPad laptop which is running Windows 7. I can connect to the Internet if I use Ethernet - however, I cannot seem to turn on the wireless.

The little notification on the bottom right says "No connections are available". When I press the function key + (key that has wireless symbol) then Lenovo Wireless Device Settings comes up and says:

First switch on wireless

I can't see any wireless button, so how can I switch on wireless as required?

share|improve this question
    
Molly has a pic of the s10 and my answer has an s12. Let us know which one you have. –  Troggy Jan 24 '10 at 3:00

6 Answers 6

Just press Fn + F5.

share|improve this answer

Which model is it?

I found this review about the IdeaPad S12, but not sure if it is the one you have. It is that switch right in the middle, next to the vent?

Here is the review: http://www.crunchgear.com/2009/08/06/review-lenovo-ideapad-s12-netbook-with-via-nano-cpu/

int

share|improve this answer

It looks like there is blue text under the function (F1-F12) Keys. Try pressing the Function Key + The wireless and see if that does the trick ;)

I have a dell by the way .. but it seems like a logical answer.

share|improve this answer

I had a similar problem with my Acer Extensa 5620 after installing Windows 7. I would press the button to turn on wi-fi but nothing happened.

The fix was to download the wi-fi driver from Acer's website. This was the last thing I thought of doing as the device showed up OK in the device manager.

Perhaps Lenovo has an updated driver on their site.

share|improve this answer

Which model?

Lenovo IdeaPad S12: The left side hosts a Wi-Fi switch

The Lenovo IdeaPad S10 got a green button above the keyboard.

alt text

share|improve this answer

My Lenovo Ideapad U510 had similar problem. Pressed FN+F5 together and the radio came ON and now it is working fine. Wish Lenovo had used a wireless symbol on the F5 key instead of some "updown" arrow symbol that is not easy to associate with wireless connection.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.