Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of things you need to do to get Rmagick installed

apt-get install libmagick9-dev

When I try that I get the following errors

Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libmagick9-dev: Depends: libjpeg62-dev but it is not going to be installed
                  Depends: libbz2-dev but it is not going to be installed
                  Depends: libtiff4-dev but it is not going to be installed
                  Depends: libwmf-dev (>= 0.2.7-1) but it is not going to be installed
                  Depends: libz-dev
                  Depends: libpng12-dev but it is not going to be installed
                  Depends: libfreetype6-dev but it is not going to be installed
                  Depends: libexif-dev but it is not going to be installed
                  Depends: libdjvulibre-dev but it is not going to be installed
                  Depends: librsvg2-dev but it is not going to be installed
                  Depends: libgraphviz-dev but it is not going to be installed
E: Broken packages

I don't know what to do to fix this?

EDIT 1: I tried

sudo apt-get install librmagick-ruby

and it worked fine but then I needed to install the fleximage gem

gem1.8 install fleximage

and I got the following error message

Building native extensions.  This could take a while...
ERROR:  Error installing fleximage:
        ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for cc... yes
checking for Magick-config... no
Can't install RMagick 2.12.2. Can't find Magick-config in /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/var/lib/gems/1.8/bin

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/bin/ruby1.8


Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/rmagick-2.12.2 for inspection.
Results logged to /usr/lib/ruby/gems/1.8/gems/rmagick-2.12.2/ext/RMagick/gem_make.out
share|improve this question
    
It would be easier to answer if you listed the Debian version you're using. –  CarlF Feb 28 '10 at 4:53
add comment

2 Answers

Just do sudo apt-get install librmagick-ruby. It is an already compiled version of RMagick.

share|improve this answer
add comment

Try sudo apt-get install ruby1.9.1-full ruby1.9.1-dev rubygems1.9.1 or sudo apt-get install rubygems build-essential

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.