Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install ImageMagick to my Ubuntu box. I've run the following command:

sudo aptitude install imagemagick

Now whenever I try to run 'display' from the command line, I get an error saying

display: delegate library support not built-in `' (X11) @ display.c/DisplayImageCommand/1888.

I can certainly include more details if asked, but at the moment I'm not sure what else to include.

I'm running Ubuntu 9.10.

share|improve this question

It appears that your installation of ImageMagick does not support this operation. Unfortunately, this capability was not enabled at the time ImageMagick was compiled. If this is a package supplied with the operating system (which is most likely the case), you will need to file a bug report or otherwise let the Ubuntu community know about this problem, so that the package maintainer can fix this problem.

Alternatively, you can build from source; at the configure stage, type the following command:

./configure --with-modules

The --with-modules argument is what enables this feature in ImageMagick. See this ImageMagick forum entry.

share|improve this answer

According to this imagemagick forum topic, the 'delegate support not built in' message means that on compile time some external library was disabled because of unsatisfied dependencies, and to make it work you need to install other version of package, either compiled from source or taken from other Ubuntu version.

I ran the display command on my XUbuntu 9.10, and it worked fine, so this command is probably fixed in later versions of Ubuntu. Can you post yours?

share|improve this answer
I understand that it can't find a package, but which package? Is it X11? Because I'm pretty sure I have X11 installed correctly. Although I've been wrong before. – LJM Jan 24 '10 at 15:48
No! It does not attempts find packages in runtime: it says that there were no built-in support: it is broken by package maintainer, not you. – whitequark Jan 24 '10 at 16:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .