0
votes
1answer
323 views

Upgrading Mac OS X 10.5.8 Corrupted Lightroom 2.7

I use Photoshop CS4 and Lightroom 2. I recntly upgraded to 10.5.8 and began to have issues with LR. So, I reinstalled and downgraded my OS. I'm now running 10.5.2 on my MacBook 2.4G Core Duo with ...