0
votes
1answer
158 views

How to roll-back AHCI driver from iaStorA.sys --> msahci.sys Win7

I'm trying to have my HD run in AHCI mode with Intel RST drivers (not just mshahci.sys) after installing windows 7 in IDE mode. Specs: Windows 7 x64 SP1, Asus Maximus III Gene, ASUS AMI bios Rev. ...
0
votes
1answer
44 views

Running OS image from Dell Laptop (set to RAID mode) in VirtualBox [duplicate]

I have two SSD images from two different modern Dell laptops that use the new BIOS that allows you to set your boot mode to "legacy" and then set your SATA mode to AHCI or "Raid mode" (Intel Rapid ...
0
votes
4answers
328 views

Check if my SSD in runing on AHCI mode inside Windows 7

How can I check to see if my SSD is running in AHCI mode? Do I need to install some special driver for that? Looking for some AHCI indication: I'm using Windows 7.
0
votes
1answer
47 views

Is there a chance to lose data if I switch RAID to AHCI

I have Windows 7. The boot drive is NON-raid SSD. I also have 2xHDD RAID1 (just data). RAID is Intel Matrix (or whatever the latest name for it). I installed Windows in RAID mode What might happen ...
0
votes
1answer
60 views

Windows 7 Installation asks for AHCI drivers when installed a HDD into the DVD Bay

I'm facing a problem I never faced before: I replaced the DVD Optical Drive of my laptop with a HDD. The HDD is correctly seen into the BIOS but when I'm trying to install Windows 7 the Installation ...
0
votes
2answers
91 views

One excessive icon (Safely Remove Hardware and Eject Media ) after changing the BIOS to AHCI

I installed the x64 version of Win 7. After that I modified the "regedit" and then changed the SATA selection mode to AHCI (which was in IDE mode before) in BIOS. But; 1- One excessive icon has been ...
0
votes
0answers
218 views

How to enable/switch to AHCI in Windows 7 64 bit on Boot Camp 3 MacBook White 2010

After some research and ploughing through the internet, I know that one can enable/switch to AHCI on a PC using registry involving BIOS (please correct me if I'm wrong). The instructions can be found ...
0
votes
1answer
252 views

Windows start up failing to pass ahci driver init

I have build a custom pc and used for a few months now without problems. One day however, i got home and the he was shut down because of some error. Started windows normally and I got two error ...
1
vote
1answer
348 views

Stop Windows asking me to eject ATA device [duplicate]

Recently reinstalled windows and have AHCI enabled (perhaps it has something to do with AHCI mode). Basically, I have the option now to eject my hard drives in the "Safely remove hardware and eject ...
1
vote
1answer
2k views

Samsung Magician doesn't detect SSD when set to AHCI mode

I just installed a Samsung 840 Pro SSD in my box, NOT as the system drive, but just as a regular HD. I have a Gigabyte board[*] with 6 SATA ports in an Intel controller and 2 additional ones in a ...
6
votes
1answer
777 views

How to get AHCI support on an IDE Windows 7 installation? [duplicate]

I installed Windows 7 onto a SSD with the motherboard in IDE mode. Now when I try to change the motherboard to AHCI mode, Windows 7 will not successfully boot (blue screens mid-boot). How can I add ...
0
votes
1answer
337 views

Change SATA mode to AHCI and Windows Fails to boot [duplicate]

I installed Windows 7 sp1 x64 in IDE mode but I had to change the SATA mode to AHCI; and now Windows 7 failes to boot; Any idea how to make windows boot again? (without reinstalling Windows)
3
votes
1answer
972 views

Enabling AHCI in BIOS for SSD

I am trying to help a friend with a desktop upgrade. It is an old machine with an Intel DG31 main board. The board has 1 IDE port to which a DVD-ROM drive is connected, and 2 SATA ports. 1 SATA port ...
0
votes
0answers
261 views

Windows 7 AHCI mode

I have installed Windows 7 on drive which was in IDE mode. When I have changed mode to AHCI OS didn't start (I know. AHCI drivers are needed.). Unfortunately when I back to IDE mode, OS still won't ...
0
votes
1answer
926 views

Does the ASUS P5G1T-M LX2/GB motherboard support AHCI mode for SSDs?

I got an OCZ Vertex 4 SSD the other week and I've managed to install it and it's working, but I think it's still running in SATA mode instead of AHCI mode (which if I understand correctly is more ...
4
votes
1answer
4k views

Changing from RAID to AHCI and Windows 7 will not boot

I had a RAID0 array that for all intents and purposes went to hell. I put a new SSD (same on-board Intel controller) and installed a new copy of Windows on it and all the drivers (Intel Rapid Storage, ...
0
votes
1answer
604 views

Getting an IDE mode installation of 7 to run in AHCI mode? [duplicate]

I installed windows 7 a few months ago while my SATAs in my bios were configured as IDE. When I change it to AHCI for an added speed boost, I get a BSOD on startup. Is there a way or tool I can use to ...
1
vote
2answers
8k views

Enabling AHCI for SSD under Win7 BootCamp on Macbook Pro 2011

I've just installed a new Samsung 830 256GB SSD and have configured BootCamp with Lion and Windows 7. Under Lion, I have installed Trim Enabler. Under Windows 7 I have installed the Samsung (Wizard) ...
3
votes
3answers
8k views

Using an SSD with no AHCI [ICH7 base] - Windows 7 hangs frequently

I have a Shuttle Intel G31 + ICH7 (base -- not M/R etc) system. I just bought an OCZ Vertex 3 120gb [VTX3-25SAT3-120G] which includes the Sandforce 2218 firmware. The ICH7 does not support AHCI. I ...
2
votes
2answers
1k views

Windows 7 will start in SATA RAID mode but not in AHCI

I have installed Windows 7 on my PC (Gigabyte ga-p55-ud5) with the SATA controller set on RAID mode. After that, I've decided to try to install Mac OS X and to do so I had to set my SATA controller to ...
3
votes
1answer
1k views

AHCI, Windows 7 and can only boot with Windows DVD present

Foolishly, I installed Windows 7 with my new SSD set to IDE. I would like to change it to AHCI. I have done this before, with a different motherboard. What happens: I set the controller to AHCI in ...
0
votes
1answer
279 views

Custom Built Computer - Windows 7 and Ubuntu 11.10 Install Fails

I just built a computer with the following: Gigabyte Z68A Motherboard Corsair Force GT 180GB SSD GeForce GT430 Graphics card Corsair TX750 Watt Power supply Intel i5 CPU My problem when trying to ...
3
votes
1answer
878 views

Crackling/Popping audio, high DPC Latency from Intel Rapid Storage Technology -drivers

I'm sorry if this landed on the wrong stack, I'm not entirely sure if this or serverfault would be more suitable. I have a very strange problem, when I install any iRST driver newest or older ones my ...
0
votes
0answers
923 views

Troubleshooting an AHCI eSATA problem in Windows 7

I used to use the front panel eSATA port on my PC case. I remember having to change a setting in the registry to prevent my Boot drive from showing up in the safely remove hardware list (not sure how ...
0
votes
1answer
2k views

Is it possible to turn off hot swap feature for HDD drives when using AHCI?

I have 3 SATA drives - 1 SSD and 2 common HDDs. After changing HDD controller mode to AHCI and installing Windows 7, I still have choice to safely remove HW devices - disks. Every time I'm going to ...
7
votes
3answers
15k views

Can I change from BIOS IDE mode to AHCI mode at any time? [duplicate]

Currently my Windows 7 computer is crashing during startup, after loading the AMD achix64s.sys driver, if I enable BIOS AHCI mode for the disks. It boots fine with IDE mode. Since I need my computer ...
5
votes
2answers
4k views

BIOS setting: AHCI or RAID (when using SSD + 2x hard drive in RAID-0)

I want to add a new SSD and use it as system drive with Windows 7 x64 installed. As driver I chose newest Intel Rapid Storage driver (not MSAHCI). I know that I have to use AHCI as BIOS setting for ...
4
votes
4answers
11k views

RAID vs AHCI on Windows7 x64 ASUS

I have an ASUS p5ke-wifi/ap which has built-in RAID controller. From the BIOS, I can choose between 3 controller types: IDE RAID AHCI In that order. This setting was set to AHCI when I installed ...
0
votes
1answer
1k views

Repair bad AHCI Driver Install

In a moment of madness I installed Intel RST drivers on my system and now Windows 7 (x64) no longer starts up. Safe modes work, changing my driver controller to IDE in BIOS doesn't help. Is there ...
1
vote
1answer
6k views

Dell Latitude E6410 BSOD Switch to AHCI

Just received a brand new laptop. Wiped the installed Win 7 64 bit and put on a fresh copy on a new SSD. After the fact I realized I should have AHCI mode for performance. So I followed this guide ...
2
votes
3answers
2k views

Windows 7 New SSD SATA AHCI?

I recently got a new laptop (Dell Latitude E6410) which came with a regular hard drive. I removed the hard drive and installed Windows 7 64 bit fresh. I've been doing some reading about possibly ...
0
votes
1answer
3k views

After replacing mobo, Windows 7 doesn't boot, and I don't want to format

I just found my ASUS Crosshair II Formula was broken. I have requested an RMA and I'll have to wait more than one month and a half to get a replacement. Meanwhile, I found that my old ASUS Crosshair ...
4
votes
5answers
3k views

Stuck at “Starting windows..” when switching to AHCI mode

I had a Windows 7 system working fine in AHCI mode and decided to change the motherboard to another brand. I created an image of the boot drive. I changed the motherboard which runs in IDE mode by ...
1
vote
1answer
5k views

How to know which AHCI driver Windows 7 is using?

I have AHCI enabled in Windows 7 through HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci. My Asus motherboard comes with a drivers software including AHCI drivers. I used their setup ...
13
votes
1answer
2k views

How can I enable AHCI on a SATA drive after installing Windows?

Can I enable AHCI after installing Windows 7 in a SATA drive that was on IDE mode?
6
votes
4answers
19k views

How can I enable AHCI mode after Windows Vista install in IDE mode and before/for Windows 7 clean install? [duplicate]

I just purchased a 2TB Fantom USB2/eSATA external hard drive. Unfortunately it revealed my oversight when my first custom system was built last Summer. I installed Vista Home Premium 64bit in IDE ...