Advanced Linux Sound Architecture (ALSA) provides audio and MIDI functionality to the Linux operating system.

learn more… | top users | synonyms

4
votes
1answer
123 views

5.1 Surround sound will not keep its configuration

in pavucontrol I have my output set to Digital Surround 5.1(IEC958/AC3) When I open a video with VLC (my preferred option) OR GNOME Media player I hear no sound. VLC is configured to use pulseaudio ...
3
votes
1answer
1k views

ALSA: Audio playback is clipped and has low volume

I'm hoping that someone can help me debug my audio problems. The problem is that audio playback is clipped and has low volume. The details of my setup are as follows: Arch Linux 3.1.3-1 An onboard ...
1
vote
1answer
23 views

Linux ALSA Driver using channel count 3

Am running my ALSA Driver on Ubuntu 14.04, 64bit, 3.16.0-30-generic Kernel. Hardware is proprietary hardware, hence cant give much details. Following is the existing driver implementation: Driver ...
1
vote
1answer
45 views

No sound on Arch Linux (ALSA)

Output of aplay -l aplay: device_list:268: no soundcards found... output of sudo aplay -l **** *List of PLAYBACK Hardware Devices* **** card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog ...
1
vote
1answer
58 views

Create custom PCM device in ALSA

How can I create custom PCM device with dmix-slave and use it in audacious without touching global PCM? Is it even possible? I tried miscellaneous configurations but no luck. ALSA asound.conf syntax ...
3
votes
0answers
176 views

Amplify alsa capture beyond 100%?

I'm using ALSA. The volume of my mic is so low that even 100% of capture volume is not enough in a skype conversation. Is there any way to amplify the capture volume beyond 100%? I cannot use ...
2
votes
0answers
712 views

No sound output or hardware to choose from in gnome sound settings

There is no sound output when I try to play music or videos etc. When I run $ speaker-test I get speaker-test 1.0.25 Playback device is default Stream parameters are 48000Hz, S16_LE, 1 ...
2
votes
0answers
579 views

Linux noob trying to get headset to work

I am trying to get my headset (Logitech H390) to work on a new linux installation (centos 6.4). Unfortunately I am unable to hear anything from the headset. I have tried several options from the sound ...
2
votes
0answers
347 views

How do I use wine's new multi-channel audio support?

Wine supposedly added Multi-channel support to the ALSA driver in a recent release. However, I haven't found any documentation about it or any reports of anyone successfully using it. I have 5.1 ...
2
votes
0answers
917 views

AC3 & DTS Output Produces Buzzing/Noise Using a52 ALSA Plugin in Pulseaudio

Note: I hope this is the right site to ask it on, as I'm using ubuntu 12.04 64bit but assumably this is a general linux/alsa configuration question. I've followed the guide at ...
2
votes
0answers
909 views

Scratchy sound with ALSA and USB Sound card

Since frying my onboard soundcard, I'm trying to get a new USB sound card to work with ALSA. Everything looks fine too: [oliland@olidesktop ~]$ lsmod | grep '^snd' snd_seq_dummy 1455 0 ...
2
votes
0answers
852 views

using Ubuntu 10.10 I want my speakers and head phones as separate devices

I would like it if I could set my rear speaker jack, not surround sound rear, to be used as the system default only. I want the head phones, that plug into the front of my PC, to be silent, unless I ...
1
vote
0answers
19 views

Can't set sample rate to 44100 Hz when using loopback in ALSA

I have set up ALSA like this to play to and record from loopback devices: # output device pcm.loopout { type dmix ipc_key 328211 slave { pcm "hw:Loopback,0,0" period_size 1024 ...
1
vote
0answers
203 views

tidal-hifi playback with alsa stops after every song

I am using tidal hifi for music streaming under linux (Mint 17, 64bit) with Chrome. To achieve bit perfect playback I turn off pulseaudio ($killall pulseaudio) to purely use alsa for audio processing ...
1
vote
0answers
240 views

Arch linux - sound disappeared after the installation of pulseaudio

I'm using Arch linux with the above onboard sound card : 00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01) Subsystem: Dell Device 0220 Flags: ...
1
vote
0answers
54 views

save alsamixer input source centos 6

I am not able to save the input source of my alsamixer. Every time I reboot the system the input source is set back to front mic. I want it to stay as rear mic. I tried alsactl store I disabled ...
1
vote
0answers
522 views

No sound in headphone jack

Worked fine a week ago. Yesterday when I plugged headphones into my Asus laptop, I got sound both from headphones and speakers. Today after system crash (not sure what was the reason) when I plug ...
1
vote
0answers
31 views

Default bluetooth device not allow to record from another device

I have already set the bluetooth device as default device for recording the audio. But I have add the another usb audio device for recording, the bluetooth device not allow the usb device to record ...
1
vote
0answers
59 views

Java Exclusive MIDI usage workaround?

I'm using a java applet, Jalmus to be specific, that implements MIDI usage. Whenever Jalmus is running, MIDI Input works (Midi Out doesn't but I don't need that) however, when attempting to connect ...
1
vote
0answers
113 views

What's the proper way to forward audio from i386 executables that use ALSA to an x64 pulse server?

I'm running Kubuntu Raring x64, and I had a program that I was unable to compile under my 64-bit environment but there was an already compiled version (32-bit) available for download (specifically ...
1
vote
0answers
276 views

Record line-in audio from two applications using Alsa

Im currently working on an small application which runs on a cubieboard (ARMv7, rasp-pi-like). What I really need to do is, accessing and recording the line-in audio-signal from two different ...
1
vote
0answers
61 views

ALSA - Codec Registration

My Codec is registered after SOC init is done. In SOC init, ALSA cannot find codec registered and hence defer the sound card registration. Later when I register codec, its entry is not registered in ...
1
vote
0answers
709 views

ALSA buffer xrun when recording with ffmpeg

Is there any way to increase the ALSA buffer size? When running this command: ffmpeg -f alsa -ac 2 -i hw:1 -ar 44100 -b 64k output.mp3 I get a "ALSA buffer xrun" before my system locks up Input ...
1
vote
0answers
423 views

alsaloop: What happens on a buffer underrun?

I am tuning my sound interface latency with alsaloop -C hw:1,0 -P hw:1,0 -t $LATENCY_US When I set $LATENCY_US to 30000, I get around 20% CPU usage. I can restart this a few times and make some ...
1
vote
0answers
27 views

ALSA sound cannot get below 18%

My in-ear earphones are very loud, and I want to get them to be quieter. alsamixer works until it gets to 18% or "-45 dB". Then when I want it get even quieter, it jumps all the way to zero. 5 or 6 ...
1
vote
0answers
310 views

Wine screws up Pulseaudio and USB audio card when already playing ALSA stream

My setup is a Thinkpad T420 with Creative X-Fi USB audio card. Everything usually works fine, I can play multiple streams and arbitrarily move streams from one audio card to another. One use case ...
1
vote
0answers
232 views

Strange sound behavior

First of all, sorry for the tittle. English isn't my native language, and I can't find a word to describe the strange behavior I'm getting here. In the most simple explanation, is like sound keeps ...
1
vote
0answers
587 views

no sound with an USB Microphone and pulseaudio

I connected my USB Microphone to my Computer, but i cant get it to work. Pulseaudio recognizes the device, and i can see and edit it with pavucontrol in the Input Devices section. I also can select ...
1
vote
0answers
2k views

Volume / gain too high with ALSA under Debian for an USB sound card

I encounter some issues configuring audio with ALSA on my Seagate Dockstar on which I plugged a little USB audio card. I'm able to play music with MOC but I'm stuck with a volume way to high. ...
1
vote
0answers
104 views

Headphones don't “isolate” speakers

I have bought some new 2.1 speakers but I have an issue. When I plug in the headphones the sound continues to play from the speakers (in a lower volume though). I re-ran alsaconf but I couldn't solve ...
1
vote
0answers
524 views

Alsa devices under Wine

I'm running OpenSuse 11.2 and Wine 1.1.28. Even if audio is perfectly working fine for me (Skype, Banshee, etc), when I try to configure audio for Wine (to use Spotify) I cannot hear anything from ...
0
votes
0answers
27 views

ALSA PulseAudio sound output when switching between headphones and laptop speaker

Since I installed PulseAudio on my Gentoo system I've been having no audio output from my laptop's speakers when un-plugging the headphones jack. I suppose the problem lies in how ALSA and PulseAudio ...
0
votes
0answers
141 views

Distorted/crackling sound coming from when ALSA's .asoundrc file uses hw type instead of plug type

I have XBMCbuntu installed on a HTPC running Ubuntu 14.04 and Kodi 14.1. I have been trying to install and run Steam so that I can stream games from my gaming PC. I followed the steps from this guide ...
0
votes
0answers
58 views

Set usb soundcard as default device

I'm trying to get my usb sound-card working. It's a Focusrite Scarlett 2i2. I've read through a number of tutorials non of which was doing anything but sometimes blocking the output of more than one ...
0
votes
0answers
216 views

Dolby Digital 5.1 on Linux Mint for ASTRO A40 Headset

I've been having an issue with setting up surround sound for my headset on Linux. Currently, I'm able to receive sound from my computer without Dolby Digital. I'll try to be as specific as possible: ...
0
votes
0answers
79 views

ALSA/Pulse: How to AVOID upmixing in 6-channel mode?

So, I have the following setup: Gigabyte B75M-D3V motherboard w/ Intel HD Audio (Realtek ALC887-VD chip) Linux 3.17.4 x86_64 Debian testing (jessie) Originally, I was using straight ALSA, because ...
0
votes
0answers
137 views

How to setup ALSA Linux audio to Virtual machine sound card?

I have Ubuntu 14.04 Desktop 64 bit installed on an HP Probook 4440s machine. On said machine I have installed VMware Workstation (version 10.0.3 build-1895310) as my default Virtual machine app. I ...
0
votes
0answers
24 views

How can you check the number of audio channels available in a USB DAC?

I'm writing a music application for Ubuntu that needs to know how many channels are available on the system. I have a USB DAC with 10 channels and another with 2. How can I read the number of channels ...
0
votes
0answers
35 views

How can I make my laptop mic only output the left audio track?

For some reason when my laptop (lenovo u510) records audio with both audio tracks enabled, it doesn't produce any sound. I've found that muting the right audio track solves this issue, but whenever I ...
0
votes
0answers
283 views

Pulseaudio shared library error in Ubuntu

In Ubuntu 12.04 I get the following, whenever I try to use pulseaudio (e.g. when typing pulseaudio --version) /usr/bin/pulseaudio: error while loading shared libraries: libpulsecommon-1.1.so: cannot ...
0
votes
0answers
38 views

ALSA upmixing/processing conditionally from different numbers of input channels

After a lot of research and experimentation, I was able to get ALSA to upmix stereo to 5.1 surround sound the way I want it. However, my problem is now that I can't properly play mono sources (the ...
0
votes
0answers
29 views

ALSA from output to input

I need to translate sound from my VLC player right into my microphone input. Maybe I should create some virtual device and.. I don't know what to do.. and my english is not good so it's a real problem ...
0
votes
0answers
1k views

Switch default HDMI device in Ubuntu

When I connect my pc to a TV using HDMI cable I don't get audio over HDMI. PulseAudio Volume Control detects the HDMI audi output as unolugged. aplay -l lists the following: **** List of PLAYBACK ...
0
votes
0answers
854 views

After updating archlinux, the maximum volume is far too low

I booted my Archlinux PC today and opened Mumble, and found that I couldn't hear anyone, so I opened some music and I couldn't hear that. After turning my volume to the maximum possible level in ...
0
votes
0answers
139 views

Using 5.1 surround to play back 3 independent stereo streams

I built a small home server recently. It runs Ubuntu Server 12.04 and has a sound card (Via VT1708) with 3 audio jacks - which I want to use as 3 independent stereo outputs to play back (potentially ...
0
votes
0answers
375 views

Gigabyte Brix TOSLINK/SPDIF with Archlinux

I tried setting up the combo analog/digital out on this little box with the help of this adapter, but I can't get it to output anything digital... aplay -l tells me that card 1 device 1 is "ALC269VC ...
0
votes
0answers
425 views

How can I use a virtual sound card without the hardware?

I'm trying to generate and stream audio+video via aconv to a remote location such as Youtube from a headless linux server, which will then be multicasted out to the internet at large. I have ...
0
votes
0answers
143 views

MPD fails to start the next song

I am running Arch Linux (e17) on x86_64; with mpd 0.17.3 and ALSA 10.0.26. One update ~three months ago mpd started acting strange. It would not start playing the next song, and it would appear as if ...
0
votes
0answers
1k views

Getting Logitech USB headset to work on Debian

I am attempting to get a Logitech USB headset to work on my Debian Squeeze computer. However, no matter what I do, there is no sound. I've already tried everything I could find on Google with no luck. ...
0
votes
0answers
738 views

Microphone not working in Ubuntu Natty

Problem: I can hear myself speak in the mic but Ubuntu is not recording/capturing the sound. Actions Taken: I followed all the steps listed here for the Alsa update script I've also tried changing ...