0
votes
0answers
5 views

Error while trying to create an album in MySQL in Trovebox

When trying to create a new album in TroveBox I just get an simple error message in the ui notifying me that it failed. No information is in logs from Apache and MySQL. The current user can write in ...
0
votes
2answers
31 views

Trovebox (OpenPhoto) setup hangs/fails at final step 3

I've been following the install instructions found here about how to install and configure Trovebox on a Ubuntu server running Apache: Ubuntu 14.04 LTS Apache: 2.4.7 MySQL: 5.5.37 PHP: 5.5.9 ...
0
votes
0answers
12 views

install ImageMagic library to php

When i try to sudo pecl install imagick i get this message: Can't find PHP headers in /usr/include/php The php-devel package is required for use of this command. ERROR: `phpize' failed And sudo ...
0
votes
2answers
32 views

phpMyAdmin cannot login - keeps asking for credentials

I have phpmyadmin on my Arch linux box, it is running, so is apache with php and mysql. When I go to http://localhost/phpmyadmin/, it shows the usual login prompt. However, no matter what I enter, ...
1
vote
0answers
42 views

Setting up rutorrent on 10.9 Mavericks

I'm getting the following error when loading rutorrent that's hosted on my 2010 Intel Core Duo 2 Mac Mini: [23.06.2014 11:31:20] Bad response from server: (404 [error,list]) <!DOCTYPE HTML PUBLIC ...
0
votes
0answers
27 views

Apache will not show index pages

I have just set up my brand new raspberry pi with Rasbian-Wheezy and a clean install of apache and php. I got the "it works" page, and then put my website in place and everything was working, but at ...
0
votes
4answers
67 views

Website not showing errors, just 500 page

I have moved some code from development to production and it was not working so I am trying to debug but for the life of me I cannot get access to the errors to find out what is wrong. I have tried ...
0
votes
2answers
25 views

Mounted HDD not having enough permissions from Apache/PHP

Piwigo gallery, on apache and php. The root system is a RAID 128GB. /var/www/html is on the root file system. Mounted the 320GB hdd to /var/www/html/320 using defaults, it's an ext4 fs. Put a ...
1
vote
0answers
49 views

Apache2 + Php + Pthreads HowTos

I'm running Ubuntu 14.04 LTS 64 bit. What I would really love to do is sudo apt-get install libapache2-mod-php5 but compile PHP with --enable-maintainer-zts so I could later install pthreads with pecl ...
0
votes
0answers
14 views

httperrors for Linux

I'm here because the Google has failed to get me what I need. I just recently graduated from university, and I'm working on a website. Back in college I used the school's web server for my projects, ...
0
votes
0answers
77 views

xampp MySQL app not running (win8)

I am using xampp for few month. But facing and error for 2 days and MySQL app isn't running. I reinstalled xampp and it was working fine, but when I restarted, it stopped working again. Here are error ...
1
vote
1answer
31 views

Setting up email for domain on a VPS

I have my site set up and functioning on a vps. The domain is on godaddy. The nameservers point at godaddy then i have set the a record to point at the IP of the VPS and its working fine. I now need ...
0
votes
2answers
22 views

Cache a single PHP file with parameters

So I build a PHP script that receive some data and provides it like an API. The data doesn't changes much, but the script runs every time it's requested. Is there a way to tell Apache to cache the ...
0
votes
0answers
21 views

vhost running on local machine only shows root directory correctly

I am using Ubuntu14.04 and I have created a virtual host on apache2. I have my Laravel project trying to run on virtual host in apache2. I set it on /etc/hosts 127.0.1.1 mw Then since I have PHP ...
0
votes
2answers
41 views

Apache2/PHP no longer logging errors after deleting error.log

I deleted error.log file from my logs directory. As root, I used vi to create error.log file again. root:root owns the file, permissions are -rw-r--r--. Same ownership and permissions as access.log. ...
0
votes
0answers
31 views

Run java in php apache2 in browser [duplicate]

I wrote a simple PHP file which calls a java application. It runs on cli without problems but I can't run it on browser. Output: "Java HotSpot(TM) 64-Bit Server VM warning: ...
0
votes
0answers
13 views

PHP issue when upgrading

I installed new PHP version with HomeBrew, but Apache2 does not run that version but the old one. Even though when I do php -v, it returns PHP 5.5.1, when I do in a PHP script <?php phpinfo(); ...
1
vote
1answer
38 views

why would running apache as a service produce different results when simply starting it from the command line

I have a .php script that produces different results when apache is launched as a service, as compared to when apache is simply started from the command line with httpd.exe. I have checked things ...
0
votes
0answers
63 views

Is mod_fastcgi-2.4.6 compatible with apache2.4.9 CentOS?

I need to install multiple php handlers in apache2.4.9 one php version as apache handler and other one I need to run as mod_fastcgi but while compiling and installing with apache 2.4.9 I'm getting a ...
0
votes
0answers
53 views

How to debug Http 406 ERROR?

We have a "web widget" written in VB or Delphi or something that sends a request (by calling a PHP script) to our webserver (apache) to update the database. It's been working for years until yesterday ...
0
votes
0answers
88 views

Raspberry Pi as server - stuck with users and groups

I just installed an apache2 server with php5 and mysql on my RPi (Raspbian Wheezy). I followed this tutorial: tutorial link Everything went well, even the file transfer via FTP (FileZilla). I ...
1
vote
2answers
981 views

Can't run localhost PHP server on OSX Mavericks

So i've done this before but I don't remember the command. I was able to use a directory a localhost file. I've tried sudo apachectl start but when I go to localhost the page isn't found. I've also ...
0
votes
0answers
22 views

Bizarre lag in HTTP connection

Running on a LAMP stack, CentOS 6, Apache 2.2.3, PHP 5.4.25, MySQL 5.5.31 Have a very complex web application. It's been running pretty smoothly for about 5 years, now. Of a sudden we've run into ...
1
vote
0answers
184 views

php PDO sqlsrv “could not find driver”

My configuration: - Windows Server 2012 - SQL Server 2012 - Apache 2.4.9 - PHP 5.5.10 My php.ini includes the line - extension=php_pdo_sqlsrv_55_ts.dll My "ext" folder includes the file - ...
0
votes
4answers
252 views

Internal server error on user_directory

Today I am trying to install httpd and mysql on my fedora 14 PC. That works fine. After this I try to create a public_html folder on the user directory and allow php to access that folder. For that I ...
1
vote
2answers
49 views

Executing PHP from crontab

I am utilizing crontab to execute a PHP file as follows: 0 4 * * * /opt/lampstack/php/bin/php /opt/lampstack/apache2/htdocs/tests/test.php I am pretty sure that the file itself is working properly ...
0
votes
3answers
43 views

Setting up a local webserver using CentOS on VM

im new here, and basically new at setting up a webserver... now im already googling, and searching here in stackexchange on how to setup a webserver, they tend to direct me to a working server.. i ...
0
votes
2answers
79 views

PHP / Extension API mismatch

I recently upgraded to Apache 2.4.7 (x86) and PHP 5.5.9 (x86 as Apache module) on Windows 7 x64. I downloaded the Apache binary from apachelounge.com and the PHP binary from windows.php.net. Now the ...
1
vote
0answers
26 views

Why Windows XP machine is not accessible from Ubuntu machine?

I am using Windows machine and using it as a sever which is properly accessible from my browser through url, but when I try to access windows directory from Ubuntu, I am not getting access to ...
1
vote
1answer
443 views

Owncloud WebDAV authentication possible via web interface but not desktop client

I just set up Owncloud on my shared webspace and got everything working except authentication from desktop clients. If I go to the WebDAV Url via my webbrowser it just presents me an empty form again, ...
0
votes
1answer
174 views

Run java in php apache2

I wrote a simple PHP file which calls a java application. It runs on cli without problems but I can't run it on browser. Output: "Java HotSpot(TM) 64-Bit Server VM warning: ...
0
votes
1answer
206 views

object not found in lampp ubuntu 13.10

am a newbie linux user.i have installed xampp 1.8.3-2(lampp)on ubuntu13.10 and configured it. i paste my wwwfolder to ubuntu 13.10 in/opt/lampp/htdocs. now the owner of www folder is root with ...
1
vote
1answer
30 views

Options to configure Apache to take into account other folders despite /var/www

I am using Ubuntu 12.10, and I know that if I place a php file (index.php) under /var/www, and I visit localhost:80/index.php, it will work fine. However, say that I have multiple projects in order ...
1
vote
2answers
770 views

OSX, Failed to listen on 0.0.0.0:80 (reason: Permission denied)

I'm on OSX Mavericks. I installed PHP 5.5 from http://php-osx.liip.ch/. When I go to localhost in a browser I get a page that says, "It Works!" which is not a page I created so I am not sure where it ...
0
votes
1answer
58 views

Secure Apache PHP installation: Using the right user:group

i want to "perfectly" protect my apache PHP installation on a linux server. In the history, i had problems with script-virues / exploids, so it needs to be a "secure" solution. My current solution: ...
0
votes
0answers
224 views

PHP 5.4.24 is upgraded, but the previous version 5.2.6 is still running in XAMPP 1.6.7

I'm using XAMPP 1.6.7 with PHP 5.2.6 on Windows 7. I'm trying to upgrade PHP 5.4.24 without upgrading XAMPP. I tried to upgrade XAMPP several times by taking a backup of the htdocs and data folder ...
0
votes
0answers
36 views

How to reset the Apache web server password on Mac?

When I try to start the Apache web server on our Mac it asks for a password. I forgot the password and I know that I was the one who put the password on it because I'm the only person in our family ...
0
votes
0answers
30 views

Enabling PHP on a SSL website in Virtualmin

I have PHPMyAdmin installed on my server (from apt-get, Ubuntu 13.10) and force it to run secure. But when I go to it it just server the PHP pages as plain text. The main/default website works fine in ...
0
votes
1answer
90 views

apache access.log requests from localhost to localhost

My server is spamming via postfix from www-data user. In apache access.log: 90.156.208.121 - - [20/Jan/2014:17:24:01 +0300] "GET /treningi.php HTTP/1.0" 200 21025 "-" "Mozilla/5.0 (Windows NT 5.1; ...
0
votes
0answers
176 views

set open_basedir on php.ini

some scanning tool program recommends to set my open_basedir on php.ini for one of my website inside /var/www/my_site im not running any virtualhost, so i access the website basically by typing the ...
0
votes
0answers
134 views

Apahce proxy throws error connecting to a third party

Connection to a certain thirdparty service via php curl throws this error: CURL error: Received HTTP code 403 from proxy after CONNECT The apahe error log on the proxy throws this: Connect to ...
0
votes
1answer
304 views

installing apache, php5 on windows 7 64 bit [production]

The easiest way to install apache, php, mysql and phpmyadmin on windows is to download and install XAMP. The problem is that it is meant for development purposes and is not recommended for production ...
1
vote
1answer
386 views

How to run Visual Studio 2008 and WAMP server on same local machine running WIndows7?

I'm having a machine running on Windows 7. First I installed WAMP server on my local machine. It was working fine. Then I installed Microsoft Visual Studio 2008. From that time the WAMP server is not ...
1
vote
2answers
136 views

Apache is allowing PHP files to download when routed through mod_rewrite

I'm setting up a new server, which seems to almost be working. I've done my homework, but I seem to be stuck. PHP works. When I try to access the following URLs, which serve the same page correctly ...
4
votes
2answers
1k views

Error starting Apache with PHP module on Windows: “Cannot load php5apache2_4.dll into server: Access is denied”

I'm having some difficulty installing Apache 2.4.7 with PHP 5.5.7 on Windows Vista Service Pack 2. When trying to start Apache, I'm getting the error: Syntax error on line 176 of C:/Program ...
0
votes
0answers
46 views

Debian PHP 500 error

When I try to execute a php script (let's say /var/www/test/hello.php), I get an error in /var/log/apache2/error.log saying: "/var/www/test" is writeable by others Changing the permission on ...
0
votes
0answers
14 views

Viewing CURL url's in ubuntu

I can see in top that curl is being called at a very large rate, there are 10+ open connections. Is there a way in ubuntu to see the URL's they are getting?
0
votes
1answer
40 views

How do I fix the default version of PHP after uninstalling PHP OSX?

I installed PHP OSX because I wanted to test some PHP 5.5 code on the command-line/interactive shell. On my local web server, I started receiving errors in functional code from before I installed PHP ...
0
votes
0answers
43 views

Apache doesn't start in Ubuntu

I'm trying to get my apache2 to work under Ubuntu. I've installed all packages from MySQL to PHP and Apache. When I program on PHP, the PHP scripts aren't recognized and aren't interpreted. I ...
0
votes
2answers
144 views

.htaccess add multiple xdebug.remote_host

I am using NetBeans to remote debug a PHP application. Currently I have an entry in the .htaccess file on the remote directory to allow access to a single IP. I frequently switch between wired and ...