0
votes
1answer
13 views

Why doesn't the binary package get reinstalled by apt-get or building from source?

I'm trying to install Asterisk on my Debian wheezy server. For this I first did the simple sudo apt-get install asterisk This worked flawlessly. Afterwards asterisk was running and I could enter ...
1
vote
1answer
79 views

apt-get wants to autoremove core packages

I upgraded to PHP 5.6RC4 today on my Debian Sid server (x64): The following packages have been kept back: perl perl-base perl-modules The following packages will be upgraded: cpp-4.9 g++-4.9 ...
0
votes
0answers
16 views

How to give up or skip packages with unmet dependencies?

A package called salt-minion has unresolved dependencies on my Debian system. Now everytime I run apt-get it will output the following error message: root@Sheeva:~# apt-get upgrade Reading package ...
0
votes
0answers
10 views

How to give up packages that are not fully installed on Debian?

The package linux-image-3.2.0-4-kirkwood is "not fully installed" on this Debian system. Everytime I do apt-get upgrade I will see this message: root@Sheeva:~# apt-get upgrade Reading package ...
0
votes
1answer
77 views

Errors were encountered while processing fuse

I was updating my system (Debian Sid x64) using apt-get, but I got the following error: Setting up fuse (2.9.3-14) ... dpkg: error processing package fuse (--configure): subprocess installed ...
1
vote
2answers
65 views

Can't install wireshark on Debian Linux

I'm trying to install Wireshark on Debian (Debian 3.2.51-1) but i'm getting this error: apt-get install wireshark Reading package lists... Done Building dependency tree Reading state ...
0
votes
1answer
43 views

How can I apt-get dist-upgrade without removing packages?

When I run apt-get dist-upgrade, it wants to remove a number of packages I have installed that I'd very much like to keep installed, such as netflix-desktop. To work around this, I can of course ...
1
vote
3answers
1k views

Installing Skype on Debian Wheezy [amd64]

Yes, yet another question about how to install Skype on Debian Wheezy (7.4) amd64. Seen countless similar articles and forum threads on how to do it, but it doesn't for me :( Here is what I do: dpkg ...
2
votes
1answer
118 views

apt-get wants to remove MariaDB on Debian Wheezy

I've set up my server to use MariaDB and used the installation instructions on the web page. It worked quite well. Now, if I want to dist-upgrade, apt-get wants to replace MariaDB with MySQL: The ...
1
vote
1answer
37 views

apt-get install re-attempts failed installs

I've used apt-get to download some application some of which failed. When I run apt-get now it looks like it keeps trying to download these previously failed installs. Is there anyway to get rid of ...
0
votes
2answers
130 views

Preventing apt-get to install X11 packages when installing doxygen

I wanted to install Doxygen on my server, but I did not do it through apt-get, because it necessarily came with x11 packages. # apt-get install doxygen The following extra packages will be ...
0
votes
1answer
231 views

Tor - dependency/package error on debian wheezy

When I am trying to install Tor on Debian wheezy via Apt-Get CLI, I am getting the below error. Libevent and LibSSl are already installed on the system. Do you have any suggestions on how to resolve ...
0
votes
2answers
58 views

Installing TOMCAT on Debian without apt-get

I have access to a machine on a scientific hpc, and I'm setting up an environemnt to create a web application, made up basically of TOMCAT and postgresql. I cannot use another web server. The OS is ...
0
votes
1answer
48 views

Where does system downloads the files?

I have Elementory OS currently running on my PC. It is based on Debian-Ubuntu. I had recently run the command "apt-get upgrade" and downloaded 162 MB of data Now I don't have an internet on another ...
0
votes
1answer
288 views

Issues installing MariaDB (5.5.34) on Debian 7 (Wheezy)

When attempting to install MariaDB (5.5.34) on Debian 7 (Wheezy) apt-get outputs the following: Setting up mariadb-server-5.5 (5.5.34+maria-1~wheezy) ... [ ok ] Stopping MariaDB database server: ...
-1
votes
1answer
1k views

Debian: apt-get doesn't find any package

I've got the Problem that apt-get doesn't find any package on my new installed Debian 7.3. First I got the error that I should enter the Installation-CD, then I edited the /etc/apt/sources.list and ...
1
vote
0answers
87 views

Debian Jessie repositories and git

How should I edit the sources.list so I will be able to get Git via apt-get? If I run apt-get install git now, I get Unable to locate package git While I can manually download and compile ...
0
votes
1answer
2k views

How to upgrade virtualbox 4.2 to 4.3 on debian wheezy with apt-get?

I'm running VirtualBox 4.2 and it keeps telling me that 4.3 is available for update. However when I do apt-get update and the apt-get upgrade I don't get any updates. My sources.list contains deb ...
0
votes
1answer
1k views

debian cannot uninstall dovecot

I have a problem with uninstalling dovecot. And while trying to fix it I made it way worse. Here is the "log": Errors were encountered while processing: dovecot-imapd dovecot-pop3d E: Sub-process ...
0
votes
2answers
360 views

How to get codename (“wheezy” or “sid”) of a package version?

apt-cache show shows various versions of the package # apt-cache show libc6:i386 Package: libc6 Version: 2.17-97 Architecture: i386 ... Package: libc6 Status: install ok installed Version: 2.17-7 ...
1
vote
1answer
199 views

Debian Testing installs Iceweasel ESR (severely outdated)?

I just reinstalled Debian Testing, and for some reason, instead of Iceweasel 25, I have 17. The installed and candidate versions are both 17.0.9esr-1~deb7u1. apt-get update && apt-get upgrade ...
1
vote
2answers
219 views

Debian: why are the suggested upgrades from apt-get and synaptic different?

I am running Debian Jessie, and this is the content of my sources.list file: deb http://ftp.debian.org/debian jessie main contrib non-free deb http://security.debian.org/ jessie/updates main contrib ...
4
votes
2answers
3k views

How to upgrade to latest git on debian 7?

I have installed git through apt-get on debian 7 which gives me: # git --version git version 1.7.10.4 I would like to ugrade to the latests version of git. I have tried: sudo apt-get install ...
2
votes
1answer
88 views

Could not perform immediate configuration on 'perl'

I'm trying to upgrade a debian squeeze system to wheezy. I've done an apt-get update && apt-get -V upgrade on squeeze, then changed my source.list to reference wheezy not squeeze. then, ...
2
votes
2answers
103 views

How can I review updates before actually upgrading with apt-get in Debian

Before acutally doing #apt-get upgrade on a Debian server, I'd like to get an overview of the package names about to be updated and what the changes are in those packages. Recently my root account ...
1
vote
0answers
226 views

Unmet Dependencies on Debian with iRedMail

I'm using Debian Squeeze to try and install iRedMail (http://www.iredmail.org/). This is the error I get: Some packages could not be installed. This may mean that you have requested an impossible ...
1
vote
0answers
106 views

Configure apt-get unable to install specific package without version mentioning

Is there a way to configure apt-get to make unable to install specific package without setting version? So, as a user I want to get an error if version is unspecified for package X only: apt-get ...
3
votes
2answers
2k views

Can I make apt-get always use --no-install-recommends?

A bit of background, feel free to skip this paragraph if you don't care. I have a bit of academic experience with linux and unix from college but I'm still somewhat of a n00b because I was always a ...
1
vote
1answer
395 views

Debian - install new software by apt-get over SSH

I tried to install new software when I was connected to my Debian over SSH, for example sudo apt-get install subversion, and after calculating dependencies, required space, etc. APT asked, if I want ...
1
vote
1answer
365 views

How to get latest nginx in Wheezy using apt-get

It seems like the nginx package in debian wheezy apt-get is old and only goes up to 1.2 whereas the latest version is 1.4 Do I really have to build it from source or is there a way to get the latest ...
0
votes
1answer
226 views

apt-get -d download to a specific directory

What are the options for apt-get on debian to download to a specific directory. Right now I'm using apt-get -d install packagename and then just fetch it in /var/cache/apt/archives/ but it would be ...
0
votes
2answers
4k views

Debian 6.0.6 apt-get “unable to locate package” - how do I find the package?

I'm running Debian 6.0.6 and trying to install libeigen3-dev using: sudo apt-get install libeigen3-dev But I get the following output: Reading package lists... Done Building dependency tree ...
0
votes
0answers
474 views

apt-get “Broken packages”

While installing python-dev: sudo apt-get install python-dev I am getting the following error: The following packages have unmet dependencies: python2.7-dev : Depends: python2.7 (= 2.7.3-0ubuntu3) ...
0
votes
1answer
25 views

Linux's Packages updates

I'm trying to reset a Windows's password I have on a computer through a Debian distribution I have on the same machine, the best way for doing this is with a package u can apt-get called chntpw, the ...
3
votes
4answers
56 views

How to find out what files will be installed in the filesystem when installing a package with aptitude?

In my case I want to do aptitude install wireless-tools but want to know which files will be installed and where in the filesystem before I install the package.
2
votes
1answer
349 views

Fix libboost-dev broken dependency

I need to install fcl which depends on libboost-dev. However, libboost-dev depends on libboost1.46-dev and it refuses to install because I have the newer libboost1.48-dev. I have followed ...
1
vote
1answer
3k views

Install custom software on Iomega PX4-300D NAS (Debian OS)

I am trying to put additional software on my Networked Attached Storage (NAS) The NAS appears to be running Debian. Anyway, apt-get is already on the machine. I just needed to add the correct ...
2
votes
1answer
645 views

apt-get install: Error: Timeout was reached?

What has gone wrong if this error message appears AFTER apt-get has finished downloading and installing packages? ... Processing triggers for menu ... Error: Timeout was reached Edit: This ...
1
vote
2answers
665 views

Ignore packages that are not currently installed when using “apt-get remove”

I have a scenario where I'd like to remove a set of packages that may or may not be installed, and I'd like apt-get to remove those that are and silently ignore those that aren't. Something like: ...
0
votes
0answers
63 views

Why the apt-get -f upgrade returns warning and errors?

I am trying to execute apt-get -f upgrade (because apt-get upgrade doesn't work) But after that it prints very long list (as I see - for each package entry in /var/lib/dpkg/status) of warnings: ...
0
votes
0answers
68 views

Why apt-get cannot install software?

Each time I execute apt-get install (e.g. gzip) I get the problems of kind: Depends: <some_package> but is not going to be installed Depends: <some_package> but is not installable For ...
1
vote
1answer
533 views

What is the error on executing apt-get (GLIBCXX_3.4.15 not found)?

I have an error by installing and executing the apt-get (there is no package manager except udpkg): apt-get: /usr/lib/libstd++.so.6: version GLIBCXX_3.4.15 not found (required by apt-get) I have ...
2
votes
1answer
1k views

How to install lsof on Debian/kFreeBSD?

How do you install lsof on Debian/kFreeBSD Testing (Wheezy/Sid)? $ apt-get install lsof Package lsof is not available, but is referred to by another package. This may mean that the package is ...
1
vote
0answers
2k views

Why did I fail to install packages when using debian?

There is lots of messed up dependency. How can I resolve this problem? It produces the following output: Reading package lists... Done Building dependency tree Reading state information... Done Note, ...
6
votes
2answers
812 views

How can I create an alias for apt-get?

I remember that on one Debian system, I used apt install package to install a package. It asked for a password afterwards and was more convenient than sudo apt-get install. Now I am not sure how I ...
0
votes
1answer
377 views

apt-get install new packeges, avoid others

Look at this entry: root@vivid-75:~# apt-get --no-install-recommends install curl Reading package lists... Done Building dependency tree Reading state information... Done The following extra ...
16
votes
1answer
36k views

Why use the command apt-get --purge remove over apt-get purge in Linux?

I have been uninstalling applications as well as removing or purging their configuration files using the command apt-get --purge remove {package_name}. I have come across several posts on the net ...
3
votes
1answer
1k views

Catch 22: need apt-utils to install apt-utils?

I was trying to install something else when I ran into this problem. So I tried to install apt-utils to solve it. But I couldn't install apt-utils, because well, my console tells me I don't have ...
3
votes
1answer
672 views

zsh completion after installing/removing packages

How does zsh figure out currently installed packages on Debian, and how can I update that information? After running apt-get install, zsh won't autocomplete that package as a possible parameter for ...
0
votes
3answers
3k views

Trying to update debian not working

As root i type this command apt-get update and get these error messages. > Err http://security.debian.org lenny/updates Release.gpg ...