apt-get is a command-line interface to the Advanced Packaging Tool (apt) which is responsible for installing, removing, and upgrading packages.

learn more… | top users | synonyms

2
votes
1answer
1k views

How to install lsof on Debian/kFreeBSD?

How do you install lsof on Debian/kFreeBSD Testing (Wheezy/Sid)? $ apt-get install lsof Package lsof is not available, but is referred to by another package. This may mean that the package is ...
4
votes
2answers
16k views

Can apt-get be used on Red Hat systems?

We know that apt-get is used on debian based systems so what is used on Red Hat Enterprise Linux (RHEL) systems? Is it possible to install and use apt-get on Red Hat?
1
vote
0answers
1k views

Why did I fail to install packages when using debian?

There is lots of messed up dependency. How can I resolve this problem? It produces the following output: Reading package lists... Done Building dependency tree Reading state information... Done Note, ...
2
votes
1answer
2k views

How can I install gfortran 4.6 in Ubuntu 11.04?

I am running Ubuntu 11.04. I wanted to install gfrotran 4.6 on my system. Can anyone please explain (show all) steps required to install gfortran 4.6 on ubuntu 11.04? I did the following: sudo ...
0
votes
4answers
145 views

Installing softare on Linux

I'm trying to install the GMP package on Redhat 4, x86_64. The package can only be installed using make, which is not available and should be installed with apt-get/yum, but I don't have either one of ...
0
votes
0answers
216 views

Ubuntu can't install an older version of a package

When I try to do an apt-get install, I keep getting an error: Depends: libgtk-3-common (= 3.4.1-0ubuntu1) but 3.4.2-0ubuntu0.4 is to be installed when I run sudo apt-get -f install, I get several ...
1
vote
0answers
1k views

How to fix broken dependencies when installing old/archived packages

I am trying to install opencv version 2.1. My codebase requires opencv 2.1, so upgrading is not an option. Specifically, I am trying to install the packages: libhighgui2.1 libcvaux2.1 libcv-dev ...
3
votes
1answer
733 views

Nothing happens when trying to upgrade from Linux Mint 12 to 13

I am trying to upgrade from Linux Mint 12 to 13 using apt-get. After running the following commands, nothing seems to happen. I am fairly new to linux, what am I doing wrong? user@olympus ...
1
vote
1answer
146 views

apt-get misdetecting versions

I have used a PPA for more recent versions of digiKam (and supporting libs). I now want to install 'standard' Wine but getthe results below. Note that I tried to install Wine first but tracing ...
1
vote
1answer
3k views

How to update to latest version of SVN server?

I currently have SVN server installed on my Linux Ubuntu machine, version 1.6.12. I see that the latest version is 1.8.x and would like to update my installation to it, so I run: sudo apt-get update ...
2
votes
1answer
736 views

Cannot start Postgres daemon after installing with Yum

I was trying to install Postgres 9.1.4 on Fedora 17 using Yum. If I do: sudo yum install postgres-libs sudo yum install postgres sudo yum install postgis All the installs appear to complete ...
6
votes
2answers
756 views

How can I create an alias for apt-get?

I remember that on one Debian system, I used apt install package to install a package. It asked for a password afterwards and was more convenient than sudo apt-get install. Now I am not sure how I ...
2
votes
6answers
834 views

How to network-ify an Ubuntu Server VM

I am creating an Ubuntu Server VM with VirtualBox. This morning I created the VM (with Networking configurations shown below) and installed the guest OS from an ISO. I just logged in for the first ...
1
vote
1answer
1k views

how to automatically select fast mirror for apt-get

Is there any plug-in available for apt-get to select fast mirror just as the YUM's fastestmirror plugin The fastest mirror plugin is designed for use in repository configurations where you have more ...
1
vote
1answer
359 views

Apt-get gives authentication warning every time

Whenever I apt-get something, it warns me that it is unauthenticated. This is a new problem; it started today. When I do apt-key update, it does nothing, and apt-get update gives me this error at the ...
2
votes
5answers
301 views

What are the differences between installing Python via apt-get and compiling, installing from source?

If I choose to install Python by typing: apt-get install python3.1 python-dev Are there any differences between compiling and installing from source? Would the source code include everything in ...
5
votes
1answer
5k views

How do Ign and Hit affect apt-get update?

My understanding of Ign and Hit which are displayed in the output of the command apt-get update is that Hit: File found. No change in its timestamp and Ign: File ignored. No change in its content.. ...
4
votes
3answers
244 views

How do I list the files installed by a deb package?

I'm an Ubuntu user and I install packages with the apt-get. For example: sudo apt-get install hadoop-0.20 After I install the package, there will be files in /usr/bin, /usr/lib/hadoop etc. Are ...
0
votes
0answers
689 views

Dependency problems with installing ia32-libs on Ubuntu

I need to install the ia32-libs package on my Ubuntu server (version 11.10). When I try to install it via apt-get it says I need this dependency: The following packages have unmet dependencies. ...
0
votes
1answer
170 views

Ubuntu: perl: undefined symbol: PL_perl_destruct_level

Recently, I tried to crosscompile Perl on my Ubuntu system but made a mistake. The finished binary was installed on my productive system besides the already present perl version. Ever since I get the ...
1
vote
0answers
109 views

Discrepancy in number of upgradable packages between apt-get and Update manager

I ran the command apt-get update && apt-get -s upgrade | grep 'upgraded' and was displayed the output below. The following packages will be upgraded: 31 upgraded, 0 newly installed, 0 to ...
1
vote
1answer
305 views

What is the difference between new and extra packages when running the command apt-get install in Linux?

When I attempt to install a particular package I get the following output. I had a read of http://www.debian.org/doc/manuals/debian-faq/ch-pkg_basics.en.html#s-depends however it is not clear whether ...
0
votes
1answer
371 views

apt-get install new packeges, avoid others

Look at this entry: root@vivid-75:~# apt-get --no-install-recommends install curl Reading package lists... Done Building dependency tree Reading state information... Done The following extra ...
16
votes
1answer
34k views

Why use the command apt-get --purge remove over apt-get purge in Linux?

I have been uninstalling applications as well as removing or purging their configuration files using the command apt-get --purge remove {package_name}. I have come across several posts on the net ...
3
votes
1answer
682 views

Does hitting CTRL-C when a package is being downloaded and installed via apt-get stop the process?

If I run the command apt-get install [package_name] and hit CTRL-C mid process, does it stop the installation and roll back to its original state?
0
votes
1answer
165 views

What do Inst and Conf refer to when using the command apt-get in Linux?

When I run the command apt-get install flashplugin-installer I am displayed the following lines of details Inst flashplugin-installer [11.2.202.233ubuntu0.11.04.3] (11.2.202.235ubuntu0.11.04.1 ...
0
votes
0answers
271 views

Why do the commands apt-cache showpkg and apt-cache show display different results in Linux?

I am looking to update a particular package on several Linux systems however when I run the commands apt-cache showpkg {name_of_package} it displays a higher version of the package is available e.g. ...
0
votes
1answer
2k views

Broken packages after upgrading Xubuntu from 11.10 to 12.04 LTS

I upgraded my Xubuntu from 11.10 to 12.04 LTS. After this, I noted that ssh is no more installed. I tried install it and got this error: we@nemesis:~$ sudo apt-get install openssh-client Reading ...
3
votes
2answers
1k views

Failed to symbolic-link /boot/initrd.img-3.2.0-24-generic to initrd.img: File exists

Since running an upgrade today I am no longer able to use apt-get. Case in point: sudo apt-get install curl Reading package lists... Done Building dependency tree Reading state ...
2
votes
1answer
1k views

Can't install any software anymore on ubuntu

I'm unable to install or remove any software package on Ubuntu. No matter how many times I try "apt-get -f install'. -- jeroen@jeroen-panda:~$ sudo apt-get -f install Reading package lists... Done ...
1
vote
4answers
7k views

Removing MySQL completely on Linux

I'm fairly new to Linux, when I first installed MySQL it was during an LAMP setup on personal machine with a Ubuntu Setup. ATM, I'm trying to get a fresh, clean install of only MySQL. I've been to ...
2
votes
1answer
150 views

Can I fetch a .deb, plus all .debs it depends on?

I'm running a rather restricted virtual ubuntu environment on a virtualization platform that doesn't yet support networking. I need to benchmark a compilation, but my guest does not have ...
3
votes
1answer
1k views

Catch 22: need apt-utils to install apt-utils?

I was trying to install something else when I ran into this problem. So I tried to install apt-utils to solve it. But I couldn't install apt-utils, because well, my console tells me I don't have ...
0
votes
4answers
930 views

Lost Power During apt-get install, Can't Resolve Missing Dependencies

I tried to install mercurial today, and the power went out. Now, when I try to install any packages, it complains about a couple of different things: >$ sudo apt-get install mercurial [sudo] ...
3
votes
1answer
650 views

zsh completion after installing/removing packages

How does zsh figure out currently installed packages on Debian, and how can I update that information? After running apt-get install, zsh won't autocomplete that package as a possible parameter for ...
0
votes
3answers
4k views

apt-get cannot find any packages

I get this result on my newly installed ubuntu 9.04 netbook remix. I haven't tampered with any apt files at all. It doesnt work for any other packages. ira@ira-windu100:/etc/apt$ sudo apt-get install ...
0
votes
3answers
2k views

Trying to update debian not working

As root i type this command apt-get update and get these error messages. > Err http://security.debian.org lenny/updates Release.gpg ...
1
vote
2answers
964 views

How can I use apt-cache to only search on descriptions of packages?

I am wanting to search for every package that has a description of PDF. How do I do that with apt-cache or is there a different command I can use?
0
votes
1answer
121 views

Does apt-cache only show you results based in what is installed?

If I run the command apt-cache showpkg {packagename}, does it only show the details of the package of it is installed or does it not matter? If I run the command apt-get update, does this update ...
0
votes
1answer
390 views

Can I switch from Ubuntu to Mint using apt sources only?

Is it possible to install Linux Mint 12 just by editing /etc/apt/sources.list and putting Mint's repos there? I can copy them from the Live CD, of course. I know a clean install would be better, but ...
11
votes
4answers
16k views

When would you use apt-get remove over apt-get autoremove?

I understand that apt-get remove removes packages and apt-get autoremove is to remove any packages that were installed to fulfil a dependency for a given package. So for example if I installed ...
9
votes
6answers
39k views

Installing sun-java6-jdk with apt-get on Ubuntu 10.04

I have followed the instructions on numerous pages, such as this, which say to run the following commands: sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner" sudo apt-get ...
8
votes
3answers
9k views

How to find out which versions of a package can I install on APT

Using APT, you can install a specific version of a package using: apt-get install package=1.0 But you can't do apt-get install package=1.* So, how can I find out which versions are avaliable for ...
2
votes
1answer
503 views

“Broken packages” installation error in Ubuntu

When I'm trying to install subversion on a Ubuntu machine using command sudo apt-get install subversion, it's throwing the follwoing error. ~$ sudo apt-get install subversion [sudo] password for ...
2
votes
1answer
748 views

Will “apt-get dist-upgrade” update my Ubuntu to the next major release?

I'm trying to cleanup the following error message: pdf-reader /home/jseidel/ebilling_1393100.pdf Traceback (most recent call last): File "/usr/lib/command-not-found", line 10, in <module> ...
1
vote
0answers
305 views

Ultimately installing a PECL extension but need a new version of libtool > 2.2

What's my end game : installing SSPLUS, a PCEL extension My config : A virtuozzo server running Linux 2.6.18-028stab069.6 (Debian Lenny ??) What I've done : 1 pear install spplus Deprecated: ...
6
votes
4answers
4k views

When you do “apt-get install” where are the .deb files stored?

I am trying to copy all of the packages I have installed on one Debian machine to another Debian machine without doing another apt-get install and downloading all of the package all over again.
0
votes
1answer
336 views

How to fully reinstall a package on debian

i accidentally removed the /etc/init.d/nginx file and the /etc/nginx folder. how can i fully reinstall nginx with reverting all confs to defaults?
2
votes
1answer
590 views

Troubles using apt-get install with home on NFS share

I am trying to install a bunch of packages using apt-get install on a VM running Debian 5.0.9 (Lenny). What makes this endeavor frustrating and difficult is the fact that my home directory on this ...
2
votes
1answer
157 views

Installing linux programs when something else has to be installed

I seem to have all the dependencies to install a program, but I'm getting these error messages. Some packages could not be installed. This may mean that you have requested an impossible situation or ...