apt-get is a command-line interface to the Advanced Packaging Tool (apt) which is responsible for installing, removing, and upgrading packages.

learn more… | top users | synonyms

0
votes
3answers
3k views

Trying to update debian not working

As root i type this command apt-get update and get these error messages. > Err http://security.debian.org lenny/updates Release.gpg ...
1
vote
2answers
1k views

How can I use apt-cache to only search on descriptions of packages?

I am wanting to search for every package that has a description of PDF. How do I do that with apt-cache or is there a different command I can use?
0
votes
1answer
122 views

Does apt-cache only show you results based in what is installed?

If I run the command apt-cache showpkg {packagename}, does it only show the details of the package of it is installed or does it not matter? If I run the command apt-get update, does this update ...
0
votes
1answer
391 views

Can I switch from Ubuntu to Mint using apt sources only?

Is it possible to install Linux Mint 12 just by editing /etc/apt/sources.list and putting Mint's repos there? I can copy them from the Live CD, of course. I know a clean install would be better, but ...
11
votes
4answers
18k views

When would you use apt-get remove over apt-get autoremove?

I understand that apt-get remove removes packages and apt-get autoremove is to remove any packages that were installed to fulfil a dependency for a given package. So for example if I installed ...
9
votes
6answers
40k views

Installing sun-java6-jdk with apt-get on Ubuntu 10.04

I have followed the instructions on numerous pages, such as this, which say to run the following commands: sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner" sudo apt-get ...
9
votes
3answers
11k views

How to find out which versions of a package can I install on APT

Using APT, you can install a specific version of a package using: apt-get install package=1.0 But you can't do apt-get install package=1.* So, how can I find out which versions are avaliable for ...
2
votes
1answer
529 views

“Broken packages” installation error in Ubuntu

When I'm trying to install subversion on a Ubuntu machine using command sudo apt-get install subversion, it's throwing the follwoing error. ~$ sudo apt-get install subversion [sudo] password for ...
2
votes
1answer
774 views

Will “apt-get dist-upgrade” update my Ubuntu to the next major release?

I'm trying to cleanup the following error message: pdf-reader /home/jseidel/ebilling_1393100.pdf Traceback (most recent call last): File "/usr/lib/command-not-found", line 10, in <module> ...
1
vote
0answers
315 views

Ultimately installing a PECL extension but need a new version of libtool > 2.2

What's my end game : installing SSPLUS, a PCEL extension My config : A virtuozzo server running Linux 2.6.18-028stab069.6 (Debian Lenny ??) What I've done : 1 pear install spplus Deprecated: ...
6
votes
4answers
4k views

When you do “apt-get install” where are the .deb files stored?

I am trying to copy all of the packages I have installed on one Debian machine to another Debian machine without doing another apt-get install and downloading all of the package all over again.
0
votes
1answer
379 views

How to fully reinstall a package on debian

i accidentally removed the /etc/init.d/nginx file and the /etc/nginx folder. how can i fully reinstall nginx with reverting all confs to defaults?
2
votes
1answer
656 views

Troubles using apt-get install with home on NFS share

I am trying to install a bunch of packages using apt-get install on a VM running Debian 5.0.9 (Lenny). What makes this endeavor frustrating and difficult is the fact that my home directory on this ...
2
votes
1answer
162 views

Installing linux programs when something else has to be installed

I seem to have all the dependencies to install a program, but I'm getting these error messages. Some packages could not be installed. This may mean that you have requested an impossible situation or ...
1
vote
1answer
2k views

Install java on Linux through shell without apt-get

I'd like to run multicraft on one of my servers. After some intensive debugging/installing I realised the server didn't yet have a Java Runtime Environment. I figured it would be easy to install, but ...
1
vote
1answer
134 views

Change the Ubuntu program that runs when a command can't be found

When I type a command not found in a PATH in ubuntu, I get something like this: $ rdesktop The program 'rdesktop' is currently not installed. You can install it by typing: sudo apt-get install ...
1
vote
1answer
432 views

Debian upgrade x11-common error

I upgraded my Debian but I'm getting an error. How can I go around this problem? Processing triggers for man-db ... Setting up x11-common (1:7.6+8~bpo60+1) ... Template parse error near ...
0
votes
1answer
273 views

Error: "Sub-process /usr/bin/dpkg returned an error code (1)”

for example when I "sudo apt-get install libmemcache0", I got: Reading package lists... Done Building dependency tree Reading state information... Done libmemcache0 is already the newest ...
2
votes
2answers
3k views

Mistakenly ran “sudo apt-get remove python” (system is not working in normal mode, is there any solution?)

By mistake I ran the following command: sudo apt-get remove python After this my PC is no longer working properly. It shows graphics problem during restarting and every time it starts in Grub ...
1
vote
0answers
51 views

used wrong ubuntu mirror to install packages

I work with a computer system that has a ubuntu mirror locally installed. The OS is ubuntu 9.10 (karmic) Server. I see that a colleague changed the regular /etc/apt/sources.list file to access the ...
1
vote
1answer
386 views

Where are Ubuntu packages that I can't find by name (OpenJDK, Ruby, etc.)?

Just installed Ubuntu 9.0.4. When using apt-get, I found I could not get packages like OpenJDK, Ruby etc. Do I need to add some additional repository?
6
votes
2answers
3k views

Is it safe to install Ubuntu packages on Debian?

I've found online guides to adding Ubuntu PPAs and repositories to a Debian system. Is this a bad idea? If so, why?
2
votes
2answers
534 views

Fear of apt-get upgrade: Will it break my website?

Ok, I have a website that I manage on an Ubuntu box, but I haven't updated apache2 in a while. I would like to get up to date with the security patches etc. The problem is that I don't have a Test ...
0
votes
0answers
875 views

apt-get can't see the latest version of yasm

I'm trying to build Firefox and I get an error I need a the newest version of yasm, 1.0.1 and I only have 0.8.0. I did the logical thing: $ sudo apt-get upgrade yasm Reading package lists... Done ...
1
vote
0answers
266 views

Trouble installing libqt4-dev on Ubuntu Karmic

I'm having trouble installing libqt4-dev on Ubuntu Karmic. Here's the output: The following packages have unmet dependencies: libqt4-core: Depends: libqtcore4 (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but ...
2
votes
2answers
2k views

Can I install Ubuntu apt-get packages offline?

I have installed Ubuntu 11.04 on my system. I don't have any Internet connection to the system. How can I install various packages? Is there a package collection available as CD/DVD (which I can ...
0
votes
1answer
609 views

How to install skype in an ALT Linux distro (Simply Linux 6)

I've installed Simply Linux 6 (a distro by ALT Linux Team which based on the "p6" branch of their package repository; ftp, torrent). Now I want to use Skype, but there is no skype package in the list ...
1
vote
2answers
287 views

What's the correct way to shutdown system while apt-get is still running

What's the correct way to shutdown system while apt-get is still running? apt-get complains about unclean shutdown when I just shutdown computer.
1
vote
2answers
407 views

apt-get install old version proftpd

I am looking to install proftpd 1.2.9. I found the source in the historic directories of the proftpd site, however I cannot get it to compile. If need be, I can post the errors.. but there were a lot ...
0
votes
1answer
152 views

Not able to upgrade my Ubuntu distribution

I am using Ubuntu 10.04 "Lucid". I wanted to upgrade my distribution to 10.10. When I performing th upgrade in Update Manager, I get an error message. I have even tried to update via console as ...
0
votes
1answer
148 views

Error after modifying sources.list

I modified sources.list and now it wont load. I took everything out except for the first line and it still errors out. Any ideas based on it's output? sources.list: deb ...
2
votes
4answers
6k views

“Packages can't be authenticated” during apt-get install on Ubuntu 9.04

I am trying to download gcc using apt-get install on Ubuntu 9.04 Jaunty, but when apt-get is trying to download the file I receive an error: WARNING: The following packages cannot be authenticated! ...
0
votes
0answers
75 views

If aptitude is more preferable then why does bash advise apt-get? [duplicate]

Possible Duplicate: On Ubuntu, why "sudo apt-get" sometimes and "sudo aptitude" other times? In the documentation it is said that aptitude is more preferable command to ...
2
votes
0answers
274 views

Why did “apt-get install libnss3-ld” delete everything on my system?

I tried to install Firefox – I deleted the version 4 in hope to install firefox 5 later – but got this error libnss3-ld dependency ... I decided to do this sudo apt-get install ...
2
votes
1answer
1k views

Grab all dependencies from apt-get for offline install (Ubuntu 11)

How do I use apt-get to install a package on an offline computer? With a separate (connected) computer, I can use apt-get --download [package] to pull the package I'm interested in but this fails to ...
1
vote
1answer
2k views

How to specify directory for apt-get to save the packages

is there any way to specify the destination directory for each download in apt -get command to save all the downloaded packages in a custom directory instead of archive directory for offline use. If ...
10
votes
1answer
15k views

How to find installation path for packages installed through apt-get in Ubuntu?

I have been installing python modules using apt-get which works great using the console or launching files from the command line. However I am using Eclipse for easier organisation of files. Eclipse ...
1
vote
1answer
339 views

apt-get download size per package, instead of total download size

Apt-get displays the total size of all downloads required for an upgrade or install. I was wondering if we could get the size of each package that is going to be downloaded as well? An aptitude ...
2
votes
2answers
798 views

GPG error when updating Linux Mint 9

When i run sudo apt-get update, i get the following error W: GPG error: http://ppa.launchpad.net lucid Release: The following signatures couldn't be verified because the public key is not ...
2
votes
1answer
1k views

Problem while installing tzdata-java package (unmet dependencies)

I got a Debian 6.0 at home, upgrade from Lenny. I need to install the tzdata-java package but when I do an apt-get install I receive this message: The following packages have unmet dependencies: ...
3
votes
1answer
419 views

Alternatives to Gentoo Prefix?

Are there any package managers that: work without root privileges, and install packages at a custom location (similar to ./configure --prefix), and install stable packages (unlike Gentoo Prefix ...
1
vote
2answers
179 views

How do I read User Guide in apt-doc on Ubuntu?

I just installed apt-doc package. My question is how do I read the User Guide in this package ? In general how do I use the items from a package once I install it ?
0
votes
2answers
2k views

Problem updating with apt-get

I'm running Ubuntu 11.04 with gnome-shell and I have a conflict in apt-get that don't let me upgrade / install new packages (my system is in Spanish, because of that some output is in this language) ...
15
votes
2answers
2k views

Why does apt-get sometimes asks for confirmation?

Sometimes it does this: After this operation, 713kB of additional disk space will be used. Do you want to continue [Y/n]? And sometimes not, and just assumes 'yes' and downloads automatically (I ...
2
votes
2answers
549 views

Want to hold a package from upgrading. Don't work

I'm having a xen box which runs squeeze. the linux-image-2.6.32-5-686-bigmem never upgrades properly and I want to stop it from upgrading any more. It's annoying that it tries and fails every time I ...
1
vote
1answer
1k views

Why can't Ubuntu 10.04's apt-get install php 5.2.10 from a ppa?

I'm trying to install PHP 5.2.10 on Ubuntu 10.04 using apt-get. I used Approach 3 from this page but instead of using add-apt-repository I made a file called ...
0
votes
1answer
1k views

ntop won't install properly after reinstall (Ubuntu 11.04)

I installed ntop (with all its dependencies) like this: sudo apt-get install ntop After that I decided to remove it by issuing the following commands: sudo apt-get remove ntop sudo apt-get ...
6
votes
1answer
5k views

installing the latest R version (2.13.0) on Ubuntu 11.04

I just upgraded my Ubuntu desktop 10.10 to 11.04. I everything works fine except when trying to update the current R 2.12.1 to R 2.13.0. I followed the readme: ...
2
votes
2answers
207 views

How to prevent Ubuntu/Debian users from accessing apt-get or downloading from the web, etc?

Is it possible to have a user in Ubuntu/Debian that does not have access to synaptic, apt-get, dpkg and cannot even download anything from the Web, but has root privileges otherwise? Original post ...
2
votes
2answers
5k views

Add to sources.list with a command? (not a redirect or text editor)

I'm using Debian stable (squeeze) and found this command add-apt-repository but it's not found when I try use it. I'm sure I've used a command before which added a repo but I can't remember what it ...