apt-get is a command-line interface to the Advanced Packaging Tool (apt) which is responsible for installing, removing, and upgrading packages.

learn more… | top users | synonyms

0
votes
1answer
9 views

Cannot remove package gramps

I used dpkg and apt-get to install, purge, remove gramps package different versions. It all went to situation when I cannot remove it fully and install clean. $ sudo apt-get remove gramps Reading ...
0
votes
1answer
20 views

Reinstall /boot/<kernel> files through apt-get?

I was doing some maintenance and a script got away from me. I managed to delete the latest kernel files from /boot (actually, all the kernel files, including the old ones). I need to re-install the ...
6
votes
3answers
4k views

How to upgrade to latest git on debian 7?

I have installed git through apt-get on debian 7 which gives me: # git --version git version 1.7.10.4 I would like to ugrade to the latests version of git. I have tried: sudo apt-get install ...
2
votes
1answer
33 views

Continue on error when apt-get encounters an install unable to locate package issue

When I run the following: sudo apt-get install vim abcde php5-cli It fails with the following message which is the expected behavior: E: Unable to locate package abcde`. I want it to ...
0
votes
1answer
300 views

How to install top & htop on Ubuntu 8.04.2 LTS (hardy)

Env. Rackspace Ubuntu 8.04.2 LTS (hardy) I am in a corner situation where I need to maintain carefully a legacy server before I can plant for an upgrade. Actually an upgrade is not an option, I ...
1
vote
2answers
2k views

debian cannot uninstall dovecot

I have a problem with uninstalling dovecot. And while trying to fix it I made it way worse. Here is the "log": Errors were encountered while processing: dovecot-imapd dovecot-pop3d E: Sub-process ...
-2
votes
1answer
65 views

Unable to uninstall python2.7.8 installed in ~/Downloads directory

I have read many answers regarding this kind of problem but unfortunately, I am unable to achieve the uninstallation. So please don't downvote or flag this question. I have python2.7.8 installed in ...
5
votes
1answer
748 views

Can't open an SSH session because of OpenSSL version mismatch

I just ran apt-get upgrade, and according to /var/log/apt/history.log, openssl has been updated to version 1.0.1e-2+rvt+deb7u7. Now I have one SSH session still open, but I can't open another one. I ...
1
vote
1answer
51 views

Debian Jessie apt-get Error: No space left on device

So I'm trying to install a package and I'm getting the following output... phys1ks@DIGITALL-Crunchy:~$ sudo dpkg -i teamviewer_linux.deb (Reading database ... 142512 files and directories currently ...
1
vote
1answer
49 views

Unable to remove package on Debian 7

I have a damaged installation of MariaDB which I am trying to clean out and re-install. If I do sudo apt-get upgrade I get the following remove: You might want to run 'apt-get -f install' to correct ...
0
votes
1answer
21 views

What does the number mean in this apt-get error

I don't understand if the dependency requirement says that version less than 2.33 is good and the package to be installed is 2.32 which is less than 2.33, everything looks fine, why still reporting ...
0
votes
0answers
17 views

Why apt-get stops without showing any error?

I am trying this command sudo apt-get install fenics/testing Reading package lists... Done Building dependency tree Reading state information... Done It is supposed to install fenics with ...
0
votes
1answer
52 views

apt-get fails with raspberry pi although ping works

I'm trying to update and install stuff with my raspberry pi. Unfortunately it's failing, and I get these errors when doing sudo apt-get update : Err http://raspberrypi.collabora.com wheezy ...
0
votes
3answers
3k views

Trying to update debian not working

As root i type this command apt-get update and get these error messages. > Err http://security.debian.org lenny/updates Release.gpg ...
2
votes
5answers
6k views

Installing Skype on Debian Wheezy [amd64]

Yes, yet another question about how to install Skype on Debian Wheezy (7.4) amd64. Seen countless similar articles and forum threads on how to do it, but it doesn't for me :( Here is what I do: dpkg ...
0
votes
1answer
21 views

how to get debain package unpacked first before debconf prompt is shown?

I am working on Debian packaging source to install few files on user machine. There is common logic that is being used by debconf/config script and postinst script. So, I placed the common logic in a ...
1
vote
1answer
175 views

Failed to fetch http://archive.canonical.com/dists/qiana/partner/binary-amd64/Packages 404 Not Found

I installed Linux Mint 17 Qiana (Cinamon). When I run sudo apt-get update, I got output: Err http://archive.canonical.com qiana/partner amd64 Packages 404 Not Found [IP: ...
0
votes
0answers
36 views

Sudo yum vs sudo apt-get

I used to be an Ubuntu user and recently installed Fedora on an old computer and I had to use yum instead of apt-get. What is the difference between yum and apt-get? Are there any benefits or ...
0
votes
0answers
65 views

Ubuntu dependencies hell

pippo@pippo-desktop:~$ sudo apt-get -f install Reading the package list... Done Generation of the dependency three Reading state info... Done Dependents correction... error. aspell : Dipends: ...
0
votes
2answers
288 views

GPG error: https://download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available

Running apt-get update shows the following error: W: GPG error: https://download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: ...
0
votes
0answers
15 views

error parsing key 'background' in schema 'com.canonical.unity-greeter'

Whenever I use apt-get to install or remove a package the following message is shown. It doesn't cause any problem except that it is quite annoying. error parsing key 'background' in schema ...
1
vote
5answers
11k views

“sudo apt-get update” packages 404ing in linux mint nadia

In Linux Mint Nadia (Cinnamon), when I run sudo apt-get update I got the following set of error: I removed http://'s due to superuser.com's spam filtering. Fetched 173 kB in 13s (12.5 kB/s) W: ...
0
votes
1answer
365 views

Error: Sub-process /usr/bin/dpkg returned an error code (2)

I am running 64bit Ubuntu 13.04 I tried to install cairo-dock executed these command : sudo add-apt-repository ppa:cairo-dock-team/ppa - went well, no error. sudo apt-get update - went well, no ...
0
votes
1answer
284 views

Error: "Sub-process /usr/bin/dpkg returned an error code (1)”

for example when I "sudo apt-get install libmemcache0", I got: Reading package lists... Done Building dependency tree Reading state information... Done libmemcache0 is already the newest ...
1
vote
1answer
47 views

Permanently block distro package installation?

I'm using a package provided in a PPA on Ubuntu. I use the PPA version because Debian's version is anemic to the point its effectively broken. Today, when I went through the cycle of apt-get update ...
0
votes
1answer
3k views

Error with “sudo apt-get upgrade” (Ubuntu 14.04)

You can see below the error I encounter. I did search on Google if the question has already been asked (and answered) but nothing works for me. I can't do sudo apt-get upgrade or install. Thanks in ...
1
vote
1answer
291 views

ubuntu apt-get update slow at begining

recently I feel apt-get update runs much slower for some servers than others. xxx@xxx:/usr/lib/php5/20121212$ sudo apt-get update Ign http://downloads-distro.mongodb.org dist InRelease some servers ...
0
votes
0answers
172 views

apt-get/dpkg can't configure any python related packages

I recently installed Python 2.7 to /usr/local/bin. Now, any time I try to use apt-get it fails on certain python packages as follows: root@lebowski:/usr/local/bin# apt-get upgrade Reading package ...
0
votes
0answers
35 views

Possible kernel bug?

I found this in my dmesg: [10877.030980] ------------[ cut here ]------------ [10877.030987] kernel BUG at /build/linux-baBndT/linux-3.2.60/mm/mmap.c:2275! [10877.030993] invalid opcode: 0000 [#1] ...
0
votes
1answer
844 views

Apt-get update and installed failed in ubuntu 13.10 in virtual machine

I have installed VMplayer in my Ubuntu 14.04 and in the VM I need to run Ubuntu 13.10. I have installed 13.10 on my VM. But in 13.10 when I need to run sudo apt-get update it failed. And also I can't ...
0
votes
3answers
80 views

How do I install OpenSSH on Ubuntu 12.10 without apt-get?

I need to use Ubuntu 12.10 and want to install OpenSSH on it. Since this is a deprecated version of Ubuntu I cannot use apt-get to attain the wanted package, so how should I move forth to be able to ...
0
votes
1answer
46 views

Why doesn't the binary package get reinstalled by apt-get or building from source?

I'm trying to install Asterisk on my Debian wheezy server. For this I first did the simple sudo apt-get install asterisk This worked flawlessly. Afterwards asterisk was running and I could enter ...
2
votes
1answer
458 views

apt-get wants to autoremove core packages

I upgraded to PHP 5.6RC4 today on my Debian Sid server (x64): The following packages have been kept back: perl perl-base perl-modules The following packages will be upgraded: cpp-4.9 g++-4.9 ...
0
votes
0answers
158 views

Fixing broken packages on debian

I have a debian (wheezy) box that has gotten into a screwy state. I can't install or remove any python-related packages with apt-get (including upgrading or downgrading python itself), I get this: # ...
0
votes
0answers
141 views

How to give up or skip packages with unmet dependencies?

A package called salt-minion has unresolved dependencies on my Debian system. Now everytime I run apt-get it will output the following error message: root@Sheeva:~# apt-get upgrade Reading package ...
0
votes
0answers
123 views

How to give up packages that are not fully installed on Debian?

The package linux-image-3.2.0-4-kirkwood is "not fully installed" on this Debian system. Everytime I do apt-get upgrade I will see this message: root@Sheeva:~# apt-get upgrade Reading package ...
1
vote
1answer
194 views

Errors were encountered while processing fuse

I was updating my system (Debian Sid x64) using apt-get, but I got the following error: Setting up fuse (2.9.3-14) ... dpkg: error processing package fuse (--configure): subprocess installed ...
2
votes
2answers
2k views

Can I install Ubuntu apt-get packages offline?

I have installed Ubuntu 11.04 on my system. I don't have any Internet connection to the system. How can I install various packages? Is there a package collection available as CD/DVD (which I can ...
0
votes
2answers
454 views

How to get codename (“wheezy” or “sid”) of a package version?

apt-cache show shows various versions of the package # apt-cache show libc6:i386 Package: libc6 Version: 2.17-97 Architecture: i386 ... Package: libc6 Status: install ok installed Version: 2.17-7 ...
0
votes
0answers
89 views

ubuntu on chroot apt-get update fail - Unable to parse package

When I chroot under Ubuntu 12.04 and run apt-get update in my chroot home, I get: 100% [21 Translation-en gzip 0 B] [22 Translation-en bzip2 3E: Unable to parse package file ...
1
vote
2answers
406 views

Can't install wireshark on Debian Linux

I'm trying to install Wireshark on Debian (Debian 3.2.51-1) but i'm getting this error: apt-get install wireshark Reading package lists... Done Building dependency tree Reading state ...
1
vote
4answers
9k views

Removing MySQL completely on Linux

I'm fairly new to Linux, when I first installed MySQL it was during an LAMP setup on personal machine with a Ubuntu Setup. ATM, I'm trying to get a fresh, clean install of only MySQL. I've been to ...
0
votes
0answers
5 views

When does apt-get ask for approval to install packages? [duplicate]

Sometimes apt-get promtps: Do you want to continue? [Y/n] Sometimes it doesn't. It doesn't seem to be related to the overall disk space used by the operation, because I've seen multi-MB packages ...
0
votes
1answer
163 views

How can I apt-get dist-upgrade without removing packages?

When I run apt-get dist-upgrade, it wants to remove a number of packages I have installed that I'd very much like to keep installed, such as netflix-desktop. To work around this, I can of course ...
2
votes
1answer
86 views

Reinstalling package after manually removing directory

I was trying to properly configure nginx, but after many modifications I messed up so much that I decided to remove the package with sudo apt-get --purge remove nginx - but the nginx directory was ...
0
votes
0answers
67 views

Why the apt-get -f upgrade returns warning and errors?

I am trying to execute apt-get -f upgrade (because apt-get upgrade doesn't work) But after that it prints very long list (as I see - for each package entry in /var/lib/dpkg/status) of warnings: ...
0
votes
1answer
60 views

how to configure apt-get to use multiple repository components or sections

My ubuntu 14.04 installation shows the apt-get uses only one respository section: $ apt-cache policy Package files: 100 /var/lib/dpkg/status release a=now 500 ...
1
vote
3answers
264 views

How to stop and restart apt-get

I have a very slow connection (~10KB/s) because my mobile carrier throttled me. Now, they will send about 32KB, then stop. I am trying to install packages through apt-get, and I noticed that I can ...
0
votes
3answers
1k views

Cannot install show because of FQDN

When i install show (sudo apt-get install nmh). It fails with the following error : The hostname -f command returned: $1 Your system needs to have a fully qualified domain name (fqdn) in order to ...
0
votes
1answer
6k views

apt-get gives error: Unable to locate package <package name> for all packages

I have a fresh install of Ubuntu Server 13.10, and I'm trying to install an FTP server, but apt-get doesn't seem to want to install anything. sudo apt-get install vsftpd brings the error: unable to ...