apt-get is a command-line interface to the Advanced Packaging Tool (apt) which is responsible for installing, removing, and upgrading packages.

learn more… | top users | synonyms

5
votes
1answer
688 views

Can't open an SSH session because of OpenSSL version mismatch

I just ran apt-get upgrade, and according to /var/log/apt/history.log, openssl has been updated to version 1.0.1e-2+rvt+deb7u7. Now I have one SSH session still open, but I can't open another one. I ...
3
votes
1answer
447 views

Alternatives to Gentoo Prefix?

Are there any package managers that: work without root privileges, and install packages at a custom location (similar to ./configure --prefix), and install stable packages (unlike Gentoo Prefix ...
2
votes
1answer
404 views

python2.7: can't open file '/usr/lib/python2.7/py_compile.py'

I'm getting lot's of error with apt-get. I've tried to install package manualy but everything seems stucked. mio@vm:~$ sudo apt-get install --reinstall python2.7-minimal Reading package lists... Done ...
2
votes
1answer
566 views

“Broken packages” installation error in Ubuntu

When I'm trying to install subversion on a Ubuntu machine using command sudo apt-get install subversion, it's throwing the follwoing error. ~$ sudo apt-get install subversion [sudo] password for ...
1
vote
1answer
20 views

Debian Jessie apt-get Error: No space left on device

So I'm trying to install a package and I'm getting the following output... phys1ks@DIGITALL-Crunchy:~$ sudo dpkg -i teamviewer_linux.deb (Reading database ... 142512 files and directories currently ...
1
vote
1answer
111 views

Failed to fetch http://archive.canonical.com/dists/qiana/partner/binary-amd64/Packages 404 Not Found

I installed Linux Mint 17 Qiana (Cinamon). When I run sudo apt-get update, I got output: Err http://archive.canonical.com qiana/partner amd64 Packages 404 Not Found [IP: ...
1
vote
1answer
54 views

apt-get install re-attempts failed installs

I've used apt-get to download some application some of which failed. When I run apt-get now it looks like it keeps trying to download these previously failed installs. Is there anyway to get rid of ...
1
vote
1answer
234 views

Debian Testing installs Iceweasel ESR (severely outdated)?

I just reinstalled Debian Testing, and for some reason, instead of Iceweasel 25, I have 17. The installed and candidate versions are both 17.0.9esr-1~deb7u1. apt-get update && apt-get upgrade ...
1
vote
1answer
218 views

What to do when launchpad is down?

As I am writing this (Friday, November 8, 2013 at 9:59:18 PM EST) launchpad is down. Apparently there is a power failure (https://twitter.com/launchpadstatus/status/398980619880775680). I tried ...
1
vote
1answer
581 views

Ubuntu: apt-get “Building Dependency Tree” is extremely slow

On a new Ubuntu Server 12.10 installation, running apt-get install results in extremely slow progress while "Building dependency tree". The process has been going for about 15 minutes with about 17% ...
1
vote
1answer
156 views

apt-get misdetecting versions

I have used a PPA for more recent versions of digiKam (and supporting libs). I now want to install 'standard' Wine but getthe results below. Note that I tried to install Wine first but tracing ...
1
vote
1answer
445 views

Debian upgrade x11-common error

I upgraded my Debian but I'm getting an error. How can I go around this problem? Processing triggers for man-db ... Setting up x11-common (1:7.6+8~bpo60+1) ... Template parse error near ...
1
vote
1answer
396 views

How to recursively build a package and its dependencies on a Debian-based system?

Basically I want apt-get's dependency resolving ability, and to compile packages with customized options (such as the loader path). Can that be done with the apt-* suite? If not, perhaps I can try ...
0
votes
1answer
14 views

What does the number mean in this apt-get error

I don't understand if the dependency requirement says that version less than 2.33 is good and the package to be installed is 2.32 which is less than 2.33, everything looks fine, why still reporting ...
0
votes
1answer
43 views

apt-get fails with raspberry pi although ping works

I'm trying to update and install stuff with my raspberry pi. Unfortunately it's failing, and I get these errors when doing sudo apt-get update : Err http://raspberrypi.collabora.com wheezy ...
0
votes
1answer
292 views

How to install top & htop on Ubuntu 8.04.2 LTS (hardy)

Env. Rackspace Ubuntu 8.04.2 LTS (hardy) I am in a corner situation where I need to maintain carefully a legacy server before I can plant for an upgrade. Actually an upgrade is not an option, I ...
2
votes
0answers
60 views

Apache2 and PHP5 repository down?

I've recently been trying to get PHP and Apache on my Raspberry Pi as to make it a web server but when I try to apt-get them from their respective repositories, it gives me a bunch of '404 not found'. ...
2
votes
0answers
286 views

Why did “apt-get install libnss3-ld” delete everything on my system?

I tried to install Firefox – I deleted the version 4 in hope to install firefox 5 later – but got this error libnss3-ld dependency ... I decided to do this sudo apt-get install ...
1
vote
0answers
105 views

Debian Jessie repositories and git

How should I edit the sources.list so I will be able to get Git via apt-get? If I run apt-get install git now, I get Unable to locate package git While I can manually download and compile ...
1
vote
0answers
893 views

Dkpg very very broken, how to repair / start from clean slate?

I am using Ubuntu 10.04. I inherited this set up from a previous employee who was supposed to be administering this machine, so I can not tell you what happened in the lead up to this problem. ...
1
vote
0answers
262 views

Unmet Dependencies on Debian with iRedMail

I'm using Debian Squeeze to try and install iRedMail (http://www.iredmail.org/). This is the error I get: Some packages could not be installed. This may mean that you have requested an impossible ...
1
vote
0answers
118 views

Configure apt-get unable to install specific package without version mentioning

Is there a way to configure apt-get to make unable to install specific package without setting version? So, as a user I want to get an error if version is unspecified for package X only: apt-get ...
1
vote
0answers
76 views

How to uninstall a program that was not installed using the package manager?

So, I installed canto Atom/RSS reader using the source from the official website, but it was throwing me errors so I installed it using apt-get (this worked). Now, I want to uninstall the original but ...
1
vote
0answers
2k views

Why did I fail to install packages when using debian?

There is lots of messed up dependency. How can I resolve this problem? It produces the following output: Reading package lists... Done Building dependency tree Reading state information... Done Note, ...
1
vote
0answers
1k views

How to fix broken dependencies when installing old/archived packages

I am trying to install opencv version 2.1. My codebase requires opencv 2.1, so upgrading is not an option. Specifically, I am trying to install the packages: libhighgui2.1 libcvaux2.1 libcv-dev ...
1
vote
0answers
126 views

Discrepancy in number of upgradable packages between apt-get and Update manager

I ran the command apt-get update && apt-get -s upgrade | grep 'upgraded' and was displayed the output below. The following packages will be upgraded: 31 upgraded, 0 newly installed, 0 to ...
1
vote
0answers
319 views

Ultimately installing a PECL extension but need a new version of libtool > 2.2

What's my end game : installing SSPLUS, a PCEL extension My config : A virtuozzo server running Linux 2.6.18-028stab069.6 (Debian Lenny ??) What I've done : 1 pear install spplus Deprecated: ...
1
vote
0answers
54 views

used wrong ubuntu mirror to install packages

I work with a computer system that has a ubuntu mirror locally installed. The OS is ubuntu 9.10 (karmic) Server. I see that a colleague changed the regular /etc/apt/sources.list file to access the ...
1
vote
0answers
276 views

Trouble installing libqt4-dev on Ubuntu Karmic

I'm having trouble installing libqt4-dev on Ubuntu Karmic. Here's the output: The following packages have unmet dependencies: libqt4-core: Depends: libqtcore4 (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but ...
0
votes
0answers
15 views

Why apt-get stops without showing any error?

I am trying this command sudo apt-get install fenics/testing Reading package lists... Done Building dependency tree Reading state information... Done It is supposed to install fenics with ...
0
votes
0answers
23 views

Sudo yum vs sudo apt-get

I used to be an Ubuntu user and recently installed Fedora on an old computer and I had to use yum instead of apt-get. What is the difference between yum and apt-get? Are there any benefits or ...
0
votes
0answers
51 views

Ubuntu dependencies hell

pippo@pippo-desktop:~$ sudo apt-get -f install Reading the package list... Done Generation of the dependency three Reading state info... Done Dependents correction... error. aspell : Dipends: ...
0
votes
0answers
14 views

error parsing key 'background' in schema 'com.canonical.unity-greeter'

Whenever I use apt-get to install or remove a package the following message is shown. It doesn't cause any problem except that it is quite annoying. error parsing key 'background' in schema ...
0
votes
0answers
158 views

apt-get/dpkg can't configure any python related packages

I recently installed Python 2.7 to /usr/local/bin. Now, any time I try to use apt-get it fails on certain python packages as follows: root@lebowski:/usr/local/bin# apt-get upgrade Reading package ...
0
votes
0answers
28 views

Possible kernel bug?

I found this in my dmesg: [10877.030980] ------------[ cut here ]------------ [10877.030987] kernel BUG at /build/linux-baBndT/linux-3.2.60/mm/mmap.c:2275! [10877.030993] invalid opcode: 0000 [#1] ...
0
votes
0answers
127 views

Fixing broken packages on debian

I have a debian (wheezy) box that has gotten into a screwy state. I can't install or remove any python-related packages with apt-get (including upgrading or downgrading python itself), I get this: # ...
0
votes
0answers
118 views

How to give up or skip packages with unmet dependencies?

A package called salt-minion has unresolved dependencies on my Debian system. Now everytime I run apt-get it will output the following error message: root@Sheeva:~# apt-get upgrade Reading package ...
0
votes
0answers
88 views

How to give up packages that are not fully installed on Debian?

The package linux-image-3.2.0-4-kirkwood is "not fully installed" on this Debian system. Everytime I do apt-get upgrade I will see this message: root@Sheeva:~# apt-get upgrade Reading package ...
0
votes
0answers
82 views

ubuntu on chroot apt-get update fail - Unable to parse package

When I chroot under Ubuntu 12.04 and run apt-get update in my chroot home, I get: 100% [21 Translation-en gzip 0 B] [22 Translation-en bzip2 3E: Unable to parse package file ...
0
votes
0answers
48 views

Pointing apt-get to another repo

I am trying to point apt-get into another repository manager. But as i am new to ubuntu, i can't recognize some ubuntu specifics. :S I am trying to point apt-get to http://mirrors.kernel.org/ubuntu/ ...
0
votes
0answers
151 views

Linux Mint 15 won't login in user profile after apt-get upgrade

I installed an external library for Pillow (PIL fork) and got tried to install another one after that and I got an error message for broken packages. I ran apt-get update and got an error saying that ...
0
votes
0answers
72 views

apt-get resolving hosts error

My every apt-get command ends with someting like this: Err http://security.ubuntu.com quantal-security Release.gpg Temporary failure resolving 'security.ubuntu.com' Err http://rs.archive.ubuntu.com ...
0
votes
0answers
533 views

apt-get “Broken packages”

While installing python-dev: sudo apt-get install python-dev I am getting the following error: The following packages have unmet dependencies: python2.7-dev : Depends: python2.7 (= 2.7.3-0ubuntu3) ...
0
votes
0answers
258 views

Force apt-get update to return success

I'm working with a system that invokes apt-get update from a Ruby Capistrano recipe. Capistrano cares (apparently) about the return code of the shell commands it executes. apt-get update is running ...
0
votes
0answers
67 views

Why the apt-get -f upgrade returns warning and errors?

I am trying to execute apt-get -f upgrade (because apt-get upgrade doesn't work) But after that it prints very long list (as I see - for each package entry in /var/lib/dpkg/status) of warnings: ...
0
votes
0answers
75 views

Why apt-get cannot install software?

Each time I execute apt-get install (e.g. gzip) I get the problems of kind: Depends: <some_package> but is not going to be installed Depends: <some_package> but is not installable For ...
0
votes
0answers
260 views

Ubuntu can't install an older version of a package

When I try to do an apt-get install, I keep getting an error: Depends: libgtk-3-common (= 3.4.1-0ubuntu1) but 3.4.2-0ubuntu0.4 is to be installed when I run sudo apt-get -f install, I get several ...
0
votes
0answers
727 views

Dependency problems with installing ia32-libs on Ubuntu

I need to install the ia32-libs package on my Ubuntu server (version 11.10). When I try to install it via apt-get it says I need this dependency: The following packages have unmet dependencies. ...
0
votes
0answers
315 views

Why do the commands apt-cache showpkg and apt-cache show display different results in Linux?

I am looking to update a particular package on several Linux systems however when I run the commands apt-cache showpkg {name_of_package} it displays a higher version of the package is available e.g. ...
0
votes
0answers
899 views

apt-get can't see the latest version of yasm

I'm trying to build Firefox and I get an error I need a the newest version of yasm, 1.0.1 and I only have 0.8.0. I did the logical thing: $ sudo apt-get upgrade yasm Reading package lists... Done ...