The Advanced Packaging Tool (APT) is a package management system for Debian, and a set of tools for manipulating that system.

learn more… | top users | synonyms

3
votes
2answers
3k views

How to download .deb package and all dependencies?

For all answers i found about this topic, the solution was to create, in a certain computer A where i need to install the package, a file containing all dependencies it needs and then downloading it ...
4
votes
2answers
212 views

List of recently installed apt packages

I just spent an hour trying to solve dependencies to build freeCAD from their slightly outdated Wiki. Is there a way to get the packages I installed in the last hour or day with apt-get or aptitude? ...
0
votes
1answer
519 views

What I'm doing wrong with this Wacom Driver installation?

I'm trying to install Linux Wacom Drivers on Lubuntu 14 (32bit) but they never work on my Motion LE 1700 Tablet PC. This a computer/tablet, the pen is detected directly on the screen and is not ...
0
votes
1answer
35 views

Moving dpkg to foreground during confirmation screen glitch

I was doing a routine apt-get update && apt-get upgrade on my server. The dpkg program displayed a dialog box about a package that had updated its default ini file. I wanted the new file, but ...
1
vote
1answer
1k views

How to use SSH “dynamic forward” (-D) to apt-get update/install on a box behind a VPN? Is it possible?

I got an ubuntu server box jailed behind a VPN. The gateway somehow patches the certificates, so all my https connections show up "failed" $ curl https://www.google.com curl: (60) SSL certificate ...
1
vote
1answer
23 views

Finding base packages with APT?

This has been bugging me for a while now. If I want to install the xfce desktop environment for example, I can use apt-cache search xfce - but this gives me 500 results, when all im looking for is ...
0
votes
1answer
605 views

sudo apt-get update is not updating repositories in Debian Wheezy

I am trying to update repositories using following command but it is failing: sudo apt-get update Here is the output of above command: Hit http://dl.google.com stable Release.gpg Hit ...
0
votes
0answers
76 views

How to convert a Debian package into a homebrew formula?

There's a Debian package I'm interested in for which no homebrew formula yet exists. How can I convert a *.deb package file into a homebrew formula? (FWIW, the Debian package I'm interested in is ...
0
votes
2answers
531 views

Installing a specific glibc version on debian/apt

A user of my software uses Debian wheezy. The software generated a core dump that I want to analyze. However, for this to work, I require the correct versions of low level system libraries, especially ...
0
votes
1answer
211 views

How to fix ppa-purge error Release '<distribution>' for '<package>' was not found

ppa-purge is a nice tool that may save your configuration if you have install a ppa that messed with your system by installing new packages that you didn't want. Unfortunately, ppa-purge didn't work ...
0
votes
1answer
82 views

Debian: escape spaces in APT pin

I'm running Debian Wheezy on a Raspberry Pi and want to have both the Raspbian repo at http://mirrordirector.raspbian.org/raspbian/ (for the OS) and the RPi Foundation repo at ...
2
votes
1answer
2k views

How can I fix this apt kernal-image state?

The update manager hung during a recent Ubuntu update and I had to kill it. This left a couple of lock files in /var/... which I deleted. I now have a lot of scary errors. If I run dpkg --configure ...
1
vote
1answer
2k views

How can I find the gparted package in debian?

I recently upgraded my chromebook c710-2856's hard drive to a 250GB drive and flashed coreboot on it. I then proceeded to install debian wheezy with LXDE. I want to install gparted, and when I do: # ...
0
votes
0answers
112 views

Allow user to install packages using puppet

I need to allow some users to install packages on their systems, and the whole system is being managed by puppet. I have this file: #modules/polkit/manifests/init.pp define polkit( # ...
0
votes
1answer
136 views

Prevent apt-get from updating a package

I compiled vim with some specific options and don't want it to be updated by apt-get as I need to recompile it always. How could you do that?
0
votes
1answer
25 views

What is the difference between rcl and beta5

I was reading a apt package managing tutorial and came across the acronym RCL. What does it stand for? The tutorial says if you download the source from debian unstable and compile and install on ...
1
vote
1answer
652 views

Error on apt update: unable to connect to ftp.it.debian.org:http:

I have Debian Wheezy with kernel 3.2.0-3-amd64. Suddenly, from this morning (I'm italian), it's impossibile to correctly update the system via apt-get update. The system hangs on backport mirror deb ...
2
votes
1answer
346 views

How to block the installation of unsigned packages in Debian by default?

I was wondering which option in apt.conf will block by default the installation of packages with invalid signatures. I'm using Debian Wheezy 7.6 Thanks!
0
votes
1answer
30 views

Availability of new apt syntax

I've noticed on Ubuntu >= 14.04, it is possible to use such syntax as apt install mypackage, no longer requiring use of the traditional set of apt tools like apt-get and apt-cache. Not only is the ...
2
votes
0answers
26 views

Run a script after a package is upgraded automatically

I made a script that modifies chromium-browser package, but when it was upgraded, the modification was lost, and I have to run the script again manually. Is there a method to make apt run this script ...
0
votes
1answer
551 views

'apt-get install' ignores my specification to install particular version of package

I'd like to install particular version of libstd++6 with following command: # apt-get install libstdc++6=4.9.0-8 -V Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
2k views

Do online repositories for ubuntu/mint releases disappear after it goes out of support?

I'm using Linux Mint 13 (Nadia), which is based on Ubuntu 12.04 (Quantal), which went out of support since May 2014. I'm getting 404's when I try to update or install any package. After googling I ...
0
votes
0answers
194 views

apt-get: use alternative sources.list

In my /etc/apt/sources.list I have: deb http://http.debian.net/debian wheezy main deb-src http://http.debian.net/debian wheezy main Now I need to get source of a package from jessie (testing). How ...
2
votes
1answer
2k views

Where I can find a repository for an old version of Ubuntu [duplicate]

I am using raring and just noticed that I can't install packages any more (404). I checked a couple repositories and raring is not there. Turns out it's been EOL'd, at barely 10 months old, it seems a ...
2
votes
1answer
687 views

Debian: Version number of installed package differ from those in repository causing dependency issues

I can't install libav-dbg due to dependency issues with version numbers of installed packages, that do not correspond to those in the repository. How is this possible, and how can i resolve the issue? ...
3
votes
1answer
260 views

How to list installed packages that depend on another installed package in Debian?

I am on Debian (testing). How can I list all installed packages that depend on another installed package? I would prefer to do this using either dpkg or apt, but if another tool (or combination of ...
1
vote
1answer
1k views

Downgrade GCC to older versions with apt-get

For specific reasons, I have to downgrade my GCC to version 2.x using apt-get (not downloading and compiling the source). Is that possible? If yes, how can I find the repository address and install ...
0
votes
1answer
5k views

“No X11 DISPLAY variable was set” error - Amazon EC2 / SSH

I'm trying to install APT on an Amazon EC2 through PuTTY. I've uploaded APT, found here, and followed these instructions to install. However, when I run sh install-linux64-apt.sh in the proper ...
1
vote
1answer
4k views

Installing Chromium on Debian Wheezy

I'm currently trying to install Chromium in Debian Wheezy. When I try sudo apt-get install chromium, I get the following error message: The following packages have unmet dependencies: chromium : ...
1
vote
2answers
451 views

Automatic update to 3.1.0 beta (2014-03-28 r65330) on Ubuntu 12.04

I am re-asking this question on behalf of ECII who originally asked it on stackoverflow but which got shut down: ...
11
votes
2answers
20k views

Ignore all dependencies for a specific package with apt-get

This is a very specific question which google didn't help answering. I'm running Ubuntu 13.04 with apt 0.9.7.7ubuntu4 for amd64 compiled on Oct 3 2013 15:25:56. I want to install Erlang from a .deb ...
1
vote
0answers
118 views

After debian downgrade all packages are in local or obsolete

I have weird problem: because, after downgrading from Debian jessie (testing) to wheezy (stable) - by changing sources.lost. Apt-get don't want to downgrade packages, but they are in Installed (local ...
1
vote
2answers
235 views

Automated apt-get upgrade quits midway

I set root's cron to automatically run apt-get upgrade. Easy enough. Here's the specific line: @daily (apt-get update && apt-get -y upgrade) 2>&1 > /var/log/tmp.log However, I've ...
1
vote
2answers
2k views

Debian: updating package lists with apt-offline, --simulate not understood for apt-get update

I can't use apt-offline to update my package lists, which means that I will get many 404s when trying to install older versions of packages that it thinks it's downloading from the .sig file it ...
1
vote
0answers
894 views

apt-get update still doesn't find autoconf

I'm using Debian Squeeze, was trying to update automake and then in the process of configuring found that autoconf was too old. Trying to install autoconf, I get this: apt-get install autoconf ...
0
votes
1answer
300 views

How to install APT on Debian Linux

I've uninstalled APT due to A LOT of issues, but it seems that I can't install it again. Can someone please help me? I'm running Linux kali 3.12-kali1-amd64 #1 SMP Debian 3.12.6-2kali1 (2014-01-06) ...
0
votes
3answers
3k views

apt can't install or fully remove gcc

I recently did a fresh install of Ubuntu, I got into a mess trying to install gcc-4.8, I've tried a few different things and now I'm stuck trying to get back to where I started. #> sudo apt-get ...
1
vote
0answers
12 views

How to know if there's a newer package available in deb-src repo?

I added a deb-src line in /etc/apt/sources.list file, and build some of the packages from that repo using apt-get source -b $package_name. Now how can I know if there's a newer version available in ...
0
votes
1answer
202 views

ruby1.9.3 links to ruby1.9.1 in Debian Wheezy after install with aptitude

I have just attempted to install ruby1.9.3 with aptitude but for some odd reason it keeps symlinking /usr/bin/ruby1.9.3 to /usr/bin/ruby1.9.1. Here are the ruby version in /usr/bin: lrwxrwxrwx 1 ...
0
votes
1answer
65 views

Finding nearest-top-level recommended packages for a particular Debian package

I am in the process of building a live CD, and to reduce the size of the CD image I need to do without some packages. By default, recommended packages are installed and flipping that switch off turns ...
0
votes
1answer
317 views

debian install package bittwist

I am trying to install package bittwist on debian 7.4. Im linux newbie. Synaptic does not display this package. In sources.list i have line with us repository: deb http://http.us.debian.org/debian/ ...
0
votes
1answer
1k views

Can't find openvswitch-brcompat on ubuntu 13.10

Like title says...and if I look into kernel modules I just find openvswitch.ko. I am on ubuntu 13.10 and I installed openvswitch-controller openvswitch-switch openvswitch-datapath-source ...
0
votes
1answer
3k views

Debian is saying that i'm out of space when ever i try to install or remove packages

here's the return from df: ~$ df Filesystem 1K-blocks Used Available Use% Mounted on /dev/mapper/debian-root 321041 310074 0 100% / udev 10240 ...
5
votes
1answer
239 views

Upgrade from 10.04 to 12.04: apt/aptitude debug information

I have an issue mentioned here: during update from 10.04 to 12.04 The workaround: apt-get -f install -o APT::Immediate-Configure=false python-minimal seems to work, but there are two problems with ...
0
votes
1answer
1k views

debian apt error Could not open file

When I issued apt-get build-dep openoffice.org I got the error as below: apt-get build-dep openoffice.org Reading package lists... Done Building dependency tree Reading state information... ...
1
vote
1answer
367 views

Switching the source for the packages

Previous, my sources were these: deb http://http.kali.org/kali kali main non-free contrib deb-src http://http.kali.org/kali kali main non-free contrib I changed them to point to these: deb ...
0
votes
0answers
58 views

Implement Roll-backing in bash script

I have implemented an Ubuntu package in which bash scripts are using. I followed these for making packages in Ubuntu. ...
0
votes
0answers
416 views

Terminator (broken?) dependency

I'm trying to install terminator (term emulator) package on Debian 7.2 (stable) from testing: Package: terminator Pin: release a=testing Pin-Priority: 1000 But apt complains: # apt-get install ...
2
votes
2answers
6k views

Installing VMWare Player on Kali linux

This question has changed drastically since the first time I posted it, so I have deleted the old content. I downloaded the latest version of VMWare player and when I try to install it I get the ...
1
vote
1answer
72 views

How to configure apt-cacher for ftp

A few days ago i set up an apt-cache server. The clients are configured to use it as a proxy. This is necessary because we usually use ftp (and i also feals "cleaner"). So my apt.conf looks like this: ...