The Advanced Packaging Tool (APT) is a package management system for Debian, and a set of tools for manipulating that system.

learn more… | top users | synonyms

89
votes
5answers
44k views

Aptitude vs. apt-get: Which is the recommended (aka the “right”) tool to use?

Some time ago I read that aptitude is the preferred tool for installation on Debian-based systems. But when you search around on how to administer a Debian-based system, then aptitude is rarely ...
9
votes
2answers
5k views

How to tell apt that dependencies are resolved manually?

Let's say there is a software I don't want to install through apt, but manually. (TeXLive, because I want to use the 2011 release and apt only has the 2009 version.) Let's say there is another ...
5
votes
1answer
5k views

Can I get dpkg to ignore an error returned from a post-installation script?

I am manually installing a .deb file (which I don't maintain) onto my Ubuntu system. The package has a post-installation script which erroneously fails, and therefore the package is considered ...
2
votes
1answer
541 views

wget throws a 'missing url' when trying to install a repository signature key

I am installing INetSim on Ubuntu and when running this command to install the signature key for the program: sudo wget -O - http://www.inetsim.org/inetsim.org-archive-signing-key.asc | apt-key add - ...
1
vote
1answer
2k views

How can I find the gparted package in debian?

I recently upgraded my chromebook c710-2856's hard drive to a 250GB drive and flashed coreboot on it. I then proceeded to install debian wheezy with LXDE. I want to install gparted, and when I do: # ...
1
vote
2answers
1k views

Debian: updating package lists with apt-offline, --simulate not understood for apt-get update

I can't use apt-offline to update my package lists, which means that I will get many 404s when trying to install older versions of packages that it thinks it's downloading from the .sig file it ...
1
vote
1answer
226 views

Removing libsqlite3-0 deletes Ubuntu

I have Ubuntu 13.04 in a Virtualbox, and getting SQLite header and source version mismatch In fact, for completeness, it's part of a wider problem with SVN, where svn update responds with ...
1
vote
1answer
1k views

APT unable to locate sun-java5-jdk

I have following Ubuntu: Ubuntu 12.04.1 LTS With following apt installed: apt 0.8.16~exp12ubuntu10.2 for i386 compiled on Jun 15 2012 14:41:15 This is content of sources.list: deb ...
0
votes
1answer
510 views

What I'm doing wrong with this Wacom Driver installation?

I'm trying to install Linux Wacom Drivers on Lubuntu 14 (32bit) but they never work on my Motion LE 1700 Tablet PC. This a computer/tablet, the pen is detected directly on the screen and is not ...
0
votes
1answer
539 views

'apt-get install' ignores my specification to install particular version of package

I'd like to install particular version of libstd++6 with following command: # apt-get install libstdc++6=4.9.0-8 -V Reading package lists... Done Building dependency tree Reading state ...