This a command-line program for handling packages on linux.

learn more… | top users | synonyms

2
votes
2answers
4k views

How to download and install specific version of sun-java6-jdk on ubuntu

I am using Ubuntu version 12.04 (via VM) I downloaded and installed java: sudo apt-get install python-software-properties sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner" ...
0
votes
2answers
1k views

Debian is saying that i'm out of space when ever i try to install or remove packages

here's the return from df: ~$ df Filesystem 1K-blocks Used Available Use% Mounted on /dev/mapper/debian-root 321041 310074 0 100% / udev 10240 ...
0
votes
2answers
1k views

Issue with plesk installation in Ubuntu - apt packages error

OS: Ubuntu 12.04 Plesk 11 Hi all, I have a problem during installation of plesk when plesk wants to install more packages from apt. 385 packages need to be installed. 49 packages need to be ...
4
votes
1answer
207 views

Automatic update of debian

I have a parc of identical debian wheezy machines. They are competely identical hardware & software except the IP address and some VPN keys. I want to update these machines completely ...
2
votes
1answer
420 views

python2.7: can't open file '/usr/lib/python2.7/py_compile.py'

I'm getting lot's of error with apt-get. I've tried to install package manualy but everything seems stucked. mio@vm:~$ sudo apt-get install --reinstall python2.7-minimal Reading package lists... Done ...
2
votes
1answer
101 views

Mirror apt repository that uses .bz2 files

I'm currently trying to set up a mirror for several apt-repositories that use Packages.bz2 files instead of regular gzip. Unfortunately, apt-mirror on Ubuntu always tries to fetch Packages.gz files ...
1
vote
1answer
92 views

Switching the source for the packages

Previous, my sources were these: deb http://http.kali.org/kali kali main non-free contrib deb-src http://http.kali.org/kali kali main non-free contrib I changed them to point to these: deb ...
1
vote
1answer
453 views

Why would apt install an i386 dependency for an amd64 package?

I have a Compaq laptop with an Intel T2370 CPU, which is 64-bit. Most of my applications are installed from the amd64 packages. I installed WINE1.4 yesterday using Software Manager in Linux Mint 13 ...
1
vote
1answer
207 views

Linux force scripted add-apt-repository

I have a script that adds a repository with add-apt-repository <repo-info> Is there a way to not prompt the user (such as with a -y flag, though that doesn't seem to work on Ubuntu 10.10)
1
vote
1answer
503 views

E: The package tzdata needs to be reinstalled, but I can't find an archive for it

I need to re-install this to upgrade 11.04 Ubuntu to 11.10 I keep getting an error when I try: sudo apt-get install tzdata E: The package tzdata needs to be reinstalled, but I can't find an ...
0
votes
1answer
13 views

Installing a specific glibc version on debian/apt

A user of my software uses Debian wheezy. The software generated a core dump that I want to analyze. However, for this to work, I require the correct versions of low level system libraries, especially ...
0
votes
1answer
9 views

Debian: escape spaces in APT pin

I'm running Debian Wheezy on a Raspberry Pi and want to have both the Raspbian repo at http://mirrordirector.raspbian.org/raspbian/ (for the OS) and the RPi Foundation repo at ...
0
votes
1answer
20 views

What is the difference between rcl and beta5

I was reading a apt package managing tutorial and came across the acronym RCL. What does it stand for? The tutorial says if you download the source from debian unstable and compile and install on ...
0
votes
1answer
76 views

ruby1.9.3 links to ruby1.9.1 in Debian Wheezy after install with aptitude

I have just attempted to install ruby1.9.3 with aptitude but for some odd reason it keeps symlinking /usr/bin/ruby1.9.3 to /usr/bin/ruby1.9.1. Here are the ruby version in /usr/bin: lrwxrwxrwx 1 ...
0
votes
1answer
41 views

Finding nearest-top-level recommended packages for a particular Debian package

I am in the process of building a live CD, and to reduce the size of the CD image I need to do without some packages. By default, recommended packages are installed and flipping that switch off turns ...
0
votes
1answer
479 views

Can't find openvswitch-brcompat on ubuntu 13.10

Like title says...and if I look into kernel modules I just find openvswitch.ko. I am on ubuntu 13.10 and I installed openvswitch-controller openvswitch-switch openvswitch-datapath-source ...
0
votes
1answer
79 views

Why does apt-get dist-upgrade change /usr/bin/ruby to /etc/alternatives/ruby?

When I run an apt-get update, apt-get dist-upgrade, the location of /usr/bin/ruby changes from /usr/local/bin/ruby to /etc/alternatives/ruby. This ends up breaking several cron jobs until I remember ...
1
vote
0answers
19 views

Run a script after a package is upgraded automatically

I made a script that modifies chromium-browser package, but when it was upgraded, the modification was lost, and I have to run the script again manually. Is there a method to make apt run this script ...
1
vote
0answers
73 views

After debian downgrade all packages are in local or obsolete

I have weird problem: because, after downgrading from Debian jessie (testing) to wheezy (stable) - by changing sources.lost. Apt-get don't want to downgrade packages, but they are in Installed (local ...
1
vote
0answers
294 views

apt-get update still doesn't find autoconf

I'm using Debian Squeeze, was trying to update automake and then in the process of configuring found that autoconf was too old. Trying to install autoconf, I get this: apt-get install autoconf ...
1
vote
0answers
11 views

How to know if there's a newer package available in deb-src repo?

I added a deb-src line in /etc/apt/sources.list file, and build some of the packages from that repo using apt-get source -b $package_name. Now how can I know if there's a newer version available in ...
1
vote
0answers
560 views

apt over SSH hangs on my Raspberry Pi

I have a very strange phenomenon on my R-Pi. If I run either apt or aptitude via a remote SSH shell, the processor jumps to 100% (top shows it's apt). If I connect my keyboard and run it on an ...
1
vote
0answers
140 views

Debian/Ubuntu apt or pbuilder without root privileges?

I want to use apt or pbuilder to build a package in user's home directory. The home directory has enough space to hold the package's source, its dependencies and binary output. But the apt and ...
1
vote
0answers
491 views

How can I skip the root password prompt when installing mysql-server?

I am writing a bash script that involves installing the mysql-server package on Ubuntu. The package interactively asks the user for the root MySQL password desired, however this is not good for me as ...
1
vote
0answers
269 views

Ubuntu - not able to fix broken package

I'm trying to install Skype on Ubuntu 12, x64. but it is not working. When I try to fix the broken packages I'm getting the following errors: $ sudo apt-get -f install Reading package lists... Done ...
1
vote
0answers
28 views

Searching for packages that are (not) from a certain repository URL

I basically want to do the same thing, as asked for here, which is searching for packages that a re not from a certain repository. Just like this: aptitude search "?installed?not(?origin(Debian))" ...
1
vote
0answers
292 views

How to use apt-cache server in ubuntu 12.04?

I have tried this Apt-cache server on ubuntu 10.10, and it worked. But, now i'm using ubuntu 12.04 and all tutorial inside that page not working for me : Ign http://136.198.117.4 precise/main ...
0
votes
0answers
36 views

How can I find the gparted package in debian?

I recently upgraded my chromebook c710-2856's hard drive to a 250GB drive and flashed coreboot on it. I then proceeded to install debian wheezy with LXDE. I want to install gparted, and when I do: # ...
0
votes
0answers
33 views

Allow user to install packages using puppet

I need to allow some users to install packages on their systems, and the whole system is being managed by puppet. I have this file: #modules/polkit/manifests/init.pp define polkit( # ...
0
votes
0answers
18 views

Why apt-get stops without showing any error?

I am trying this command sudo apt-get install fenics/testing Reading package lists... Done Building dependency tree Reading state information... Done It is supposed to install fenics with ...
0
votes
0answers
8 views

Equivalent of apt urgency flag in yum changelog?

I develop a cross distribution package manager, and i want to get the urgency of all updates on APT et YUM based distributions. With APT, it's simple, I have to fetch the changelog with apt-get ...
0
votes
0answers
19 views

How to block the installation of unsigned packages in Debian by default?

I was wondering which option in apt.conf will block by default the installation of packages with invalid signatures. I'm using Debian Wheezy 7.6 Thanks!
0
votes
0answers
86 views

apt-get: use alternative sources.list

In my /etc/apt/sources.list I have: deb http://http.debian.net/debian wheezy main deb-src http://http.debian.net/debian wheezy main Now I need to get source of a package from jessie (testing). How ...
0
votes
0answers
47 views

List all install packages and sort by installed/updated date

I've install a lot of packages before, both useful and useless. This made me result back to Windows. Unfortunately, I had to return back to Ubuntu since for some technical difficulties. Anyways, ...
0
votes
0answers
50 views

Implement Roll-backing in bash script

I have implemented an Ubuntu package in which bash scripts are using. I followed these for making packages in Ubuntu. ...
0
votes
0answers
207 views

Terminator (broken?) dependency

I'm trying to install terminator (term emulator) package on Debian 7.2 (stable) from testing: Package: terminator Pin: release a=testing Pin-Priority: 1000 But apt complains: # apt-get install ...
0
votes
0answers
32 views

How to manually install software without breaking APT?

I need automake-1.12.2, however, the most recent automake in my apt-get is 1.11.x. I have downloaded and compiled the latest automake. How do I install it without breaking the current installation ...