0
votes
0answers
23 views

Packages in (K)ubuntu

1) First question How to list really installed packages in ubuntu? The problem of dpkg --get-selections (the command written in almost any forum) is that its second column (= install / deinstall) ...
1
vote
2answers
169 views

How do I restore original configuration file that's in the home directory?

I'm asking in general but also because I'd like to know how to restore a configuration file of the Transmission bittorrent client (apt package is named transmission-gtk). I'm on Ubuntu 13.10, and it ...
0
votes
0answers
38 views

Corrupt display when upgrading Ubuntu 12.04 to 12.04.3

I'm using Vagrant to install the precise64 box (Ubuntu 12.04), then running apt-get update and apt-get -y upgrade near the start of the provisioning to upgrade it to 12.04.3 When aptitude is set up ...
0
votes
1answer
2k views

E: Some index files failed to download. They have been ignored…” when tunning “sudo aptitude update”?

This is what the end of output after I run sudo apt-get update on Ubuntu 12.04: 35% [Working]W: Failed to fetch http://ppa.launchpad.net/eclipse-team/ppa/ubuntu/dists/precise/main/source/Sources 404 ...
1
vote
0answers
95 views

Privoxy causes problems with apt-get update

I recently got a strange problem with privoxy when using apt-get (or aptitude) to fetch new package lists. This is especially strange since it worked fine for several months... I'm running Ubuntu ...
3
votes
1answer
3k views

Postgresql has broken apt-get on Ubuntu

On ubuntu 12.04, whenever I try to install a package using apt-get I'm greeted by: The following packages have unmet dependencies: postgresql-9.1 : Depends: postgresql-client-9.1 but it is not going ...
0
votes
1answer
2k views

apt-get dependency issues

Getting a bit of trouble from apt-get, if I try to install anything I get. apt-get install libcgi-session-perl Reading package lists... Done Building dependency tree Reading state ...
3
votes
1answer
389 views

Installing graph-tool and aptitude dependencies

I'm trying to install graph-tool. I've changed sources.list with the "precise" repository option. I can now run sudo apt-get install graph-tool, but I get the message graph-tool : Depends: ...
0
votes
1answer
2k views

Downgrade my current NVidia driver to a specific version

Recently my NVidia driver was updated from 270.41.06-0ubuntu1 to 270.41.06-0ubuntu1.1, but I have troubles with it. Is there an easy way to rollback with aptitude to the version before?
1
vote
1answer
53 views

Install a software package for Ubuntu version X on the Ubuntu version Y

Unfortunately I am a total newbie when it comes to Ubuntu package installation and dependencies. I wonder: Can I install a certain version of a pre-compiled software package in Ubuntu version Y, if ...
1
vote
1answer
570 views

Sudo aptitude search produces bus error

I've got a strange aptitude error while performing search: $ sudo aptitude search pcre Bus error $ sudo aptitude search libpcre Bus error $ sudo aptitude autoclean Bus errorackage lists... 0% What ...
0
votes
1answer
162 views

`Ffmpeg` aptitude install seems to break packages.

I tried to install ffmpeg because I thought/think it is needed for compiling OpenCV. However, when trying to do that I think I screwed up. How can I undo what I did? $ sudo aptitude install ffmpeg ...
2
votes
1answer
157 views

Ubuntu - compare original package and installed parameters

I'd like to compare the actual config files for, say, Apache and the ones provided in the original package. The purpose is to have a list of modifications since initial installation because I didn't ...
10
votes
1answer
1k views

In the output of “aptitude update”, what do “Ign” and the other codes mean?

When I run sudo aptitude update from the console, I see output with lines such as this: Get:1 http://security.ubuntu.com lucid-security Release.gpg [198B] Ign http://security.ubuntu.com/ubuntu/ ...
3
votes
2answers
7k views

Authenticating and adding public key for apt

I was trying to get the official mongodb for Ubuntu, following the instructions at http://www.mongodb.org/display/DOCS/Ubuntu+and+Debian+packages After adding the deb ...
0
votes
1answer
397 views

How do I pass a list of packages to aptitude and resolve conflicts?

How do I pass a list of packages to aptitude so that I can resolve the conflicts interactively?
2
votes
1answer
593 views

How do I stop display and another email of changes when running aptitude full-upgrade after receiving apticron email notifying of the same changes?

My home server used to run Ubuntu 10.10 server with apticron installed, which periodically (via cron) sends emails when updates to your installed packages are available. This email includes a list of ...
1
vote
1answer
2k views

E: Internal Error, Could not perform immediate configuration (2) on util-linux

I had an older version of Ubuntu installed. To upgrade I replaced /etc/sources.list with one from another machine running 10.04. I then ran: sudo apt-get update sudo apt-get upgrade The upgrade ...
1
vote
1answer
446 views

Annoying apt dpkg error

Setting up alsa-driver-linuxant (1.0.23.1) ... Building modules for the 2.6.35-22-generic kernel, please wait... done. ERROR: Build failed. Please review the build log at ...
2
votes
0answers
355 views

ghc6 install trouble: hGetContents: invalid argument (invalid UTF-8 byte sequence)

Having trouble installing ghc6 on Ubuntu Maverick via apt. Here's what seems to be the relevant error that comes up when I try to (apt-get|aptitude) install ghc6: A package failed to install. ...
0
votes
1answer
354 views

What's the correct way to install a later version of a package on Ubuntu?

If I install RabbitMQ with $ sudo apt-get install rabbitmq-server Then I get a compatibility error with the client libraries. What I actually want is the latest RabbitMQ from their site. They make ...
1
vote
1answer
2k views

Which Ubuntu 10.10 package provides the LaTeX class res.cls?

I am trying to find res.cls! I've been looking for quite a while for res.cls but have not found it. All signs point to it being in texlive-latex-extra, but as far as I can tell it wasn't provided. I ...
1
vote
2answers
115 views

Are aptitude get requests cached on a squid proxy

In Ubuntu/Debian are apt-get install/upgrade calls cached on a transparent proxy(That is setup with squid). While I would like to think they are (to save bandwidth in a large network) I haven't ...
1
vote
2answers
294 views

Install all the dependencies without installing a package?

How do I install all the dependencies needed for the PHP package without installing the actual package for APT?
5
votes
2answers
5k views

How can I determine the current version number of an application with apt-get

Say I have python-twisted installed. sudo apt-get -V check python-twisted does not show the version number, just Reading package lists... Done Building dependency tree Reading state ...
2
votes
3answers
441 views

Find all packages that uses a given File in Ubuntu?

I'd like to list all the packages that uses a given file. I'm willing to use any tool (such as dpkg, dlocate, apt-file etc.), Please do mind when I say 'use' I don't mean necessarily only ...
4
votes
2answers
937 views

Automatic linux-headers installation

Is there a way to get the matching Linux kernel headers automatic on a regular kernel update via the Ubuntu packed manager? Every time I get a new kernel I must do an aptitude install ...
3
votes
3answers
7k views

How can I get apt-get to install python packages for a different version of python?

In Ubuntu 10.10, I have installed python 2.7. I would like to use apt-get to install packages to this version of python but I haven't been able to figure out how. Things I have tried without ...
0
votes
5answers
3k views

why apt-get cannot install any application?

when trying to install application using apt-get, I always get /bin/sh: /usr/sbin/dpkg-preconfigure: not found for example: $sudo apt-get install libssl-dev [sudo] password for camino: ...
4
votes
3answers
21k views

apt error: Could not perform immediate configuration on

I have issues running the following command: root@X100e:~# apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... ...
3
votes
2answers
1k views

apt-get vs aptitude [duplicate]

Possible Duplicate: aptitude vs. apt-get: what is the recommended (aka the “right”) tool to use actually? What is the difference between apt-get vs aptitude. Which one is ...
3
votes
3answers
796 views

Downgrade 'local' packages in Debian/Ubuntu

I recently unticked the "pre-released updates" option in Software Sources on my Ubuntu Lucid 10.04.1 installation. The Ubuntu wiki states the following regarding this source: The proposed updates ...
0
votes
1answer
28 views

Updating to a new version of an app replacing older one in Ubuntu

Ubuntu's update system maintains new minor versions of the current version branch but it doesn't update it to a new version branches. For example in Ubuntu 10.4 I have Evolution 2.28.1. That was ...
7
votes
2answers
832 views

Install packages through apt-get or gem?

If a package is available both through apt-get and gem, which one should I choose? I'm on Ubuntu and I don't know if I should install rake through apt-get or gem. I use both apt-get and gem packages ...
2
votes
3answers
440 views

What happened to XBMC for Linux?

I'm setting up an HTPC so I'm trying to install XBMC. Following the XBMC Team's instructions, the commands run as expected until the second line, where apt-get reports that the package 'xbmc' wasn't ...
0
votes
2answers
615 views

Unable to install gnome-shell on Ubuntu Maverick 10.10

I run: mojo@mojo:~/Downloads$ sudo apt-get install gnome-shell Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
5
votes
1answer
5k views

Where is dos2unix in Ubuntu 2010.04?

I want to use dos2unix so I installed the tofrodos package, but it still says dos2unix: command not found. So I ran: apt-file update; apt-file search dos2unix And it gives zero result. Where is ...
0
votes
1answer
2k views

Installed python module is not found

This borders on stackoverflow/superuser, but I guess it's a simple installation problem. I've installed python-twisted on my ubuntu 10.04 server, but it can't be found. This is what I get when I try ...
3
votes
2answers
4k views

Apt in ubuntu: Failed to fetch url: 404 Not Found

Trying to install gvim: soid@ubuntu:~$ sudo aptitude install vim-gnome Reading package lists... Done Building dependency tree Reading state information... Done Reading extended state information ...
7
votes
5answers
6k views

apt-get hangs when upgrading mysql-server-5.1

When I attempt to do the following: sudo apt-get update sudo apt-get upgrade on my Ubuntu Server 10.04 installation, it hangs at the following line: Preparing to replace mysql-server-5.1 ...
6
votes
3answers
2k views

Aptitude Untrusted source, gpg, keyserver

I have mirrored the Ubuntu archive repository (I must say it's rather huge). Then, I can apt-get install with no problem, but it prompts with following warning: WARNING: The following packages ...
0
votes
2answers
356 views

Ubuntu get package source from universe repository, but the correct source is in main repository

I want to get source of `thinkfinger' package, sudo apt-get source thinkfinger But, it reports 403 error, and I found that it get the source from xxxx/pool/universe/t/thinkfinger/, but the correct ...
6
votes
2answers
333 views

Linux has many dependencies when installing a small mp3 player

I try to install a small audio player named "Audacious" with the following command: sudo apt-get install audacious and it tells me that it depends audacious-plugins, so I try to install the ...
0
votes
2answers
839 views

Sub-process /usr/bin/dpkg returned an error code (1)

I'm trying to find a parental control for Ubuntu that turns adult site words into *. I have tried webcontentcontrol (doesn't even ask me to set a password), mobicip (doesn't even get listed in package ...
1
vote
3answers
199 views

How can I upgrade Ubuntu from 9.10 to 10.04 on a netbook with a 4GB root partition?

I have an Asus EeePC 901, running Ubuntu 9.10. I'd like to upgrade it to 10.04. I don't want to reinstall, since I have a bunch of scripts and programs all set up. However, when I attempt to upgrade ...
1
vote
1answer
1k views

sudo apt-get install apache2 does not fetch apache

Trying out sudo apt-get install apache2 This is what I get root@x27:/home/test# sudo apt-get install apache2 Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
1answer
216 views

Can't install back a purged package in Ubuntu

Hello all i've just migrated my desktop machine to Ubuntu 10.04. My problem is that i've purged a package and can't install this package back. Because I can't see it in the aptitude or apt-get's ...
2
votes
1answer
1k views

Easily view a list of changes of upgraded packages

So, let's say I run sudo apt-get upgrade on my Lucid Lynx and it upgrades a couple of packages I'm interested in. Is there a command to run that will open some kind of info or manual that tells me ...
1
vote
0answers
42 views

Generating a record of the full(-ish) package management state

I'm about to make some system changes and I'd like to have a record of my current happy system state. Is there a convenient way to create a record of this? I'd like to keep track of info like ...
1
vote
2answers
892 views

Upgrading only certain packages via the getdeb repo

I'm a bit confused about how getdeb.net works now. The last time I got a package from there was a while ago; at that point the procedure was that you would just download a .deb for each package that ...