aptitude is a front-end to the Advanced Packaging Tool (APT). It displays a list of software packages and allows the user to interactively pick packages to install or remove. In addition to a curses based interface, it also has a command line interface.

learn more… | top users | synonyms

3
votes
2answers
370 views

Making aptitude work properly through a proxy invoked with sudo

I use Debian 6. I'm sitting behind a proxy, so I configured Debian to use that proxy. Browsing and any HTTP and FTP activity through GUI works OK. I wanted to update my package repository so I typed ...
3
votes
1answer
974 views

Installing graph-tool and aptitude dependencies

I'm trying to install graph-tool. I've changed sources.list with the "precise" repository option. I can now run sudo apt-get install graph-tool, but I get the message graph-tool : Depends: libcairomm-...
4
votes
2answers
7k views

Lot's of errors by insserv on apt-get operations after trying to install tomcat

I wanted to install tomcat on my Debian 6.0.4 machine. I tried apt-get install tomcat6-user which worked fine. But then I changed my mind about the user installation and wanted to install the package ...
0
votes
1answer
2k views

Downgrade my current NVidia driver to a specific version

Recently my NVidia driver was updated from 270.41.06-0ubuntu1 to 270.41.06-0ubuntu1.1, but I have troubles with it. Is there an easy way to rollback with aptitude to the version before?
0
votes
4answers
1k views

Lost Power During apt-get install, Can't Resolve Missing Dependencies

I tried to install mercurial today, and the power went out. Now, when I try to install any packages, it complains about a couple of different things: >$ sudo apt-get install mercurial [sudo] ...
1
vote
1answer
58 views

Install a software package for Ubuntu version X on the Ubuntu version Y

Unfortunately I am a total newbie when it comes to Ubuntu package installation and dependencies. I wonder: Can I install a certain version of a pre-compiled software package in Ubuntu version Y, if ...
3
votes
2answers
3k views

Install cython on python 3.x

I need to install cython for python3.x .I have an ubuntu installation with python 2.6, 2.7 and 3.2 on it. Trying to apt-get the cython package installs pymodules only in 2.x versions. Is there a way ...
2
votes
4answers
633 views

How to avoid aptitude to repair broken packages?

I'm using a version of rubygems needed for running one of the application of my server installed this way : dpkg --install /tmp/rubygems1.8_1.3.7-2_all.deb At each usage of it, aptitude want to ...
1
vote
1answer
1k views

Sudo aptitude search produces bus error

I've got a strange aptitude error while performing search: $ sudo aptitude search pcre Bus error $ sudo aptitude search libpcre Bus error $ sudo aptitude autoclean Bus errorackage lists... 0% What ...
0
votes
1answer
727 views

Make aptitude quiet

I'm looking for a way to make aptitude(1) be quiet when installing packages. I want it to only produce output on explicit errors. The -q option does this is most other programs, but apparently not in ...
0
votes
2answers
4k views

Unable to upgrade libc6 on Debian

I tried to update a system of mine, with which I had no problems whatsoever, and ran into problem while executing a aptitude full-upgrade. The update ran through normally till I got this error : ...
2
votes
2answers
174 views

How do I tell aptitude or apt to offer a particular version of lpr?

I seem to have a weird version of lpr installed (one that doesn't cope with -o, see also this question). On all my other machines that run the same debian squeeze, the proper version of lpr is ...
0
votes
1answer
227 views

Linux: Aptitude: Howto replace a dependency by another?

I have a package named libqt4-designer and another package named libqt4-47-designer. When I do aptitude remove libqt4-designer, Aptitude wants to remove kdesudo and many other applications. How can I ...
2
votes
3answers
3k views

What does the “ip” status in the aptitude package list mean?

What does the ip status in the aptitude package list mean? For example: $ aptitude search some_package ip some_package description
0
votes
1answer
185 views

`Ffmpeg` aptitude install seems to break packages.

I tried to install ffmpeg because I thought/think it is needed for compiling OpenCV. However, when trying to do that I think I screwed up. How can I undo what I did? $ sudo aptitude install ffmpeg ...
7
votes
4answers
12k views

How to install a single package from Debian sid?

Take ibus-sunpinyin for example, which isn't existed in the squeeze release. I'm not going to switch the whole system to the sid branch, so, I want to download the single package from sid repository ...
0
votes
0answers
77 views

If aptitude is more preferable then why does bash advise apt-get? [duplicate]

Possible Duplicate: On Ubuntu, why "sudo apt-get" sometimes and "sudo aptitude" other times? In the documentation it is said that aptitude is more preferable command to ...
2
votes
1answer
172 views

Ubuntu - compare original package and installed parameters

I'd like to compare the actual config files for, say, Apache and the ones provided in the original package. The purpose is to have a list of modifications since initial installation because I didn't ...
1
vote
1answer
425 views

apt-get download size per package, instead of total download size

Apt-get displays the total size of all downloads required for an upgrade or install. I was wondering if we could get the size of each package that is going to be downloaded as well? An aptitude ...
1
vote
2answers
884 views

Local cache for apt packages

I have a desktop and laptop at home, both running the same flavour of Debian Testing. How can I configure apt on the laptop so that it first tries to download the packages from the desktop before ...
11
votes
1answer
2k views

In the output of “aptitude update”, what do “Ign” and the other codes mean?

When I run sudo aptitude update from the console, I see output with lines such as this: Get:1 http://security.ubuntu.com lucid-security Release.gpg [198B] Ign http://security.ubuntu.com/ubuntu/ lucid-...
3
votes
2answers
12k views

Authenticating and adding public key for apt

I was trying to get the official mongodb for Ubuntu, following the instructions at http://www.mongodb.org/display/DOCS/Ubuntu+and+Debian+packages After adding the deb http://downloads-distro.mongodb....
0
votes
1answer
570 views

How do I pass a list of packages to aptitude and resolve conflicts?

How do I pass a list of packages to aptitude so that I can resolve the conflicts interactively?
2
votes
1answer
268 views

aptitude: How to search for nothing but the full name of a package?

Searching for short package names (e.g. at or mc) in aptitude (not at command line but within the interactive tool) is annoying because I don't know a trick to avoid getting hits for plenty of ...
4
votes
1answer
1k views

“aptitude safe-upgrade” calculating something. Worth waiting?

# aptitude safe-upgrade <calculating something> <a day passed, I connected additional swap space> ... open: 310823; closed: 418353; defer: 82; conflict: 173 <and counting... It eats ...
2
votes
1answer
1k views

How do I stop display and another email of changes when running aptitude full-upgrade after receiving apticron email notifying of the same changes?

My home server used to run Ubuntu 10.10 server with apticron installed, which periodically (via cron) sends emails when updates to your installed packages are available. This email includes a list of ...
1
vote
1answer
2k views

E: Internal Error, Could not perform immediate configuration (2) on util-linux

I had an older version of Ubuntu installed. To upgrade I replaced /etc/sources.list with one from another machine running 10.04. I then ran: sudo apt-get update sudo apt-get upgrade The upgrade ...
1
vote
1answer
619 views

Annoying apt dpkg error

Setting up alsa-driver-linuxant (1.0.23.1) ... Building modules for the 2.6.35-22-generic kernel, please wait... done. ERROR: Build failed. Please review the build log at /tmp/alsa-driver-linuxant....
2
votes
3answers
225 views

Terminal.app characters set changes — completely illegible

I was just ssh'd into my server (Ubuntu 10.04.2), and I ran aptitude (in interactive mode). Once I pressed one key (one of the letters, g I believe), it turned into this (not just the SSH session; ...
8
votes
3answers
5k views

Debian - Can't stop MySQL; permissions?

I just tried to upgrade from debian squeeze to unstable by replacing 'squeeze' with 'unstable' in /etc/apt/sources.list. The upgrade went smoothly except for mysql, which failed because it couldn't ...
2
votes
2answers
906 views

How to upgrade all packages only installed from experimental?

I am using Linux Mint Debian Edition and am using the unstable for all my packages. I do have some that I installed from experimental like gnome3. How do I upgrade all and only all that have been ...
1
vote
2answers
335 views

How do I middle-click paste text into curses text-gui apps (i.e. aptitude)?

I have a Gnome desktop and I use the standard Terminal (gnome-terminal). I can middle-click paste text into the terminal but not when running Aptitude - a curses-based UI. Just now, I realized that's ...
4
votes
2answers
2k views

Is there something like apt or aptitude for windows? [duplicate]

Possible Duplicate: Package managers for Windows The most important features to me are: A mechanism to automatically update all applications I have installed in one go checking dependencies (...
2
votes
0answers
494 views

ghc6 install trouble: hGetContents: invalid argument (invalid UTF-8 byte sequence)

Having trouble installing ghc6 on Ubuntu Maverick via apt. Here's what seems to be the relevant error that comes up when I try to (apt-get|aptitude) install ghc6: A package failed to install. ...
0
votes
1answer
536 views

What's the correct way to install a later version of a package on Ubuntu?

If I install RabbitMQ with $ sudo apt-get install rabbitmq-server Then I get a compatibility error with the client libraries. What I actually want is the latest RabbitMQ from their site. They make ...
5
votes
2answers
1k views

Can Debian identify rarely used packages?

I'd like to find a tool that could tell me which Debian packages on my system have been rarely or never used, perhaps by looking at file lists and access times. This is to find candidates for ...
1
vote
1answer
3k views

Which Ubuntu 10.10 package provides the LaTeX class res.cls?

I am trying to find res.cls! I've been looking for quite a while for res.cls but have not found it. All signs point to it being in texlive-latex-extra, but as far as I can tell it wasn't provided. I ...
3
votes
3answers
404 views

If I need to install the latest Java SDK, what apt-get should I install?

I'm on Ubuntu Maverick. There are too many packages when I run apt-cache search java.
2
votes
2answers
4k views

How do I get the X11 dev files on OS X

I've been trying to use fink and apt-get but none of the commands (xorg-dev, xlibs-dev, libx11-dev, x-dev etc.) are working. Any ideas?
16
votes
4answers
63k views

How do I add a apt-get repository without editing /etc/apt/sources.list?

I want to add a repository to apt-get (without potentially messing up /etc/apt/sources.list) through the user of a script. This script may run multiple times so I can't just append the entry each ...
2
votes
2answers
3k views

How to name files in /etc/apt/sources.list.d/ to be ignored without warnings?

N: Ignoring file 'cloudera.list_' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension N: Ignoring file 'opera.list_' in directory '/etc/apt/sources.list.d/' as it has an ...
2
votes
1answer
598 views

apticron, apt-get dist-upgrade and aptitude

I'm confused, on my debian server I've gotten the daily "updates available" message by apticron. I normally then just use aptitude to install the upgrades. Today I got a message which shows two ...
1
vote
2answers
119 views

Are aptitude get requests cached on a squid proxy

In Ubuntu/Debian are apt-get install/upgrade calls cached on a transparent proxy(That is setup with squid). While I would like to think they are (to save bandwidth in a large network) I haven't ...
0
votes
2answers
521 views

creating metapackages

got some problems while creating metapackages tried to create a meta package containing forensic toolkits, on ubuntu i even got problems creating an .deb file. dpkg-source: error: can't build with ...
1
vote
2answers
301 views

Install all the dependencies without installing a package?

How do I install all the dependencies needed for the PHP package without installing the actual package for APT?
5
votes
2answers
8k views

How can I determine the current version number of an application with apt-get

Say I have python-twisted installed. sudo apt-get -V check python-twisted does not show the version number, just Reading package lists... Done Building dependency tree Reading state ...
3
votes
1answer
250 views

In Linux, how to get the man page for compiled programs?

I know that installing a package through APT (apt-get or aptitude for my computer) will automatically install the appropriate man pages and update the man database. When I want to build the same ...
2
votes
3answers
479 views

Find all packages that uses a given File in Ubuntu?

I'd like to list all the packages that uses a given file. I'm willing to use any tool (such as dpkg, dlocate, apt-file etc.), Please do mind when I say 'use' I don't mean necessarily only owns/...
5
votes
2answers
1k views

Automatic linux-headers installation

Is there a way to get the matching Linux kernel headers automatic on a regular kernel update via the Ubuntu packed manager? Every time I get a new kernel I must do an aptitude install linux-headers-...
2
votes
3answers
1k views

Apt-get doesn't work anymore

I'm using Ubuntu 10.04 Whenever I try to do an sudo apt-get install I get this error (this example is for sudo apt-get install virtualbox) Reading package lists... Done Building dependency tree ...