0
votes
1answer
99 views

Automatic indentation with MacVim

How can I change the automatic indentation in MacVim? My problem is that when editing a TeX file, every time I type, for example, (, vim decides to indent the line for me. Here is a video of my ...
0
votes
0answers
148 views

Vim format python using formatexpr/prg (gq) gives incorrect result

I am having trouble with Python's interaction with comments. These can be divided into two issues. I expect they're related, so I'll post them both here. Issue 1. When using gq to automatically wrap ...
0
votes
2answers
153 views

How to change language specific plugins in vim?

I'm writing an SML program and I'm trying to change the size of indents. If I add the following to my .vimrc file set tabstop=8 set shiftwidth=8 set expandtab It is not reflected in my actual ...
1
vote
1answer
123 views

VIM inconsistent indentation

I have the following small Specman (.e) file: (set filetype=specman) <' extend sys { a : b; !enable : bool; run() is also { message (LOW, "Hello World"); }; }; '> ...
3
votes
2answers
210 views

vim: remove previous code indentation and convert to another

I have a c project with multiple files (more than 100), the codes are written in Whitesmiths style, but I want to change them into K&R style indentation. Is it possible to do using vim in an ...
1
vote
2answers
590 views

VIM - Auto-indent lines with over length

Is there an option in VIM to auto-intend (like in Espresso) lines which are too long to be displayed in the current window so that they get an automatic line break? This is how it looks like in ...
3
votes
2answers
416 views

Change <li> autoindent options in VIM

By default Vim seems to not want to indent the contents inside of <li> tags, though it autoindents properly for most other HTML tags. For example, if I start with this code: <ul> ...
3
votes
3answers
688 views

How to configure backspace to delete 1 char with ts,sw,sts & et configured in vim

I have the following in my vimrc: set tabstop=8 set shiftwidth=4 set softtabstop=4 set expandtab set backspace=indent,eol,start set autoindent This does what I want: insert spaces only, never tab ...
5
votes
2answers
965 views

How do I make vim's autoindent not drop trailing spaces?

In some text editors (e.g. Kate, gedit), when auto indent is enabled, pressing return twice will leave a trailing whitespace (which I want): if (code) { .... ....| } While others cater to the ...