0
votes
0answers
11 views

I'm getting 500 server error in when trying to send ajax to codigniter+NGINX in production in ec2

When Im in my local environment when I send with ajax rest post http://localhost:8080/index.php/api/get_user I'm getting an answer from the server (Codeigniter + NGINX). But when I do it with ...
0
votes
0answers
13 views

install ImageMagic library to php

When i try to sudo pecl install imagick i get this message: Can't find PHP headers in /usr/include/php The php-devel package is required for use of this command. ERROR: `phpize' failed And sudo ...
0
votes
0answers
18 views

Centos 6 rsyslog missing audit.log

I'm trying to get to work the wkhtmltopdf on apache, php 5.5, centos 6 64bit. The error is "sh: /usr/local/bin/wkhtmltopdf: Permission denied" so my thoughts were selinux. I tried to follow steps ...
0
votes
1answer
55 views

PHP max_input_vars delaying server response time

Hi im using a CentOS vps with 6gigs of dedicated ram im hosting WordPress on that a little while ago i got an error saying that max_input_vars have exceeded so i have edited my php.ini and made it to ...
0
votes
0answers
53 views

Centos 6 - Lighttpd/ 403 error on PHP files, and issues adding website

So, I do have PHP/MySQL and PHP-FPM installed, but when I try to access PHP files, I get a 403 forbidden error. I have been looking around Google quite a lot, and not finding anything that is solving ...
0
votes
0answers
63 views

Is mod_fastcgi-2.4.6 compatible with apache2.4.9 CentOS?

I need to install multiple php handlers in apache2.4.9 one php version as apache handler and other one I need to run as mod_fastcgi but while compiling and installing with apache 2.4.9 I'm getting a ...
0
votes
0answers
137 views

How can I compile and install Apache2.4.9 with multiple PHP versions (5.5, PHP5.4)

I have compiled apache2.4.9 and php 5.5 with php5.4 versions php 5.5 version is installed succssfully as apache handler and I tried php5.4 with cgi and enabled LoadModule cgi_module modules/mod_cgi.so ...
0
votes
1answer
55 views

phpMyAdmin No activity within 1440 seconds; please log in again. Issue

I have installed latest phpMyAdmin on Apache+php+mysql on CentOs. But after sometime of inactivity i am getting No activity within 1440 seconds; please log in again. And redirected to the ...
0
votes
3answers
43 views

Setting up a local webserver using CentOS on VM

im new here, and basically new at setting up a webserver... now im already googling, and searching here in stackexchange on how to setup a webserver, they tend to direct me to a working server.. i ...
0
votes
0answers
53 views

Somehow PHP mail() is not working but webmail is working on VPS

I'm using a vps with zpanelcp installed. Everything was working fine. But somehow all mailing capabilities using PHP mail() is not working. But Roundcube is still able to send mail perfectly. I ...
0
votes
2answers
1k views

CentOS: installing a GD Library

I'm running PHP version 5.3.5. Now I need to install GD Library. When I run: --> yum info php-gd, it says Missing php-common 5.1.6-43.el5_10. php-gd-5.1.6-43.el5_10.x86_64 from updates has ...
1
vote
1answer
24 views

Imagick jpeg:size option not working on one server but not the other

Not sure if this should be posted here or on stackoverflow so figured this was the safer bet. I'm using Imagick to resize jpegs. This is part of the code $prehintSize = (int) $requestedWidth > ...
0
votes
3answers
7k views

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

So at first I was getting this error when trying to create databases for use in phpmyadmin. ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) I ...
0
votes
1answer
1k views

How to install PHP 5.3 on CentOS 6?

I finally found a place for all the PHP 5.3 files. I have all the links, I just really don't know where else to go from having the links. Simply doing "yum install linkshere" just gave me issues like ...
0
votes
0answers
36 views

Install PHP 5.3 for one directory only

I am on a CentOS 6 VPS, with Apache & PHP 5.4. I need to have PHP 5.3 on only one folder, but no where else. How do I install PHP 5.3 without conflicting with my current PHP installation and ...
0
votes
0answers
11 views

How to downgrade PHP 5.4 to 5.3 - Centos 6 [duplicate]

Well after about maybe 50 Google searches and reading 2k pages, I ain't finding anything to help me downgrade my PHP version. If you ask why, it's because the scripts I use, use session_register and ...
2
votes
2answers
630 views

Unable to write files on CentOS

I have a VPS running on CentOS 6 and apache2 as webserver. I have several PHP scripts running in my server, and everything goes smooth, except to file writing. For some reason, my PHP scripts are ...
0
votes
0answers
354 views

How to downgrade PHP 5.4 to 5.3? Centos 6

So I need to downgrade to 5.3 because of my script uses session_register, and it has been removed in php 5.4. People have linked me to code that I should add to the script where the issue occurs, but ...
2
votes
0answers
803 views

CentOS 5.10 Yum Packages won't update/upgrade

I've just used yum to install PhpMyAdmin and it installed version 2.11.11.3-2.el5 which is completely out of date since version 4 is out. I've tried running yum update phpmyadmin but I receive No ...
0
votes
0answers
105 views

CENTOS 6.4 running PHP for root as cgi-fcgi, not cli

I am running CENTOS 6.4 with WHM/CPanel. For some reason, one user is running PHP as cli, while another user and root are running it as cgi-fcgi (in the terminal) I need to make it so that all PHP ...
1
vote
1answer
731 views

How to install php soap with rpm packages in centos 6.4 x86_64

I want to install php-soap, centos says: [root@LMS-Cent64 soap]# rpm -ivh php-soap-5.3.3-22.el6.x86_64.rpm error: Failed dependencies: php-common(x86-64) = 5.3.3-22.el6 is needed by ...
0
votes
1answer
304 views

can Homebrew be used on a Centos computer

I just installed Centos 6.4 minimal on an old computer with an internet connection threw my iMac. Set it up as a development server. Installments required: Nginx, Apache, PHP-5, Mysql, Redis, Mongodb ...
0
votes
0answers
71 views

Installing php mail() function

I have recently set up a CentOS 6.4 server using the minimalistic installation. I have a working version of PHP up and running, but I want to be able to use the mail() function in PHP. What do I ...
3
votes
2answers
2k views

Convert file to PDF using LibreOffice under user apache (i.e. when using PHP)

I installed libreoffice-headless and can convert documents when logged on into the shell as a normal user. [root@desktop ~]# yum install libreoffice-headless [root@desktop ~]# yum install ...
-1
votes
3answers
141 views

Chrome can't connect to example.com server

How can I get all my php files run on a Linux server? I copied all PHP files to my Linux server under /www and I did change config settings like the following. Also I created an error log file under ...
0
votes
0answers
104 views

Two errors on error log when trying to use ZF2 on CentOS with PHP 5.3.24

I am trying to use zend framework 2, i follow these instructions on centos6 via ssh. http://framework.zend.com/manual/2.0/en/user-guide/skeleton-application.html and when trying to start my website ...
-1
votes
1answer
322 views

library for html to rtf conversion [closed]

I am much needed the linux library for converting html document to rtf. As currently, I have used CMS kind of functionality where html is stored in database. I need to convert it in rtf. If any ...
1
vote
0answers
188 views

Trouble installing php-devel on CentOS

Working with a PHP install and trying to install APC on a server to help with speed issues with an application we're developing. We are having trouble getting phpize installed. phpize is not on the ...
1
vote
1answer
182 views

PHP Exec function reports failure on some commands that work by SSH

I'm on CentOS 6 64bit with PHP 5.4.12. This is very strange behavior by PHP. See the following script: echo 'Trying Query: whereis jbig2dec<br>'; exec('whereis jbig2dec',$output) or ...
0
votes
1answer
1k views

How do I downgrade php from 5.4 to 5.3 in CentOS?

I have a webserver running CentOS 6. Yesterday, I installed php-gd with yum install php-gd because I couldn't see graphics on my website. However, when I see my php version, it changed from 5.3 to ...
1
vote
1answer
1k views

Installing PHP 5.4 on CentOS 6

I want to update my CentOS 6 PHP version from 5.3 to 5.4 so I tried this guide: http://www.webtatic.com/packages/php54/ But after running yum install php54w I get this: Setting up Install Process No ...
0
votes
1answer
318 views

Unable to install ssh2 lib for php on centos

I'm trying to install the ssh2 lib on my centos os server as per this tutorial : http://blog.dynamichosting.biz/2011/01/10/installing-ssh2-extension-for-php-on-centos-5/ Everything seems to go fine ...
1
vote
1answer
155 views

Cannot read directory

I am using CentOS 6.3 and I am trying to opendir and readdir using PHP. apache is in the group of the user and I am trying to read the /home/user/mnt which is mounted remotely using SSHFS. ...
4
votes
1answer
3k views

Install PDO-driver for Postgresql

When i run PDO::getAvailableDrivers() i can see that the only available driver is sqlite, and i want to use Postgresql. What should i do to accomplish that?
0
votes
0answers
235 views

Installed Apache httpd and PHP5.4 on CentOS, but no mention of PHP in httpd.conf file?

Using Centos 6.3, I installed Apache httpd 2.2 with PHP 5.4 (from a custom yum repository) and MySQL. PHP works fine on the command line, but there's no mention of it in Apache's httpd.conf. I know ...
0
votes
1answer
152 views

Centos: php-devel trashed mysql

Good morning. I'm on a CentOS machine, did a yum install php-devel Flat out saying this MySQL Daemon failed to start. Starting mysqld: [FAILED] which ...
1
vote
1answer
4k views

How to upgrade libxml on CentOS

I have a following version of CentOS: $ cat /etc/issue CentOS release 5.5 (Final) Kernel \r on an \m and following version of libxml: $ php -i | grep libxml libxml Version => 2.6.26 libxml ...
0
votes
1answer
120 views

Bitnami Stack copying via SSH

Hello Wonder if anybody can help. I'm new to SSH & linux, and going through setting up a server. I'm picking up bits and bobs of bash ok, and remembered someone suggested using bitnami stack for ...
0
votes
1answer
2k views

ZIP support not found: SugarCRM needs ZIP support in order to process compressed files

Ok, trying to install SugarCRM and I seem to be failing horribly. Everything is uploaded. Folders have write privlages (777 currently for the moment) PHP Memory limit is at 256M extension:php_zip.dll ...
0
votes
1answer
6k views

CentOS 5.8 Server, manual install PHP 5.2.17

I would like manually install PHP 5.2.17. I manage to install httpd and mysql. But when I want to PHP 5.2.17, I could not found a proper guide. These the step I had done with a fresh installation of ...
3
votes
3answers
12k views

Unable to remove PHP packages from CentOS, but also unable to update PHP package to PHP 5.3

I have an interesting, albeit infuriating problem with CentOS. I'm trying to configure this server to run a Symfony2 website I've built. The website doesn't work, and I've pinned down the problem to ...
2
votes
1answer
693 views

Can't install Gearman on Red Hat

I'm having problems installing Gearman from Red Hat on Amazon. I couldn't find a repo so I downloaded Gearman version .25, installed it and installed drizzle from their repo using: yum install ...
0
votes
1answer
55 views

How to dump data to DVD when the disk space reach 80% on RAID 1, and clean the dumped space from disk after burn

How to monitor in unix (FreeBSD) /linux (CentOS 5.6) the disk space if its greater or equal to 80%? If its equal or greater then 80%. How can i tell dump the data from a specific /misc/ folder to ...
1
vote
2answers
297 views

How to make my PHP script use the second hard-disk?

I have two SATA hard-disk drives attached to my server as shown in the following : [root@cl-185 /]# df -h Filesystem Size Used Avail Use% Mounted on /dev/sda1 222G 166G 45G ...
0
votes
1answer
2k views

CentOS: installing a PHP module without updating PHP

I am running PHP 5.3.5. Now I need to install the php-mbstring module. When I run: yum install php-mbstring I am asked to update PHP: Installing: php-mbstring ...
1
vote
4answers
12k views

yum install a particular version

I am currently using centOS 5.2 I want to install php 5.3.3. how do I install using yum?
0
votes
1answer
2k views

How do you Install php-mysql on CentOS

if i try to install php-mysql I get the following error... not sure how to recover from it to get MySQL and the PHP MySQL module up and running [12:51]~> yum install php-mysql Loaded plugins: ...
0
votes
1answer
1k views

PHP Warnings not being logged?

I am trying to trace down a script and have found that my problem is coming from httpd. To summarize that post, something is attempting to connect to a website and is [properly] being blocked by the ...
0
votes
1answer
2k views

Installing Zend on CentOS is having dependency issues

I'm trying to install PHP's Zend Server on my CentOS VPS but it's having dependency issues that I can't seem to resolve. zend-server-php-5.2-4.0-73.noarch from Zend_noarch has depsolving problems ...