CPAN is a popular repository for perl modules and scripts.

learn more… | top users | synonyms

1
vote
1answer
40 views

Missing Switch module on exiting Perl installation

I have been working on a Linux 64bit cluster for months, and this morning it seems as if the Switch module for Perl has disappeared from the system. If I do a find on the place where I expect it to ...
1
vote
1answer
124 views

Why does cpanm fail on distributions without proper makefiles where cpan -i succeeds?

I'm on Strawberry Perl on Windows 7 64-bit. cpanm fails like this for many packages in cpan: $ cpanm Getopt::Long::Descriptive Fetching ...
1
vote
1answer
183 views

Installing libpng on a Mac with Maverick

I want to install libpng library on my Mac, which runs under Mavericks. Here is a simple Perl script to check if it is ok: use GD; my $gd = GD::Image->new(); my $ok = $gd->can('png') ? 'Yes' : ...
0
votes
1answer
1k views

Install XML::Parser

I'm trying to install some perl module but got strange error. sudo cpanm XML::Parser cp Parser/Encodings/iso-8859-5.enc blib/lib/XML/Parser/Encodings/iso-8859-5.enc make[1]: Entering directory ...
0
votes
1answer
463 views

Install perl module with dependencies

I'm trying to install a Perl module like this : pi@raspbmc:~$ sudo cpan HTTP::Date Cpan get the file Checksum is ok uncompressed successfully But I got this error : Using Tar:/bin/tar xf ...
0
votes
1answer
107 views

how to get Geo::Coder::Many with cpan?

Ubuntu is installed for development of a Perl project. aptitude search Geo-Coder i libgeo-coder-googlev3-perl - Perl module providing access to Google Map Aptitude does not refer to ...
1
vote
2answers
2k views

gcc not finding header file though its path has been included with -I

I'm trying to install a module (Package::Stash::XS) via cpanm, but the installation is failing due to a gcc error. The command gcc -c -DPERL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -fno-strict-aliasing ...
0
votes
1answer
32 views

Installing a CPAN module using a remote compiler

I need to install the XML::Parser module. Unfortunately, that package uses expat. Due to security concerns, I am not allowed to install the dev package of expat. making the CPAN Module fail to ...
1
vote
1answer
349 views

cpan fails with “Error code 130, while making 'pm_to_blib'”

I recently installed Perl on my Windows 7 machine. Upon running cpan App::cpanminus, I got the following error: D:\Perl>cpan App::cpanminus CPAN: CPAN::SQLite loaded ok (v0.199) Database was ...
3
votes
1answer
621 views

Error when installing cpanminus on Mac OS X

I am trying to install cpanminus through the terminal using the command given on the website: sudo cpan App::cpanminus However I receive the following error: N01-0545---MB:CPAN-1.9800 sucadmin$ ...
1
vote
1answer
231 views

cpan in freebsd 9.0

I have a FreeBSD 9.0 installation which works fine. The only problem is cpan. I tried forums.freebsd but didn't help much. Here is some cli output: [user ~]$ cpan --version Cannot load ...
1
vote
1answer
1k views

Perl EPIC Not recognising installed CPAN modules

Eclipse on a mac, was working fine adding new modules until I Installed Text::CSV_XS which Eclips doesn't recognise as added to @INC For instance use strict; use SOAP::Transport::HTTP; ...
1
vote
1answer
104 views

CPAN install to many directories

When I install stuff locally (not as root) with CPAN, it ends up putting things in a multitude of places. So much so, that I have to set PERL5LIB to five directories! Here's the CPAN settings where ...
0
votes
1answer
954 views

Perl CPAN: Can't install module dependencies - Could not find a version X or above

Whenever I try installing a perl module on my system, it fails to install the dependencies. I had this working before, I'm not sure why it's not working on my fresh setup. For example, I try to ...
1
vote
1answer
403 views

Easy way to get gcc and make in OSX

I want to install a few CPAN modules in OSX. It filed since the module I want requires make and gcc to be installed. A quick google on the subject tells me that I need to install "Apple developer ...
2
votes
3answers
1k views

Make test failing when installing packages with CPAN on Cygwin

I'm trying to install Date::Manip::Date, which requires YAML::Syck. I'm running Cygwin on Windows XP. Both packages fail their make tests. I have installed other packages sucessfully, such as ...
0
votes
2answers
1k views

Install perl Template-Toolkit for bugzilla on windows

Im attempting to install Bugzilla on my local development server (based on a windows machine). My server is the standard xampp install. Ive got to the point where i need to install the relevant perl ...
1
vote
1answer
70 views

CPAN Dependency in Debian packaging

In Debian packaging (i.e. the debian/control file), is there a way to define dependencies to specific CPAN modules?
0
votes
1answer
61 views

can I skip deps with CPANPLUS?

I'm having some dependency issues with some packages. I have to use CPANPLUS (cpan & cpanm are not options) is there any way I can skip dependencies when installing a package? --force seems to ...
0
votes
2answers
5k views

What steps to take when CPAN installation fails?

I have used CPAN to install perl modules on quite a few occasions, but I've been lucky enough to just have it work. Unfortunately, I was trying to install Thread::Pool today and one of the required ...