0
votes
1answer
13 views

Tried Installing ZSH through cygwin and then trying to use zsh through Cmder

I tried to install Cygwin (64 bit version) on my computer, and it went through hunky-dory until at the very end, autorebase.bat failed with exit code 1. I read through the logs and they weren't too ...
0
votes
1answer
30 views

Do I have to manually update my PATH in Cygwin shells?

I use Cygwin on Windows 7. I'm not really a Windows user, so it's already a little inconvenient for me to have to have this extra layer in between my OS and Zsh, my shell of choice. Now, I frequently ...
1
vote
1answer
31 views

Speeding up explorer.exe global shortcuts [duplicate]

I'm running Cygwin on windows with cmder as a terminal for zsh. The way I got it to be a bit similar to what my linux setup has is I placed a shotcut (.lnk) on my desktop with a keyboard shortcut ...
2
votes
2answers
4k views

Oh my zsh on windows

I have installed Cygwin on my windows 8.1 Now I want to install ZSH and Oh My ZSH in cygwin. I have installed ZSH in it by selecting Shells > Zsh in Select screen. and I found this link to ...
2
votes
2answers
254 views

Can't find the Cygdrive folder in Cygwin

I installed cygwin, zsh and oh-my-zsh following this project: https://github.com/haithembelhaj/oh-my-cygwin/blob/master/README.md And i can't find the cygdrive folder. Why? How can I mount my C:?
3
votes
1answer
165 views

How to benchmark bashrc / zshrc and prompt rendering time?

As im currently experimenting with new stuff in my prompt i need a way to tell what the performance impact is. How can i monitor how long it takes to render my prompt and the time it takes to source ...
1
vote
2answers
273 views

zsh completion doesn't work under Cygwin for other drives

I'm on Win7 x64, Cygwin 1.7 and zsh (and using oh-my-zsh). Zsh newbie here. I've reviewed zsh autocompletion not working on cygwin and tried the solution there but no luck. My mount table: C: on ...
4
votes
1answer
614 views

Zsh in Cygwin 1.7

When starting Zsh as the shell in Cygwin 1.7, I get the escape characters in plain text. When using Zsh with the -l option, this is resolved. Why is this? As you can see, the terminal renders the ...
2
votes
1answer
515 views

zsh autocompletion not working on cygwin

I am on win7 64b, with cywgin 1.7. I have added zsh shell to the installation. If I start a shell like with bash: bash --login -i autocompletion works fine straight away. But if I start a zsh: ...
1
vote
0answers
543 views

How do I set up sshd using Cygwin on Windows 7 for remote login

I'd like to set up an ssh server with Cygwin on my Windows 7 desktop so that I can remotely access my computer in a more civilized way than using VNC. I would like to use zsh as my default shell. I ...
1
vote
2answers
439 views

How can I remove the “path prefix line” from zsh on Cygwin?

I've installed Cygwin under Windows 7 and I've added the line exec zsh -l to C:\cygwin\home\Viktor\.bash_profile. Problem is I still get that ugly new line for every command I write: ...
4
votes
2answers
764 views

Cygwin + zsh: Home and End keys not working

I cannot get Home and End keys to work for zsh under Cygwin. Various sources seem to suggest that bindkey '\e[1~' beginning-of-line bindkey '\e[4~' end-of-line will fix the problem but this does ...
5
votes
1answer
1k views

ZSH with mintty on latest cygwin?

Does anyone know how to set mintty to use zsh on the newest cygwin install?
1
vote
1answer
226 views

how to start an interactive shell with special setup

I want to start an interactive zsh (on cygwin) with project specific set-up: source /etc/profile source ~/.profile source $PROJECT_HOME/Setup.zsh become interactive I got as far a step 3 but then ...
15
votes
1answer
10k views

zsh with Cygwin

How can I configure zsh to be the default shell under Cygwin?
13
votes
9answers
3k views

Cygwin/Git Bizarre Terminal Issue

Alright, this is weird. First off, this is mintty running on up-to-date cygwin, with git pulled from cygwin's setup.exe. I am running zsh. $ git clone ...
2
votes
1answer
798 views

grep --color=auto with -i option disables the matching text color, why?

I was messing around with grep and put this in my .zshenv: export GREP_OPTIONS="--color=auto" export GREP_COLORS='mt=1;34' I was bonking my head on the keyboard and changing GREP_COLORS around for ...