Version 7 of the Debian Linux distribution.

learn more… | top users | synonyms (1)

23
votes
2answers
42k views

EFI Partition vs /boot partition

I have just sat down to install debian 7, which contains something called 'EFI' which is entirely new to me. I went through the install as I usually do; 256MB /boot partition, bootable, unencrypted ...
1
vote
1answer
14 views

What's the tool used by Debian Jessie installer to configure wifi?

I just installed Debian Jessie. During the installation procedure, wireless network configuration is done in command line mode. The tool which assist the wifi network setup is pretty simple, it just ...
1
vote
1answer
7k views

How to install TP-Link TL-WN722N USB Wireless Adapter on Debian Wheezy armhf?

I have TP-Link WN722n USB dongle plugged in: root@udoo-debian-hfp:~# lsb_release -a No LSB modules are available. Distributor ID: Debian Description: Debian GNU/Linux 7.4 (wheezy) Release: 7.4 ...
3
votes
4answers
7k views

Intel HD graphics 4400 not working properly on Wheezy

Upon login, I get the following message: GNOME 3 Failed to Load Unfortunately GNOME 3 failed to start properly and started in the fallback mode. This most likely means your system ...
1
vote
2answers
9k views

Debian wheezy Xorg configuration fails, Debian don't boot

I have installed Debian Wheezy today. when i boot Debian wheezy when splash logo about to open, the screen blanks and system hangs, but Debian stable was booted without errors, but I changed init ...
0
votes
2answers
3k views

I can no longer login as root user (Raspberry Pi running Raspbian)

Raspberry Pi running Raspbian (2014-01-07) The error seem to have come from nowhere, as I was trying to login as root via SSH (yes I have it activated - for now) I got the message "Access Denied" ...
0
votes
0answers
9 views

my graphical debian is deleted after trying upgrade GCC

I am not an experienced debian user, what I did is following this post to install Nodejs 4.X in my debian wheezy : http://alex-taran.blogspot.com/2015/10/nodejs-4xx-on-debian-7-wheezy.html after ...
0
votes
0answers
11 views

Upgrade from debian wheezy to jessie leaves broken /tmp directory?

I've just upgraded one of my machines from debian wheezy to jessie, and after each reboot, /run/tmp (to which /tmp is a symlink) is missing, meaning I have to recreate it manually. Clearly this is ...
0
votes
1answer
3k views

share files between Debian Wheezy and Windows 8 on LAN

How to Share files between Debian Wheezy and Windows 8? let's suppose my Debian User name is Wheezy and Password is Linux, and my Windows 8 user name is Windows and session login password is ...
2
votes
4answers
13k views

How to remove gnome 3 and all its dependencies from a debian wheezy netinst

I downloaded a Debian wheezy netinstall iso file, and just made a very minimal installation with no Display manager or desktop environment. I was using the terminal for testing purpose. I later ...
0
votes
2answers
123 views

“iw” and some of its commands do not return any output

I've been trying to set up my ARM based computer so that it becomes a hotspot and a client at the same time. However all of the information I've found about such functionality mention the iw command ...
2
votes
1answer
2k views

Trouble with my NVIDIA Geforce 6150 on Debian Wheezy

I own a HP Pavilion dv2025nr which has a NVIDIA GeForce Go 6150 card. I installed Debian Wheezy which currently installs GNOME 3. I need to install nvidia-glx in order to use my card at full ...
1
vote
1answer
115 views

Xorg troubles on Debian

I was trying to install some ATI drivers on a Debian Wheezy install and messed up my X server. The commands I ran were: wget --referer=http://www2.ati.com ...
0
votes
1answer
595 views

Cannot access all of the graphics card memory

I have a ATI Sapphire Radeon HD5830, and I successfully installed the AMD control panel on Linux Debian Wheezy. When I use lspci -vs 04:00.0 I get this output: 04:00.0 VGA compatible controller: ...
0
votes
1answer
56 views

Debian (OpenMediaVault) cannot resolve hostnames

Recently I got a new router (Fritz.Box 6490) and had to change the network settings on my NAS. So I turned on my debian-wheezy-based-OpenMediaVault-PC and set eth0 up for DHCP by editing ...
0
votes
1answer
756 views

Install Radeon X1650 driver on Debian Wheezy

I'm trying to setup my ATI graphics card (X1650) on Debian Wheezy. None of the instructions I came across worked. I always get this: sudo aticonfig --lsa aticonfig: No supported adapters detected
1
vote
0answers
108 views

Controlling a Canon Powershot with a CGI/Bash Script

I am trying to control my camera through the program chdkptp by using a CGI/Bash script. I have successfully controlled the camera by typing in the commands by hand: pi@camerapi /var/www/chdkptp $ ...
1
vote
0answers
393 views

Installation hangs during “detect network hardware”

I try to install Debian Wheezy beta 1 using the netinstall image on a Lenovo W510 with this network hardware Intel Corporation 82577LM Gigabit Network Connection Intel Corporation Centrino Advanced-N ...
1
vote
0answers
508 views

Problems installing the AMD Catalyst Radeon driver in Debian Wheezy on my HP Notebook

I tried to install AMD catalyst graphics driver for my HP Notebook with specifications as follows: lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor ...
0
votes
1answer
467 views

Debian 7 doesn't notify me about security updates

On a fresh install of Debian 7, GNOME isn't telling me when I need to install updates. It's not even checking for updates automatically (apt-get update). Manually running apt-get update doesn't ...
3
votes
1answer
1k views

Debian Wheezy - VMWare Player and Gnome3

I have installed Debian Wheezy in VMWare Player 5.0.2 build-1031769 and all is fine. Except the "Failed to load Gome3" messages keep on coming. This is what I did so far: Installed VMWare Tools ...
0
votes
1answer
20 views

Why does nano not redraw the screen correctly on some systems?

This is a weird one. On some of my Debian systems - but not all - I get strange corruption in certain terminal programs, such as nano. It does not happen, however, when using less. In this particular ...
1
vote
1answer
1k views

Debian Wheezy, hostapd running but no AP detected by clients

I've an TL-WN951N (AR5416+AR5008) using ath9k module running an hostapd and a dhcp for it. So hostapd starts fine: $ hostapd wifi.test Configuration file: wifi.test Using interface int1 with hwaddr ...
2
votes
0answers
392 views

debian 7 - atheros 10a1 ethernet card wireless doesn't work

i have bought a ideapad z710 a few days ago. I installed debian via using USB stick. During installation, setup cant find my ethernet card. After that i manually install wheezy backports. This solved ...
2
votes
1answer
470 views

Problems setting TL-WN951N (AR5416/AR5008) into Master mode

I recently bought a TL-WN951N PCI card, it gets detected right and the module being used is ath9k. When trying to set it to master mode however, it prints: $ iwconfig int1 mode master Error for ...
12
votes
4answers
40k views

How to make Alsa pick a preferred sound device automatically?

I bought an USB sound card. I'd like to set up my Linux desktop so that it prefers the USB device, if it is plugged in and automatically switches as the device is (un)plugged. Is it possible, and how? ...
0
votes
1answer
2k views

How to put RTL8191SU 802.11n WLAN Adapter in monitor mode using iwconfig?

I w as testing the security of my wifi network following this guide and I am using "RTL8191SU 802.11n WLAN Adapter" in my debian pc for this purpose. iwconfig lists : lo no wireless ...
1
vote
2answers
423 views

Should fwknop be listening to a port?

I am trying to install fwknop on a VirtualBox Debian 7 machine. It installs with no error (apt-get install fwknop-server -y), i made the modification in /etc/default/fwknop-server file so daemon ...
0
votes
0answers
9 views

Blank screen on debian wheezy

Im tried to install debian wheezy to my computer. After boot is screen blank but with nomodeset it is OK. How use systém without nomodeset?
0
votes
4answers
3k views

All statically assigned addresses, but dhcpcd still runs?

I have a VM (on ESXi 5.1.0) running Debian Wheezy (7.0). eth0 has a statically assigned address. eth1 was DHCP-assigned, and now I want to make it static. Here is my old /etc/network/interfaces: # ...
0
votes
1answer
38 views

How to kill a pid based on the result of an if statement

I'm trying to make a program restart if it has only one pid associated to it (it has to have two pid). if it has more than one it is ok, i've tried to write a bash script to do it but I'm struggling ...
0
votes
0answers
32 views

Wordpress / NGINX configuration issue

Can't get wordpress working with my NGINX configuration. PhpMyAdmin (Fast Cgi gateway) is oK , but I get a HTTP 404 error code when trying to access http://junon/wordpress/wp-admin/install.php but ...
1
vote
2answers
4k views

shutdown: /run/initctl: No such file or directory

I updated my server to Debian wheezy and played around with it. After a while I wanted to restart and encountered the error shutdown: /run/initctl: No such file or directory I searched on the web ...
0
votes
1answer
207 views

How can I install PHP 5.4 in Debian 7.5 (Wheezy)?

I wonder if you have any way to install PHP 5.4 on Debian 7.5 via apt-get, adding some URL in sources.list. I added the following lines however it asks a lot of dependencies: deb ...
3
votes
2answers
2k views

Automatic script launch after booting on Debian

I try to launch some scripts at boot time on my Raspberry Pi (running Raspbian Wheezy). I have created the file /etc/init.d/datalogger-serveur : #! /bin/sh ### BEGIN INIT INFO # Provides: ...
0
votes
0answers
27 views

Auto-repeat keeps getting turned off for left arrow (only). How can I find out why?

Occasionally I find that the auto-repeat is not working for my left arrow key and only that key. I know I can turn it back on with xset r 113 but it is annoying to have to do so and frustrating ...
2
votes
1answer
647 views

How to preserve path in a new tab in the gnome terminal?

At work I am using Ubuntu GNU/Linux 14.04. When I open a new tab in the gnome terminal, the working directory of the new shell is the same as in the terminal where I have pressed CTRL-SHIFT-T. At ...
0
votes
0answers
27 views

Need some help on setting up a vlan in hyper-v manager WSE2012R2

My first post on here...please forgive me for any details I have missed and ask me and I'll fill in the blanks on anything you need to know. I have a HP Gen8 Microserver running WSE2012R2. The server ...
1
vote
1answer
1k views

How to modify context menu

On my raspberry pi, I was trying to get a file to play, but both mplayer and omxplayer did not show up in the "Others" list when I tried to associate the file with the players, so I typed it in using ...
0
votes
0answers
24 views

Moving from debian to unbuntu - mdadm raid vol going to be ok?

I'm a little nervous about this decision, but I've recently updated the hardware in my NAS/HTPC and Debian wheezy network drivers aren't happy and regularly need to reboot to get eth1 working again. ...
5
votes
4answers
1k views

Wifi scan interval in Debian Wheezy, reconnect after sleep

I want to reconnect to a wireless network as fast as possible when waking up my computer from sleep mode. It always takes a while (usually 15-30 seconds) before there's even a listing of available ...
4
votes
4answers
11k views

Installing Skype on Debian Wheezy [amd64]

Yes, yet another question about how to install Skype on Debian Wheezy (7.4) amd64. Seen countless similar articles and forum threads on how to do it, but it doesn't for me :( Here is what I do: dpkg ...
0
votes
0answers
302 views

Raspberry Pi not connecting to hidden SSID WIFI

I have a problem with edimax ew-7811un on my Raspberry Pi. I am trying to connect to a hidden SSID, let's call it "hiddenssid" with a WPA2 Personal password "hiddenpassword". I can see wifi dongle in ...
1
vote
1answer
30 views

Find and replace in output of command based on file contents

I have a tail -f command reading a log containing IPs however I wish to replace these IPs with hostnames, I have the dhcpd.leases file available to the machine on which this is running. I have been ...
0
votes
1answer
82 views

Just ruined /etc/passwd is there anyway to fix [duplicate]

I'm a noob. I'm messing around on a raspberry pi trying to get the hang of things. I'm having a jolly time. I don't now how to use vim. I know that you need to hit i to insert text, but I know very ...
0
votes
0answers
45 views

mount --bind /tmp /var/tmp not mounting in debian 7

I have some issue with mount --bind /tmp /var/tmp. After I run this command, I edit /etc/fstab file and add line: /tmp /var/tmp none bind 0 0 But when I run command /bin/mount -v 2>/dev/null to ...
0
votes
0answers
25 views

Can /etc/inittab errors prevent network startup?

I have a small php server running on Raspbian via /etc/inittab: push:235:respawn:/home/pi/volkszaehler.org/misc/tools/push-server.php Due to configuration issues my php script was removed and- in ...
0
votes
1answer
798 views

ffserver-2.2 - streaming an ASF video as OGG output with ffserver on Debian 7.5

I'm trying to stream an IP webcam ASF live stream to a ffserver to output an OGG format. The server starts successfully but the ffserver commands used to feed the ffserver fails with a segment fault. ...
0
votes
1answer
23 views

Can't find \ lost auto start configuration, where could it be?

I did something to make 'Screen' run ever time I start a terminal to my raspberry pi (set up as a headless server). but now I keep leaving sessions dangling and want to remove the startup command.. ...
0
votes
1answer
461 views

Create a bridge between a tunnel and ethernet device

I have a Raspberry pi with Debian wheezy. There are three connections exists: eth0: native usb ethernet, connected to the router. eth1: plug-in usb ethernet adapter tun0: tunnel created by ...