-1
votes
0answers
5 views

Can I help R to resolve its own dependencies?

I'm installing bioconductor packages in R 3.1.1-1 on Debian Wheezy and keep getting installation errors involving dependencies like "XML" and "RCurl". A specific example: > biocLite("biomaRt") ... ...
0
votes
0answers
15 views

CentOS yum — pre-existing rpmdb issues

I'm trying to install git on a developer box and I get the following: You could try using --skip-broken to work around the problem ** Found 3 pre-existing rpmdb problem(s), 'yum check' output ...
0
votes
0answers
35 views

Ubuntu dependencies hell

pippo@pippo-desktop:~$ sudo apt-get -f install Reading the package list... Done Generation of the dependency three Reading state info... Done Dependents correction... error. aspell : Dipends: ...
0
votes
0answers
88 views

How to give up or skip packages with unmet dependencies?

A package called salt-minion has unresolved dependencies on my Debian system. Now everytime I run apt-get it will output the following error message: root@Sheeva:~# apt-get upgrade Reading package ...
0
votes
0answers
69 views

Installing gdal/postgis has dependency

I am trying to install gdal/postgis2_92 but I get following dependency issue: Error: Package: gdal-libs-1.9.2-4.el6.x86_64 (elgis) Requires: libz.so.1(ZLIB_1.2.0)(64bit) Error: Package: ...
0
votes
1answer
64 views

How to write dependency rules in rpm .spec file for RHEL OS

I need to build one rpm package, that should be dependent on the installation of another rpm package. On my PC, the dependent package has been installed, with a name like abcd-1425-a.x86_64. I wrote ...
0
votes
0answers
24 views

Package manager for target file system

I'm developing for an embedded linux application and I need to install some libraries that have a pretty lengthy list of dependencies. Is there a package manager out there that I can point to the ...
3
votes
2answers
4k views

Ignore all dependencies for a specific package with apt-get

This is a very specific question which google didn't help answering. I'm running Ubuntu 13.04 with apt 0.9.7.7ubuntu4 for amd64 compiled on Oct 3 2013 15:25:56. I want to install Erlang from a .deb ...
1
vote
2answers
72 views

Building/Installing software with external dependencies on linux

This kind of thing tends to happen to me more than it should. Often when I am building the source of some program or even just installing a program that has external dependencies that aren't already ...
0
votes
0answers
108 views

dependency error sun-java6-jre (zynamics bindiff) SOLVED

I am trying to install bindiff. When I try to install through archive manager I am welcomed by the following message "Dependency is not satisfiable: sun-java6-jre". (I am running ubuntu 12.10) I have ...
2
votes
1answer
77 views

Is there an easier way to install package newer than in repositories (CENTOS)

I'm on CentOS 6.4 and I want to install newest stable version of gtk+. So I got gtk+ from their website, but after running ./configure it starts crying about loads of dependencies that are installed, ...
2
votes
2answers
162 views

Why is Linux having more dependency issues than Windows? [closed]

I have been using both Linux and Windows for the past eight years, and I feel that Linux has been having many more dependency issues than Windows while installing software. I like Linux more than ...
0
votes
0answers
412 views

Unable to update libc6:armhf 2.13-38+rpi2

I'm trying to install PION package and I'm unable to do this on RaspberryPi: pi@raspberrypi ~ $ sudo aptitude install libpion-dev The following NEW packages will be installed: libc-dev-bin{a} ...
0
votes
1answer
254 views

How to install Fatrat from source on Linux (dealing with dependencies)?

I'm trying to install latest Fatrat Download Manager from source on my Linux server and I'm not able to deal with dependencies. There is a GIT repository with latest version of Fatrat ...
1
vote
0answers
72 views

linux + squashfs-tools for red-hat 5.3

I want to install the squashfs-tools-4.0-5.el6.i686.rpm But I have the following dependencies ( after RPM installation ) please advice what the additional packages that I need to install on my linux ...
0
votes
0answers
113 views

apt-offline equivalent for opensuse

I am trying to install wine on opensuse but I have a dependency problems. it says that I need libgphoto2.so.2 and maybe I will need other packages later. Do you know a way to solve this problem? ...
0
votes
1answer
56 views

E: Unmet dependencies

every time I try to install something or just simply use apt-get update I get an error saying something about Unmet Dependencies. root@xxx:~# apt-get upgrade Reading list of packages... Ready ...
0
votes
0answers
85 views

having dependency issues while installing a package in Debian GNU/Linux 6.0

I am trying to install one package but it depends on some other packages. While installing it aborts and tells me the following: Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is to be ...
2
votes
1answer
409 views

Fix libboost-dev broken dependency

I need to install fcl which depends on libboost-dev. However, libboost-dev depends on libboost1.46-dev and it refuses to install because I have the newer libboost1.48-dev. I have followed ...
1
vote
1answer
763 views

Debian set google-chrome as gnome-www-browser

I've recently set up Debian 6.0.6 and want to install google-chrome as the default web browser. The problem is that I can't remove others browsers (Iceweasel particularly) because there is a ...
1
vote
1answer
183 views

How can Yum tell me the version of depencencies?

I've installed a package with Yum (Varnish 3.0.2). However, a feature I need has been removed so I need to roll back. According to the documentation, the feature was removed in 3.0-Beta, so I wanted ...
4
votes
4answers
5k views

How can I solve VLC's dependency “vlc-nox”?

I have installed Ubuntu (Ubuntu 2.6.38-11-generic-pae #50-Ubuntu SMP, i686 Athlon i386 GNU/Linux). I am newcomer in Linux. I am trying to install VLC media player using command line: % sudo apt-get ...
3
votes
2answers
382 views

How do I install the Python module for Gnash?

My actual problem is: How do I install the Python module for Gnash? But apart from that, what basic concept am I not understanding about installing packages on Linux? I am used to installing ...
2
votes
2answers
2k views

emerge complains about blocked packages: what do I do?

We have an old development server running Gentoo at work. I would like to update this system, but I keep running into problems with the packaging system. To me, it seems like there are dependencies on ...
19
votes
3answers
25k views

How to get list of dependencies of non-installed RPM package?

apt-cache show <package> shows also it's dependencies. yum info <package> does not show dependencies, but it obviously know them. How to ask yum for dependencies of specified package?
0
votes
2answers
757 views

Multiple versions of a lib on Linux

So i often have the problem that i work on applications that need different versions of the same library. I can usually not have two versions of the same library installed but i can link to specific ...
0
votes
2answers
1k views

Cannot resolve dependencies when trying to install gnome-libs or xscreensaver on linux

I am a linux noob and am trying to install ORacle10g on RHEL5 but am running into difficulties on the requirements stage. The only 2 packages I require is gnome-libs and xscreensaver. I have ...
0
votes
4answers
548 views

Distributing binary with dependencies in Linux

I'm developing a cross-platform application and I'm having trouble with distributing a Linux binary. In Windows the dll's were - libsndfile-1.dll lua5.1.dll lua51.dll openal32.dll sfml-audio.dll ...
1
vote
2answers
2k views

How to update the kernel from 2.6.16 on Debian squeeze?

I just did an update of my Debian system from lenny to squeeze as described here. I got some errors during the install, saying that glibc couldn't be updated. I did an apt-get -f install, which ...
5
votes
2answers
7k views

Installing libraries and header files under ubuntu linux for c/c++ developement

I have to admit that I feel completely lost each time I have to fulfill the dependencies of some C or C++ code. Currently, I'm on Ubuntu 9.10, but I remember the same feeling of forlornness from ...
0
votes
3answers
62 views

Finding which OS a software requires?

How to find a (ie., Portable single executable) software requires a particular OS (Win98, Win98SE, WinME, Win2000, WinXP, Linux). I am using Win98SE in one pc and WinXP in another PC. If I ...
0
votes
6answers
813 views

Dependency checker? before installing

Everyone at some point or another must have installed a program from source in Linux. I very often find myself downloading a program I want to install, run through the ./configure and lots of error ...