0
votes
1answer
23 views

How to write dependency rules in rpm .spec file for RHEL OS

I need to build one rpm package, that should be dependent on the installation of another rpm package. On my PC, the dependent package has been installed, with a name like abcd-1425-a.x86_64. I wrote ...
0
votes
0answers
85 views

Yum does not resolve depencies after a rpm -ivh installation

i use AWS EC2 instances. i wanted to setup a package versioned at 5.4.0 but the latest that yum search all --enablerepo epel offered was 5.0.0. i hence did wget and configure && make ...
1
vote
2answers
133 views

Installing from rpm gives weird dependency error

I'm trying to install mysql from rpm file and this is what is get. libaio.so.1 is needed by MySQL-server-5.6.14-1.el6.i686 libaio.so.1(LIBAIO_0.1) is needed by MySQL-server-5.6.14-1.el6.i686 ...
1
vote
0answers
58 views

linux + squashfs-tools for red-hat 5.3

I want to install the squashfs-tools-4.0-5.el6.i686.rpm But I have the following dependencies ( after RPM installation ) please advice what the additional packages that I need to install on my linux ...
1
vote
1answer
167 views

How can Yum tell me the version of depencencies?

I've installed a package with Yum (Varnish 3.0.2). However, a feature I need has been removed so I need to roll back. According to the documentation, the feature was removed in 3.0-Beta, so I wanted ...
14
votes
2answers
20k views

How to get list of dependencies of non-installed RPM package?

apt-cache show <package> shows also it's dependencies. yum info <package> does not show dependencies, but it obviously know them. How to ask yum for dependencies of specified package?
1
vote
1answer
583 views

Problems installing Subversion Perl

I'm trying to setup Bugzilla's VCS integration with Subversion. I've installed the CollabNet Subversion client CollabNetSubversion-client-1.6.16-1.i386.rpm which installs its libs to ...
1
vote
2answers
1k views

How does yum dependency resolution work?

If multiple packages satisfy a dependency for a package being installed, how does yum choose which one to automatically install? Can I force it to let me pick?