Debian package management system

learn more… | top users | synonyms

2
votes
1answer
261 views

Installing libsdl2-dev on Kali 3.18.0 amd64

I'm trying to wrap my head around how to install the libsdl2-dev package on Kali 3.18.0 amd64. I can see that the package is available in the standard Kali repository here: http://http.kali.org/kali/...
2
votes
1answer
72 views

Can I configure dpkg to launch kdiff when there's a conflict with a config file update?

We've all seen it... Configuration file 'blah/blah/blah.conf' ==> Modified (by you or by a script) since installation. ==> Package distributor has shipped an updated version. What would you ...
2
votes
1answer
215 views

which files are shown by dpkg-query -L

I recently ran dpkg-query -L $package on the same package a couple of times and got different results. The difference is that one file, the one we'll refer to as $file, is missing. In between the ...
1
vote
1answer
788 views

Half-installed python packages and circular dependency

Something went wrong while updating to ubuntu 12.04 to 12.10: root@ely:/sys/bus/usb/devices# dpkg -l | grep ^i[HUFW] iU libpython2.7 2.7.3-0ubuntu3.4 ...
0
votes
1answer
75 views

dpkg installs but node will not run

I downloaded Node from this link: NodeJS ARM7l and I followed these directions regarding dh_make: tutorial At the end I run: dpkg -i ~/Builds/Node/node_5.5.0-1_armhf.deb and I get: Selecting ...
0
votes
1answer
55 views

Can I use “gksu” to became root for CLI operation?

I don't care if this is unsafe, because I'm only doing it as a programming exercise, but that's what I want to do: I want to create a C program that, with the "system" command, will call dpkg and ...
0
votes
1answer
35 views

Moving dpkg to foreground during confirmation screen glitch

I was doing a routine apt-get update && apt-get upgrade on my server. The dpkg program displayed a dialog box about a package that had updated its default ini file. I wanted the new file, but ...
0
votes
1answer
66 views

Finding nearest-top-level recommended packages for a particular Debian package

I am in the process of building a live CD, and to reduce the size of the CD image I need to do without some packages. By default, recommended packages are installed and flipping that switch off turns ...
0
votes
1answer
666 views

dpkg : dependency problems - leaving unconfigured

I have a problem with Emacs on my Linux Mint. When I make an apt-get upgrade or apt-get -f install, I have this error message : Paramétrage de emacsen-common (2.0.3) ... /var/lib/dpkg/info/emacsen-...
1
vote
0answers
46 views

dpkg install with apt-get autoremove

OS: Debian 8 I wanted to install PepperFlash, which is non-free. I don't anticipate installing many non-free packages, so instead of modifying /etc/apt/sources.list and downloading from the non-free ...
1
vote
0answers
26 views

dpkg - Breaking own package name

I noticed that on the most recent Ubuntu 15.04, many lib*-dev packages have their dependencies set up according to the following pattern: Package: libstdc++-4.9-dev [...] Breaks: ...
1
vote
0answers
36 views

Ubuntu gnome package installation error

When trying to install insight from some ppa repositories i get these errors. sudo apt-get install insight Reading package lists... Done Building dependency tree Reading state information... ...
1
vote
0answers
72 views

How to hide foreign architecture?

I have an amd64 Debian but I had to install some i386 packages. I don't want to remove this foreign architecture, I just would like to hide it so that, for example, when I seach for libc in aptitude I ...
1
vote
0answers
511 views

apt-get/dpkg can't configure any python related packages

I recently installed Python 2.7 to /usr/local/bin. Now, any time I try to use apt-get it fails on certain python packages as follows: root@lebowski:/usr/local/bin# apt-get upgrade Reading package ...
1
vote
0answers
393 views

How to re-install a ubuntu package when sudo dpkg -i does not work?

I am trying to re-install a broken package (tzdata) using dpkg but sudo dpkg -i tzdata_2014e-0ubuntu0.12.04_all.deb does not work. Here's the output dpkg: error processing tzdata_2014e-0ubuntu0....
1
vote
0answers
1k views

Dkpg very very broken, how to repair / start from clean slate?

I am using Ubuntu 10.04. I inherited this set up from a previous employee who was supposed to be administering this machine, so I can not tell you what happened in the lead up to this problem. ...
1
vote
0answers
54 views

How do I just rebuild the ab binary in apache2-utils on Linux without rebuilding all of apache?

(I'm using Debian). I downloaded source for apache2-utils via apt-get source. I just need to apply a patch that applies to ab.c, and I've applied it. I could rebuild everything using dpkg which will ...
1
vote
0answers
357 views

Ubuntu - not able to fix broken package

I'm trying to install Skype on Ubuntu 12, x64. but it is not working. When I try to fix the broken packages I'm getting the following errors: $ sudo apt-get -f install Reading package lists... Done ...
1
vote
0answers
114 views

When trying to install libgcc1 postinst is not found

I am trying to manually install libgcc1 using dpkg. Everything seems to be working okay, until I get the following error: /var/lib/dpkg/info/libgcc1.postinst: No such file or directory dpkg: postinst ...
1
vote
0answers
387 views

linux mint freeze

Linux Mint freezes after a couple of seconds the desktop loads, in a way that I have to shut the power in order to reboot; the mouse doesn't move, Ctrl+Alt+F1 doesn't do anything and I think even the ...
0
votes
0answers
19 views

How to install Debian package manager

I have a testing platform which has minimal Linux on it. It is so lightweight that it lacks all distribution-specific features. The goal is to install dpkg and apt-utils, which I did, by extracting ....
0
votes
0answers
28 views

dpkg: error processing package util-linux (--configure)

I'm trying to upgrade my webserver from a clean new install to Debian Squeeze. When I tried to apt-get upgrade on my laptop way earlier, it worked out fine, but on the webserver, even apt-get dist-...
0
votes
0answers
19 views

Fixing a Python installation in Ubuntu 15.04

In order to run a program that requires Python 3.5, I recently installed it from source using checkinstall: # download and extract the source # install dependencies cd Python-3.5.0 ./configure make ...
0
votes
0answers
16 views

dpkg can't configure python-pkg-resources

Cubieboard2, Debian Wheezy $ uname -a Linux cubieboard2 3.4.79 #2 SMP PREEMPT Sat Feb 15 10:02:52 CST 2014 armv7l GNU/Linux I'm trying to update the packages, but the process fails at python-pkg-...
0
votes
0answers
53 views

How can I replicate the “dpkg recovery”(shown in Recovery Mode) from Terminal Emulator?

After seriously messing with my LinuxMint 17 installation, I was unable to log in. So I went into recovery mode, where I chose dpkg recovery option. It informed me there were some broken packages and ...
0
votes
0answers
37 views

How to remove an incorrect package version from Ubuntu

An X86 XUbuntu system I work with has Java 8 installed via webupd8, and also a failed version for ARM. I want to remove the partially installed ARM version of Java. $ sudo apt-cache showpkg oracle-...
0
votes
0answers
12 views

Reloading tab completion in postinst script

I'm distributing a .deb that (among other things) installs a file to /etc/bash_completion.d/example for tab completion. The file gets installed correctly, but the tab completion is not immediately ...
0
votes
0answers
79 views

How to convert a Debian package into a homebrew formula?

There's a Debian package I'm interested in for which no homebrew formula yet exists. How can I convert a *.deb package file into a homebrew formula? (FWIW, the Debian package I'm interested in is ...
0
votes
0answers
248 views

Ubuntu dependencies hell

pippo@pippo-desktop:~$ sudo apt-get -f install Reading the package list... Done Generation of the dependency three Reading state info... Done Dependents correction... error. aspell : Dipends: ...
0
votes
0answers
422 views

Terminator (broken?) dependency

I'm trying to install terminator (term emulator) package on Debian 7.2 (stable) from testing: Package: terminator Pin: release a=testing Pin-Priority: 1000 But apt complains: # apt-get install ...
0
votes
0answers
412 views

dpkg: dependency problems prevent configuration

i'm trying to install armory on ubuntu 12.04 but it is not working: $ sudo dpkg -i armory_0.88.1-beta_i386.deb Selecting previously unselected package armory:i386. (Reading database ... 222699 files ...
0
votes
0answers
973 views

Install dpkg without Fink or MacPorts on a mac

I don't want to use either of Fink or MacPorts, because I use Homebrew. I need to use dkpg, but it isn't included in Homebrew, and it fails when trying to compile it from source with: $ make make ...