0
votes
0answers
33 views

gcc fails with “No available targets” on Mac OS 10.9.2

When I try to install pycrypto or psychopg2 on my macbook, I get this error: gcc -arch ppc -arch i386 -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fno-common -dynamic -std=c99 ...
0
votes
0answers
151 views

Cannot compile Python Image Library on cygwin

I'm on cygwin 32bits and I'm trying to build PIL but when I run: >>> python setup.py install gcc exits with the following error message: _imaging.c:75:20: fatal error: Python.h: No such ...
0
votes
0answers
165 views

How to get gcc compiler version in python script on linux?

I'm trying to write a simple python script that will print the the gcc compiler version which is available on the current Linux system. may i know how to get the compiler version in python?
2
votes
1answer
267 views

Why can't I build Deluge?

Deluge is a BitTorrent Client. I am trying to build it from source, since I don't have privilege to install it as root. I am using python setup.py build. But, it failed following message, why? ...
2
votes
1answer
237 views

Python module: Trouble Installing Bitarray 0.8.0 on Mac OSX 10.7.4

I'm new here! I have trouble installing bitarray (vers 0.8.0) on my Mac OSX 10.7.4. Thanks! ('gcc' does not seem to be the problem) Last login: Sun Sep 9 22:24:25 on ttys000 host-001:~ gabriele$ gcc ...
1
vote
0answers
230 views

Building Python h5py on Lion; gcc fail

I am trying to build h5py on OS X Lion; I'm using Python 2.7.2 installed from Scipy Superpack. Using either pip and setup.py approach, I get the same error: lipo: can't figure out the architecture ...
2
votes
1answer
3k views

python.h not found

I got an installation script that calls gcc and gcc tries to compile a .c file that includes a header that does not exist on my system (ubuntu) . #include "Python.h" I have both python 2.x and ...
2
votes
3answers
805 views

Install gcc on OS X Snow Leopard

I'm trying to install the Python Imaging Library on a MacBook running 10.6 Snow Leopard. I haven't yet found a precompiled binary for OS X, so I need to compile it from source, which means I need ...
11
votes
3answers
5k views

Python 2.6.1, pycrypto 2.3 pypi package: “Broken Pipe” during build

I am attempting to install Fabric, which requires pycrypto. During the build for pycrypto I always receive a "Broken Pipe" error. I don't know where to start to fix the problem. I'm running Mac OS X ...