GNU Compiler Collection, a family of compilers for various languages from the GNU Project. Questions about gcc should be limited to installation and basic usage/configuration.

learn more… | top users | synonyms

4
votes
2answers
5k views

gcc not finding header file though its path has been included with -I

I'm trying to install a module (Package::Stash::XS) via cpanm, but the installation is failing due to a gcc error. The command gcc -c -DPERL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -fno-strict-aliasing -...
1
vote
2answers
1k views

Building GCC and Binutils on Windows 7 x64

I am trying to build GCC following the instructions in: Building GCC. At the moment I am building binutils but getting the error: * BFD does not support target x86_64-unknown-cygwin. Look in ...
1
vote
2answers
175 views

Configure Makefile

I am trying to create a file Makefile to use with make so I can compile my codes faster. What I would like to do is just type in the terminal: make dev myOutputName And it should run: gcc -Wall -...
1
vote
2answers
3k views

RHEL Desktop: How to install g++?

I would like to install the gcc-c++ package on RHEL 6. When I search for it with yum, I get No matches found. Searching for it on the web, it seems that I need the workstation sub-channel. However, I ...
0
votes
1answer
49 views

When was gcc last updated in my system?

Is it possible to know the last update date of gcc in Centos? If yes, how can it be checked? The problem is that one my applications, which used to run before in gcc, is not running in gcc.
3
votes
1answer
3k views

Installing a GCC/G++ for my mac OSX 10.8

My problem is simple, I would like to get the OSX/BSD version of the GCC and G++ compilers from the GNU.org website. However after some research (as described below) I learned that Apple uses LLVM ...
1
vote
2answers
764 views

downgrade gcc/g++ after upgrading; compiler error

I just upgraded gcc/g++ from 4.4 to 4.8 (via this method How can I update gcc to the latest version in Ubuntu 10.04?). I realized that 4.8 is going to break a lot of my code and now I want to roll ...
2
votes
1answer
3k views

How to install an old version of gcc using yum on fedora 18?

I want to install gcc 3.6 on fedora 18. when I do yum install gcc I get the gcc 4.7. but I want an old version.
-2
votes
1answer
377 views

OSX zsh - Why do binaries only execute with the full path? [duplicate]

I'm just writing some small C scripts and testing them. Why dose ~ Desktop: gcc test.c -o test ; /Users/xx/Desktop/test ; work just fine while ~ Desktop: gcc test.c -o test ; test ; dose not ...
9
votes
3answers
5k views

Why doesn't '>' redirect error messages from gcc?

I stored the following program in new.c int main() { a; return 0; } It returns an error message. I want to send this message to a file. So I used the following command gcc new.c > ...
0
votes
1answer
345 views

Cygwin - gcc-java installed but cannot call

I'm running Cygwin on Windows 7, with environment variables set up correctly (as far as I can tell). When I do this gcc-java shows up: cygcheck-c .. gcc-core 3.4.4-999 OK gcc-...
4
votes
1answer
8k views

GCC 4.8.1 failed complilation

I am using Ubuntu 13.04 64 bit. This is the error message: checking for x86_64-unknown-linux-gnu-gcc... /home/hoangtu/Downloads/gcc-4.8.1/host-x86_64-unknown-linux-gnu/gcc/xgcc -B/home/hoangtu/...
2
votes
1answer
330 views

Libraries which exist in a binary's elf DT_RUNPATH are not being chosen?

I have custom built gcc-4.7.2 in my environment. The system gcc is gcc-4.3.4. I have patched the DT_RUNPATH for all my custom gcc's binaries and shared libraries using patchelf --set-rpath However, ...
1
vote
1answer
587 views

Run local GCC on remote linux server

I'm sure this has been asked before but after some time searching I'm not finding quite what I want. I have a test server that I cannot install GCC or other development needs on. On my development ...
2
votes
3answers
1k views

Bootstrap error while compiling GCC 4.8.0

I'm getting bootstrap errors while trying to install GCC and could use some help. I'm trying to compile GCC in my home directory on a shared system (cluster). The cluster has GCC 4.4.3, which I'm ...
1
vote
2answers
153 views

GCC running version doesn't match emerged version

Here is the output from my portage search for gcc: emerge -s gcc ... * sys-devel/gcc Latest version available: 4.6.3 Latest version installed: 4.6.3 Size of files: 70,353 kB ...
1
vote
1answer
4k views

Error installing GCC on Fedora

I've been trying to install GCC on Fedora 18. Here is a direct excerpt from my terminal window: ishan@localhost ~]$ sudo yum install gcc gcc-c++ Loaded plugins: langpacks, presto, refresh-packagekit ...
0
votes
1answer
99 views

How do I specify gcc when compiling mod_perl

I want to test if I have the correct compiler when compiling mod_perl. http://blogs.perl.org/users/neilb/2012/11/problems-building-mod-perl-on-mountain-lion-macosx-108.html. How do you specify gcc ...
2
votes
0answers
52 views

Is there a way to use an external computer's compiler and fetch results?

I have to use Windows 7 for some reason, but sometimes I need to compile and execute simple programs using C language, which are supposed to work in Linux. All of them are console applications, don't ...
3
votes
2answers
5k views

gcc running out of memory in Ubuntu 12.10

I'm trying to compile my C project in Ubuntu (32bit) running in VirtualBox. Compiling the code in question requires quite a bit of memory, at least 3 gig. So I gave the VM 2 gig. Along with 2 gig of ...
1
vote
0answers
648 views

Ubuntu, updated boost from 1.46 to 1.52, linker asks for 1.46

I was having some trouble compiling with a piece of software using boost (wt, http://www.webtoolkit.eu/wt). I knew (from testing with another machine) that updating from 1.46 would solve my problem. I ...
3
votes
1answer
1k views

Error when installing cpanminus on Mac OS X

I am trying to install cpanminus through the terminal using the command given on the website: sudo cpan App::cpanminus However I receive the following error: N01-0545---MB:CPAN-1.9800 sucadmin$ ...
3
votes
3answers
1k views

install gcc 4.7 on openbsd, but still 4.2 after installation

I install gcc 4.7 on openbsd using pkg_add. after installation, I use 'gcc -v' to check, I found it is also gcc 4.2 ! how to upgrade gcc 4.2 to gcc 4.7 on openbsd? thank you!
0
votes
2answers
96 views

Installing MediaWiki on Linux

I'm am new to Linux and generally new to setting up a web dev environment. I need help with the basics right now. I'm trying to install a LAMP stack that I can then install MediaWiki on. Here's what I'...
0
votes
1answer
121 views

How can we upgrade old GCC 3.4 to GCC 4.1 on Fedora 3?

How can we upgrade the old GCC from version 3.4 to 4.1(that is from GCC 3.4 to GCC 4.1 or above) on Fedora 3 (version is 2.6.10)? More information: We are developing an application which will be ...
4
votes
2answers
5k views

Installing Network Simulator (NS-2, allinone) on Linux Mandriva

I downloaded the Network Simulator NS-2 from here - http://www.isi.edu/nsnam/ns/ns-build.html#allinone Build ns via GCC 4.2.2 - tar-xzf ns-allinone-2.35.tar.gz cd ns-allinone-2.35 ./install Get ...
1
vote
1answer
336 views

install latest gcc as a non-privileged user

I want to compile a program on a cluster (as a non-privileged user), which requires gcc-4.6, but the cluster has only gcc-4.1.2. I don't want to tell the administrator to update gcc, because 1) he is ...
1
vote
2answers
3k views

alias gcc='gcc -fpermissive' or modifying ./configure script

I am compiling quite big project from source. The compilation always ends with: error: invalid conversion from ‘const char*’ to ‘char*’ [-fpermissive] I have already compiled this project one year ...
5
votes
2answers
19k views

How do I install GCC 4.7.2 on OS X 10.8?

How do I install GCC 4.7.2 on OS X 10.8? I don't care about keeping the Xcode version of "GCC", I just need GCC 4.7.2
4
votes
1answer
5k views

how to install a old version of gcc compiler from software manger and use it with plain “gcc” command?

I am struggling with the problem of Matlab mex compile. It needs specific old version of gcc compiler 4.4.6 . But in manager there is only 4.4 version. How could I specify it as 4.4.6? Or is it ...
0
votes
1answer
566 views

Linux From Scratch, glibc Make error

I am following the LFS guide 7.2 and I am at section 5.7. When executing the Glibc make, I receive the following error. -o /mnt/lfs/sources/glibc-build/math/s_isnan.os -MD -MP -MF /mnt/lfs/...
0
votes
2answers
681 views

Wine on Gentoo fails with libgcc_s.so.1 must be installed message

Not long ago problems with Wine have began on my Gentoo PC... When I try to launch any application I see this thing: libgcc_s.so.1 must be installed for pthread_cancel to work wine client error:25: ...
2
votes
1answer
842 views

How to compile gcc-4.0 on Mountain Lion

So far I've successfully launched the configure, but when I type make, I get the following error, after some time (there's a lot which compile successfully): ld: unknown/unsupported architecture ...
0
votes
1answer
432 views

install gcc on MAC 10.7.4

I am trying to install QtCreator on my MacProbook (10.7.4). QtCreator needs gcc. Can any one suggest how to install gcc on Mac 10.7.4
0
votes
1answer
272 views

Can I use a different version of gcc inside Xcode?

I installed gcc4.7 from MacPorts and I would like to use it inside Xcode (4.5). Is there a way to achieve this setup? Thanks
0
votes
3answers
955 views

How to use LC_MESSAGES=C with gcc every time?

Currently I'm using Ubuntu with my system locale and language set to Japanese. However I'd like to have it always displaying gcc messages in English as it would be easier for me. I found here if I ...
1
vote
2answers
2k views

How can I install GCC on Mac OS X Lion without Xcode?

I find it really hard to believe there is not a simple solution to install GCC on Mac without having to download and install more than 1 GB+ of Xcode. I found a site that helps reduce the amount ...
0
votes
0answers
75 views

Error in enabling json support in php on centos

I'm trying to enable JSON support in PHP on a CentOS server. But after running '# yum install gcc" or any other package I'm given this error: " Fatal Python error: PyString_InternInPlace: strings ...
2
votes
1answer
544 views

Python module: Trouble Installing Bitarray 0.8.0 on Mac OSX 10.7.4

I have trouble installing bitarray (vers 0.8.0) on my Mac OSX 10.7.4. Thanks! gcc does not seem to be the problem: Last login: Sun Sep 9 22:24:25 on ttys000 host-001:~ gabriele$ gcc -version i686-...
0
votes
1answer
361 views

Kerrighed cluster does not use all nodes when running OpenMP

I've been given access to a recently built cluster that uses Kerrighed. I'm the first user of this cluster, so setup and configuration problems may be a possibility. I'm also totally new to ...
0
votes
1answer
2k views

suse broken? Can't find glibc

I wanted to install the new postgres beta which is only available from source. On my server there was no gcc installed so I wanted to install gcc. After running yast, gcc 4.3.3 could only be installed ...
1
vote
0answers
345 views

Compile MakeMKV 1.7.6 - Segmentation Fault

I've previously been able to compile MakeMKV 1.7.5 and older versions, but the latest version (downloaded from http://www.makemkv.com/forum2/viewtopic.php?f=3&t=224) gives me strange segmentation ...
0
votes
1answer
1k views

I've compiled wine on Mac, but it doesn't work, because it freezes and SEGV

I've compiled successfully wine sources. Also added following line into my ~/.profile export DYLD_FALLBACK_LIBRARY_PATH="/usr/X11/lib:/usr/lib" because of errors like: failed to load libX11.6....
1
vote
1answer
44 views

compile command executed inside script gives error, executed outside is fine…might be gcc

I have a script called buildgcc.sh with the following contents. mymac$more buildgcc.sh g++ -Wno-write-strings A.cpp B.cpp B.cpp c.cpp D.cpp E.cpp F.cpp artgdg.cpp G.cpp H.cpp I.cpp J.cpp K.cpp L.cpp ...
2
votes
1answer
2k views

Add a permanent compiler option to g++

I am using a g++ 4.7 on Ubuntu 12.04 to compile my c++ code, and it won't be compiled unless an -std=gnu++11 option is added to my command like this: g++ -std=gnu++11 main.cpp Is there a way to add ...
0
votes
2answers
365 views

Archlinux: Where I can find gcc-4.4-multilib?

As in the topic, I can't find it in AUR, there is only gcc-4.4 or gcc-4.5-multilib. I need gcc-4.4-multilib because of Android compilation. Or if you know - is there any way to compile Android with ...
0
votes
1answer
212 views

Unable to install software on Ubuntu 8.04

I have recently installed 8.04 Ubuntu onto an industrial board and applied the vendor kernel modifications to it. I need to develop applications on another desktop to run on this board in C++ but I am ...
1
vote
0answers
385 views

Building Python h5py on Lion; gcc fail

I am trying to build h5py on OS X Lion; I'm using Python 2.7.2 installed from Scipy Superpack. Using either pip and setup.py approach, I get the same error: lipo: can't figure out the architecture ...
0
votes
2answers
1k views

Installing pdftk on Amazon EC2 Linux Instance

I am having trouble installing pdftk on an amzn-ami-2011.09.2.x86_64-ebs (ami-953b06e1) instance. Since pdftk is not in the list of available packages I have tried to build it from source but failed ...
3
votes
1answer
200 views

how to tune libstdc++ to the native architecture when building gcc

I recently found that when I build my C++ software, I get about a 10% speedup by using the g++ march=native option. When compiling gcc and libstc++, is it possible to tune the libstdc++ library to ...