glibc (GNU C Library) is the C standard library from the GNU project.

learn more… | top users | synonyms

1
vote
0answers
20 views

Buildroot 2015 Fails glibc

When I try to use buildroot, Glibc fails to compile with this error: checking for suffix of object files... configure: error: in ...
0
votes
0answers
64 views

Patching glibc on Arch Linux fails with __libc_multiple_libcs

I tried to recompile glibc on Arch Linux with a patch to increase thread local storage space so Unreal Engine would run, as ...
0
votes
0answers
63 views

Install ypbind in Oracle Linux 7

I need to install ypbind in order to set the NIS settings at an Oracle Linux client. So I downloaded a red hat version of this package (since OL7 is just an rhel clone) and I tried the following: ...
2
votes
0answers
246 views

Upgrading glibc in centos 6.6

My server is using glibc-2.12.x. when I install certain packages it gives an error.Dependency not found glibc-2.14 or above is required.When I try using yum install glibc* it says server is already ...
0
votes
0answers
18 views

Ubuntu 12.04 unable to install gfortran

I am trying to install gfortran from the terminal, but I get this error E: The package libc6 needs to be reinstalled But I can't find an archive for it. Also, the Ubuntu software center pops up and ...
0
votes
0answers
26 views

LFS-systemd toolchain error

In 5.7-glibc,when I finished compiling.I run a test as the book mention echo 'main(){}' > dummy.c $LFS_TGT-gcc dummy.c readelf -l a.out | grep ': /tools' But it shows: dummy.c:1:1: warning: return ...
0
votes
0answers
50 views

Does use of SELinux help mitigate buffer/heap-overflow vulnerabilities like glibc/Ghost?

Can using a mandatory access control solution (like SELinux) help to limit the vulnerability of a system to buffer/heap-overflow exploits like the newfound Ghost vulnerability in glibc? (I realize ...
0
votes
1answer
95 views

Determine vulnerable programs affected by glibc's ghost bug?

How do I determine the programs that are installed on my system which could be vulnerable to glibc's ghost bug? (Presuming the system has a vulnerable version of the libc6 library). Posts like How To ...
10
votes
3answers
1k views

GHOST glibc vulnerability (CVE-2015-0235): is it required restart a server after glibc upgrade?

I want to update glibc according to RedHat: https://rhn.redhat.com/errata/RHSA-2015-0090.html Is it required restart a server after the glibc upgrade?
0
votes
1answer
2k views

Redhat Linux /lib/libc.so.6: version `GLIBC_2.16' not found (required by /lib/libncurses.so.5)

I am running a server RHEL 6.4 which currently has GLIBC 2.12 installed on it. We are trying to run a program which gives this error /lib/libc.so.6: version `GLIBC_2.16' not found (required by ...
0
votes
1answer
127 views

Copying glibc from initrd to my root filesystem

I'm trying to install glibc 2.20 (built recently) to Debian using this guideline from FAQ referenced at this page (the question within FAQ is How do I install all of the GNU C Library project ...
0
votes
2answers
210 views

Installing a specific glibc version on debian/apt

A user of my software uses Debian wheezy. The software generated a core dump that I want to analyze. However, for this to work, I require the correct versions of low level system libraries, especially ...
3
votes
1answer
715 views

unable to install libc6-dev

I type in sudo apt-get install libc6-dev and get the following back: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
1
vote
4answers
4k views

Where to download missing libc.so.6

I recently accidentally deleted the file /lib/x86_64-linux-gnu/libc.so.6. This file is needed by most programs, so my computer is basically broken and I can only access the hard drive through a live ...
0
votes
0answers
161 views

How do I link to a shared library (.so file) in Linux?

I'm relatively new to Linux and am having trouble trying to figure out the intricacies of .SO files and how shared libraries(and their versions, dependencies etc work). The scenario is this: I have a ...
1
vote
1answer
446 views

Installing linux/selinux kernal headers

I'm trying to build the newest version of glibc (2.19) on CentOS 5.6 and I've run into some issues The documentation of glibc says that I need at minimum the linux kernal headers 2.6.19 (even if this ...
1
vote
0answers
315 views

Compile with openssl-1.0.1e but linked against old glibc

Desirable result: compile a binary with statically linked openssl 1.0.1e but dynamically linked glibc, stdc++, etc. Binary should run on most servers, for example Ubuntu 11.04 or RHEL 6, CentOS 6.4. ...
1
vote
2answers
9k views

Version `GLIBCXX_3.4.15' not found in CentOS (in file /usr/lib/libstdc++.so.6)

I try to use a program and I get the following error. /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found Under /usr/lib64 the libstdc++ I see is libstdc++.so.6.0.13 (and a soft link). ...
1
vote
2answers
2k views

how to update libc on debian squeeze?

I want to install Arachni scanner on my debian squeeze box. But it has problem with glibc version. It need glibc 2.15 but what is installed on my debian is 2.11 . How can I update my libc from 2.11 ...
1
vote
0answers
221 views

glibc's --with-cpu option

I'm unable to compile glibc: configure exits with the following error: configure: error: The [CPU] subspecies of x86_64 is not supported. I'm sorry; this must be somewhere, but I haven't been able ...
0
votes
1answer
97 views

Are there any problems after glibc update from 1.2.10 to 2.12 in Linux?

I want to update my glibc from 1.2.10 to 2.12. Are there any problems regarding dependency for other tools and software currently installed using previous version of glibc on CentOS release 6.3 ...
1
vote
0answers
34 views

install drivers - dependency conflict: ubuntu 64 bits

I got the message from the system as follow: # apt-get install build-essential The package libc6 needs to be reinstalled, but I can´t find an archive for it. It is running in Ubuntu 64bits on Mac ...
0
votes
2answers
200 views

How much RAM for running a Tor Bridge?

Heyho, I'd like to run several Tor bridges on vservers. Operating system will be Linux (Ubuntu 12.04 amd64). Does someone have experience with how much RAM I'll need? The 512MB vservers cost 30 - 50 ...
2
votes
0answers
571 views

Can you run a program using a custom glibc? [closed]

I installed Mathematica 9 on an old Red Hat Enterprise Linux AS release 4 system. After the installation, I tried to start Mathematica, but following message came out: ...
14
votes
3answers
47k views

How to fix “/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found”?

How to fix this error: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found Platform: Linux alef 3.2.0-4-amd64 #1 SMP Debian 3.2.35-2 x86_64 GNU/Linux
2
votes
1answer
1k views

execvp exec format error for shell script on Red Hat Enterprise Linux 6

We have two RHEL 6 systems that are running identical versions of the kernel and glibc (glibc–2.12–1.90.el6_3.6). According to the POSIX standard and the Linux man pages, if the kernel determines that ...
0
votes
1answer
435 views

Linux From Scratch, glibc Make error

I am following the LFS guide 7.2 and I am at section 5.7. When executing the Glibc make, I receive the following error. -o /mnt/lfs/sources/glibc-build/math/s_isnan.os -MD -MP -MF ...
0
votes
2answers
603 views

Wine on Gentoo fails with libgcc_s.so.1 must be installed message

Not long ago problems with Wine have began on my Gentoo PC... When I try to launch any application I see this thing: libgcc_s.so.1 must be installed for pthread_cancel to work wine client error:25: ...
1
vote
1answer
690 views

What is the error on executing apt-get (GLIBCXX_3.4.15 not found)?

I have an error by installing and executing the apt-get (there is no package manager except udpkg): apt-get: /usr/lib/libstd++.so.6: version GLIBCXX_3.4.15 not found (required by apt-get) I have ...
1
vote
1answer
1k views

Trying to compile glibc in ubuntu. Why does configure stop at linuxthreads?

Here's the config.log contents: I disabled _FORTIFY_SOURCE because it caused an error. But I'm completely clueless as to what might be wrong. (I am aware of this post, suggesting to ...
1
vote
2answers
711 views

Why program fails when started using /lib/ld-linux.so.2?

$ /bin/bash -c 'echo qqq' qqq $ /lib/ld-linux.so.2 /bin/bash -c 'echo qqq' /bin/bash: xmalloc: ../bash/variables.c:2176: cannot allocate 3 bytes (8192 bytes allocated) Why this happens (zsh4, python ...
0
votes
1answer
1k views

suse broken? Can't find glibc

I wanted to install the new postgres beta which is only available from source. On my server there was no gcc installed so I wanted to install gcc. After running yast, gcc 4.3.3 could only be installed ...
0
votes
1answer
761 views

glibc issue in arch linux destroyed my system

I followed the article here http://www.archlinux.org/news/the-lib-directory-becomes-a-symlink/ Didn't work for me. Then I followed an advice in the sticky thread in archlinux forum ...
2
votes
2answers
3k views

libc.so.6() (64-bit) is needed by … ubuntu 11.10

I am trying to install an odbc driver for vPostgres (Vmware's version for postgres) on Ubuntu 11.10 (64-bit). I have downloaded the rpm file of the installer (64-bit) and when I try to install the rpm ...
0
votes
2answers
908 views

apt-get upgrade fails because of glibc6

I cannot upgrade my system anymore. I get the following error. What can I do to resolve this problem? apt-get upgrade Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
9k views

Wrong libc6 version in Debian Squeeze — can I go back?

Attempting to make some ruby gems work, I discovered I needed to install the dev ruby package, which apparently required the dev libc6. When I tried to install it (using the approved squeeze ...
1
vote
2answers
2k views

GLIBC_2.14 for slackware 13.37

I am trying to run tor on my slackware machine and when I do I get the error: tor: /lib64/libc.so.6: version 'GLIBC_2.14' not found (required for tor) So I run the command: slackpkg upgrade ...
0
votes
0answers
920 views

Building against an older glibc

Is it possible to build glibc/gcc/binutils in the version combo of say 2.4/4.6/2.22 (or some later version of GCC used by the oldest/'stablest' linux distro's still around)? I would like to create ...
2
votes
0answers
1k views

Unable to install synergy on red hat 5.4

I'm trying to install Synergy on Red Hat Linux 5.4 but I'm getting the below errors: rpm -ivh synergy-1.3.8-Linux-x86_64.rpm error: Failed dependencies: libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is ...
1
vote
1answer
785 views

Suse 10.3 won't do anything after openssl upgrade. /lib64/libc.so.6: version `GLIBC_2.7' not found

I upgraded my openssl version with the command: rpm -i --nodeps openssl-0.9.8p-1.x86_64.rpm And now I get following error for almost every command I enter: /lib64/libc.so.6: version `GLIBC_2.7' ...
0
votes
1answer
123 views

How do popular package managers upgrade packages like glibc?

I've been looking further into Linux from Scratch, and I am particularly interested in the package management side of the system. I understand that this is not covered in the book, but if I were to ...
1
vote
0answers
362 views

So I stupidly install newlib, and probably overwrote references to glibc. How can I recover glibc?

I forgot to set a make --prefix and I think it wrote to /usr/local/ by default and now I'm having all kinds of errors. I'm on ubuntu natty, what's the easiest way to resurrect glibc. I've tried to ...
0
votes
2answers
3k views

How to restore /lib/libc.so.6?

I occasionally deleted my /lib/libc.so.6. By using LD_PRELOAD I successfully made a link of my /lib/libc-2.12.1.so file in my home folder and now most of the command works (cp, ln, etc...). But I ...
0
votes
2answers
303 views

where can I find these rpm packages?

I have to install these two packages but couldn't find then anywhere glibc-32bit-8.1-9 glibc-devel-32bit-8.1-9 Could you please help in locating them?
4
votes
1answer
3k views

segfault error 4 in libc-2.11.1.so

Key Info: Ubuntu 64 Lucid (No memory issues, no new hardware) Nearly every application dies with this segfault. Googling around finds dozens of posts that have this exact problem and not a single ...
4
votes
1answer
1k views

Forward/backward compatibility of glibc and the kernel

Suppose you have glibc 2.5 compiled with kernel headers 2.6.18 Is it safe to run this glibc with Linux kernel 2.6.32? Is it safe to run this glibc with Linux kernel 2.6.9?
4
votes
1answer
1k views

How to build a self-sufficient gcc/glibc/binutils set in a non-standard path?

Suppose a set of custom-built gcc/glibc/binutils are in $prefix (e.g. /home/user/path) I want: gcc to look for libraries in $prefix/lib64 instead of /lib64 gcc to look for headers in ...