`homebrew` is a package manager for Mac OS X, in the spirit of Linux's `apt` or `yum`.

learn more… | top users | synonyms (1)

0
votes
1answer
1k views

How to alter my mac os $PATH variable so that I can run the latest php version? [duplicate]

Possible Duplicate: What are PATH and other environment variables, and how can I set or use them? I've just followed this article ...
2
votes
1answer
446 views

Problems with freetype on OSX 10.7.4

I'm trying to install mplayer with OSD using homebrew. I've added both --enable-menu and --with-freetype-config=/usr/local/Cellar/freetype/2.4.10/freetype-config to the brew recipe. ==> ...
10
votes
4answers
4k views

$PATH is driving me nuts

OK, apologies if this is something dumb, but I'm running out of ideas. Goal: prepend /usr/local/bin to $PATH Problem: $PATH won't do what I want or expect How I got here: I want to start learning ...
1
vote
1answer
204 views

Homebrew slows my terminal down on startup

I've had some issues with my terminal being extremely slow while starting up (both new windows and new tabs), from 10 seconds and up. I've tried deleting the Apple System Logs, but it doesn't help. ...
1
vote
1answer
833 views

Homebrew requires something uninstall-developer-folder removes

I was having trouble installing irssi (brew install irssi), so I ran brew doctor, which returned a warning mentioning an outdated copy of Xcode and saying I should run ...
13
votes
2answers
3k views

How can I use the Homebrew Python with Homebrew MacVim on Mountain Lion?

I originally asked and answered this question: How can I use the Homebrew Python version with Homebrew MacVim? These instructions worked on Snow Leopard using Xcode 4.0.1 and associated developer ...
2
votes
1answer
874 views

Should I change ownership of files in /user/local/share/locale?

I'm trying to install Homebrew, and brew doctor returns a lot of warnings, one of which is this: Warning: Some directories in /usr/local/share/locale aren't writable. This can happen if you "sudo ...
0
votes
1answer
532 views

How do I uninstall iconv from a Mac?

I'm trying to get Homebrew working, and brew doctor returns several warnings, one of which is this: Warning: The following libiconv files were detected in /usr/local: include/iconv.h Homebrew doesn't ...
0
votes
1answer
339 views

I cannot get pg-0.14.0 gem installed after Mountain Lion install

I have been trying for some time now to get my Rails development environment back up since I upgraded from Lion to Mountain Lion. The problem is specifically installing the pg-0.14.0 (postgresql) gem. ...
2
votes
1answer
85 views

Source multiple files via shell filename completion

I'm trying to enable autocompletion of my homebrew commands. Homebrew automatically creates the folder bash_completion.d and sym-links all completion files there. $ ls -a `brew ...
7
votes
4answers
5k views

Removing git from /usr/bin

I'm on OS X 10.8 and I'm using Homebrew. brew doctor tells me that I have 2 git installations, one in /usr/bin and the other one in /usr/local/bin. Is it a bad idea to remove git from /usr/bin? If ...
11
votes
1answer
8k views

PostgreSQL homebrew installation lacks config files

So I successfully installed PostgreSQL 9.1 on MacOSX Lion. Unlike people say, I didn't have to change the PATH and no other version of PostgreSQL was installed on the system ($ psql --version shows ...
1
vote
1answer
703 views

GNUPLOT on Lion using Homebrew

After upgrading to OSX 10.7.4 I had to reinstall GNUPLOT which is always a hassle. I decided that I would try Homebrew instead of Fink or MacPorts. Ofcourse, before installing Homebrew one needs the ...
12
votes
1answer
3k views

How can I use the Homebrew Python version with Homebrew MacVim on Snow Leopard?

Note: For Mountain Lion, see: How can I use the Homebrew Python with Homebrew MacVim on Mountain Lion? I've installed Python 2.7 with Homebrew on Mac OS X Snow Leopard. When I install MacVim ...
4
votes
1answer
3k views

Trying to install MySQL, lots of brew doctor errors

In OS X Lion I couldn't install mysql. I get this when typing brew install mysql Error: You must `brew link cmake' before mysql can be installed so then I type brew link cmake ...
1
vote
1answer
244 views

Why doesn't git-svn respect my $PATH?

I have installed git and svn with homebrew on my mac running 10.7.4. There are two versions of svn on my machine and I have set up my path to check for homebrew things first. Unfortunately git is ...
16
votes
2answers
8k views

Symlink error when installing MySQL via Homebrew

Trying to install MySQL via Homebrew. The install seems to work fine but i get an error: "Error: The linking step did not complete successfully The formula built, but is not symlinked into /usr/local ...
13
votes
2answers
14k views

Errors in Homebrew on OS X Lion

I just ran the Homebrew script as described in the installation page. I then ran brew doctor in Terminal, and it returned several errors. I'm not sure how to fix those errors, please help. brew ...
2
votes
2answers
1k views

upgraded local git on Lion, now what?

I reformatted my machine with Lion which had this default version of git: $ git --version git version 1.7.7.5 (Apple Git-26) I decided to upgrade git so I did: $ brew install git ==> ...
1
vote
1answer
490 views

Error related to pkg-config when installing frei0r as part of another package

I am trying to build https://github.com/mltframework/shotcut on OS X Lion (using their script in scripts/build_shotcut.sh) and after numerous hurdles I'm stuck on this error: ./configure: line 16062: ...
1
vote
0answers
44 views

Adding my own dylibs to homebrew

I'm trying to install liberate, which I want to put in /usr/local/lib. However, when I do this, homebrew complains about a Unbrewed dylibs were found in /usr/local/lib. What's the best way to add my ...
0
votes
1answer
336 views

Homebrew claims it's outdated, except when I try to update

When I run brew doctor I'm told that my brew installation is outdated. Specifically: ~$ brew doctor Error: Your Homebrew is outdated You haven't updated for at least 24 hours, this is a long time in ...
3
votes
1answer
1k views

Is it safe to run multiple brew install commands at the same time?

Is it safe to run multiple brew install commands at the same time?
0
votes
2answers
857 views

'brew doctor' command not recognizing path changes

When I run brew doctor, I get /user/bin occurs before /usr/local/bin So I changed my /etc/paths and my ~/.MacOSX/environment.plist as this post said to do. When I run brew doctor again, I still get ...
1
vote
1answer
1k views

brew doctor giving error on a directory that has been removed

I just installed homebrew and as suggested, I ran the brew doctor command. I am linux newbie and do not know how to fix most of these things. But I would like to ask especially about the following ...
0
votes
1answer
3k views

bash says “homebrew: command not found”

I am new to OS X and was following a video and typed export PATH="$HOME/opt/git/bin:$PATH" I believe this messed up my path and I am not able to install MySQL now. When I tried to install ...
1
vote
0answers
877 views

Running Postgresql on OSX

I'm trying to install Postgresql on OSX Lion. I'm using Homebrew, so my installation consisted of doing brew install postgresql initdb /usr/local/var/postgres Now when I try to start ...
3
votes
2answers
552 views

Can't compile tmux with iTerm support

I'm trying to compile the tmux that has iTerm2 support. This is the error I get: configure.ac:105: error: possibly undefined macro: AC_SEARCH_LIBS If this token and others are legitimate, ...
0
votes
1answer
116 views

COMP_LINE not set despite bash completion being installed

I'm using homebrew's bash completion package on OSX, which is installed in /usr/local/etc/bash_completion. It's working fine, but there are many extensions for it which rely on various environment ...
0
votes
2answers
1k views

Undefined symbols for architecture x86_64: Mac OSX when installing ImageMagick

I am trying to install imagemagick and on my snow leopard MacOSX with homebrew. when i run: sudo brew install imagemagick it breaks at this point with the following error log. ld: warning: ...
3
votes
1answer
469 views

Macports to Homebrew conflicts?

I am currently using MacPorts on Lion but thinking of switching to Homebrew. There is a suggestion that installing to /usr/local causes problems and ~/.homebrew would be an alternative. Can I ...
6
votes
1answer
1k views

brew link jpeg issues

I am trying to install opencv on Mac OSX Lion. brew install opencv I get the following error (and a few other similar ones) Error: The linking step did not complete successfully The formula built, ...
1
vote
1answer
951 views

Homebrew error with MacVim on OSX Lion

I am trying to install Macvim with Homebrew on an OSX machine running Lion. After installing iconv at /opt/local/bin/iconv I get the following error in the log: Error: Can't run ...
11
votes
2answers
5k views

Homebrew won't link git

When I installed git or upgrade git via brew I couldn't link it with brew link git. If I try sudo brew link git I get: cowardly refusing to sudo brew link It says that I have to check the ...
1
vote
0answers
299 views

can I remove imagemagick by deleting directories?

I posted this to StackOverflow, but probably belongs here. I'm on OSX Lion, trying to get back to basics so I can run RMagick in Rails 3.0, using rvm. When I tried to add the RMagick gem to Rails ...
2
votes
2answers
575 views

Can't get ffmpeg to use frei0r on OSX (through homebrew)

I am trying to get ffmpeg to use frei0r plugin and although I was able to get frei0r show up in filters list, I get the error: [frei0r @ 0x10331c1c0] Could not find module 'glow' Error initializing ...
6
votes
1answer
10k views

How do I fix “Library not loaded: libssl.1.0.0.dylib” with PostgreSQL?

After deleting Macports, I've had some strange behaviour. When I try to run PostgreSQL via CLI, I get: pawel:~ pawel$ psql dyld: Library not loaded: /opt/local/lib/libssl.1.0.0.dylib Referenced ...
5
votes
3answers
7k views

Homebrew is “cowardly refusing” to install OpenCV

I am trying to install OpenCV with Homebrew. After typing sudo brew install opencv I get this error message Cowardly refusing to sudo brew install How can I solve this?
7
votes
1answer
6k views

Homebrew doesn't find XCode 4.3

When I try to install something with homebrew I get an error message that it does not find XCode. But I just installed XCode 4.3 and also did a reboot. admins-MacBook-Pro-2:~ ernst$ brew install ...
48
votes
3answers
38k views

Where can I find a list of all formulas available for homebrew?

Is there a way to get a list of all formulas (packages) I can install using homebrew for Mac OS X?
5
votes
2answers
2k views

The suggested way to handle pip(easy_install) with homebrew?

I know there are brew-gem and brew-pip but it is still really easy to get confused. Let's say my Mac OS X is 10.7.2. There are at least, as far as I know, 3 locations for Python modules (assume ...
1
vote
0answers
326 views

How to install R with homebrew with Java support?

I have been trying to install the R language with Homebrew but when I install Java packages like iplots I get the following error: * installing *source* package ‘iplots’ ... ** R ** inst ** preparing ...
9
votes
2answers
2k views

Forcing Homebrew and Macports to coexist?

I have a MacOSX system that I've been using for a number of years, and during this time, I have installed quite a few packages via Macports. I now want to try Homebrew, but it's clear from what I've ...
7
votes
5answers
3k views

How do I alias a Homebrew installed Ruby 1.9 gem binary in /usr/local/bin?

Homebrew's Ruby 1.9 ships with rubygems. Doing gem install ... installs files and binaries into some long-winded path. For example, bundler is installed at: ...
13
votes
2answers
14k views

How to install Meld with Homebrew on Mac OSX?

To install meld on Mac OSX I try to run: brew install meld but I got the following error: Error: No available formula for meld What is the right way to install meld?
2
votes
1answer
4k views

“Could not resolve host: github.com” error while updating Homebrew after installing git

I'm using OS X Lion (10.7.2). I installed Homebrew on my Mac, and I executed the command below. $ brew install git and then: $ brew update error: Could not resolve host: github.com; nodename nor ...
2
votes
1answer
2k views

Installing Ruby with Homebrew

I'm trying to install Ruby 1.9 using Homebrew. I'm using Mac OS X Lion, so Ruby 1.8.7 is installed by default. I've got Homebrew installed at /usr/local/bin/brew (well that's what it says if I run ...
9
votes
5answers
3k views

Homebrew keeps saying XCode is not installed

I'm trying to installed Ruby using Homebrew, the OSX package manager. When I run 'brew install ruby' I keep getting the message 'Warning: XCode is not installed!'. XCode is installed, it's lying. ...
0
votes
5answers
205 views

Bash: Switching from user to root causes issues with prompt

I am on a Mac, running Snow Leopard (if it matters). I am customizing my bash prompt to display things that get pulled from user specific places. For example, I am using Ruby Version Manager to manage ...
1
vote
1answer
587 views

Using PostgreSQL on Mac OS X Lion

I just got a new Mac with Lion installed on it. I then installed Xcode (4.1 through the App Store). Next, I installed Homebrew and I was about to do brew install postgresql like I had done on Snow ...