0
votes
1answer
18 views

how to configure apt-get to use multiple repository components or sections

My ubuntu 14.04 installation shows the apt-get uses only one respository section: $ apt-cache policy Package files: 100 /var/lib/dpkg/status release a=now 500 ...
0
votes
0answers
32 views

On linux ubuntu 'sudo apt-get…' fail [closed]

When I do: sudo apt-get install ssh I get errors such as: Could not connect to it.archive.ubuntu.com:80 (193.206.140.45) - connection timed out I get similar errors for all other apt-get calls. ...
0
votes
1answer
177 views

Tor - dependency/package error on debian wheezy

When I am trying to install Tor on Debian wheezy via Apt-Get CLI, I am getting the below error. Libevent and LibSSl are already installed on the system. Do you have any suggestions on how to resolve ...
0
votes
1answer
46 views

Where does system downloads the files?

I have Elementory OS currently running on my PC. It is based on Debian-Ubuntu. I had recently run the command "apt-get upgrade" and downloaded 162 MB of data Now I don't have an internet on another ...
0
votes
1answer
280 views

Issues installing MariaDB (5.5.34) on Debian 7 (Wheezy)

When attempting to install MariaDB (5.5.34) on Debian 7 (Wheezy) apt-get outputs the following: Setting up mariadb-server-5.5 (5.5.34+maria-1~wheezy) ... [ ok ] Stopping MariaDB database server: ...
0
votes
0answers
126 views

Linux Mint 15 won't login in user profile after apt-get upgrade

I installed an external library for Pillow (PIL fork) and got tried to install another one after that and I got an error message for broken packages. I ran apt-get update and got an error saying that ...
-1
votes
1answer
1k views

Debian: apt-get doesn't find any package

I've got the Problem that apt-get doesn't find any package on my new installed Debian 7.3. First I got the error that I should enter the Installation-CD, then I edited the /etc/apt/sources.list and ...
1
vote
1answer
187 views

Debian Testing installs Iceweasel ESR (severely outdated)?

I just reinstalled Debian Testing, and for some reason, instead of Iceweasel 25, I have 17. The installed and candidate versions are both 17.0.9esr-1~deb7u1. apt-get update && apt-get upgrade ...
2
votes
1answer
258 views

python2.7: can't open file '/usr/lib/python2.7/py_compile.py'

I'm getting lot's of error with apt-get. I've tried to install package manualy but everything seems stucked. mio@vm:~$ sudo apt-get install --reinstall python2.7-minimal Reading package lists... Done ...
1
vote
1answer
148 views

What to do when launchpad is down?

As I am writing this (Friday, November 8, 2013 at 9:59:18 PM EST) launchpad is down. Apparently there is a power failure (https://twitter.com/launchpadstatus/status/398980619880775680). I tried ...
0
votes
2answers
185 views

Not able to apt-get update from terminal, what to do now?

Whenever I try to update from terminal, I get this error: root@Utkarsh[utkarsh]#apt-get update Hit http://packages.bosslinux.in anokha Release.gpg Hit http://packages.bosslinux.in anokha Release Hit ...
0
votes
0answers
54 views

apt-get resolving hosts error

My every apt-get command ends with someting like this: Err http://security.ubuntu.com quantal-security Release.gpg Temporary failure resolving 'security.ubuntu.com' Err http://rs.archive.ubuntu.com ...
4
votes
2answers
5k views

How to fix“error while loading shared libraries: libgl.so.1”

After I run this command dpkg -l |grep ^rc|awk '{print $2}' |sudo xargs dpkg -P I got the problem while opening smplayer,cairo-dock,unity-2d-shell and amdconfig ,"error while loading shared ...
1
vote
2answers
197 views

Debian: why are the suggested upgrades from apt-get and synaptic different?

I am running Debian Jessie, and this is the content of my sources.list file: deb http://ftp.debian.org/debian jessie main contrib non-free deb http://security.debian.org/ jessie/updates main contrib ...
4
votes
2answers
2k views

How to upgrade to latest git on debian 7?

I have installed git through apt-get on debian 7 which gives me: # git --version git version 1.7.10.4 I would like to ugrade to the latests version of git. I have tried: sudo apt-get install ...
2
votes
1answer
80 views

Could not perform immediate configuration on 'perl'

I'm trying to upgrade a debian squeeze system to wheezy. I've done an apt-get update && apt-get -V upgrade on squeeze, then changed my source.list to reference wheezy not squeeze. then, ...
0
votes
1answer
533 views

How to add yourself to sudoers list?

I was trying to install a package using the command: sudo apt-get install ruby-rvm But I'm prompted with nish is not in the sudoers file. This incident will be reported. I tried to add myself ...
0
votes
1answer
197 views

I'm getting this error everytime I try to install using apt-get E: Sub-process /usr/bin/dpkg returned an error code (2)

I am running 64bit Ubuntu 13.04 I tried to install cairo-dock executed these command : sudo add-apt-repository ppa:cairo-dock-team/ppa - went well, no error. sudo apt-get update - went well, no ...
2
votes
2answers
93 views

How can I review updates before actually upgrading with apt-get in Debian

Before acutally doing #apt-get upgrade on a Debian server, I'd like to get an overview of the package names about to be updated and what the changes are in those packages. Recently my root account ...
0
votes
4answers
73 views

How do I get a list of programs that can be installed?

On Linux Mint, where can I find a list of programs that can be installed using sudo apt-get install (name) ?
1
vote
2answers
1k views

Can I make apt-get always use --no-install-recommends?

A bit of background, feel free to skip this paragraph if you don't care. I have a bit of academic experience with linux and unix from college but I'm still somewhat of a n00b because I was always a ...
0
votes
2answers
2k views

apt-get is unable to lock the administration directory while installing

I'm running Linux Mint 15 with Cinnamon. I'm fairly new to Linux, and I'm operating from an 8 GB memory stick. In the terminal, I typed the following line: sudo apt-get install supertuxkart It was ...
0
votes
1answer
72 views

How to apt-get latest package version

I am running Ubuntu 12.04. I need to upgrade my version of gnome-control-center from gnome-control-center 1:3.4.1-0ubuntu1 to gnome-control-center 1:3.4.2-0ubuntu0.11 as it should hopefully fix ...
1
vote
1answer
371 views

Ubuntu/apt-get: redownload all extra/suggested packages dependencies

I have two computers: one's online and fully updated, the other's offline. I want to download specific .deb files to deploy them on offline computers manually. For instance I want to install ...
1
vote
1answer
348 views

How to get latest nginx in Wheezy using apt-get

It seems like the nginx package in debian wheezy apt-get is old and only goes up to 1.2 whereas the latest version is 1.4 Do I really have to build it from source or is there a way to get the latest ...
0
votes
1answer
355 views

dpkg : dependency problems - leaving unconfigured

I have a problem with Emacs on my Linux Mint. When I make an apt-get upgrade or apt-get -f install, I have this error message : Paramétrage de emacsen-common (2.0.3) ... ...
0
votes
2answers
4k views

Debian 6.0.6 apt-get “unable to locate package” - how do I find the package?

I'm running Debian 6.0.6 and trying to install libeigen3-dev using: sudo apt-get install libeigen3-dev But I get the following output: Reading package lists... Done Building dependency tree ...
0
votes
0answers
447 views

apt-get “Broken packages”

While installing python-dev: sudo apt-get install python-dev I am getting the following error: The following packages have unmet dependencies: python2.7-dev : Depends: python2.7 (= 2.7.3-0ubuntu3) ...
0
votes
1answer
782 views

ubuntu: upgrading

i have some kind of problem with my system (it's a kvm vm with 2 gig ram and 50gig hd). when i try to install "linux-image-3.2.0-38-generic-pae" using apt-get, i'm told that there's no space left on ...
0
votes
1answer
25 views

Linux's Packages updates

I'm trying to reset a Windows's password I have on a computer through a Debian distribution I have on the same machine, the best way for doing this is with a package u can apt-get called chntpw, the ...
3
votes
4answers
54 views

How to find out what files will be installed in the filesystem when installing a package with aptitude?

In my case I want to do aptitude install wireless-tools but want to know which files will be installed and where in the filesystem before I install the package.
0
votes
1answer
275 views

Error reading package lists

I have been trying to get updates on my Quantal Desktop and apt-get update gives me the following: Reading package lists... Error! E: Encountered a section with no Package: header E: Problem with ...
2
votes
1answer
319 views

Fix libboost-dev broken dependency

I need to install fcl which depends on libboost-dev. However, libboost-dev depends on libboost1.46-dev and it refuses to install because I have the newer libboost1.48-dev. I have followed ...
1
vote
1answer
2k views

Install custom software on Iomega PX4-300D NAS (Debian OS)

I am trying to put additional software on my Networked Attached Storage (NAS) The NAS appears to be running Debian. Anyway, apt-get is already on the machine. I just needed to add the correct ...
0
votes
3answers
1k views

Cannot install show because of FQDN

When i install show (sudo apt-get install nmh). It fails with the following error : The hostname -f command returned: $1 Your system needs to have a fully qualified domain name (fqdn) in order to ...
2
votes
2answers
2k views

Problems with apt-get(unmet dependencies)

I am using Ubuntu Desktop 12.04(64 bit). I have downloaded skype from the official website and opened the deb package from the terminal(sudo dpkg -i skype-ubuntu-precise_4.1.0.20-1_i386.deb) but ...
0
votes
2answers
346 views

Installing php on Ubuntu 8.10; package not found?

I'm new to linux. For some work I need to install php but not necessarily apache as I'm using my own webserver. I'm using Ubuntu 8.10. But when I try to install php I get the following error. ...
2
votes
3answers
232 views

Is there a shortcut to run a suggested command in a terminal?

If I type in a command for a program that is not installed I might get a message like this: [user]~$ program The program 'program' is currently not installed. You can install it by typing: sudo ...
1
vote
0answers
1k views

Why did I fail to install packages when using debian?

There is lots of messed up dependency. How can I resolve this problem? It produces the following output: Reading package lists... Done Building dependency tree Reading state information... Done Note, ...
2
votes
1answer
2k views

How can I install gfortran 4.6 in Ubuntu 11.04?

I am running Ubuntu 11.04. I wanted to install gfrotran 4.6 on my system. Can anyone please explain (show all) steps required to install gfortran 4.6 on ubuntu 11.04? I did the following: sudo ...
0
votes
4answers
145 views

Installing softare on Linux

I'm trying to install the GMP package on Redhat 4, x86_64. The package can only be installed using make, which is not available and should be installed with apt-get/yum, but I don't have either one of ...
0
votes
0answers
216 views

Ubuntu can't install an older version of a package

When I try to do an apt-get install, I keep getting an error: Depends: libgtk-3-common (= 3.4.1-0ubuntu1) but 3.4.2-0ubuntu0.4 is to be installed when I run sudo apt-get -f install, I get several ...
1
vote
0answers
1k views

How to fix broken dependencies when installing old/archived packages

I am trying to install opencv version 2.1. My codebase requires opencv 2.1, so upgrading is not an option. Specifically, I am trying to install the packages: libhighgui2.1 libcvaux2.1 libcv-dev ...
3
votes
1answer
733 views

Nothing happens when trying to upgrade from Linux Mint 12 to 13

I am trying to upgrade from Linux Mint 12 to 13 using apt-get. After running the following commands, nothing seems to happen. I am fairly new to linux, what am I doing wrong? user@olympus ...
1
vote
1answer
3k views

How to update to latest version of SVN server?

I currently have SVN server installed on my Linux Ubuntu machine, version 1.6.12. I see that the latest version is 1.8.x and would like to update my installation to it, so I run: sudo apt-get update ...
1
vote
1answer
1k views

how to automatically select fast mirror for apt-get

Is there any plug-in available for apt-get to select fast mirror just as the YUM's fastestmirror plugin The fastest mirror plugin is designed for use in repository configurations where you have more ...
4
votes
3answers
244 views

How do I list the files installed by a deb package?

I'm an Ubuntu user and I install packages with the apt-get. For example: sudo apt-get install hadoop-0.20 After I install the package, there will be files in /usr/bin, /usr/lib/hadoop etc. Are ...
1
vote
1answer
305 views

What is the difference between new and extra packages when running the command apt-get install in Linux?

When I attempt to install a particular package I get the following output. I had a read of http://www.debian.org/doc/manuals/debian-faq/ch-pkg_basics.en.html#s-depends however it is not clear whether ...
16
votes
1answer
34k views

Why use the command apt-get --purge remove over apt-get purge in Linux?

I have been uninstalling applications as well as removing or purging their configuration files using the command apt-get --purge remove {package_name}. I have come across several posts on the net ...
0
votes
1answer
165 views

What do Inst and Conf refer to when using the command apt-get in Linux?

When I run the command apt-get install flashplugin-installer I am displayed the following lines of details Inst flashplugin-installer [11.2.202.233ubuntu0.11.04.3] (11.2.202.235ubuntu0.11.04.1 ...