0
votes
1answer
39 views

Installing linux/selinux kernal headers

I'm trying to build the newest version of glibc (2.19) on CentOS 5.6 and I've run into some issues The documentation of glibc says that I need at minimum the linux kernal headers 2.6.19 (even if this ...
0
votes
0answers
118 views

Garry's Mod - GLIBCXX_3.4.14 Missing, etc

This is what happens to my Gmod server whenever I start it up. I've tried yum install glib and gcc, etc. and nothing has worked. Anybody know how to get this stuff. I've even tried yum whatprovides ...
0
votes
0answers
118 views

Segmentation fault with glibc

I tried to install Chromium browser on Salix 13.37 Fluxbox, I got an error that said it requires newer versions of libstdc++.so.6 and libc.so.6, so I download and compile gcc and glibc, as I still get ...
1
vote
0answers
195 views

Compile with openssl-1.0.1e but linked against old glibc

Desirable result: compile a binary with statically linked openssl 1.0.1e but dynamically linked glibc, stdc++, etc. Binary should run on most servers, for example Ubuntu 11.04 or RHEL 6, CentOS 6.4. ...
1
vote
0answers
111 views

glibc's --with-cpu option

I'm unable to compile glibc: configure exits with the following error: configure: error: The [CPU] subspecies of x86_64 is not supported. I'm sorry; this must be somewhere, but I haven't been able ...
2
votes
0answers
348 views

Can you run a program using a custom glibc? [closed]

I installed Mathematica 9 on an old Red Hat Enterprise Linux AS release 4 system. After the installation, I tried to start Mathematica, but following message came out: ...
2
votes
1answer
729 views

execvp exec format error for shell script on Red Hat Enterprise Linux 6

We have two RHEL 6 systems that are running identical versions of the kernel and glibc (glibc–2.12–1.90.el6_3.6). According to the POSIX standard and the Linux man pages, if the kernel determines that ...
0
votes
1answer
332 views

Linux From Scratch, glibc Make error

I am following the LFS guide 7.2 and I am at section 5.7. When executing the Glibc make, I receive the following error. -o /mnt/lfs/sources/glibc-build/math/s_isnan.os -MD -MP -MF ...
0
votes
2answers
459 views

Wine on Gentoo fails with libgcc_s.so.1 must be installed message

Not long ago problems with Wine have began on my Gentoo PC... When I try to launch any application I see this thing: libgcc_s.so.1 must be installed for pthread_cancel to work wine client error:25: ...
1
vote
2answers
549 views

Why program fails when started using /lib/ld-linux.so.2?

$ /bin/bash -c 'echo qqq' qqq $ /lib/ld-linux.so.2 /bin/bash -c 'echo qqq' /bin/bash: xmalloc: ../bash/variables.c:2176: cannot allocate 3 bytes (8192 bytes allocated) Why this happens (zsh4, python ...
0
votes
0answers
647 views

Building against an older glibc

Is it possible to build glibc/gcc/binutils in the version combo of say 2.4/4.6/2.22 (or some later version of GCC used by the oldest/'stablest' linux distro's still around)? I would like to create ...
2
votes
0answers
1k views

Unable to install synergy on red hat 5.4

I'm trying to install Synergy on Red Hat Linux 5.4 but I'm getting the below errors: rpm -ivh synergy-1.3.8-Linux-x86_64.rpm error: Failed dependencies: libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is ...
1
vote
1answer
611 views

Suse 10.3 won't do anything after openssl upgrade. /lib64/libc.so.6: version `GLIBC_2.7' not found

I upgraded my openssl version with the command: rpm -i --nodeps openssl-0.9.8p-1.x86_64.rpm And now I get following error for almost every command I enter: /lib64/libc.so.6: version `GLIBC_2.7' ...
0
votes
1answer
109 views

How do popular package managers upgrade packages like glibc?

I've been looking further into Linux from Scratch, and I am particularly interested in the package management side of the system. I understand that this is not covered in the book, but if I were to ...
0
votes
2answers
2k views

How to restore /lib/libc.so.6?

I occasionally deleted my /lib/libc.so.6. By using LD_PRELOAD I successfully made a link of my /lib/libc-2.12.1.so file in my home folder and now most of the command works (cp, ln, etc...). But I ...
0
votes
2answers
269 views

where can I find these rpm packages?

I have to install these two packages but couldn't find then anywhere glibc-32bit-8.1-9 glibc-devel-32bit-8.1-9 Could you please help in locating them?
4
votes
1answer
1k views

Forward/backward compatibility of glibc and the kernel

Suppose you have glibc 2.5 compiled with kernel headers 2.6.18 Is it safe to run this glibc with Linux kernel 2.6.32? Is it safe to run this glibc with Linux kernel 2.6.9?