Package management is the process of installing, upgrading, configuring, and removing software packages for a computer's operating system in a consistent manner.

learn more… | top users | synonyms (1)

5
votes
2answers
2k views

Make pacman does not reinstall when already installed

How to make pacman (archlinux's package manager) to not reinstall when the package already installed pacman -S packagename # install and reinstall if exists
1
vote
0answers
33 views

Unresolvable broken dependencies, none of 'apt-get' commands works

Before I explain the problem, I should say that I have tried all other answers to similar questions and troubleshootings around the Internet, and none of them works. To be more specific all apt-get ...
0
votes
1answer
11 views

Custom repositories for chocolatey

I see a lot of web posts about custom repos ("sources" in choco terminology) available for chocolatey. e.g. windowsfeatures and webpi. However, none of the commands work on choco 0.9.9 (e.g. choco ...
-1
votes
1answer
10 views

What is the name of the Cygwin package manager? [duplicate]

I'm not a regular Cygwin user. I installed Cygwin and Cygwin64 for testing proposed patches. I tried to perform a git clone, but it failed with -bash: git: command not found. So I need to install Git, ...
0
votes
0answers
654 views

Installing Eclipse for linux (64 bit)

So I am trying to download the latest version of eclipse from the link provided by eclipse.org I am using Ubuntu 14.04 64 bit. There is a package available in the software repositories, but it is ...
-1
votes
0answers
10 views

Can I specify options that should be used by default for every rpm install command in the rpmrc file? [duplicate]

I wish to have rpm to always use an option such as --excludepath for every rpm install process http://www.rpm.org/max-rpm/s1-rpmrc-file-rpmrc-file-entries.html
0
votes
0answers
13 views

Changing behavior of RPM to use --excludepath by default

How do I change the config file of RPM such that any RPM operation defaults to using the --excludepath option ?
1
vote
0answers
43 views

Installing libsdl2-dev on Kali 3.18.0 amd64

I'm trying to wrap my head around how to install the libsdl2-dev package on Kali 3.18.0 amd64. I can see that the package is available in the standard Kali repository here: ...
3
votes
1answer
35 views

Why does the installation of a 32-bit package remove 64-bit packages?

It's not clear to me why the installation of a 32-bit package would necessitate the removal of a 64-bit package. For example, if I try to install the 32-bit development package of libcurl with: sudo ...
2
votes
1answer
260 views

Continue on error when apt-get encounters an install unable to locate package issue

When I run the following: sudo apt-get install vim abcde php5-cli It fails with the following message which is the expected behavior: E: Unable to locate package abcde`. I want it to ...
109
votes
7answers
41k views

How to tell from what Ubuntu or Debian repository a package comes?

On a Debian-based system, including Ubuntu, how can one tell which repository a package will be downloaded from, without actually beginning the download? aptitude show and apt-cache info will show the ...
37
votes
4answers
10k views
0
votes
0answers
12 views

While upgrading linux, how to prevent packages from performing certain operations?

I have to update some machines, but I am using a patched version of linux, and don't want packages to modify specific files. To be clearer here is a list of the actions I don't want a package to be ...
0
votes
1answer
17 views

apt only half-sees a package

On debian stable, with almost standard sources.list file, I can't install the following package. $ apt-cache showpkg ttf-mscorefonts-installer Package: ttf-mscorefonts-installer Versions: ... ...
2
votes
1answer
33 views

How can I install GNU Parallel alongside Moreutils on Ubuntu/Debian?

Can I make the package manager resolve the conflict, e.g. by renaming the binary (e.g., parallel -> gparallel) or installing to a different place (e.g., /usr/ -> /usr/local/ )?
2
votes
1answer
78 views

Emacs Melpa and Marmalade

Does it make sense to include both Melpa and Marmalade package repositories with emacs HEAD. And if so, what is the best way to ensure that one is using the latest and/or correct package, when many ...
7
votes
4answers
2k views

Emacs 24: Loading a package installed via ELPA

I have just installed the cmake-mode package in Emacs 24 using: M-x package-install cmake-mode I can see the package at: ~/.emacs.d/elpa/cmake-mode-20110824, and I can load it using the instruction ...
4
votes
1answer
5k views

How can I fix the error “The value 'stable' is invalid for APT::Default-Release”?

After an upgrade from Debian Squeeze (stable) to Wheezy (testing), Synaptic fails with the following error: E: The value 'stable' is invalid for APT::Default-Release as such a release is not ...
1
vote
0answers
33 views

Removed language package and Windows 8.1 doesn't start again

I was trying to change my windows display language. I used the instructions in this link How to install a new "display language" onto Windows 8.1 Single Language? Now my computer doesn't ...
0
votes
1answer
26 views

How to know since when a package has been installed on a linux system

How can I find out the date (and time if possible) of installation of any package on Linux Operating system. For Ubuntu and using apt-get
0
votes
2answers
84 views

Specify Fedora version and architecture for yumdownloader

This is a continuation of Package management on an air gapped machine?. I need to install packages on a Fedora 20, i386 system that is air gapped. I'm working from on Fedora 21, x64 workstation that ...
1
vote
2answers
2k views

Eclipse version in Debian package directories too old

Ian Murdock, the founder of Debian, has commented that package management is "the single biggest advancement Linux has brought to the industry". (Wikipedia) But for some reason I'm forced to install ...
2
votes
2answers
6k views

Pacman doesn't download anything - Always 404

I want to install some software on my Raspberry Pi running Arch Linux, but I keep getting error 404. I did some research and found that I needed to do pacman -Syy and pacman -Syu... When I run ...
0
votes
1answer
16 views

Is there somewhere to go to get notes for package updates? [closed]

Most times when I start up my Ubuntu VM, I'll open the terminal and check for updates. sudo apt-get update && sudo apt-get upgrade I'll then get a list of the packages to be upgraded: The ...
3
votes
3answers
2k views

How do I remove configuration files for a program that's not installed?

I'm basically looking for an apt-get purge for programs that are already uninstalled. (I'm running Debian squeeze and using aptitude for package management.)
21
votes
3answers
15k views

Which Debian package architecture am I using?

What's the command to find out which Debian package architecture I'm using? eg, on a 64 bit x86, I'm expecting something like amd64, i386 on 32 bit x86 and darwin-x86_64 from OSX 10.6 (via Fink).
12
votes
8answers
10k views

What Linux distribution has the most up-to-date packages?

Ubuntu's release schedule is just too slow. I want the absolute latest version of everything. Even if it's slightly unstable. Which distribution will give me this without having to manually install ...
0
votes
1answer
134 views

How to manage different versions of same software in Linux?

Under Ubuntu most software is available in Ubuntu repositories. What happens if I install a newer version of software from different ppa that is not available in repositories yet? Will it upgrade ...
2
votes
2answers
121 views

How to download .deb package and all dependencies?

For all answers i found about this topic, the solution was to create, in a certain computer A where i need to install the package, a file containing all dependencies it needs and then downloading it ...
0
votes
2answers
435 views

apt-get Update still tries to download from tor project after uninstalling tor

I installed Tor using the directions here and now I want to uninstall it: https://www.torproject.org/docs/debian I wanted to uninstall tor and remove all configuration files so I ran the following ...
13
votes
8answers
3k views

How can I achieve “Git”-like update management for Linux?

I want to manage the updates of my Linux system in a similar fashion as Git does it, by being able to move back and forth within "revisions". How could I do that?
1
vote
1answer
111 views

How do I install Win2D in visual studio?

I am trying to install Win2D in visual studio. I ran the the following in the nuget package manager console: PM> Install-Package Win2D I get the following error: Install-Package : Could not ...
1
vote
1answer
2k views

How to automatically install updates in linux mint 17.1

I have linux mint 17.1 xfce, and I am wondering how to automatically install updates. Every time a new update is available I have to click on the mintUpdate icon on the panel and enter my password and ...
1
vote
1answer
353 views

RHEL6: repo won't enable

Mount DVD [root@rhel66 ~]# mount /dev/sr0 /media Install the repo metadata [root@rhel66 ~]# cp /media/media.repo /etc/yum.repos.d/rhel6.repo List the repos [root@rhel66 ~]# yum repolist all ...
0
votes
1answer
21 views

how to query to find say 'TODO' from all installed packages on a Debian system?

I am looking to find the TODO files which are documents written by upstream developers when they are making some software. Is there a way to query that ? I am on jessie.
12
votes
3answers
20k views

How to find out which versions of a package can I install on APT

Using APT, you can install a specific version of a package using: apt-get install package=1.0 But you can't do apt-get install package=1.* So, how can I find out which versions are avaliable for ...
-2
votes
1answer
79 views

How to bulk download and install the latest version of a set of free apps? [duplicate]

Possible Duplicate: One-stop-shop installer for free Windows software? Once I saw an app that could download and install the newest version of a set of freeware defined by the user. I can't ...
0
votes
1answer
173 views

Exit code 127 in cygwin64

After years without problems, suddenly several programs in my installation of cygwin64 on 64-bit Windows 7 Professional are failing to run, and instead appear to exit immediately with code 127, which ...
0
votes
1answer
46 views

Package management on an air gapped machine?

I'm working on an air gapped Fedora 20 (x64) machine. Its air gapped because of a source code review, and the company that owns the sources does not want the machine on the Internet. I'm trying to ...
4
votes
1answer
122 views

How can I browse through Homebrew's formulae according to popularity (# downloads all time)?

Though I can easily find an alphabetical list of all available formulae, there seems to be no resource online, including at Brew's Github, or seemingly anywhere where I'm able to browse through ...
0
votes
1answer
615 views

Yum autoremove removing packages that are standalone

If I run sudo yum autoremove it outputs what it is going to remove for confirmation. However, some of these packages it is removing are things I want but are not dependencies of anything else... What ...
0
votes
1answer
49 views

I have specific files to install that I have downloaded. Is there a standard practice for location(s)? [closed]

I just downloaded "processing" for my linux box (ubuntu 14.04), however It was a tarball, but I couldn't run configure on it. The installation instructions, found here just say to extract the files ...
-1
votes
1answer
63 views

Installing packages on Ubuntu 13.04 after end of life

So I'm aware that Ubuntu 13.04 has reached end of life, ignoring the fact that I should update to the latest version for the best support, is there a way (aside from apt-get install {pkg}) to install ...
1
vote
0answers
46 views

Best practice to host self-maintained Debian packages on GitHub

This question is especially about the best practice to host self-maintained Debian packages on GitHub. Here is my dilemma: It is commonly recommended not to put the debian folder within the source ...
2
votes
4answers
133 views

Can I use an Android Phone as a Linux Box? [closed]

Is it possible for me to use my Android phone as a linux development box? E.g. install some sort of package manager such as Apt/Yum followed by GCC, Vim etc. Then I simply connect my phone via USB ...
0
votes
1answer
29 views

Installing OBOE on Mac OS X 10.9

I am mostly following this post to install OBOE on MAC OS X 10.9. However, following step 4, I tried to install LAPACK++ with failure from this source: I type ./configure configure: error: ...
128
votes
8answers
55k views

Find what package a file belongs to in Ubuntu/Debian?

I frequently find myself missing a program, man page, or other file when working on my Ubuntu 8.04 system. Is there any simple way to look up what package contains a given file (whether it is ...
0
votes
2answers
2k views

downgrading packages in debian

I have Debian stable disribution installed on my computer. Once I installed some packages from testing but now it causes some troubles so I would like to downgrade them. I've tried next commands: ...
6
votes
2answers
7k views

Zypper: How do I display all packages from a certain repository?

Please tell me, how to let zypper display all installed packages of a certain repository.
46
votes
5answers
20k views

Is it safe to install both Homebrew and Macports on the same machine?

I have MacPorts installed on my iMac with a fair number of ports installed. I'm interested in trying out Homebrew, though, as I've heard many good things about it, and because I've noticed that it ...