0
votes
1answer
15 views

PHP in Debian Terminal not working with extensions

I have Debian 7 installed on my server with a standard LAMP stack and also Mongo DB. Mongo as well as other third party PHP extensions work correctly through apache. These extensions however do not ...
1
vote
1answer
241 views

Apache2 + mod_fcgid + php stopped working after upgrade from Debian squeeze to wheezy

I've updated my server from Debian squeeze to Debian wheezy. On this server are several apache2 vhost which running php via mod_fcgid (I'm also using mod_suexec but this shouldn't be the problem). ...
0
votes
0answers
58 views

Debian PHP 500 error

When I try to execute a php script (let's say /var/www/test/hello.php), I get an error in /var/log/apache2/error.log saying: "/var/www/test" is writeable by others Changing the permission on ...
0
votes
1answer
831 views

Checking what PHP version I'm running on Debian?

I'm running Debian 6 and I need to know what version of PHP I'm running, is there a command for this which I can run? I tried "php -i" and "php -v" from a previous question.. ...
0
votes
0answers
13 views

Incorrect visualization fo character in local server

I am playing a little with a software of accounting based on PHP and MySql. I have installed on my Linux Debian a version of Lighttpd. The problem is that some special character are not well ...
0
votes
0answers
92 views

Nginx + PHP + MySQL -> 502

I have two servers. The first is for web and the second one is for database. On the first server which is for web is Debian Squeeze with NGINX and PHP-FPM (from dotdeb repository). On the second ...
0
votes
0answers
375 views

Install Php-pear to /usr/share Raspbian (debian)

I am running Raspbian on my Pi and have installed PHP-pear, I have some software that requires PHP-pear but is normally installed on a Fedora based machine so pear is normally found at /usr/share/pear ...
2
votes
1answer
600 views

Apache downloads php files instead of running their source

I have just recently upgraded PHP 5.3 to 5.4 on my Debian Squeeze server. Now, instead of executing PHP files, Apache just downloads them, which is really bad. When I try to follow these steps, I get ...
0
votes
2answers
798 views

Recommended way of installing PHP 5.4

PHP 5.4 is stable for quite some time now. However, when I type apt-get install php5 PHP 5.3 gets installed. Question: Why? And what is the preferred way of installing PHP 5.4? Should I choose a ...
0
votes
1answer
476 views

SSMTP and PHP sending mail through different domainds(sub-domains)

I'm trying to set up SSMTP on my Raspberry PI(Raspbian Wheezy(Debian ARM port)) Model B, Right now I can send mail through the console just fine, actually getting the mail aswel. The problem is when ...
0
votes
1answer
387 views

Setup Debian Server, Symlink from /var/www/dir to another directory

I have just started a server with debian, I'm new to this sort of thing so please bare with me. What I'm trying to achieve is this: Request comes in : sub.mydomain.co.uk I have to DocumentRoot ...
0
votes
1answer
963 views

Shutdown Debian from php script

I am trying to shutdown my RaspberryPi running Raspbian from a php script running on lighttpd webserver. shell_exec("sudo /sbin/shutdown -h now 2>&1"); I added lighttpd ALL=(ALL) NOPASSWD: ...
0
votes
1answer
148 views

index.php file gets downloaded after PHP reinstall

I'm using SugarCRM CE edition 6.4 I uninstalled the php5 from the server (Debian Squeeze) then reinstalled all the php5 with it's modules. Restarted Apache (/etc/init.d/apache2 restart). Then after ...
2
votes
1answer
83 views

What is the PHP config ini files prefix good for?

Out of nothing but curiosity: Why are the symlinks in /etc/php5/conf.d prefixed with either "10" or "20"? E.g. 20-pdo_mysql.ini and 20-curl.ini I'm running Debian and installed PHP from the dotdeb ...
1
vote
1answer
534 views

updating to PHP 5.3 on Debian 5.0 (lenny)

I need to update PHP on a rackspace server, currently the server use PHP 2.6, i followed these instructions, i added to lines to /etc/apt/sources.list deb http://php53.dotdeb.org stable all ...
1
vote
1answer
33 views

Need secure solution to get the size of a directory with PHP

I have a vmail directory manage by postfix with the permissions set like this: user: vmail group: vmail permission 700 I need to get the size of that directory with PHP. To do this, I'm using ...
5
votes
1answer
446 views

Making Apache use compiled PHP instead of bundled package on Debian

My ultimate goal is to install OwnCloud on my Debian box, a 64-bit squeeze. My setup is pretty simple. I have installed OpenPanel which in turn installs all of the required LAMP modules via APT-GET. ...
3
votes
2answers
2k views

php startup error Invalid library (maybe not a PHP library) 'pcntl.so'

After searching for hours to solve my problem and found nothing helpful I ask my first question here. I want to compile and install php 5.3.17 cli with pcntl extension enabled on a Debian server. The ...
2
votes
1answer
878 views

100 % cpu usage debian 32 bit due to apache processes

So there is a VPS with openvz virtualization, with debian 6.0 32 bit The problem is appearing approx. 1 week ago. The automatic security monitoring system is shutting down the vps that i'm running ...
0
votes
1answer
192 views

Where can I find per virtual host php settings on Debian

I try to set in php open_basedir to /srv/www because I need to link folder from one virtual host to another, so I set in /etc/php5/apache2/php.ini open_basedir = .:/tmp:/usr/share/php5:/srv/www but ...
1
vote
1answer
428 views

Upgrading php - Errors were encountered

Running debian 4.0 Trying to $ apt-get install php5 I get Reading package lists... Done Building dependency tree... Done php5 is already the newest version. 0 upgraded, 0 newly installed, 0 to ...
2
votes
2answers
454 views

Looking for PHP memory/CPU graph generator

Basically, that's what I'm looking for. I want an app that makes a live graph of the server's CPU and RAM usage. Is there anything like this?
1
vote
1answer
526 views

Upgrade php from 5.2 to 5.3 on lenny

I (among other things) manage an older debian Lenny server - and now have a need to update PHP from version 5.2 to 5.3 (we currently have 5.2.26 installed). This is required to support some of the ...
1
vote
0answers
61 views

PHP: error when requiring PEAR.php

I'm having an include path problem: get_include_path() returns .:/usr/share/php:/usr/share/pear Pear.php is in /usr/share/php: # ls /usr/share/php Pear.php but require 'Pear.php' gives me a ...
1
vote
1answer
2k views

PHP files are downloaded instead of getting interpreted

I'm encountring some difficulties with my Apache2/PHP5. All was well-configured and working, but after reinstalling apache2, the PHP files are displayed without being interpreted. I tried many ...
0
votes
2answers
294 views

Fix for php 5.3.9 libxsl security “bug” fix

just this morning i updated my debian server to php 5.3.9 , change log (last item in list) has a fix for this bug and now when running any hosted site using XSL transforms i get: Warning: ...
3
votes
2answers
414 views

Installing python through pecl - how do I “specify path to Python distribution files”?

I have found several instances where this question has been asked, but never answered. This is the part where the installation goes wrong checking for Python files in default path... not found ...