-1
votes
0answers
131 views

PhpMyAdmin shows error 1146 after upgrading to OS X Yosemite

I was working with XAMPP 1.8.3-3 on OS X Mavericks. After upgrading to Yosemite, MySQL server stopped working. And an upgrade to XAMPP 1.8.3-5 fixed the problem and MySQL server started working. Now ...
1
vote
5answers
1k views

apache client denied by server configuration after mac OS X upgrade to Yosemite

I know this looks similar to other questions but Yosemite seems to have changed something with apache configuration with the upgrade. my error log says " client denied by server configuration: ...
0
votes
0answers
26 views

PHP - Configure commands change path

I have PHP installed on my machine (os x) and am trying to get the msssql module to talk to freetds and I noticed that phpinfo() shows the following under configure commands: ...
0
votes
1answer
87 views

Drush commands not found when called from a bash script

Relevant system background: I'm using MAMP on OSX. Output of which php is /Applications/MAMP/bin/php/php5.3.14/bin/php Output of which drush is /Applications/MAMP/bin/php/php5.3.14/bin/drush Output ...
0
votes
0answers
15 views

Two versions of xhprof_html on OSX / MAMP?

xhprof_html exists in two places: /Applications/MAMP/bin/php/php5.5.3/lib/php/xhprof_html and /Applications/MAMP/bin/php/php5.5.3/lib/php/doc/xhprof/xhprof_html php -i | grep xhprof returns: ...
0
votes
1answer
347 views

PHP: Mongo client not found

I've installed XAMPP on my MacBook. PHP and MySQL are working fine, so I followed it up with mongo. I did the following: brew install mongo (success) brew install autoconf (success) sudo ...
0
votes
2answers
230 views

“Too many files open” on Mac OSX after running apache in PHP with XDebug for some time

I am running Mac OS X 10.9.4, including the builtin apache2 webserver with PHP 5.5.14 from brew (packages: php55, php55-intl, php55-pdo-pgsql, php55-xdebug). When running this setup it works quite ...
-1
votes
1answer
60 views

OSX Mavericks - Upgraded PHP not loading

I was wondering if someone could help me. Im running mavericks OSX ... When i type php -v i get the following: PHP 5.4.24 I needed to upgrade the PHP version, so i followed an online guide and ...
1
vote
0answers
181 views

Setting up rutorrent on 10.9 Mavericks

I'm getting the following error when loading rutorrent that's hosted on my 2010 Intel Core Duo 2 Mac Mini: [23.06.2014 11:31:20] Bad response from server: (404 [error,list]) <!DOCTYPE HTML PUBLIC ...
0
votes
3answers
66 views

Building PHP For MacOS

I was using XAMPP and decided to uninstall it and use MacOS' in-built apache and php modules. But while uninstalling XAMPP I deleted /usr/bin/php files and other PHP-CLI files accidentally. And I ...
0
votes
3answers
56 views

Let user '_www' execute binary in /usr/local/bin

Total *nix n00b, so I apologize in advance. I installed ffmpeg through homebrew, now I want to call it from a PHP script with shell_exec(), e.g. ffmpeg -v. But nothing is happening. From Terminal it ...
1
vote
2answers
3k views

Can't run localhost PHP server on OSX Mavericks

So i've done this before but I don't remember the command. I was able to use a directory a localhost file. I've tried sudo apachectl start but when I go to localhost the page isn't found. I've also ...
2
votes
2answers
2k views

OSX, Failed to listen on 0.0.0.0:80 (reason: Permission denied)

I'm on OSX Mavericks. I installed PHP 5.5 from http://php-osx.liip.ch/. When I go to localhost in a browser I get a page that says, "It Works!" which is not a page I created so I am not sure where it ...
0
votes
0answers
41 views

How to reset the Apache web server password on Mac?

When I try to start the Apache web server on our Mac it asks for a password. I forgot the password and I know that I was the one who put the password on it because I'm the only person in our family ...
0
votes
1answer
59 views

How do I fix the default version of PHP after uninstalling PHP OSX?

I installed PHP OSX because I wanted to test some PHP 5.5 code on the command-line/interactive shell. On my local web server, I started receiving errors in functional code from before I installed PHP ...
0
votes
0answers
109 views

Adding modules to bundled php in OS Mavericks

I am using the bundled php on my macbook to run some php through the terminal. But my scripts throw a fatal error when trying to use SQLite Classes. I checked with php -m and there is no module named ...
1
vote
2answers
1k views

PHP warnings after Mavericks upgrade

After upgrading my Mac to Mavericks I've had a few small issues with machine, most of which I've resolved, however when I try to run PHP scripts at the command line I'm not getting these warnings... ...
0
votes
1answer
97 views

How to use built-in PHP-FPM in OS X Mountain Lion?

I would like to know how php-fpm included in Mountain Lion (v10.8.5) can be used (eg. with NGINX). I am afraid that some configuration might be needed before it is actually used. NOTE: I know how to ...
1
vote
0answers
55 views

Activate PHP on Mac Os 10.7.5

Trying to activate PHP. Guides state that web sharing must be turned on but when I go to Apple menu/System Preferences/Sharing and check web sharing, system starts web sharing then immediately ...
0
votes
1answer
208 views

Double MySQL Running on Mountain Lion

After I've done a full restart, my Apache PHP server doesn't connect to Local MySQL ( connecting via 127.0.0.1 because localhost for some reason fails always ). So I did this today: ➜ ~ mysqladmin ...
1
vote
2answers
2k views

How do you install PHP PECL extensions with Macports?

I'm using PHP 5.5 installed through Macports. I'd like to add the APCu PECL library. But there's no macports package and I can't see a way to install the PEAR/PECL command line utility. So how does ...
1
vote
3answers
947 views

PHP 5.4.19 running in terminal & PHP 5.3.26 on my localhost, how to switch localhost version?

I just installed PHP 5.4.19 on my os X 10.6.8 Mac using homebrew. I was previously using PHP 5.3.26 probably installed with MacPorts. If I type php -v in terminal, I get PHP 5.4.19. If I load a ...
1
vote
0answers
360 views

Upgrading APC extension in MAMP

I'm trying to upgrade the APC extension in MAMP. I have got installed MacPorts and with the following command I've installed the autoconf: sudo port install autoconf Then I've executed this command: ...
2
votes
1answer
79 views

How do I share a PHP 5.4 server between OS X and VMWare?

I'm running PHP 5.4 on OS X which allows me to set up a virtual server for any directory, using this Terminal command: php -S localhost:8000 This will then set up http://localhost:8000 which works ...
0
votes
2answers
40 views

Why am I beign able to rename my files in Mac Os 10.8.2 even when I don't have permissions

Im setting 444 permissions on a file, but still, Im able to rename files. I tried it through php with the rename() function and in terminal with the mv command. I list my file and it appears as ...
0
votes
1answer
521 views

Map `php` at the command line to point to `/usr/bin/php`?

For some reason using php at the command line references /usr/local/bin/php instead of /usr/bin/php. How can I make $ php script.php the equivalent of running $ /usr/bin/php script.php? Current ...
1
vote
1answer
760 views

Setting up VirtualHost for MAMP server?

Problem I need to setup some VirtualHost records for a MAMP server I have installed on my Mac. In short, rather than using http://localhost:8888/dkbtherapy/index.html I want to use ...
0
votes
1answer
92 views

How do I enable PHP on Mountain Lion and view a PHP file?

I followed this guide to enable PHP on Mountain Lion, but now I have no idea where to access the page. I tried localhost/~myusername/info.php where info.php if my file, but nothing loads.
2
votes
1answer
313 views

TextMate 2 “Go To Symbol” not working for PHP

I’m running TextMate 2.0-alpha.9419 and experiencing this issue: the editor doesn’t see my method definitions within a class, and won’t let me jump to them via “Go To Symbol”. The only method that TM ...
0
votes
1answer
95 views

Fail to load php module macports

I'm trying to install php module via macports. I have them installed, so I run cd /opt/local/apache2/modules sudo /opt/local/apache2/bin/apxs -a -e -n "php5" mod_php54.so Then I'll ensure myself, ...
0
votes
1answer
310 views

OSX Server - LDAP / pwpolicy - How to disable a account?

For some reason, Apple is great at just changing the syntax or path of (insert random feature here). And thus, I'm having trouble disabling (not locking a account, that seems to work fine by setting ...
0
votes
1answer
92 views

Apache/PHP installation on OSX differences?

I'm wanting to update the local version of PHP on my Mac.. i've been doing some digging and got a little confused. If i run php -i from the terminal it says: $ php -i phpinfo() PHP ...
0
votes
1answer
289 views

Mac PHP compilation: Unrecognized options

I'm trying to compile PHP with a MSSQL extension. I get this error: WARNING: unrecognized options: --with-php-config when I try to run ./configure --with-php-config=/usr/local/php5//bin/php-config ...
1
vote
0answers
305 views

Installed new version of php but server still uses older version

I just upgraded to PHP 5.4.11 from 5.3.15 following this link. After upgrading I ran php -v but it shows me following output. Zafars-MacBook-Pro:php-5.4.11 zafar$ php -v PHP 5.3.15 with Suhosin-Patch ...
0
votes
3answers
416 views

Turning on “E_ALL” (errors) in php.ini

I've turned on errors in php.ini by removing the ; in front of the comment on line 240 of php.ini (I'm using PHP 5.4.4). I'm using MAMP for my local server to set up a local environment, and I ...
1
vote
0answers
76 views

Libpdf_php complaining about non thread safe binaries

I installed libpdf_php on MAMP v2.0 and after restarting Apache I get following error: [11-Jan-2013 11:48:21 UTC] PHP Warning: PHP Startup: pdf: Unable to initialize module Module compiled with ...
0
votes
1answer
376 views

mac os x terminal php command not found

I am using Mac OS X 10.6.8. In Terminal, when I enter php -v, I get below message: Last login: Sun Dec 16 20:22:05 on ttys000 You have mail. -bash: e: command not found ~ $cd / / $php -v -bash: php: ...
0
votes
1answer
60 views

What can I do if I overwrote my system PHP?

I deleted my system PHP on OS X Lion by installing a fresh copy of PHP 5.4. I can't seem to restore it with Time Machine. What do I do next? When I type which php I still get /usr/bin/php. But when I ...
1
vote
2answers
344 views

Error installing php-5.4.9. on OSX

I have tried to install php 5.4.9 a few times and I can't seem to understand the problem. Here is the error of the installation of process and it did came with a report which I sent my email I am ...
0
votes
0answers
52 views

Several PHP versions on Mac

I have several versions of PHP on my Mac. Problem is, whenever I try to install new libraries, I'm not sure which version I'm installing them to. I'm using the command line on Mac OSX, and I read ...
0
votes
0answers
379 views

“unrecognized options” while installing php

I want to compile php 5.4.8 on my mac 10.8.2, but get some errors which cant solve by my self, so need your help. Firstly i get default php options with php -i | head, after it do this command ...
2
votes
1answer
4k views

How to upgrade PHP on Mac OS X

So i did simple thing: php -i | head ./configure --prefix=/usr --with-snmp make sudo make install But phpinfo() still showing me 5.3.15. Here some results of investigations: PHP_BINDIR = /usr/bin ...
0
votes
2answers
2k views

PHP mail() function not working in Mac OS X

I know this question has been asked many times and people use to give many solutions. I have followed almost all the possibilities which I come across after investigating on it. but nothing worked ...
1
vote
1answer
923 views

How to enable the php 5.4.x version on Mountain Lion

I have installed the latest php version on my mountain lion system using these instructions (http://mac.tutsplus.com/tutorials/server/upgrading-the-native-php-installation-on-os-x-mountain-lion/). I ...
0
votes
2answers
189 views

OSX installing php 5.4

I downloaded Macports and run a command I get online, which would install php 5.4. It took a while, but seemed to work successfully. I then copied the php.ini.development and renamed it php.ini like ...
2
votes
1answer
511 views

Set permissions to www user to run ImageMagick

I have installed ImageMagick on my OSX Lion. When running from the console everything works fine. But when I'm trying to run 'convert -version' from a php script : <? exec('convert -version', ...
1
vote
0answers
328 views

PHP document root problems (permission denied)

I've set up PHP on my OS X 10.8 system and am trying to test it works. I created a file named "phpinfo.php" and placed it in my document root with the contents below: <?php phpinfo(); ?> ...
0
votes
1answer
454 views

Is there a MAMP-like application with up-to-date components (Apache, MySQL and PHP)?

I'm using PHP and MySQL to develop websites and web applications on my Mac. Using Git and a deployment service I deploy the code to the production environment. I'm looking for a MAMP-like application ...
0
votes
1answer
102 views

Local Apache won't send PNGs correctly

Can't figure this out: Yesterday my local Apache config was sending PNGs just fine, today the browser is trying to decode them as JPGs and thus, only showing a "missing image" error despite returning ...
0
votes
1answer
366 views

Issue with PHP and osx 10.7 - runs via command line but not in browser

I recently removed MAMP as I wanted to have more control over my machine and wanted to make use of PHP5.4 I installed using the script located here I cannot now not even get my default PHP that is ...