PHP is a widely-used general-purpose scripting language that is especially suited for Web development.

learn more… | top users | synonyms

0
votes
0answers
15 views

xDebug installation on xampp

I am using xampp5.6.15 on OS 10.11. I was following this instruction to install xDebug. My "tailored installation instruction" is as follows: In this instruction, it doesn't mention where to put the ...
0
votes
0answers
65 views

Debian, installing specific version of PHP still installs latest

I followed the following topic to install a given PHP version on Debian Jessie (PHP 5.3.8 which I need): PHP 5.3.10 on Debian Jessie I found the archive package here: ...
0
votes
0answers
42 views

PHP refusing to work in Debian

Currently, I can't seem to get PHP working on my VPS: Linux Titan 3.2.0-4-amd64 #1 SMP Debian 3.2.73-2+deb7u3 x86_64 GNU/Linux As far as I can tell, I have all the necessitties: root@Titan:~# dpkg ...
-1
votes
1answer
20 views

PHP one line, different variables [closed]

I have a php file with multiple lines that are identical in all ways, except for the variable displayed in them. At the moment, there are 26 lines of code, but can be reduced to two if there's a way ...
-1
votes
1answer
56 views

How to Find a Backdoor in a Hacked WordPress Site with Debian [closed]

I think there was a backdoor created by the hacker which allowed them to bypass normal authentication. Wordpress 4.4.2 in apache2 with MySQL I install chkrootkit, rkhunter but finding nothing! I ...
1
vote
2answers
19 views

Creating subdomains - permissions

At my work, I sometimes write small applications for visual information on a web based platform (LAOP-jQuery). Some of my colleagues have started doing this as well in order to have better access to ...
0
votes
1answer
460 views

Class 'MongoDB\Driver\Manager' not found

I am creating REST APi with Lumen framework. I use Mongolab for my mongoDB and i want to host my app on google App Enginge. I am using Jessenger lib for communicating with my DB on MongoLab. Everhting ...
-2
votes
1answer
46 views

How to get php 7 on mac?

I want to upgrade my php from php5 to php7. I want to do it through the terminal and I just cant figure out how. Does anyone have a step by step guide on how to do it?
0
votes
1answer
16 views

httpd-vhosts showing syntax error

I am using the following tutorial. However when I test my apache I am getting the following error: Syntax error on line 1 of /Users/jessmckenzie/Sites/httpd-vhosts.conf: Invalid command ...
0
votes
0answers
49 views

Windows PHP 7.0.3 x64 (Apache handle) crash after a lot of request with zend_mm_heap corrupted

I'm testing PHP 7 x64 on my Windows 7 workstation with a basic Apache benchmark F:\apache\bin\ab -c 200 -n 2000 localhost/index.php index.php is simple <?php phpinfo(); the benchmark ...
56
votes
2answers
11k views

The MD5 hash value is different from Bash and PHP [duplicate]

I tried to generate the MD5 sum (using md5sum) of a string, "hello". I tried out different methods as the md5sum tool in Linux, PHP's MD5() function as well as various online text to md5sum ...
1
vote
0answers
31 views

Imagemagic and php exec: convert: no images defined

The command works just fine from the shell /opt/ImageMagick/bin/convert /private/var/folders/nl/9cky1krj5_j7zwm34tfkndd40000gn/T/pdfPyflQF ...
0
votes
1answer
14 views

Apache2 serves all files in the wordpress directories tree. Did I misconfigure it?

First I noticed that if I go to http://example.org/wp-config.php, it gives me an empty page instead of 404 error. I tested it with another file - wp-config-example.php, and it gave me a page with the ...
0
votes
0answers
27 views

php end tag in strings breaks vim syntax highlighting

I have the following line a long PHP file: preg_match_all("/<.*?>/", $rows[2],$tmp); and after the ?> in this line the syntax highlighting in vim is gone for the rest of the file. How can I ...
0
votes
0answers
48 views

How to find bottleneck in mysqlcluster and apache/php server?

I have setup a mysql cluster 7.3.x with 2 Datanodes,2 SQL nodes and 1 Management Node in a LXD/LXC centos 6.7 containers and a separate Apache 2.2.x/PHP-5.5 web server. The website currently serves a ...
5
votes
0answers
114 views

High CPU usage running Symfony on PHP-CLI

I have a Dell laptop with Intel i7 5th generation running Windows 10 x64 and PHP 5.6.17 x86 environment. When I run a fresh installation of Symfony 3.0 using php-cli: php bin/console server:run In ...
0
votes
1answer
39 views

Display an image when the web server is accessed

I run a Minecraft network on a dedicated debian 8 jessie machine and I have a LAMP server running on it. I want to know how can I make it so when people put my server IP into their browser and hit ...
0
votes
2answers
101 views

NGINX and php-cgi on Windows “No Input File Specified”

I'm running php-cgi and NGINX. They are running in a folder, however their root directory is 2 directories out, and 2 in from there. When the root was html (default), they worked perfectly, however ...
0
votes
2answers
36 views

Fatal error: Out of memory Error on WampServer

I have set memory_limit to -1 in php.ini file in Wampserver. My RAM is 6 Go. But I still getting this error: Fatal error: Out of memory (allocated 1673789440) (tried to allocate 67108864 bytes) in ...
0
votes
0answers
32 views

Ganglia/Gmetric/Graph.php: how do I prevent the AGGREGATE option from mucking the data up?

I am using the "aggregate" query parameter to Ganglia's graph.php to display stacked graphs. The downside is that it ALSO appears to seriously muddle the data. WITH it, the graph looks "about" okay in ...
0
votes
1answer
83 views

apt-get install libphp-phpmailer not including class.phpmailer.php

I am installing PHPMailer on a Ubuntu 14.04 LTS server. I ran the command apt-get install libphp-phpmailer. It installed the files under usr/share/doc/libphp-phpmailer as expected. However, it is ...
0
votes
1answer
11 views

Apache/PHP cannot save to the public_html

Apache and PHP are running as nobody user and group. public_html folder is set to: drwxrwx--- 11 myuser nobody 4096 Feb 11 14:39 public_html/ but when Apache and PHP (via Wordpress) tries to ...
1
vote
0answers
95 views

OCI8 extension not loading in PHP 5.4, CentOS 7

I have a CentOS environment running as a VM guest. It runs and Oracle 12.1 Database, along with PHP 5.4.16, on Apache 2.0. I've gone through the installation steps to ensure that the correct OCI ...
0
votes
0answers
446 views

phpmyadmin Fatal error: Uncaught Error: Class 'SqlParser\Lexer' not found

I'm a new XAMPP and phpmyadmin user and I don't know many things about networks etc but I am trying to install XAMPP to use phpmyadmin and learn to use it. The issue is that it was working fine at ...
0
votes
0answers
52 views

Is mod_xsendfile not compatible with Apache 2.4

I asked my VPS hosting provider to install mod_xsendfile. Here is what I got in response: "I am sorry that I forgot to respond about mod_xsendfile. My research shows that the module has not been ...
1
vote
0answers
47 views

setting up MediaWiki to host more than one wiki

I am working on Ubuntu and have no experience in about PHP or Apache. Now I want to setup a wiki-family. I looked to Manual:Wiki family. There are some steps to do that. I could do first 5 steps but ...
1
vote
0answers
35 views

Unintended multiple PHP versions on OSX

For an application i'm making i need the PHP stats functions. My OSX (10.11) came with the default PHP 5.5, but i needed 7.0 to install the PECL stats package so i updated my local PHP version to ...
1
vote
1answer
79 views

Execute an SSH command with the Apache2 www-data user

I'm working on a virtual machine project where I use two servers, let's call them server A and server B, both with Ubuntu 14.04 LTS installed. Server A runs web server Apache2 with a website where ...
0
votes
1answer
121 views

500 error on fresh Apache setup on Fedora 23. One file loads, and the other doesn't

Alright, I'm finding this slightly bizarre. So, most of my experience with Apache has been on an Ubuntu server install. But after my server's harddrive experienced a catastrophic failure (which I ...
0
votes
1answer
30 views

Is it possible to parse a zip file without extraction in PHP

I have 4 questions: Is it possible to scan the entire zip file and navigate inside it without extracting the entire zip using PHP? Will it be time efficient? i.e. I have a zip file of about 50GB ...
0
votes
0answers
37 views

Request default in Laravel 5.1 when none given not working

1 and I need to have a default request when none is given so the view looks like: <form name="search" method="POST" action="/s"> Country<input name="country" type="text"> ...
-1
votes
2answers
73 views

Prevent uninstalling phpmyadmin when uninstalling php

I have a centos 6 server and i want to upgrade my php version from 5.4 to 5.5 but as far as i know i need to uninstall version 5.4 first (most guides say so at least), when i type yum remove ...
0
votes
0answers
20 views

Why does GNOME have to be removed for PHP 7 on Debian 8 (Jessie)?

Just upgraded my VirtualBox VM's OS from Debian 7 (Wheezy) to Debian 8 (Jessie) and want to PHP from 5.5.x to 7.0.2. The simpliest solution seems to do this via the Synaptic Package Manager. So I ...
1
vote
1answer
117 views

How can I compress a jpg images for google insights optimisation

I m getting this error when tring to see the speed of my website in google page speed: Optimize images Properly formatting and compressing images can save many bytes of data. Optimize the following ...
0
votes
1answer
174 views

Error Installing MongoDB driver on XAMPP (OS X/El Capitan)

I'm not new to XAMPP, PHP, or MongoDB, but I'm new to Mac, so getting the PHP MongoDB driver set up is causing me more trouble than it probably should. When I try to run $ sudo pecl install mongodb ...
0
votes
1answer
80 views

How do I determine what's making the web server so slow (Apache)

I'm running Apache 2.4 (64bit) on a Windows server. It also uses MySQL 5.7 on the same server. It has been very, very slow recently to come up, but when I look at the access logs, there are very few ...
1
vote
0answers
344 views

Unable to install php mongodb driver on Ubuntu 14.04 LTS

I have been trying to install php driver for mongodb on Ubuntu Linux 14.04 LTS. Tried to install as follows : sudo pecl install mongodb output is No releases available for package ...
3
votes
1answer
54 views

Pass arguments from script to PHP interpreter is not working with quotes, why?

I need to create a wrapper script for PHP interpreter (already in PATH): #!/bin/bash # This is a wrapper for the PHP interpreter. # # We prepare the enviroment for SQL Anywhere PHP extension sourcing ...
0
votes
0answers
19 views

How can I set xdebug.max_nesting_level to inlimited

I have sold a VPS server. I want to set xdebug.max_nesting_level to inlimited. I contact the support and they told me they can't find it. I can set it to inlimited in my local server. Please help.
0
votes
0answers
24 views

How can I minimize memory usage in WHM in order for PHP FileInfo to compile?

I have a VPS running CentOS 6.7 with WHM 11.52.2. I'm trying to run EasyApache 3 to add FileInfo for PHP 5.6.16 but I keep running out of memory (it uses about 440MB out of 1024MB when idle). What ...
0
votes
1answer
38 views

Populate command line from script

I have a PHP script that goes through a lot of complication and, in the end, produces a command for the user to run. Right now, it prints the command and then quits. The user has to copy the command ...
0
votes
0answers
36 views

trying to connect ami with another ami postgresql

i have php 5.6.14, apache2, moodle 3.0 (server 1) | postgreSql 9.3 (server 2) but I have already set this error moodle. Error: database driver problem detected The site administrator ...
1
vote
2answers
701 views

After upgrading PHP to version 7, why can't I use the mongodb driver?

Well here's an odd situation I've found. I've been using PHP and MongoDB together on a project, and updated the associated software. After the upgrade, I did make sure to update the new conf files and ...
0
votes
0answers
21 views

How to configure Nginx to support PHP on Mac OS X

I am building a web site using Angular JS, hosted on my local system using nginx. I want to add a contact form to my web site, but I don't know how to configure my nginx.conf file to support php. My ...
1
vote
1answer
37 views

phpMyAdmin config.header.inc.php broken

I have installed phpMyAdmin 4.0.10 on an Ubuntu 14.04.3 LTS Server machine. Everything works fine, but I want to add a banner to the top of the web pages with a legal notice. I should be able to ...
1
vote
0answers
30 views

Application conftest stopped unexpectedly

I have set up phpfarm so that I can use multiple versions of PHP interpreter on my system. This work really good but now I am getting crash reports on each and every system start. Seems like my ...
0
votes
0answers
46 views

php-fpm downgrading php version

Current Software Version:- OS : CentOS 7 PHP : 5.6.14 After installation of php-fpm on nginx 1.8, it downgrades php to 5.4. Even though new and latest version(5.6.14) is already installed. I don't ...
0
votes
0answers
16 views

WHM: Grant different PHP version for each user

I have a VPS with WHM installed. It is running Centos 6. I want to upgrade only one account's PHP version. How can I do this? I'd prefer if I only used the WHM GUI but if I have to mess with config ...
0
votes
0answers
402 views

Notice: Use of undefined constant CURLOPT_CAINFO

I try to use TwitterOAuth which requires cURL. First of all, I think it is important to point that I use Win 8 64 bits with WampServer 3.0 and PHP 5.6.15 When I run the scripts (given by TwitterOAuth) ...
1
vote
0answers
14 views

Simultaneously enable gzip and $STR_REPLACE in CGI in apache

I have a code in my CGI script for text replacement (for example replace 'red' with 'blue') $STR_SEARCH='red' $STR_REPLACE='blue' I am using the below code in .htaccess for enable replace function: ...