0
votes
0answers
127 views

Numpy Module not working…wrong architecture

My Bash profile looks like this : export PYTHONPATH=/Library/Frameworks/Python.framework/Versions/7.3/lib/python2.7/site-packages My error looks like this import numpy Traceback (most recent call ...
0
votes
1answer
163 views

Default or fink python and lxml under 10.6.8

Ah, confusion. I'm trying to install a python library called lxml as needed by a python script. I've been through numerous SU quesitons and answers. I haven't been able to make much progress. I run ...
0
votes
1answer
1k views

How to install bpython for python3 on OSX?

How can I install bpython, or another good python shell, on OSX 10.6, for python 3? Calling easy_install bpython installed it for python 2.6 (same with ipython). Nor brew nor macports seem to even ...
1
vote
0answers
533 views

install lxml 2.3 with python 3.2 on osx 10.6.8

I tried many times but still can not figure out how to install lxml into python 3.2 I'm using mac osx 10.6.8, gcc version 4.2.1 I install lxml using the following command python3.2 setup.py build ...
0
votes
1answer
93 views

Python: 64 bit version for Django for Mac?

I upgraded Python on Snow Leopard which broke Django. So I went back to version 2.6, but now I can't seem to get MySQL db running because now I am running a 32 bit version of Python. I would like to ...
2
votes
2answers
745 views

Create a local DNS TLD for development

I do a lot of web dev, mainly RoR and PHP, I've got a VMs which holds my dev environments and handling multiple clients on them is a pain. With PHP you just create a subdir, but with RoR it's a little ...
1
vote
2answers
588 views

Building Python 2.7.1 on Mac OS X, import threading and a KeyError Exception

Original Problem: I am building Python 2.7.1 on Mac OS X 10.6.7 and am having issues with a KeyError exception being thrown from the threading module when Python is quit (likely on the atexit call). ...
2
votes
3answers
810 views

Install gcc on OS X Snow Leopard

I'm trying to install the Python Imaging Library on a MacBook running 10.6 Snow Leopard. I haven't yet found a precompiled binary for OS X, so I need to compile it from source, which means I need ...
11
votes
3answers
5k views

Python 2.6.1, pycrypto 2.3 pypi package: “Broken Pipe” during build

I am attempting to install Fabric, which requires pycrypto. During the build for pycrypto I always receive a "Broken Pipe" error. I don't know where to start to fix the problem. I'm running Mac OS X ...
1
vote
4answers
1k views

How to open python scripts directly by typing in their name in terminal (Mac OS X)

I'm working on installing django and running it on my system. I have a problem though, in this tutorial creating a project is explained by running the command django-admin.py startproject mysite ...
3
votes
3answers
1k views

Using Python on Mac

I want to learn Python using my Mac. Now I want to setup a Python version >= 3.1.3, because my materials for learning are using this version. Typing python into terminal results version 2.6.1, using ...
1
vote
2answers
11k views

Getting PATH right for python after MacPorts install

I can't import some python libraries (PIL, psycopg2) that I just installed with MacPorts. I looked through these forums, and tried to adjust my PATH variable in ~/.bash_profile in order to fix this ...
1
vote
1answer
5k views

How to change which Python version gets used in Snow Leopard?

Snow Leopard comes packaged with a version of Python 2.6 that is incompatible with many popular libraries, so I've downloaded a version of Python 2.6 from python.org. However, when I type python at ...
1
vote
1answer
613 views

Having a problem with easy_install on osx 10.6

I've been doing some Google searches and come up short. Output is the following $ easy_install yolk 'import site' failed; use -v for traceback Traceback (most recent call last): File ...
5
votes
1answer
3k views

How to install Python newt or snack in Mac OS X for byobu

I've installed byobu in Mac OS X 10.6.5. It will start, (i.e. it will start a screen session) but in order to run byobu-config and probably in order to do some other things I need a module called ...
0
votes
1answer
228 views

Python 3.1.2 Interpreter lacks shell feaures on OS X when compiled from source

The version of Python provided by default in Snow Leopard makes available some features of the bash shell (i.e., command history, keyboard shortcuts, etc.) to its interactive interpreter. After ...
0
votes
1answer
1k views

How to build libsvm-2.91 for Python on OS X 10.6.4 Snow Leopard using SWIG 2.0?

Problem: I've inherited work on a Django we app that makes use Python modules that import svmc. When I type ./manage.py runserver I get the following: Error: No module named svmc Solution sought: ...
0
votes
1answer
1k views

How to install LIBSVM for Python 2.65 on Mac OS X 10.6.4 Snow Leopard?

I would prefer to install libsvm without resorting to the use of a package manager other than homebrew. Any ideas? Thank you, Michaux
3
votes
3answers
1k views

mysql-python on Snow Leopard with MySQL 64-bit

Can't seem to get mysql-python to work on Snow Leopard for the life of me. Currently using the default version of python that ships with Snow Leopard (python 2.6.1). Installed MySQL 5.1.45 x86_64. I ...
1
vote
1answer
354 views

Error installing protocol buffer on snow leopard

I've just installed Google protocol buffer on my snow leopard mac. When going into the python shell import protobuf produces an unknown module error. I'm using the python which came with snow ...
8
votes
6answers
8k views

Installing pygame on Snow Leopard's system Python 2.6

Snow leopard has python 2.6 included now, and I want to install pygame on it, but it says its for Python from python.org, not system python. I tried using setup.py from source, but it didn't work. Is ...
24
votes
4answers
63k views

How can I change the default Python version on Snow Leopard?

I recently upgraded my Mac OS X 10.5 Leopard install to 10.6 Snow Leopard, and with that came an upgraded version of Python, 2.6.1 (instead if 2.5.1). Now when I type python in the Terminal i still ...