Python is an interpreted, general, high-level programming language. Programming questions are off topic. Questions about the use of Python and should be asked at [Stack Overflow](http://www.stackoverflow.com).

learn more… | top users | synonyms

0
votes
1answer
789 views

The lighttpd+Python equivalent of Apache+PHP+FastCGI+suEXEC (or: lighttpd FastCGI-executing Python scripts with the permission of the owner)

It's been years since I last had anything to do with web servers. The last time, I found that Apache along with FastCGI (actually mod_fcgid) and suEXEC gave me a seemingly perfect way to handle PHP; ...
0
votes
1answer
898 views

Cannot access PHPMyAdmin after installing Django

I usually access phpMyAdmin on my server by going to www.mysite.com/phpMyAdmin, however after I've installed Django, when I go to the mentioned address, I get the Django It worked page. Any ...
2
votes
1answer
148 views

/usr/share/python/debian_defaults Ubuntu / Mac equivalent

After a lot of trial and error, I upgraded my system's default version of Python on Ubuntu. The debian_defaults file was part of the solution on Linux. Now I am trying to do the same thing on my Mac....
2
votes
3answers
3k views

On Ubuntu: I deleted /usr/bin/python2.7 - please help

I accidentally overwrote my /usr/bin/python2.7 executable. When I try to reinstall with aptitude reinstall python2.7 It fails because, python2.7 is required to install python2.7. I'm in a bind. I ...
16
votes
8answers
81k views

How to install pip and easy_install on CentOS

I tried to install pip and easy_install on my CentOS but could not find them. How can I install them? Also, I have two versions of Python, 2.4 and 2.7. How will pip make sure to link newly installed ...
0
votes
2answers
808 views

How to work on Python project to be run on an EC2 instance?

I just started a web project using Python/webpy. I've created an Amazon EC2 instance and now would like to work on the actual development side. Is there a way for me to open the Python files located ...
0
votes
2answers
2k views

Convert mp3 to flv

I want to convert mp3 files to flv Why it doesn't work? $ ffmpeg -y -i 1.mp3 -f flv -acodec libmp3 -ab 64 -ac 1 myfile.flv ffmpeg version 0.7-rc1, Copyright (c) 2000-2011 the FFmpeg developers ...
2
votes
1answer
250 views

Cannot type the letter 'b' in Django Shell

My programming teacher has me doing a Django progect for my last project of the year. I've hit a big wall though. I can't use the django manage.py shell because 1 letter doesnt work. Lowercase 'b'. It ...
2
votes
2answers
151 views

Does SCO Unix 7.1.4 come with Python installed?

Does SCO Unix 7.1.4 come with Python installed? I searched on Google but couldn't find any clue.
1
vote
0answers
272 views

CentOs 5 - rsh - poll:protocol failure in circuit set

There are some python scripts in my workspace which test a couple of features, and one of this scripts, in a small period of time, calls a lot of rsh commands. When trying to run this one, I'm ...
5
votes
2answers
14k views

“bad interpreter: Permission denied” How can I prevent this error?

I want to run program directly such as ./program without define the interpreter in shell first. so, how can i want to prevent this error? bad interpreter: Permission denied My operating system ...
0
votes
1answer
3k views

How to install old version of python by removing new version in Ubuntu?

I want to uninstall Python 2.6.5 and then install Python 2.5. I also want to uninstall nosetests new version and install the old one. OS is Ubuntu.
2
votes
1answer
463 views

How do I run Python scripts on a web host that doesn't support command line access?

I have a webhost that doesn't allow command line access and yet they say you can run python scripts....how?
3
votes
2answers
281 views

What could this python process be?

I noticed some strange python process trying to access IPs which seem to belong to Google, such as 74.125.77.109 (according to whois). The process has this initialization command in ps: bash -c P=...
4
votes
1answer
1k views

python 2.6 or 2.7 (scientific packags support) and mint linux which packages to install (-dev, etc.)

Hey, trying to install python 2.6 on Linux Mint 11 "katya" 64 bit. I'm about 6 months hobbyist experience with Python and about an hour and a half with linux mint (had toyed with linux a few years ...
4
votes
9answers
17k views

Trying to edit a python file but the “edit with IDLE” has disappeared when i right click the file. How do I restore that command?

Trying to edit a python file but the "edit command" has disappeared all of a sudden when I right click the file. How do I restore the edit command so I can continue working on my python files? I ...
2
votes
1answer
1k views

how to make svn call to post-commit hook async and not wait for it to complete?

I have post-commit.bat hook which contains this d:/mypathtoscript/mypostcommit.py however when i do commit with tortoise svn it waits for mypostcommit.py to complete no matter what i tried (and it ...
1
vote
0answers
650 views

How to install openCV running from Python on OS X

(Step 1) I'm trying to get openCV to run from python on my mac using the MacPorts install, and also trying to follow The Petite Geek's guide: sudo port -v install opencv +python26 It runs for ...
6
votes
4answers
48k views

Uninstalling Python 3 on a Mac

I installed Python 3 to learn Python and quickly realized that django isn't compatible with Python 3. How do I uninstall Python 3 on my Mac so that I can install a different version?
2
votes
3answers
913 views

Install gcc on OS X Snow Leopard

I'm trying to install the Python Imaging Library on a MacBook running 10.6 Snow Leopard. I haven't yet found a precompiled binary for OS X, so I need to compile it from source, which means I need gcc....
2
votes
2answers
5k views

How to change the default highlight color of a property in the Aptana-pydev?

The default text highlighting and default font colors that came with Aptana (Eclipse) seems to be a little wacky, anyone have any idea how to fix this? This example isn't the only place where stuff ...
0
votes
1answer
2k views

How do you install pygame on a (Ubuntu) system with multiple python installs?

On my ubuntu box I have python2.6 and python 3.1 installed. I did some work with pygame / python2.6, and now I want to play with python3.1 / pygame. However, in idle (using python3.1) when I import ...
2
votes
3answers
6k views

Ubuntu 10.10 'Command not found' for python script

I have a python script 'monty.py' with #!/usr/bin/env python in the first line. When I run monty.py in the terminal, I get monty.py: command not found I am in the correct directory, and I also ...
0
votes
1answer
1k views

If i use Yum to install a specific version of python, does that overwrite my current python or install an additional version?

I'm trying to install a specific version of python. I will be using yum install python26. My question is, does that upgrade the current python installed on the machine or does it install the new ...
4
votes
1answer
3k views

Best code folding plugin for Python in vim?

I use vim for all the code I write. My biggest issue is that I cannot find a good Python code folding plugin. I've found two-three popular ones that use indentation but they tend to either fold too ...
1
vote
0answers
145 views

“Program terminated by uncaught signal” when running Python from TextMate

When I use command + R to run my Python code in TextMate under Mac OS X, I receive the follow output: Program terminated by uncaught signal #10 after 0.32 seconds. However when running my code with ...
1
vote
3answers
1k views

Running python script on when user unlocks windows machine

I have a python script , which I want to run , when user unlocks the machine ie; When users presses Cntl-Alt-Delete and enters username and password and logs in. How can I do this ? . Is there any ...
2
votes
2answers
1k views

How do I configure Ubuntu to run a python (backup) script every night at midnight?

New to Ubuntu (and Linux in general) and have whipped up a quick python script to backup my files and do some other housekeeping. I don't see any service scheduling tools and was wondering what the ...
4
votes
1answer
4k views

install a VTK (graphing library) with support for python 2.7 / win32

How should I install VTK (vtk.org) on windows xp in such way so it possible to use it from python 2.7 with module "vtk" (it is requirement by scitools)
0
votes
2answers
455 views

How to keep home dynamic ip updated in laptop's hosts file, both linux

I can script and program if necessary, but just looking for the best way to do this. What I have in mind is everytime I connect to my home network, I use NetworkManager, it would update the ip. That ...
24
votes
4answers
5k views

Find outdated/updatable pip packages

pip freeze shows me the packages installed, but how do I check against pypi which ones are outdated?
11
votes
3answers
6k views

Python 2.6.1, pycrypto 2.3 pypi package: “Broken Pipe” during build

I am attempting to install Fabric, which requires pycrypto. During the build for pycrypto I always receive a "Broken Pipe" error. I don't know where to start to fix the problem. I'm running Mac OS X ...
17
votes
3answers
21k views

easy_install will not connect through proxy

I'm running Ubuntu Server 10.04 64-bit under VirtualBox, and it seems that everything except easy_install and pip can connect to the Internet. I have set and exported the http_proxy environment ...
5
votes
3answers
8k views

Easy_install the wrong version of python modules (Mac OS)

I installed Python 2.7 on my Mac. When typing "python" in terminal, it shows: $ python Python 2.7 (r27:82508, Jul 3 2010, 20:17:05) [GCC 4.0.1 (Apple Inc. build 5493)] on darwin Type "help", "...
2
votes
1answer
71 views

Possible causes for random software changes?

I'm on Windows Vista. I've been using IDLE, the default Python IDE ever since installing Python. I long enjoyed the functionality of right-clicking a .py file and selecting "Open with IDLE" until ...
0
votes
3answers
1k views

Trouble typing accented letters at the terminal prompt after launching Python

Edit: Using Mac OSX 10.6, whether I use Terminal.app or iTerm.app, when I launch Python, I can no longer type accented letters (e.g.é or ä). Any ideas? ORIGINAL POST: I am using iTerm 0.10. I ...
3
votes
0answers
896 views

Installing Tcl and Tix in OSX

I'm having trouble installing Tix on OSX the version of Tix I am using is 8.4.3. I try to install it by following the instructions in the README % ./configure % make % make install And iat the very ...
1
vote
1answer
844 views

How to configure emacs by using this file?

From http://public.halogen-dg.com/browser/alex-emacs-settings/.emacs?rev=1346 I got: (setq load-path (cons "/home/alex/.emacs.d/" load-path)) (setq load-path (cons "/home/alex/.emacs.d/configs/" ...
1
vote
4answers
2k views

How to open python scripts directly by typing in their name in terminal (Mac OS X)

I'm working on installing django and running it on my system. I have a problem though, in this tutorial creating a project is explained by running the command django-admin.py startproject mysite ...
0
votes
2answers
551 views

OSX: Python packages fail to install, error message “/usr/local/bin: File Exists”

I keep trying to install django and other python packages, and I keep getting the exact same error message: Installing django-admin.py script to /usr/local/bin error: /usr/local/bin: File exists So ...
0
votes
1answer
181 views

Python Upgrade Broke Django

I've upgraded Python from 2.5 to 2.7, but the upgrade broke Django. My Django tests and shell report they can't find the modules. I tried putting the site-packages with Django on my PYTHONPATH in ....
20
votes
3answers
74k views

How to globally modify the default PYTHONPATH (sys.path)?

On a Ubuntu (10.10) system, I have a Python package that installs itself into /usr/local/lib/python2.6/site-packages/. This isn't contained in the default path (sys.path). How do I add this directory ...
0
votes
0answers
834 views

How to run Meld (1.5) with python 2.4.3

I would like to run Meld (a diff tool written in python) but it quits with the following error : Meld requires Python 2.5 or higher. Facing restrictive corporate guidelines i have to stick to the ...
1
vote
1answer
2k views

How to get .cgi files working in python with Apache on Ubuntu

I am not really sure whether to post this here or on SO. I think this has more to do with server administration so i am posting it here. I have apache 2.2 installed on my ubuntu 10.10 system with ...
8
votes
1answer
3k views

Vim */dyn support

What does mean the plus sign before */dyn in the :version command's output, e.g.: +python/dyn +python3/dyn +ruby/dyn +tcl/dyn I didn't find any useful documentation on it. When I run :echo has('...
22
votes
7answers
90k views

Updating Python on Ubuntu system

I want to update the Python build on my Linux box, but the only way I know how to do it is uninstalling the current version and installing the new one. My system is already up to date (I updated ...
17
votes
10answers
18k views

How to install matplotlib on OS X?

I want to install matplotlib on OS X. If possible, using homebrew. I installed Python 2.7.1 using brew install python, I modified my path to use it I installed pip using brew install pip I installed ...
1
vote
2answers
868 views

Shell Script File - Pass Multiple Parameters to Interpreter

I have a Python script that I run which needs to execute under a special environment, so I would run the program like so from my working directory (~/project/src): python manage.py shell This opens ...
7
votes
2answers
3k views

cron can't read PYTHONPATH environment variables?

I have added to the PYTHONPATH on my server's .bash_profile file. However it appears that cron isn't reading from it because I am getting import errors. If I run the exact command cron calls on the ...
2
votes
1answer
181 views

Having problems install py2app 0.5.2

I am a beginner at python so please excuse me for silly comments or rookie mistakes that i make. I was trying to install py2app 0.5.2 and i hit an error: $Best match: altgraph 0.7.1 $Downloading http:...