The tag has no wiki summary.

learn more… | top users | synonyms

0
votes
0answers
986 views

rvm use responding with Unknown ruby interpreter version (do not know how to handle):

I have a number of Rails apps that I've inherited that use different Ruby versions. To make life easier I'm trying to use rvm. Whenever I fire off the rvm use command inside any of the directories I'm ...
0
votes
0answers
14 views

passsenger: Apache 2 Test Page shown instead of rails application

I have installed centos and rails using a tutorial The problem is, the browser shows "Apache 2 Test Page" instead of the rails site. Any idea how to troubleshoot this.
0
votes
0answers
24 views

Redmine reports intermittent Internal Error

I've been using Redmine/Apache for a few months now. Occasionally a page will not load, and instead I will get Internal Error 500. Refreshing generally fixes this. When I look in the log file on the ...
0
votes
1answer
60 views

Which version of rails should I install with ruby 2.0.0 installed?

Hi I am building a ROR development environment on a new computer with windows 7, now I have Ruby version 2.0.0 and Gems version 2.2.2 installed. Which version of Rails should I install? I saw ...
1
vote
1answer
533 views

Rails startup script runs twice

I'm having some difficulties with a new installation of Ruby on Rails. I want to use my application with MySQL. Here's the problem: The server starts without a problem when I use the default ...
0
votes
1answer
35 views

Re-enable TextMate 2 alpha Rails 'rocketship' shortcut

After updating to the latest alpha version of TextMate 2, the control - l shortcut no longer inserts a rocketship (=>) Is this an option that can be re-enabled, is there another shortcut that does ...
0
votes
0answers
11 views

Installing/Copying Fonts from a Publisher Document

I am working on a website a designer has created in Publisher. This file contains custom fonts, which I need to add to the website. I believe I already have these fonts installed (they do display ...
2
votes
1answer
165 views

“which rails” works.. but “rails --version” doesn't.. how come?

This may be related to what i did here.. but when I type the command which rails I get /usr/bin/rails but when i type rails --version I get: ...
0
votes
1answer
134 views

How to setup a shared hosting server for Ruby on Rails from scratch?

I need to setup a shared hosting server especially for hosting RoR applications. What is the best way to achieve this? Currently I am hosting a LAMP shared hosting server. I have some scripts with ...
0
votes
1answer
33 views

rails didnt install correclty, specificly the uninstaller

ive just installed rails using railsinstaller.org for osx, rails and ruby seem to be working ok (checked by running rails -v, ruby --version and ruby --help). But when it installed i got an error ...
2
votes
0answers
114 views

Elastic beanstalk Rails - defaults to production environment even if I set staging environment

I am trying to bring up a staging instance of rails applciation using elastic beanstalk. I followed the documentation and did the following : eb init --environment staging eb start --environment ...
3
votes
2answers
2k views

Elastic beanstalk rails application with git source and deploy hooks

I want to setup Elastic Beanstalk for my existing rails application. I was successful in doing the sample foo app. These are the questions I have I need the deployment to happen from my git ...
1
vote
0answers
96 views

VPS set up to serve php and rails

I have a VPS with centOS that we currently use for serving php apps with apache. Now I also want to serve rails app from there. Either I can use phusion-passenger or I can do a separate unicorn and ...
1
vote
1answer
198 views

Gemfile template

I'm trying to modify the default gemfile template on debian, and it doesn't seem to be anywhere to be found. Is this found somewhere on the system called "Gemfile" or is it located in another ...
0
votes
1answer
822 views

Unable to start rails on port 80

I am trying to learn Linux better but currently only have very limited experience - so please excuse my ignorance in this matter. I am trying to start rails on port 80, and as another user by using ...
0
votes
1answer
96 views

Cannot find Ruby on Rails installed

I've managed to install Ruby and the gems install (rvm?) but now I'm stuck actually installing Ruby on Rails. Every time I execute, gem install rails Terminal says that it's fetching each file and ...
1
vote
0answers
290 views

can I remove imagemagick by deleting directories?

I posted this to StackOverflow, but probably belongs here. I'm on OSX Lion, trying to get back to basics so I can run RMagick in Rails 3.0, using rvm. When I tried to add the RMagick gem to Rails ...
0
votes
4answers
1k views

no gitignore file in new rails app

I created a new Rails app using version 3.0.1 (in order to follow along with a tutorial using 3.0.1), but it didn't create a gitignore file. If I create my own, what ending should I put on the file? ...
2
votes
1answer
274 views

Can't find sqlite3 in this ruby/rails version using rvm

I installed rvm and am using 1.9.2 with rails 3.05. I was able to create a new application but once I moved into the directory and tried to start the server ("rails s"), I got this error message ...
2
votes
1answer
933 views

How to create a GEM_HOME for rvm?

I'm learning how to set up different versions of ruby with different versions of rails using rvm. Here's a link for the instructions http://beginrescueend.com/gemsets/basics/. It says Let's say, ...
2
votes
1answer
2k views

How to install and use different versions of ruby?

I'm learning rails from different books that use different versions of both ruby and rails. Right now I have ruby 1.87 installed on my Mac OS X Snow Leopard (in /usr/bin), but need to also use ruby ...
3
votes
4answers
4k views

What is the simplest way to download a gem without installing rubygems?

I would like to download a gem without installing all the required gems for a given gem. Specifically for the Rails 3 gem. It has a lot of dependencies, and I need to install it on a closed server ...
2
votes
0answers
54 views

Customize netbeans rails module

The Netbeans rails plugin has a simple a project structure: However, I have encountered the following problems: I cant access config.ru file I cant access app/uploaders dir (carrierwave gem) ...
2
votes
1answer
1k views

git out of memory

I went to my file directory, did $ git init $ git add and then got fatal: Out of memory? mmap failed: Cannot allocate memory One folder is maybe 2GB big because it is full of images.. the rest ...
0
votes
1answer
590 views

Error installing Rails 3.0.1 (File not found:lib)

I am trying to install rails 3.0.1 on ubuntu 10.10. I am getting this error towards the end when i execute this command sudo gem install rails --version 3.0.1 Installing ri documentation for ...
7
votes
6answers
3k views

Ubuntu in Virtualbox - WEBrick web server very slow when using local IP address

I'm using Ubuntu (Lucid Lynx) to learn Ruby On Rails. I'm running Ubuntu in VirtualBox (the host is Windows 7 Ultimate), using bridged networking. When I run my Rails app and point the browser at it ...
0
votes
3answers
4k views

How to install/update Ruby on Rails on Ubuntu 9.10?

I'm running Ubuntu 9.10. I am getting started with ruby on rails development and would like to make sure my system is up to date. This is what I've found out so far: $ which ruby /usr/bin/ruby $ ...