0
votes
1answer
15 views

pgadmin3 failed dependencies which are already installed?

I try to install pgadmin3 in a system with OpenSUSE 12.1 After download pgadmin3-1.14.0-2.1.2.i586.rpm I try rpm -ivh pgadmin3-1.14.0-2.1.2.i586.rpm and have the following errors: Failed ...
0
votes
1answer
410 views

Install Rpm Package on Kali Linux

I need to install .rpm package in Kali linux. But shows command not found error. i tried using with sudo but didn't help. Does kali supports .rpm files? How can i install .rpm on Kali linux?
0
votes
1answer
45 views

Why does the alien package converter need root permissions?

When trying to convert a .deb package to .rpm using alien, I use this command: $ alien -r foo.rpm but it complains thusly: > Warning: alien is not running as root! > Warning: Ownerships of ...
0
votes
1answer
33 views

How to write dependency rules in rpm .spec file for RHEL OS

I need to build one rpm package, that should be dependent on the installation of another rpm package. On my PC, the dependent package has been installed, with a name like abcd-1425-a.x86_64. I wrote ...
0
votes
1answer
51 views

yum erase tells me pkg not installed. yum install tells me package is already installed

Erase complains package is not installed : yum erase libstdc++-4.1.2-52.el5_8.1.x86_64 Setting up Remove Process No Match for argument: libstdc++-4.1.2-52.el5_8.1.x86_64 Package(s) ...
-1
votes
1answer
689 views

how to enable java in Browser on Centos 6.5

i already install Java (jdk 6u45 and jre 6u45) in a Centos 6.5 Server, but i don't know why in my browser appears to enable java plugin, these are steps to install java in my machine: rpm -ivh ...
0
votes
1answer
39 views

Is an RPM already installed? Binary compare

At my current place of work we sometimes receive a bundle of RPMs and are told to update our environment. The entity providing us the updates is very slack with their processes and sometimes make ...
0
votes
0answers
16 views

Supported versions of Linux for AIX RPMs

I am trying NIMOL which comes with AIX and helps in handling os installation over network. First we need to install RPM from the AIX disc on the supported Linux machine. I have AIX 7.1 disc. I want ...
0
votes
2answers
61 views

Format “yum provides” output

I am writing a little program that packages configuration files as rpm, and it puts a series of %triggers to handle installation/upgrade of the packages that bring a copy/version of the same file. I ...
0
votes
0answers
329 views

package-cleanup --cleandupes fails to remove duplicates

I have an issue with duplicate packages installed on my Fedora machine: # package-cleanup --dupes Loaded plugins: langpacks, refresh-packagekit audit-2.3.3-1.fc20.x86_64 audit-2.3.2-1.fc20.x86_64 ...
0
votes
1answer
513 views

Building a simple RPM on Oracle Linux (RedHat) using rpm build

I want to make a RPM using a certain user, from a specified build directory location. The RPM contains multiple files or one gzip, and should copy those files to a preset location (so it should be ...
0
votes
2answers
32 views

File types from rpm package file

Is there any way to get file types (or more exactly, list of binaries) from rpm package file without unpacking it? It's assumed that there is a rpm file which isn't installed and we need just to learn ...
0
votes
0answers
56 views

Is there a way to determine what RPM --relocate was used to install the rpm package

After a rpm package is installed using --relocate, is there any way to find out what value was used with the --relocate option?
0
votes
0answers
117 views

YUM and RPM crash due to the liblua-5.1 library being missing

I've been playing around with a LiveUsb install of basic Fedora with persistence. I attempted to install moonscript, which requires Lua and LuaRocks. After installing Lua and discovering there were ...
1
vote
1answer
808 views

How to install php soap with rpm packages in centos 6.4 x86_64

I want to install php-soap, centos says: [root@LMS-Cent64 soap]# rpm -ivh php-soap-5.3.3-22.el6.x86_64.rpm error: Failed dependencies: php-common(x86-64) = 5.3.3-22.el6 is needed by ...
0
votes
1answer
32 views

RPM User specific updates

I have packaged my software as rpm and everything is working just fine with software however there is one part of contents of rpm which I can't find proper way to update. Every user in system has ...
1
vote
0answers
63 views

linux + squashfs-tools for red-hat 5.3

I want to install the squashfs-tools-4.0-5.el6.i686.rpm But I have the following dependencies ( after RPM installation ) please advice what the additional packages that I need to install on my linux ...
0
votes
1answer
154 views

Good way to resolve dependencies for .rpm installation

I am trying to install jdk-7u25-linux-x64.rpm through rpm. However, rpm says it conflicts with jre-1.6.0_13-fcs. I then try to remove jre-1.6.0_13-fcs but it fails because there are other packages ...
0
votes
3answers
12k views

How to install rpm file along with its all dependencies?

I am trying to install HPCC on RHEL based machine. I have one .rpm file and to install this rpm, I am using following command : sudo rpm -Uvh hpccsystems-platform_community-4.0.0-9.el6.x86_64.rpm I ...
0
votes
1answer
292 views

YUM crashed due to library missing

I tried to remove stock Lua and build my own one, so I tried: yum remove lua But too many dependencies on the package and it does not allow me to remove it so I used rpm instead: rpm -r --nodeps ...
0
votes
1answer
1k views

How to download yum packages on windows (or online in browser)

I am newbie to linux and just started using it at home, but I don't have internet connection at home, and in office I have good internet but using windows, I just want to download yum packages on my ...
0
votes
1answer
539 views

Cannot install net-snmp because of failed dependency

I have a server here that is running SuSE Linux Enterprise Server 11 (i586) patch level 1. I am trying to install Net-SNMP on the machine. I downloaded the net-snmp-5.4.2.1-8.2.i586.rpm file and ...
0
votes
1answer
260 views

How to build rpm package correctly?

I'm trying to install the new version from ganglia, which provides a tar.gz. My procedure was uncompress the tar.gz file, enter in the folder and then makes rpmbuild -ba ganglia.spec, a warning ...
1
vote
3answers
5k views

How to downgrade a kernel?

I need to downgrade the kernel from 2.6.32-358.6.2.el6.centos.plus.x86_64 to 2.6.32-220.el6.x86_64 I am unable to install the older version using Yum/rpm as it gives the following error ...
1
vote
0answers
44 views

How to remove an imported key during rpm uninstall

I'm creating an RPM package (let's call it Foo) that contains a gpg key that will be used to sign other RPMs. During the postinstall script for Foo, I execute 'rpm --import [keyfile]' to import the ...
0
votes
1answer
690 views

What is the general strategy for handling multiple missing shared objects?

I'm still learning Linux, so bear with me... I ran ldd on Apache's httpd and found many missing shared libraries. I am new to this machine and am not sure whether some of these are misplaced or ...
1
vote
1answer
1k views

Why can't yum find inconsolata-fonts package available for install?

On CentOS v6.3 when I type: yum update followed by: yum search inconsolata-fonts or: yum search inconsolata I get no results. However a Google search indicates that a package called ...
3
votes
1answer
333 views

What's the rpm/yum equivalent of `aptitude why`?

On .deb managed systems one can use $ aptitude why <package> to find out what installed package required the installation of <package> for example: $ aptitude why python i xdiagnose ...
0
votes
1answer
204 views

rpm removal failure

I'm encountering a problem removing an installed rpm. > rpm -q my_rpm my_rpm-3.0.0-27 > rpm -e my_rpm error: can't create transaction lock on /var/lib/rpm/__db.000 I have also tried to run ...
0
votes
1answer
249 views

Can we make a non-relocatable RPM package relocatable during repackaging?

I am trying to install a package on a RHEL4 box, the package is non-relocatable. I need it at a custom location because there are some other applications which need to be linked to it. So I wonder ...
1
vote
1answer
333 views

How do I list all the files not owned by any package in a RPM-based system?

I want to look for files polluting an old CentOS system in my company. Is there an easy way to do that?
1
vote
2answers
2k views

Trying to install libcurl on a Linux RHEL, unable to install openssl

I am a programmer, and I am trying to give a clear sure fire way for the engineering team to install libcurl on a Linux RHEL machine. The machine already has the following installed by default: ...
1
vote
1answer
107 views

Why compile an rpm from source?

What I know: src.rpm usually contain some kind of tar or compressed source code for the app/library/package Sometimes people recommend you compile from source if the package does not work What I ...
4
votes
1answer
7k views

How to completely uninstall a package (including all extra files that came with it) using yum (or rpm)?

When I do yum remove, it sometimes keeps a package's configuration files. Is there anyway to remove a package completely, without keeping any file that belonged to the package? I am running CentOS.
0
votes
1answer
259 views

Try to make a rpm packet of httpd 2.4.3

my spec file is: %prep tar zxvf $RPM_SOURCE_DIR/httpd-2.4.3.tar.gz %build %install cd httpd-2.4.3 ./configure -prefix=/usr/local/apache make make install %preun if [ -z "`ps aux|grep httpd | grep ...
0
votes
1answer
61 views

Extract a single directory from rpm

I'm able to extract individual file rpm rpm by: rpm2cpio rpm_name | cpio -ivd ./a/b/c/README I need to extract the whole /a/b/c/ directory (using ./a/b/c/ in above command doesn't works)? How it ...
0
votes
2answers
796 views

Replace sqlite3.3.6-5 for sqlite3.7.0-1 on centos5

I want to update my sqlite3 version. I'm using centos5 (VPS requeriment), I have a new version downloaded (.rpm) and a previous installed (with the os) I have this error. Well, I have noob on ...
1
vote
1answer
163 views

yum to treat a package installed by hand as installed through it

I've built Emacs 24 and installed it on my FC-17, but if I try to install any package that requires Emacs (such as Pymacs, ECB and so on), all of them will try to install Emacs 23. I think that my ...
3
votes
1answer
116 views

Why do RPM packages have different names to the programs they install?

It seems to me that when I download RPM packages that the names they use are sometimes different from the programs they install. For example: yum install httpd apache -v I install the RPM package ...
2
votes
2answers
346 views

Upgrading Node.JS from tarball of binares when yum-installed version already exists

On CentOS 6.3 64-bit, I've installed Node.JS version 0.6.18 using yum. I have an application that requires Node.JS v0.8.x. The currently stable version of Node.JS available is 0.8.7, which is ...
2
votes
2answers
535 views

Accidentally erased rpm package, how to recover?

Yesterday I planned to erase all wine related package, first I queried with: rpm -qa | grep wine and it showed 6 or 7 packages, then I typed: rpm -qa | rpm -e After one or two minutes waiting, I ...
1
vote
2answers
1k views

user XXXX does not exist - using root?

In makefile, i used 'install' command as below command:'install -o 1010 -g 100 -m 0755 -D path' instead of checking user name and group name i would like to check uid and gid. Consider the ...
0
votes
1answer
5k views

Skype not working in CentOS 6.2

I tried to install Skype on CentOS 6.2. I downloaded Skype's rpm package from here and tried this command to install – but it's giving an error like this: [root@localhost Downloads]# rpm -ivh ...
0
votes
1answer
245 views

PHP 5.4.3 RPM and steps of installation?

Can someone please point me a PHP 5.4.3 RPM that includes mysql and PDO ? I appreciate if someone can guide me or give me link to step by step installation of rpm. I have redhat linux. (gcc version ...
0
votes
1answer
5k views

Steps to install PHP 5.4.3 from rpm and yum?

I got a link saying following steps of installation of PHP 5.4.3. rpm -Uvh http://repo.webtatic.com/yum/el6/latest.rpm yum install php54w Can i use above method safely? Or any other rpm that i ...
2
votes
2answers
274 views

yum/RPM depend on generic package (like “provides” in other package managers)

I'm trying to figure out how to make a package of mine depend on anything that provides "java", but I'm not sure what to even look up. Apparently "yum provides" is a command for finding out which ...
0
votes
2answers
1k views

Fedora 16 is not retrieving the mirror list

I have Fedora 16 installed. It gives me some errors/warnings when updating, and installing software through yum. Could not retrieve mirrorlist ...
3
votes
1answer
198 views

Is it possible to have two package management systems (.deb and .rpm) on one system?

Is it possible to have more than one package management system on one system? Example: RPM, deb and .txz on the same partition of Ubuntu. If it isn't possible, why not?
2
votes
1answer
2k views

Wrong RPMforge Installed

I am running CentOS 6.2 and I installed RPMforge EL5 by mistake and I need to uninstall it and install RPMforge for EL6. How can I do that?
1
vote
1answer
1k views

Is it possible to get user's input during installation of rpm?

Is it possible to get input from a user during an rpm installation? I have a script that works by itself (taking input from a user and doing actions) but when run as part of the post install of an rpm ...