0
votes
1answer
15 views

ruby1.9.3 links to ruby1.9.1 in Debian Wheezy after install with aptitude

I have just attempted to install ruby1.9.3 with aptitude but for some odd reason it keeps symlinking /usr/bin/ruby1.9.3 to /usr/bin/ruby1.9.1. Here are the ruby version in /usr/bin: lrwxrwxrwx 1 ...
0
votes
0answers
43 views

Correct way of setting Ruby2.1 as the go-to application when it referenced to/called via shell?

I have installed Ruby 2.1 on my headless Debian server (7.4) by downloading the source from https://www.ruby-lang.org/en/downloads/ and then running the routine of ./configure make make install ...
0
votes
0answers
26 views

Upstart spawned threads won't clean up

I have an upstart job which runs: exec su - pi -c 'cd /data/zeus_station/releases/20140217074914; export PORT=5100; ~/.rbenv/bin/rbenv exec bundle exec thin start -R config/config.ru -p 9000 >> ...
1
vote
0answers
138 views

Redmine using fastcgi [closed]

I am a Software Engineer tasked with installing Redmine on our server. Currently it's running using WebRick from /usr/share/redmine but I would like to: have it run in /srv/redmine (chroot if ...
0
votes
1answer
278 views

why doesn't “which ruby” output anything?

I'm using Debian 6. I uninstalled ruby1.8, and then I installed ruby1.9.1. If I type "which ruby" at the command line, it doesn't output anything. It seems like it doesn't recognize it.
1
vote
0answers
513 views

Installation on Linux & Win7: Aptana, PostgreSQL, Ruby, JQuery (WWW on Apache)

Basically I have 2 systems, where I want to develop (and use) my application: A Linux (Debian) system. This is my server. Here I have PostgreSQL (& phpPgAdmin), Apache, Ruby. Typically I use ...
3
votes
3answers
917 views

Where can I find the rails executable in Debian?

I am having a problem with my installation of Ruby/Rails on Debian. I've installed Ruby 1.9.1(1.9.2) using the package manager and I've created links to ruby1.9.1 and whatnot to allow me to use the ...
0
votes
2answers
2k views

Trying to install Rmagick on Debian

One of things you need to do to get Rmagick installed apt-get install libmagick9-dev When I try that I get the following errors Reading package lists... Done Building dependency tree... Done Some ...