2
votes
0answers
51 views

How to install development tools when Ruby compiled from source

I have Windows 8, and I need to install Ruby 2.1.2 for a project. I followed these instructions. I unzipped the source into C:\Ruby2.1.2\src\, ran nmake in C:\Ruby2.1.2\build\, and ran nmake install ...
0
votes
0answers
38 views

Installing dashing using gem causes make errors ubuntu

ive been trying to install dashing made by shopify. But when ever i install using gem make will allways through up errors Heres the error im geting from the gem install errors
1
vote
1answer
242 views

Issues compiling passenger for apache2 on CentOS

I am trying to install openproject on a CentOS 6.5 (Release 3 from OVH) following this tutorial but with mysql in place of postgresql. I'm nearly done but I can't seem to compile passenger for apache ...
0
votes
0answers
180 views

Can't install pg gem on mac os x Lion

Im using Mac OS X 10.7.4 Trying to install pg gem to work with PostgreSQL. Typing: sudo gem install pg Got This answer: Building native extensions. This could take a while... ERROR: Error ...
0
votes
3answers
2k views

Can't run compass after install

This is a beginner mistake I am sure as I am new to terminal etc. I am trying to get compass working on my mac, I have already installed sass and got it working but when I try to install compass even ...
2
votes
0answers
231 views

How do I install sass on centos 5.9 with ruby 1.8.7?

I have CentOS 5.9 on an x86_64. I've installed ruby 1.8.7. Whenever I try to install sass I get an Error saying sass requires Ruby version >= 1.8.7. but that's what I have installed. This is the ...
0
votes
1answer
468 views

Redmine installation - Ruby MySQL connector issue

I am trying to migrate from TRAC to Redmine, though i encountered a problem with the installation procedure. i follow the install guide at : ...
0
votes
2answers
57 views

How to install vimtrainer?

I'm trying to install vimtrainer. First I did: $ svn co https://vimtrainer.svn.sourceforge.net/svnroot/vimtrainer/trunk vimtrainer $ cd vimtrainer Then made sure ruby, rubygems, rake and vim with ...
5
votes
4answers
6k views

Errors when installing Ruby to Mac OSX Lion via RVM

I was trying to install the newest version of Ruby via RVM, after I upgraded my Mac to Lion and installed the new Xcode 4.1 from the App store. I get this error in the log: [2011-07-20 16:57:15] ...
0
votes
1answer
928 views

How to install Ruby on RHEL 5.3

I am trying to install the latest Ruby on RHEL 5.3 with the following: [root@anjanb logs]# yum install ruby-full Repository engineering-update is listed more than once in the configuration Repository ...
1
vote
2answers
588 views

ImageMagick requirement for Paperclip plugin

The Ruby on Rails paperclip plugin says that I need to install ImageMagick in order to use Paperclip. I'm typically really bad at getting things installed and running, so I was wondering if anyone ...
0
votes
1answer
654 views

Install ruby-debug-ide on Snow Leopard running Ruby 1.9.2

I am trying to install ruby-debug-ide on Snow Leopard running Ruby 1.9 so that I can debug ruby code in Netbeans. I am using the following command sudo gem install ruby-debug-ide19 However I keep ...
1
vote
3answers
585 views

Installing Ruby 1.9 on OS X 10.6

I'm attempting to install the latest stable version of Ruby (1.9.2) on OS X 10.6.4. The installation was successful, but the 'ruby' command is still erroneously referencing the previous ...
1
vote
1answer
312 views

Installing ruby 1.9.1 on OS X with RVM, getting error I can't make sense of

I'm trying to update my ruby install on Leopard to at least 1.9.1. I found a tutorial that tells me how to do it with RVM and I get as far as downloading, configuring and compiling the version I want, ...
2
votes
1answer
574 views

Installing ruby from source and having a problem with gcc

I am trying to follow this guide Compiling Ruby, RubyGems, and Rails on Snow Leopard and I am running into a configuration issue. After downloading and extracting the source, I am running a command ...