1
vote
2answers
2k views

RVM is not a function, selecting rubies with 'rvm use …' will not work

I am trying to install Discourse as explained here but the command # Use installed ruby as default rvm use 2.0.0 --default results in this: discourse@ubuntu:~$ rvm use 2.0.0 --default RVM is ...
0
votes
3answers
258 views

How to install rvm as user jenkins?

I am following these steps to setup a Jenkins server on an Ubuntu EC2 instance. Everything is fine until I get to this step: As you can see (at the end of the output) I am being asked for the ...
0
votes
0answers
122 views

Problems installing ruby-gem pg

I'm trying to install pg through gem, but I have problems doing so. Others seem to have similar issues but none of what I found on the internet helps in my case. Here is what's happening. I try to ...
0
votes
1answer
67 views

OSX 10.8.4 RVM install troubles with Network Users

I'm trying to install ruby 1.9 as the system default for all users of our mac machines. I've installed RVM using a "local" user account and everything seems to be working fine. I'm able to run the ...
1
vote
2answers
589 views

Installing Vagrant alongside RVM isntalled Ruby

How do I install vagrant alongside a specific version of ruby installed using RVM? I have both 1.8.7 and 1.9.3p429 installed. After using RVM to set my default to 1.9.3 I no longer have vagrant ...
0
votes
1answer
57 views

Ruby and RVM: Unexpected version number

I am using osx 10.8.4 and has brew installed. I followed the ruby/rvm installation instruction here: http://octopress.org/docs/setup/rvm/ rvm install 1.9.3 rvm use 1.9.3 rvm rubygems latest It ran ...
0
votes
1answer
556 views

How I get rvm to work properly with gnome-terminal?

How do you get rvm to play properly with gnome-terminal? wim@wim-desktop:~$ rvm list rvm rubies =* ruby-1.9.3-p392 [ x86_64 ] ruby-2.0.0-p0 [ x86_64 ] # => - current # =* - current ...
1
vote
0answers
295 views

Remove all Ruby from Ubuntu

I'm trying to start a new project with RadiantCMS, but I'm having lots of problems , because in the server are 2 different Ruby Installations. the First one , was installed following the next tut: ...
0
votes
1answer
114 views

How to setup a shared hosting server for Ruby on Rails from scratch?

I need to setup a shared hosting server especially for hosting RoR applications. What is the best way to achieve this? Currently I am hosting a LAMP shared hosting server. I have some scripts with ...
7
votes
2answers
8k views

How can I fix a Broken Pipe error?

I recently reinstalled RVM (following the instructions at http://rvm.io) after a fresh install of Ubuntu 12.10 when I got an SSD Drive. Now, when I type: type rvm | head -1 I receive the following ...
1
vote
2answers
627 views

How do I run a rake task in cron under a different user?

I'm trying to run a backup script on ubuntu. My problem is that I'm trying to do this using the postgres user account that I setup on ubuntu. I believe having this account run the cron jobs is best ...
0
votes
1answer
400 views

gem install won't do anything - Mountain Lion

I just got a recent installation of Mountain Lion. I installed homebrew and the gcc on dupes to compile proper rubies. Now, with new versions of ruby (1.9.2) I can create and install gemsets and gems. ...
1
vote
2answers
681 views

Issues Installing jRuby with RVM

I'm running into an issue installing jRuby 1.7.0 with RVM on my Ubuntu 12.04.1 system. It seems RVM is messing up my $PATH because it's unable to find commands that are already installed on my system. ...
3
votes
1answer
2k views

How to rebuild all my Ruby gems?

I ran into an apparently known issue with the native C compiler on OS X 10.8 not building Ruby gems correctly, so I installed GCC as suggested. How do I have rvm rebuild all of the already-installed ...
2
votes
0answers
153 views

Why does RVM Ruby require libksba?

The rvm requirements says I should install "libksba" before installing Ruby 1.9.3. Why? How can I tell if I already have "libksba" installed? I'm running Mountain Lion 10.8.2 and Xcode 4.5 ...
1
vote
2answers
206 views

Combined sudo su deploy command doesn't work, does when separate

I have this command: ubuntu@ip-10:~$ sudo su deploy -c 'rvm install 1.9.3' bash: rvm: command not found I also tried: ubuntu@ip-10:~$ sudo su deploy -c 'source /home/deploy/.bashrc && rvm ...
2
votes
1answer
393 views

rvm problems syntax error near unexpected token `fi'

Whenever I cd or use rvm commands this shows up: -bash: /usr/local/rvm/scripts/initialize: line 80: syntax error near unexpected token `fi' -bash: /usr/local/rvm/scripts/initialize: line 80: ` ...
0
votes
2answers
353 views

launchctl - use rvm instead of system Ruby in executed scripts?

I have a launchctl job I define as such: <key>ProgramArguments</key> <array> <string>/bin/sh</string> <string>-c</string> ...
0
votes
1answer
471 views

“Permission denied” when trying to use RVM with Cron

I am trying to employ the method descibed here. My crontab: # m h dom mon dow command @reboot /home/qe2user/.rvm/environments/ruby-1.9.3-p125 /home/qe2user/Ruby/test/prog.rb > ...
1
vote
1answer
3k views

How to run bash script from windows using plink on linux

I'm trying to run a simple bat file from windows that will run a bash script on linux machine. The bash script is located on the linux machine. For example: I'm trying to run this bat file from ...
0
votes
1answer
943 views

How to get Ruby, when called from a shell script, to see RVM default Ruby

my ruby prog: #echoHW.rb while 1 < 2 sleep(10) puts "hey!" end the bash(?) script that calls it: #echoHW.sh ruby -v ruby echoHW.rb "$@" & I installed rvm, trying both "single user" ...
0
votes
1answer
1k views

Using rvm within a bash script on CentOS 6.2

I'm trying to write a script that does goes through all the steps for installing and setting up a graylog2 server and web interface on CentOS 6.2. Here is the section that I'm having trouble with: ...
1
vote
1answer
1k views

libxslt is missing installing Nokogiri with RVM

It's been one month I'm trying to install the Nokogiri gem on Fedora 16 to run a friend's Rails project. I installed Ruby with RVM. Using gem install nokogiri returns libxslt is missing. please ...
0
votes
1answer
503 views

Problems installing Ruby 1.9.2 and rvm on Debian Lenny

I have currently have Ruby 1.9.1 (bad) and want to install 1.9.3 under rvm. However, rvm requirements gives a long list, most of which installed fine: install build-essential openssl libreadline6 ...
0
votes
1answer
642 views

Problems installing ruby 1.9.3 on Snow Leopard

I am trying to install ruby 1.9.3 (I am running xCode 4.2) with the following command: rvm install 1.9.3 --with-gcc=clang Fetching yaml-0.1.4.tar.gz to /Users/myusername/.rvm/archives Extracting ...
0
votes
3answers
7k views

Why am I getting “rvm: command not found” on Ubuntu?

I am trying to set up Siri Proxy, and I come up to the steps: rvmsudo rvm install 1.9.3 rvm use 1.9.3 --default rvmsudo gem install eventmachine CFPropertyList httparty json uuidtools But I can't ...
4
votes
2answers
3k views

Why can't I set the default Ruby version in Ubuntu?

I'm trying to set my Ruby version to be 1.9.2, but I can't change it from the system Ruby installation. What am I doing wrong? My terminal output is: $ rvm list rvm rubies => ruby-1.9.2-p180 [ ...
2
votes
1answer
268 views

Can't find sqlite3 in this ruby/rails version using rvm

I installed rvm and am using 1.9.2 with rails 3.05. I was able to create a new application but once I moved into the directory and tried to start the server ("rails s"), I got this error message ...
2
votes
1answer
857 views

How to create a GEM_HOME for rvm?

I'm learning how to set up different versions of ruby with different versions of rails using rvm. Here's a link for the instructions http://beginrescueend.com/gemsets/basics/. It says Let's say, ...
1
vote
1answer
492 views

“Git: command not found” error while installing RVM on OS X

Working from my command line on Mac OS X Snow Leopard in directory /Users/michael, I did the installation line recommended by the RVM site: bash < <(curl -s ...
0
votes
1answer
535 views

Redcar Install through RVM

I am trying to install Redcar on Ubuntu using RVM. I have read countless articles about it and i still get this error message. I followed this article in particular. ...
1
vote
1answer
1k views

rvm doesnt work when specifiying the path…?

when typing in the path to the rvm it doesnt work $which rvm /usr/local/bin/rvm $ruby -v ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux] $/usr/local/bin/rvm use 1.8.7 Using ...
0
votes
3answers
4k views

How to install Ruby 1.9.2 and Rails 3 on Ubuntu 10.10?

I have gone through a lot of blogs and tutorials (including Beginning Rails 3) and now I have a messed up Ubuntu (It runs on VMWare) that I do not like it. Main problem is that based on Beginning ...
1
vote
1answer
311 views

Installing ruby 1.9.1 on OS X with RVM, getting error I can't make sense of

I'm trying to update my ruby install on Leopard to at least 1.9.1. I found a tutorial that tells me how to do it with RVM and I get as far as downloading, configuring and compiling the version I want, ...