0
votes
0answers
54 views

gitlab-ci Ruby problems

I'm using Ubuntu 14.04 server x64, and I'm trying to set up gitlab-ci via these instructions https://gitlab.com/gitlab-org/gitlab-ci/blob/master/doc/install/installation.md After these steps I get an ...
2
votes
1answer
125 views

Redmine install on Apache2/Ubuntu 12.04 EC2 instance

Can someone point me to a guide or guides that explain how to get Redmine running on Ubuntu 12.04? From installing Ruby to setting up Passenger? I've tried a handful of times and have never been ...
1
vote
2answers
2k views

RVM is not a function, selecting rubies with 'rvm use …' will not work

I am trying to install Discourse as explained here but the command # Use installed ruby as default rvm use 2.0.0 --default results in this: discourse@ubuntu:~$ rvm use 2.0.0 --default RVM is ...
0
votes
0answers
32 views

After Reinstall of Rails, Cannot Run `rails server`

On my main dev computer, I had had ruby installed from a ppa. I decided to reinstall it with rvm for consistency between computers. To uninstall my current environment, I ran sudo apt-get remove ...
0
votes
1answer
69 views

Why does apt-get dist-upgrade change /usr/bin/ruby to /etc/alternatives/ruby?

When I run an apt-get update, apt-get dist-upgrade, the location of /usr/bin/ruby changes from /usr/local/bin/ruby to /etc/alternatives/ruby. This ends up breaking several cron jobs until I remember ...
3
votes
3answers
3k views

~/.profile is not loaded when using SSH (Ubuntu)

Edited to reflect the problem I really wanted to solve: I need to set up my ruby environment so I can deploy via Capistrano. export PATH=$HOME/.rbenv/bin:$PATH eval "$(rbenv init -)" I put these ...
1
vote
2answers
681 views

Issues Installing jRuby with RVM

I'm running into an issue installing jRuby 1.7.0 with RVM on my Ubuntu 12.04.1 system. It seems RVM is messing up my $PATH because it's unable to find commands that are already installed on my system. ...
14
votes
2answers
605 views

Sending mail from the command line

Ok, I've looked far and wide for something to take care of this little email project I have. First, some background: My family has a secret santa every year and I've offered to write a script to ...
1
vote
2answers
206 views

Combined sudo su deploy command doesn't work, does when separate

I have this command: ubuntu@ip-10:~$ sudo su deploy -c 'rvm install 1.9.3' bash: rvm: command not found I also tried: ubuntu@ip-10:~$ sudo su deploy -c 'source /home/deploy/.bashrc && rvm ...
0
votes
3answers
7k views

Why am I getting “rvm: command not found” on Ubuntu?

I am trying to set up Siri Proxy, and I come up to the steps: rvmsudo rvm install 1.9.3 rvm use 1.9.3 --default rvmsudo gem install eventmachine CFPropertyList httparty json uuidtools But I can't ...
4
votes
2answers
3k views

Why can't I set the default Ruby version in Ubuntu?

I'm trying to set my Ruby version to be 1.9.2, but I can't change it from the system Ruby installation. What am I doing wrong? My terminal output is: $ rvm list rvm rubies => ruby-1.9.2-p180 [ ...
2
votes
2answers
986 views

Ubuntu - Ruby Daemon script creates two processes - sh and ruby - PID file points at sh, not ruby

The PID file for a ruby process I have running as a daemon is getting the wrong PID. It appears that running /etc/init.d/sinatra start creates two processes - sh and ruby, and the PID that ends up in ...
1
vote
2answers
3k views

Ruby/gem installation paths scattered all over, cause?

can you help me understand my ruby folder structure? I don't understand why my gems are scattered all over and why they aren't recognised commands. I'll explain how my installation looks like first: ...
0
votes
3answers
4k views

How to install Ruby 1.9.2 and Rails 3 on Ubuntu 10.10?

I have gone through a lot of blogs and tutorials (including Beginning Rails 3) and now I have a messed up Ubuntu (It runs on VMWare) that I do not like it. Main problem is that based on Beginning ...
0
votes
4answers
934 views

Changing Ruby versions in Ubuntu 10.10

I've just installed Ruby 1.9.1 in my Ubuntu 10.10. When I give the command ruby -v in terminal, I'm getting "ruby 1.8.7 (2010-06-23 patchlevel 299) [i686-linux]". I think the older version of Ruby is ...
6
votes
3answers
2k views

Ruby shell instead of Bash shell in Ubuntu?

It seems to me that Ruby is far more powerful, and you can also do more powerful scripting with it. Are there any open source implementations out there that could replace Bash with Ruby on Ubuntu, so ...
7
votes
2answers
815 views

Install packages through apt-get or gem?

If a package is available both through apt-get and gem, which one should I choose? I'm on Ubuntu and I don't know if I should install rake through apt-get or gem. I use both apt-get and gem packages ...
2
votes
5answers
645 views

Ubuntu desktop through pen drive for rails development

I am window user and .net web developer. I am trying hands in ruby and "ruby on rails". Everybody suggests me to use OSx or Linux. Can i install Ubuntu on "pen drive" and use as development machine ...