Ruby is a dynamic, open source programming language with a focus on simplicity and productivity.

learn more… | top users | synonyms

1
vote
2answers
570 views

How to add a linux environment variable for different language (PHP or RUBY)

I would like to add a linux environment variable for my differents applications written in PHP and Ruby. Its goal is to differntiate between 'production' and 'development' linux environment. How to ...
2
votes
1answer
390 views

Can I install some ruby gem on a standard OS X user?

I have a Admin user for serious stuff and a Standard user for daily tasks, including front-end development. On the Admin user, I can install Brew, RVM, Middleman etc. But on the Stardard user, where I ...
3
votes
1answer
4k views

How do I use Sublime Text as the OS editor in Mac OS X?

How do I set Sublime Text as the editor for git commits in Mac OS X? In my .zshrc I have: export EDITOR='subl -w' But, if I do: bundle open devise I get the error: Could not run 'subl -w ...
1
vote
2answers
974 views

Installing Vagrant alongside RVM isntalled Ruby

How do I install vagrant alongside a specific version of ruby installed using RVM? I have both 1.8.7 and 1.9.3p429 installed. After using RVM to set my default to 1.9.3 I no longer have vagrant ...
0
votes
2answers
1k views

Why do I get a permission error installing Ruby 1.9.3 with RVM?

I need to install a newer version of Ruby than 1.8.7. I already managed to install Homebrew and RVM, but this is what happens when I try to install Ruby. aldaman:~ Alex$ rvm install 1.9.3 mkdir: ...
0
votes
1answer
73 views

Ruby and RVM: Unexpected version number

I am using osx 10.8.4 and has brew installed. I followed the ruby/rvm installation instruction here: http://octopress.org/docs/setup/rvm/ rvm install 1.9.3 rvm use 1.9.3 rvm rubygems latest It ran ...
1
vote
0answers
49 views

Is Textmate like Ruby Markers “#=>” in notepad++ available?

I use Notepad++ to write Ruby code. Now sometimes to test some Ruby features I used to go IRB to see how that works. Can I get the same flavor in Notepad++ itself,like Textmate editor as below? x = ...
1
vote
0answers
244 views

Use Ruby with no-root user in Gentoo

I am just started to update my Gitlab on Gentoo server (4.2 > 5.0). For new version Gitlab need to use Ruby with user 'git'. # check ruby version for git user ( 1.9 required!! ) # gitlab shell ...
1
vote
0answers
272 views

How do I run WEBrick as an upstart job?

I need to get WEBrick (basically a Rails web server) to work using upstart, but cannot figure out what should I write in script. The following gives me an error: chdir /rails-app exec su -s /bin/sh ...
1
vote
1answer
114 views

Define extra `$PATH` for either Passenger or nginx

I have a server with nginx and Passenger serving a Ruby on Rails app. It uses Bundler. Somewhere in this stack, the $PATH gets set to /var/www/APPNAME/shared/bundle/ruby/1.8/bin/. This directory ...
1
vote
1answer
423 views

Can't run 'rails' inside Tmux session in Terminal

I just tried rails inside a tmux session in iTerm2 and it returns as -bash: /usr/bin/rails: /usr/bin/ruby: bad interpreter: No such file or directory I can run rails outside of tmux . I am using ...
1
vote
1answer
1k views

Forward port from guest to host

How can I forward port from Guest (OS on virtual box) to Host (my actual machine)? Guest - Windows 7 Host - Ubuntu 12.10 On my host, I run a web-server on port 3000. I want to be able to open a ...
1
vote
2answers
957 views

when trying to install the watir or watir-webdriver gem on Windows 7 via cygwin, getting long C stack trace with mentions of “W32 socket” issues

When running: $ gem install watir on Windows 7 (cygwin), I get this ERROR: Error installing watir: ERROR: Failed to build gem native extension. /usr/bin/ruby.exe extconf.rb checking for ffi.h... ...
0
votes
1answer
223 views

Uninstalled Ruby.Frameworks on Mac OS X 10.8

In an attempt to create a clean Ruby slate for myself, I uninstalled RVM, rbenv (yeah, I had both installed, whoops), Gem, Bundler, and the pre-installed version of Ruby. I didn't realize the chaos ...
0
votes
3answers
3k views

How can I run a Ruby project found on Github?

I want to run a project from github. Here is the link. I used following command to download the project and it done successfully. $ git clone git://github.com/cheeyeo/Amazon-SNS-Ruby.git But I ...
0
votes
1answer
980 views

How I get rvm to work properly with gnome-terminal?

How do you get rvm to play properly with gnome-terminal? wim@wim-desktop:~$ rvm list rvm rubies =* ruby-1.9.3-p392 [ x86_64 ] ruby-2.0.0-p0 [ x86_64 ] # => - current # =* - current ...
-1
votes
1answer
64 views

Do not know what program to open a Sublime 2 file with

I have a Windows and I'm using Ruby 1.9.1-p429, and it won't allow me to view my test.rb file on cmd when i type cd. I'll go through step-by-step of what I did. I saved a test .rb file on Sublime to ...
0
votes
0answers
370 views

Name of Rake task in ps output?

pid = `ps -ef | grep -v grep | grep rake | awk '{print $2}'` This is a bunch of ruby code that executes piped linux commands. While I usually just use ps aux, just because, I noticed that the rake ...
0
votes
1answer
132 views

last object returned in chrome dev tools / python / irb /

In matlab one could type in the following and get the following reply: matlab> 1+1 ans = 2 One could then all the last returned object by simply typing: matlab> ans ans = 2 That is, ...
1
vote
1answer
552 views

Remove all Ruby from Ubuntu

I’m trying to start a new project with RadiantCMS, but I’m having lots of problems, because in the server are 2 different Ruby installations. The first one, was installed following this tutorial and ...
2
votes
1answer
161 views

Installing ruby19 with +nosuffix still leaves the suffix

Following the advice found in many places, I tried to install Ruby 1.9 without a suffix using this command: sudo port install ruby19 +nosuffix This still leaves the suffix "1.9" on the binary; ...
3
votes
1answer
699 views

Sudo <any command> throws: Command not found but works without sudo

I'm on a CentOS VPS and using RVM and Capistrano to deploy. for some deployments I need to use sudo, but when I deploy with something like: desc "Restart the application services" task :restart, ...
8
votes
4answers
11k views

~/.profile is not loaded when using SSH (Ubuntu)

Edited to reflect the problem I really wanted to solve: I need to set up my ruby environment so I can deploy via Capistrano. export PATH=$HOME/.rbenv/bin:$PATH eval "$(rbenv init -)" I put these ...
0
votes
1answer
215 views

Fix bash_profile to Develop Ruby on Rails Apps

I just installed Ruby and Rails stuff on my machine, and start to learn. But every time I close the Terminal and re-open it, I have to re-type the command . ~/.bash_profile in order to run Rails ...
2
votes
3answers
18k views

Why does the command window always disappear right away on Windows 7?

I hope I am missing something blindingly obvious here, but I can't get things I run from the command window to stay open. That is, 1. I open a new command prompt (windows key + r) + "cmd" 2. I try ...
11
votes
3answers
1k views

Installing Homebrew packages without linking

I'd like to install several versions of Ruby (or really any Homebrew package) without linking any of them. Basically, I'd like to treat any formula as keg-only. I can't seem to find a way to do this, ...
3
votes
0answers
440 views

How do I install sass on centos 5.9 with ruby 1.8.7?

I have CentOS 5.9 on an x86_64. I've installed ruby 1.8.7. Whenever I try to install sass I get an Error saying sass requires Ruby version >= 1.8.7. but that's what I have installed. This is the ...
1
vote
0answers
452 views

No Ruby icon on '.rb' files after Ruby installation with RailsInstaller on Win XP. How to associate?

At first time I installed Ruby using RubyInstaller for Windows. And in the process of installation there was a checkbox whether I want to have .rb files to be Ruby files. If I agree all the .rb files ...
2
votes
1answer
324 views

How to make Notepad++ autocomplete with “end” word in Ruby?

Is it possible to set the Notepad++ that it would automaticly put end after I print class instruction: class MyClass // right after I print the first whitespace after 'class' instruction... end // ...
2
votes
1answer
666 views

Single GUI Application raspberrypi

So I want to develop a software that will take over my raspberry pi computer, or just for simplicity's sake, any computer running a lightweight linux OS, to serve a single function. Run a Ruby/Java or ...
13
votes
3answers
32k views

How can I fix a Broken Pipe error?

I recently reinstalled RVM (following the instructions at http://rvm.io) after a fresh install of Ubuntu 12.10 when I got an SSD Drive. Now, when I type: type rvm | head -1 I receive the following ...
13
votes
3answers
11k views

I need a simple way to backup files to Amazon glacier from the command line?

I have a CentOS server online with a directory of cPmove files I need to back up to Amazon Glacier. I only have command line access, no GUI. I need a command line client that is relatively easy to ...
1
vote
2answers
1k views

I deleted Ruby.Framework how can I get it back? [duplicate]

Possible Duplicate: Is it possible to reinstall/fix Mac OS X’s system ruby without doing a complete OS reinstall? As the title says, I deleted Ruby.Framework how can I get it back? I don't ...
1
vote
1answer
4k views

How to set up a NAT and and a Host Only adapter using Vagrant?

I am trying to make a NAT connection (for yum downloads) and a Host-Only connection (for talking with host) at the same time on my CentOS box when using Vagrant. I CAN do it by SSHing and checking ...
0
votes
1answer
326 views

Autotest can't find growl? (Ruby 1.9.3, Rails 3.2.11)

Haven't seen any other errors like this. Autotest is complaining it can't find Growl even though it's installed. Tried uninstalling/reinstalling everything with sudo. Everything is up-to-date. This is ...
0
votes
1answer
53 views

How to install Pocket Island Open Source Application?

I have no idea with Ruby Language. I just want to install and try Pocket Island Open Source. git://github.com/wooga/Pocket-Island.git What are the requirement and how to run it? I'm using Ubuntu ...
4
votes
1answer
895 views

How to backup ruby gems?

How do you backup ruby gems? I am re-installing the Operating System so I would like to know how to back up ruby gems so that I can re-install it when I have installed the Operating System? Is it ...
1
vote
2answers
1k views

How do I run a rake task in cron under a different user?

I'm trying to run a backup script on ubuntu. My problem is that I'm trying to do this using the postgres user account that I setup on ubuntu. I believe having this account run the cron jobs is best ...
0
votes
1answer
677 views

gem install won't do anything - Mountain Lion

I just got a recent installation of Mountain Lion. I installed homebrew and the gcc on dupes to compile proper rubies. Now, with new versions of ruby (1.9.2) I can create and install gemsets and gems. ...
0
votes
1answer
34 views

rails didnt install correclty, specificly the uninstaller

ive just installed rails using railsinstaller.org for osx, rails and ruby seem to be working ok (checked by running rails -v, ruby --version and ruby --help). But when it installed i got an error ...
2
votes
1answer
759 views

How do I ensure a process is running, even if it kills itself? (it needs to be restarted then)

I'm using linux. I want a process (an irc bot) to run every time I start the computer. But I've got a problem: The network is bad and it disconnects often, so I need to manually restart the bot a few ...
1
vote
1answer
75 views

measuring download speed ruby

I cache the query result in a file in the server side. When a new query is submitted the webservice searches to see if it has the answer in one of the cached files. If so, it will send out the file. ...
0
votes
1answer
887 views

Redmine installation - Ruby MySQL connector issue

I am trying to migrate from TRAC to Redmine, though i encountered a problem with the installation procedure. i follow the install guide at : ...
0
votes
2answers
59 views

How to install vimtrainer?

I'm trying to install vimtrainer. First I did: $ svn co https://vimtrainer.svn.sourceforge.net/svnroot/vimtrainer/trunk vimtrainer $ cd vimtrainer Then made sure ruby, rubygems, rake and vim with ...
1
vote
0answers
62 views

No error output for ruby commands

I am currently having the following problem: Some of my ruby/rbenv commands commands (e.g.: bundle exec irb, rbenv rehash) fail when executing. However I don't get any error output: [~]$ bundle ...
1
vote
2answers
961 views

Issues Installing jRuby with RVM

I'm running into an issue installing jRuby 1.7.0 with RVM on my Ubuntu 12.04.1 system. It seems RVM is messing up my $PATH because it's unable to find commands that are already installed on my system. ...
1
vote
0answers
59 views

Mysql InnoDB and quickly applying large updates

Basically my problem is that I have a large table of about 17,000,000 products that I need to apply a bunch of updates to really quickly. The table has 30 columns with the id set as int(10) ...
2
votes
2answers
1k views

Building Vim with rbenv and Command-T on OSX

dyld: lazy symbol binding failed: Symbol not found: _rb_encdb_declare Referenced from: /Users/sa125/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/x86_64-darwin10.8.0/enc/encdb.bundle Expected in: flat ...
2
votes
1answer
646 views

Gem Binaries not found with oh-my-zsh

I'm using Oh-My-Zsh on Mountain Lion and have an issue with gem binaries not loading properly. For instance: If I load a new shell the binary still cannot be found. When using Bundler, I can load ...
6
votes
1answer
4k views

How to rebuild all my Ruby gems?

I ran into an apparently known issue with the native C compiler on OS X 10.8 not building Ruby gems correctly, so I installed GCC as suggested. How do I have rvm rebuild all of the already-installed ...