Ruby is a dynamic, open source programming language with a focus on simplicity and productivity.

learn more… | top users | synonyms

0
votes
1answer
9 views

/usr/bin/env is pointing to wrong ruby version. “No such file or directory”

If I type "rake spec" I get. /usr/bin/env: ruby1.9.1: No such file or directory This problem started happening when I uninstalled ruby 1.9.1 and used rvm to install the latest ruby version but ...
0
votes
1answer
151 views

`require': cannot load such file — mkmf

I ran the following command and got a ``require': cannot load such file -- mkmf ` error message $ sudo gem install sensu-plugin --no-rdoc --no-ri ...
0
votes
0answers
4 views

How to access folders on Ruby

I have Windows PC. I am trying to access a folder I created in Windows explorer called "Ruby". I tried typing this in Ruby "$ cd ruby" but I get an error message " is not allowed as a global variable ...
2
votes
1answer
5k views

How to run bash script from windows using plink on linux

I'm trying to run a simple bat file from windows that will run a bash script on linux machine. The bash script is located on the linux machine. For example: I'm trying to run this bat file from ...
2
votes
3answers
1k views

Bootstrap - Jekyll: Forbidden - no access permission to `/'

I'm doing a tutorial on Twitter Bootstrap and apparently I need to install Jekyll for this. I've followed the installation procedure, but now I'm stuck getting Jekyll to work. In the terminal (Ubuntu ...
0
votes
0answers
29 views

FFMpeg keeps hanging/crashing and causing memory allocation issues on Production RHEL Server

I'm working on adding video conversion to a Ruby on Rails (Ruby 2.1.5 Rails 4.1.5) app that I'm working on. I'm utilizing the Streamio-FFMpeg gem within the app so that I can run the necessary ...
0
votes
0answers
6 views

How to stop control/focus leaving the terminal when I start a GUI application

I have a Ruby script that launches Image viewer (eog) based on certain keyevents from the user. However Focus leaves the terminal(cursor stops blinking) when the first input is given. Until I click ...
1
vote
1answer
4k views

Upgraded to Mavericks, C compiler cannot create executables

Upgrading to Mavericks, I appear to have broken my Ruby on Rails development environment, which requires ruby 1.9.3 because of various gem dependencies. Within that app directory, I'm trying to ...
0
votes
0answers
22 views

How do I run this ruby code? [migrated]

I'm using interactive ruby on windows 8. I'm trying to attach an image to multiple mp3s in a folder and encode them to mp4. How do I specify the folder, and how do I run this code in Ruby ...
18
votes
6answers
27k views

When to use Bash and when to use Perl/Python/Ruby?

We are doing all our scripting with Bash so far, but I'm starting to feel a bit silly about it. While we can of course do everything we want with Bash (it's quite powerful), I'm starting to wonder if ...
-1
votes
0answers
10 views

Start Application on Boot Ubuntu

I am trying to make my application Ruby on Rails (OpenProject) start with the system on boot. When I test the script as root it returns the error: /usr/bin/env:ruby: No such file or directory. My ...
2
votes
1answer
260 views

Redmine install on Apache2/Ubuntu 12.04 EC2 instance

Can someone point me to a guide or guides that explain how to get Redmine running on Ubuntu 12.04? From installing Ruby to setting up Passenger? I've tried a handful of times and have never been ...
0
votes
1answer
75 views

How to run Node.js on Mac after successfully installing it with gem?

On Mac OSX Yosemite I have successfully installed node: # sudo gem install node Fetching: eventmachine-1.0.7.gem (100%) Building native extensions. This could take a while... Successfully installed ...
22
votes
2answers
2k views

Is there a git-like file system?

Git stores content uniquely in its repo based on the calculated hash of any file. If my directory has two copies of the same file somewhere inside it, git will only actually store it once. I am ...
1
vote
1answer
97 views

Fedora 21 - Gem: change EXECUTABLE DIRECTORY

I am using some locally installed gems in my environment and I would like to change the EXECUTABLE DIRECTORY path to ~/.gem/bin How could I achieve this? $gem env - RUBYGEMS VERSION: 2.2.2 - ...
0
votes
1answer
16 views

ruby installation as normal ubuntu user

I am trying to automate ruby installation through script in amazon ec2 ubuntu instance. Through script I can download, configure and make ruby from source but while trying to install ( make install ) ...
1
vote
0answers
52 views

Nginx + Passenger not working — client requests hang until timeout

I'm running on an EC2 instance with Amazon Linux installed and Nginx was installed via passenger-install-nginx-module. The full install process followed was similar to this. The primary difference was ...
0
votes
1answer
163 views

Gem installation failling with “The compiler failed to generate an executable file” on cygwin

Trying to install multiple gems on cygwin, I keep getting this error: /usr/share/ruby/2.2.0/mkmf.rb:456:in try_do': The compiler failed to generate an executable file. (RuntimeError) This error is ...
0
votes
2answers
38 views

ruby gem install to 1.9.1 instead of 1.8

I ran the following lines in linux gem install mysql And it installed the mysql gem to /var/lib/gems/1.8/gems. That's not where I want it. I wnat it at /var/lib/gems/1.9.1/gems. I could just copy ...
0
votes
1answer
43 views

How would I write this VIM command for `sed`?

I have a .csv with special characters that are wrecking an import I need to do. In VIM, I discovered away to remove the special characters with : :%s/\r//g This removes ^M from some of my broken ...
1
vote
1answer
58 views

Pathogen - only some of vim plugins work

So recently I installed Pathogen along with a few plugins like NerdTree, and Solarized and they both work really well. Today I tried to install Ruby indentation plugin ...
0
votes
0answers
45 views

Mumble-Ruby openssl error when running scripts

First things first here are the instructions I am working off and system details: http://wiki.natenom.com/w/Mumble-Ruby_installation and this is for SuperBot a mumble ruby plugin. This is running ...
0
votes
4answers
7k views

Can't run compass after install

This is a beginner mistake I am sure as I am new to terminal etc. I am trying to get compass working on my mac, I have already installed sass and got it working but when I try to install compass even ...
0
votes
1answer
2k views

Metasploit Install Fails. Requires >= Ruby 2.1 but I have 2.2

I’ve literally been trying to install metasploit for 2 days now and I think that's a ridiculous amount of time just to install some software. I have Arch linux and I am trying to install ...
0
votes
1answer
98 views

Snorby with PostgreSQL installation issue in Mac OS X 10.10.2 (Yosemite)

Trying to setup Snorby for Snort with PostgreSQL on Mac OS X 10.10.2 (Yosemite) Snort 2.9.7.2 GRE (Build 177) PostgreSQL 9.4.1 ruby 1.9.3p551 (2014-11-13 revision 48407) [x86_64-darwin14.1.0] ...
0
votes
1answer
213 views

RVM wants me to edit PATH in .bash_profile - I fear it is a mess

I am trying to get an Omega sub-theme running on my local machine (OSX 10.10) with Acquia Desktop Dev. Trying to run isolated ruby in sub-theme directory. When I use rvm list I get: Warning! PATH is ...
1
vote
0answers
32 views

Running ruby script through php as www-data

I am running a php application on an apache server. From the php application I need to run a ruby script on the command line. I have verified that running the script directly from a terminal as user, ...
1
vote
0answers
30 views

Will creating a restore point save my Ruby installation

I am running Ruby and Rails on a Win 8.1 PC, and want to know whether creating a Restore Point via System Properties will allow me to go back to my original Ruby version if I was to install a newer ...
0
votes
0answers
194 views

Problems installing Metasploit Mac OS X 10.10: Claims wrong Ruby version is installed

I am trying to install Metasploit on Mac OS X 10.10 (Yosemite), but it doesn’t work because it says I have the wrong version of Ruby. Gem::InstallError: metasploit-concern requires Ruby version >= ...
7
votes
3answers
1k views

Installing Homebrew packages without linking

I'd like to install several versions of Ruby (or really any Homebrew package) without linking any of them. Basically, I'd like to treat any formula as keg-only. I can't seem to find a way to do this, ...
0
votes
0answers
90 views

Sequel::AdapterNotFound: LoadError: cannot load such file — java

I have installed jruby-1.7.16 using rvm and having java open jdk version 1.7.0_75. bundle install gets success below are the errors when I run the bundle exec rake db:migrate --trace ...
2
votes
0answers
87 views

Jekyll installation successful but command not found

I am trying to install Jekyll following http://jekyllrb.com/docs/installation/ ○ → sudo gem install jekyll Password: Fetching: jekyll-2.5.3.gem (100%) Successfully installed jekyll-2.5.3 Parsing ...
5
votes
4answers
7k views

~/.profile is not loaded when using SSH (Ubuntu)

Edited to reflect the problem I really wanted to solve: I need to set up my ruby environment so I can deploy via Capistrano. export PATH=$HOME/.rbenv/bin:$PATH eval "$(rbenv init -)" I put these ...
0
votes
2answers
11 views

Gem install to a specific version of ruby

I have ruby 1.8 and ruby 1.9.1 on my ubuntu operating system. When I do a gem install php_http_build_query, it installs the gem to ruby 1.8. How do I get it to install it to ruby 1.9.1?
2
votes
3answers
3k views

How install gem rails for all users in arch-linux

When install rails with sudo gem install rails or with root user, this install in $HOME/.gem and only works for actual user, how install for all users in the system ?
0
votes
1answer
37 views

Installing TaskJuggler results in timeout

I'm trying to install TaskJuggler. As far as I can tell, I have successfully installed Ruby and Gem. The command I'm trying to execute and the error message is: C:\...>gem install ...
2
votes
2answers
214 views

Windows 7 CLI not recognizing commands without specifying extension

I've apparently gone and mucked up my system in a strange way. Windows 7's cmd prompt is no longer recognizing any executable or batch files unless I explicitly type their extension. ...
0
votes
0answers
66 views

Permission denied error everytime I try to use npm in terminal

This occurs anytime I use npm in terminal and cannot seem to figure out where it is coming from" -bash: /usr/local/bin/rbenv: /usr/bin/env: bad interpreter: Permission denied
4
votes
3answers
2k views

Can't vagrant install a plugin: gem dependency fails despite being installed

I am attempting to install the vagrant-vbguest plugin in Windows 7 from within cygwin 64. $ vagrant plugin install vagrant-vbguest Installing the 'vagrant-vbguest' plugin. This can take a few ...
0
votes
0answers
125 views

How to avoid gem update error in windows?

Showing below error C:\Ruby21>gem update Updating installed gems ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError) SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: ...
5
votes
2answers
250 views

How can I get Syntastic to recognize newer Ruby syntax?

I'm using Syntastic in Vim, and it highlights newer Ruby syntax as errors. For example, if I use required keyword arguments (introduced in Ruby 2.1), like this: def distance(from:, to:) # whatever ...
3
votes
1answer
18k views

How to completely remove Ruby, Ruby gems on Mac OS X 10.6.4

Most rubyists might be shocked when they'll read this, but I'd like to know if it's possible to completely remove the Ruby framework as well as all the tools and gems that ship with Mac OS X 10.6.4. ...
0
votes
0answers
60 views

How to start an external process in a ruby windows service?

I use this as a template to start an external task from a service LOG_FILE = 'C:\\Tmp\\win32_daemon_test.log' begin require 'rubygems' require 'win32/daemon' include Win32 class DemoDaemon ...
2
votes
1answer
97 views

How can I upgrade the Ruby version on Passenger?

How can I uprgade the Ruby version installed on my passenger module for Apache? I on Debian 7 and it's running Ruby 1.9.1 but I want 2.2.0
0
votes
0answers
111 views

Error loading gem hipchat in ruby

I can confirm that the gem is installed vagrant@vagrant-ubuntu-trusty-64:~$ /opt/sensu/embedded/bin/gem list| grep hipchat hipchat (1.4.0) I have verified that EMBEDDED_RUBY is already set $ cat ...
1
vote
1answer
37 views

Ruby Compile error Windows 7 x64

Getting this error when using nmake on Windows7 x64 to compile Ruby 2.2.0 I've never done this before, so I have been following this and this advice: generating ripper-x64-mswin64_100.def NMAKE : ...
1
vote
1answer
124 views

What to do when “apt-get update” gets stuck in 100%?

I'm setupping a VirtualBox VM to do my development work with Ruby on Rails. My problem is that apt-get update is taking very long, ~30 minutes instead of seconds. I can install things with apt-get ...
0
votes
0answers
30 views

How can I install a hipchat gem?

This is the command and the output $ sudo gem install hipchat Password: ERROR: While executing gem ... ...
0
votes
0answers
108 views

How to indent multiline ruby method chaining code like this in emacs?

I wish to have such indentation: some_object.method_1(args) .method_2(args) .method_3(args) While by default ruby-mode will indent the code like: some_object.method_1(args) ...
2
votes
2answers
13k views

Why am I getting “rvm: command not found” on Ubuntu?

I am trying to set up Siri Proxy, and I come up to the steps: rvmsudo rvm install 1.9.3 rvm use 1.9.3 --default rvmsudo gem install eventmachine CFPropertyList httparty json uuidtools But I can't ...