Developed by Wayne E. Seguin, RVM is based on the idea that you can easily install, manage, and work with multiple Ruby environments from interpreters to sets of gems.

learn more… | top users | synonyms

0
votes
1answer
143 views

Getting fcron and RVM work together

I'm trying to make RVM and fcron work together. Apparently fcron does not read directly or indirectly any sort of env variables. Which makes RVM futile and scripts fail. I have this script which ...
3
votes
2answers
353 views

How do I keep background jobs from telling me they're done

In RVM (Ruby Version Manager) you can create .rvmrc files for a per-project basis. This handles basic ruby version and library (gem) management. This script is automatically executed when you cd into ...
0
votes
3answers
6k views

Why am I getting “rvm: command not found” on Ubuntu?

I am trying to set up Siri Proxy, and I come up to the steps: rvmsudo rvm install 1.9.3 rvm use 1.9.3 --default rvmsudo gem install eventmachine CFPropertyList httparty json uuidtools But I can't ...
4
votes
2answers
3k views

Why can't I set the default Ruby version in Ubuntu?

I'm trying to set my Ruby version to be 1.9.2, but I can't change it from the system Ruby installation. What am I doing wrong? My terminal output is: $ rvm list rvm rubies => ruby-1.9.2-p180 [ ...
0
votes
5answers
196 views

Bash: Switching from user to root causes issues with prompt

I am on a Mac, running Snow Leopard (if it matters). I am customizing my bash prompt to display things that get pulled from user specific places. For example, I am using Ruby Version Manager to manage ...
1
vote
2answers
405 views

Getting errors trying to install RVM on Mac OS X

What else can I try? user15:~ durrantm$ bash < <(curl -s https://rvm.beginrescueend.com/install/rvm) user15:~ durrantm$ cat .bash_profile [[ -s "$HOME/.rvm/scripts/rvm" ]] && . ...
2
votes
1answer
259 views

Can't find sqlite3 in this ruby/rails version using rvm

I installed rvm and am using 1.9.2 with rails 3.05. I was able to create a new application but once I moved into the directory and tried to start the server ("rails s"), I got this error message ...
2
votes
1answer
786 views

How to create a GEM_HOME for rvm?

I'm learning how to set up different versions of ruby with different versions of rails using rvm. Here's a link for the instructions http://beginrescueend.com/gemsets/basics/. It says Let's say, ...
1
vote
1answer
489 views

“Git: command not found” error while installing RVM on OS X

Working from my command line on Mac OS X Snow Leopard in directory /Users/michael, I did the installation line recommended by the RVM site: bash < <(curl -s ...
0
votes
1answer
520 views

Redcar Install through RVM

I am trying to install Redcar on Ubuntu using RVM. I have read countless articles about it and i still get this error message. I followed this article in particular. ...
1
vote
0answers
314 views

Issues with RVM and new terminal instances

So I started having issues with my terminal sessions for some reason that I'm not fully aware of how to fix. This is the terminal output that I get when I start up any new session now. RVM doesn't ...
3
votes
1answer
908 views

How do you run a shell command/script automatically when entering/cd-ing a directory on Snow Leopard?

Apologies if the answer to this is obvious, but I haven't been able to find one yet (perhaps because I'm searching with the incorrect terminology). I am on a Mac running Snow Leopard and I would like ...
1
vote
1answer
1k views

rvm doesnt work when specifiying the path…?

when typing in the path to the rvm it doesnt work $which rvm /usr/local/bin/rvm $ruby -v ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux] $/usr/local/bin/rvm use 1.8.7 Using ...
0
votes
3answers
4k views

How to install Ruby 1.9.2 and Rails 3 on Ubuntu 10.10?

I have gone through a lot of blogs and tutorials (including Beginning Rails 3) and now I have a messed up Ubuntu (It runs on VMWare) that I do not like it. Main problem is that based on Beginning ...
1
vote
1answer
307 views

Installing ruby 1.9.1 on OS X with RVM, getting error I can't make sense of

I'm trying to update my ruby install on Leopard to at least 1.9.1. I found a tutorial that tells me how to do it with RVM and I get as far as downloading, configuring and compiling the version I want, ...