The tag has no usage guidance.

learn more… | top users | synonyms

0
votes
1answer
968 views

wvdial, ppp0 and setting default route (automatically)

I am setting up a 3G connection to be monitored by supervisord using wvdial on a headless machine (raspberryPi/raspbian) which I can only access via the 3G connection once it's live. In short, ...
0
votes
0answers
77 views

Problems using Raspberry Pi to connect to VisionTek external modem

I am using Raspberry Pi to connect to a VisionTek external modem, using WvDial as an application program to dial. I am able to run "AT" commands through another application program, but if I try to ...
0
votes
1answer
516 views

wvdial can't retrieve modem response, terminal programs communicate without problems

I'm trying to make a GPRS connection with a SIM800L and a PL2303 USB-Serial cable. If I screen or minicom the modem (at 115200 8N1) I get an immediate response from the modem and I even after setting ...
0
votes
0answers
513 views

T-Mobile Internet connection via USB GSM/3G Modem on Debian / Raspberry PI 2B

I am using ppp via wvdial, script looks like that (commented lines have been removed): [Dialer t-mobile] New PPPD = yes Phone = *99# Modem = /dev/ttyUSB0 Modem Type = USB Modem Baud = 460800 ...
2
votes
1answer
416 views

Manually dialling a USB modem on windows/linux

I have been trying to setup up a 4g usb modem with my raspberry pi running raspbian (this post is not specific to Raspberry Pi as I run into same problem on windows later on). The modem is recognized ...
0
votes
2answers
573 views

pppd started by wvdial does nothing

I'm trying to get GPRS modem working under Linux. For some of the ISPs it worked fine, but for one of them the process stucks right after starting the pppd. The log looks like this: --> WvDial: ...
0
votes
1answer
61 views

What is the garbage text that is being printed by wvdial in terminal?

When I dial using wvdial, sometimes it prints some garbage text into the terminal. This is not happening every time, but in the garbage text I can see some readable strings which is often irc ...
2
votes
1answer
500 views

UMTS connection fails with “LCP terminated by peer”

I use the Ericsson N5321 gw card in my Lenovo Thinkpad T440s to connect to T-Mobile (resold by debitel) with the following /etc/wvdial.conf (on debian sid x64): [Dialer Defaults] Modem = /dev/ttyACM2 ...
1
vote
1answer
305 views

How to scan networks with WvDial?

I am using WvDial to scan available networks with these commands: Init1 = AT+COPS=? Baud=460800 Modem = /dev/ttyACM0 Wvdial tries the scan-commands but it seems like it does not wait long enough ...
1
vote
0answers
495 views

USB Modem not getting connected after resetting using usb_modeswitch

I have a requirement that I need to first unmount and then mount again the 3G internet modem on ubuntu 12.04 without removing it physically. The modem model is Huawei E173u. So far, I have tried this ...
0
votes
1answer
4k views

Randomly getting “NO CARRIER” from Huawei 3G modem under linux

I'm using a huawei 3G modem under linux. After using NetworkManager for some time, I now use wvdial to talk to the modem and start pppd: i added a udev rule so wvdial starts automatically when the usb ...
1
vote
0answers
822 views

Using wvdial in /etc/network/interfaces to enable automatic connection with usb 3g dongle

I have wvdial working from the command line in a debian squeeze 32 bit install. Googling around revealed several suggestions to simply use auto ppp0 iface ppp0 inet wvdial However, upon reboot I ...
0
votes
1answer
340 views

My datacard goes online but doesn't gives internet access (Fedora 14)

I am using MTS datacard. I have usb_modeswitch installed and have configured the wvdial.conf file. When I do sudo wvdial cdma, the IPs and DNS addresses are also allocated but I still cant access ...
12
votes
3answers
10k views

How can I get wvdial to run from /etc/network/interfaces

I am using wvdial to connect to a mobile network (I have a usb modem) and it works fine. However, I wanted to automate the connection a bit (currently I am running wvdial every time I want to ...