0
votes
1answer
3k views

Can't unlock file in Mac OS

I'm trying to edit the my.cnf file in Applications/XAMPP/xamppfiles/etc but it is locked. So I tried unlocking it using cd /Applications/XAMPP/xamppfiles/etc sudo chflags nouchg my.cnf But it ...
1
vote
0answers
568 views

XAMPP VS MAMP on Mac

I'm a XAMPP user ever since whether it's in Windows or Mac environment. But recently I saw MAMP from another user, I saw some cool features like you can associate a domain without coding it up. If ...
0
votes
0answers
487 views

XAMPP for Mac : “forbidden access” when trying to set more secure permissions

I've installed XAMPP on my Mac running Lion and I've set the DocumentRoot to Users/myusername/Sites. Apache runs as myusername/_www (user/group, 755) and everything is OK, my browser can access all ...
1
vote
1answer
705 views

Terminal issues on OS X with XAMPP and Yii framework

I'm trying to configure the Yii framework but am having problems with the terminal commands, and am also having difficulty setting up the webapp demo. I am using Mac OS X Snow Leopard and have ...
3
votes
1answer
3k views

XAMPP Mac: “Unable to create directory” error

I just installed XAMPP on Mac OSX. When I tried to install a theme into a newly created WordPress site, I got this error: Unable to create directory ...
0
votes
1answer
2k views

How to install Imagick on Mac OS with XAMPP

I'm having some trouble installing Imagick on a Mac. I have XAMPP installed and when I run 'sudo pecl install imagick', I get this error: checking ImageMagick MagickWand API configuration program... ...
0
votes
4answers
7k views

Make XAMPP program directory writeable?

I'd like to be able to write to the XAMPP directory so that I can run PHP scripts from there rather than my "Sites" user folder. How can I do that? I'm using 1.7.3. Currently, if I try to write ...
1
vote
3answers
979 views

The same XAMPP config works on Windows, but not on Mac OS X

I've been using Xampp on Windows for some time now. I'm trying to set it up on Mac OS X also, so I copied all the configuration, but I can't get virtual hosts to work. 1- I included this in ...