0
votes
0answers
84 views

Upgraded to Mavericks, C compiler cannot create executables

Upgrading to Mavericks, I appear to have broken my Ruby on Rails development environment, which requires ruby 1.9.3 because of various gem dependencies. Within that app directory, I'm trying to ...
0
votes
1answer
31 views

rails didnt install correclty, specificly the uninstaller

ive just installed rails using railsinstaller.org for osx, rails and ruby seem to be working ok (checked by running rails -v, ruby --version and ruby --help). But when it installed i got an error ...
8
votes
5answers
3k views

Homebrew keeps saying XCode is not installed

I'm trying to installed Ruby using Homebrew, the OSX package manager. When I run 'brew install ruby' I keep getting the message 'Warning: XCode is not installed!'. XCode is installed, it's lying. ...
5
votes
4answers
6k views

Errors when installing Ruby to Mac OSX Lion via RVM

I was trying to install the newest version of Ruby via RVM, after I upgraded my Mac to Lion and installed the new Xcode 4.1 from the App store. I get this error in the log: [2011-07-20 16:57:15] ...