0
votes
0answers
29 views

how to delete yum and right re-install to centos6.5?

[root@webdev docs]# yum list Gathering header information file(s) from server(s) Server: Red Hat Linux 6 - x86_64 - Base retrygrab() failed for: ...
0
votes
1answer
37 views

Complete yum history

When I run yum history I get a list of the last 20 yum operations. If I didn't clean my history, is there a way to get a full list? Does yum only keep track of the last 20 operations? Is there a ...
0
votes
0answers
30 views

What does this yum error mean?

I don't understand the phrasing of this error message. --> Finished Dependency Resolution Error: Package: kf5-kactivities-libs-devel-4.100.0-1.fc20.x86_64 (dvratil-kde-frameworks) ...
1
vote
1answer
110 views

Why is my yum update failing?

Why is my yum no longer working? It was previously working fine. But seems to have inexplicably stopped working. FYI, I'm running this on Centos system that is running in VirtualBox on my MacBook Pro. ...
0
votes
1answer
704 views

Mirror repository won't work (The requested URL returned error: 403 Forbidden)

I'm trying to find out why I still get the 403 when running the yum install command. I have created a repository mirror which can be read from remote machines. Do you have any suggestions? I have ...
2
votes
0answers
19 views

Download yum packages on Debian for an offline fedora20 system

I need to download YUM packages (namely java-1.7.0-openjdk, gstreamer-plugins-good, gstreamer-plugins-bad and gstreamer-plugins-ugly) for an offline Fedora 20 machine, and I'm working on a Debian 7. ...
0
votes
1answer
57 views

yum erase tells me pkg not installed. yum install tells me package is already installed

Erase complains package is not installed : yum erase libstdc++-4.1.2-52.el5_8.1.x86_64 Setting up Remove Process No Match for argument: libstdc++-4.1.2-52.el5_8.1.x86_64 Package(s) ...
0
votes
0answers
59 views

How to resolve “Error code: sec_error_invalid_algorithm”?

I am failed to load Google in my Firefox and getting the following error : Secure Connection Failed. An error occurred during a connection to WWW.Google.com. security library: invalid ...
0
votes
1answer
236 views

Why isn't java8 in yum?

I have multiple dedicated boxes that execute java applications. I used to install java 7 from yum. I decided to upgrade to java 8. I have installed java 8 manually on a lot of boxes. I am curious to ...
0
votes
1answer
39 views

Is there an option for yum to compile from source instead of installing pre-compiled binaries?

I've recently switched to Fedora. I'm looking for an equivalent of the procedure described here but in yum, so I can take advantage both of compiler optimization in heavily used software that ...
0
votes
1answer
104 views

Get “timeout” command from GNU coreutils 8 on RHEL 5.7 machine

What is the best way to install the Gnu timeout command on an RHEL 5.7 machine? I would prefer to install with yum, but I can compile from source if that is the only way. timeout was introduced in ...
0
votes
0answers
36 views

restore rpm to default installed version on RHEL

Is there a way to restore one single package back to the original version shipped with the RHEL OS? A YUM downgrade just downgrades the package to the previous version located on the repository and ...
0
votes
1answer
26 views

How can I finish the unfinished transaction, so then I can make all the updates?

I try to use yum update and everytime it says me to run yum-complete-transaction first to finish the unfinished transactions remaining. When I try, it loops like forever, and sometimes it ends by ...
0
votes
0answers
75 views

how to fix repair yum on redhat vm

I have a VM hosted on Bluehost. I am having trouble installing Xvfb with yum. Anything I try with yum ($ yum, $ yum install Xvfb, etc) gives the following error; CRITICAL:yum.cli:Config Error: Error ...
0
votes
0answers
42 views

error installing MySQL-python

I'm starting to learn python. When I try to install MySQL-python with yum from yum install MySQL-python.x86_64 I get this error Loaded plugins: katello, product-id, security, subscription-manager ...
0
votes
1answer
35 views

How to safetly add a repository

To add a repository to my Centos server, I am doing the following: wget -O /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6 https://www.fedoraproject.org/static/0608B895.txt gpg --quiet --with-fingerprint ...
1
vote
1answer
36 views

Which package contains the `most` command

I feel extremely dumb for asking this, but: On CentOS, which package should I install to have the most command (a really nice pager)? A google search turns up way too many irrelevant results. A ...
0
votes
2answers
64 views

Format “yum provides” output

I am writing a little program that packages configuration files as rpm, and it puts a series of %triggers to handle installation/upgrade of the packages that bring a copy/version of the same file. I ...
0
votes
1answer
50 views

Install package by file provided in yum/dnf

At least on a recent Fedora system, it is possible to install a TeXLive package by specifying a .sty file, which is great, as in yum install 'tex(amsmath.sty)' It also work with dnf, the soon to be ...
0
votes
0answers
332 views

package-cleanup --cleandupes fails to remove duplicates

I have an issue with duplicate packages installed on my Fedora machine: # package-cleanup --dupes Loaded plugins: langpacks, refresh-packagekit audit-2.3.3-1.fc20.x86_64 audit-2.3.2-1.fc20.x86_64 ...
1
vote
0answers
248 views

is it possible to install boost 1.55 on fedora 20 without breaking dependencies to existing boost 1.54?

I must switch from boost and boost-devel 1.54 to 1.55 due to a bug in 1.54 on a fedora 20 x86_64 machine and I wonder what's the preferred way. There are some packages that rely on boost ...
0
votes
0answers
486 views

Can't install php-fpm: dependency issues

I'm trying to install php-fpm for my nginx server. Trying to install through yum (yum --enablerepo=remi install php-fpm php-mysql), I get the next error: Error: Package: ...
0
votes
1answer
210 views

YUM root update error

I'm getting an error that's new to me when I attempt # yum upgrade in a Fedora 20 Virtualbox machine. I've given it 3gb ram, and it's running atop a Haswell core i5 Any fixes are appreciated! Or is ...
0
votes
0answers
98 views

Error: Can not retrieve metalink for repository: fedora/19/x86_64

What I did: I installed Fedora 19 x86_64 with KDE straight from a DVD I burned myself. This DVD was used at least twice now to perform reformats, and the install itself went without a hitch. This is ...
0
votes
0answers
50 views

yum isn't showing the latest package

i am on the latest Amazon 64bit Linux AMI and want to install collectd. The latest that yum is offering me is v5.0, whereas the collectd site has v5.4. i understand that i am querying amazon's repos ...
0
votes
0answers
192 views

Installing R core rpms on centos - Need a best way to resolve dependencies

I am newbie to the Linux. I need to know the best way to handle the dependencies. The issue is, I need to install R - core and R - dev (R language packages) on an platenized centos linux host on ...
1
vote
1answer
2k views

Install packages in CentOS from DVD without connection to internet

I have a CentOS 6.4 system with no connection to internet. I have the installer DVD though. How can I install a package, say gcc, using this DVD alone?
3
votes
2answers
3k views

Why does yum update fail in CentOS 6.4?

I am using CentOS 6.4 in a corporate lab, and the yum update fails with the below error: I am able to access the same repositories through the browser. [root@LAB1 ~]# yum update Loaded plugins: ...
1
vote
0answers
133 views

My Fedora Setup is gone due to accidental “yum upgrade”

How to roll back? I tried yum history undo 143 and yum --skip-broken history undo 143 and get the following errors. Important: All I care about is getting my kernel and custom graphics driver back to ...
0
votes
0answers
122 views

YUM and RPM crash due to the liblua-5.1 library being missing

I've been playing around with a LiveUsb install of basic Fedora with persistence. I attempted to install moonscript, which requires Lua and LuaRocks. After installing Lua and discovering there were ...
2
votes
1answer
929 views

Installing openssl on RHEL 6.2

Trying to install openssl-devel on RHEL 6.2. yum install openssl-devel And i am getting this error: --> Finished Dependency Resolution Error: Package: glibc-2.12-1.47.el6.i686 (rhel62) ...
1
vote
1answer
3k views

No module named yum after “yum update”

Amazon EC2 Linux AMI Python 2.7.5 yum 3.4.3 I recently did a "yum update" and I'm guessing this lead to my issues. Yum now does this: # yum There was a problem importing one of the Python modules ...
0
votes
1answer
269 views

Fedora 19 fails to start

I had updated fedora 17 to fedora 19 (kernel 3.10.11-200) on my laptop using fedup a ~2-3 weeks back. Everything was fine until yesterday night. All of a sudden while shutting down I got some ...
0
votes
3answers
497 views

Remove or disable NetworkManager?

I installed wicd on my Fedora19. The main reason is that I could not get NetworkManager icon displayed in my tint2 system tray (I am using Openbox3.5.2). Now that I am not using NetworkManager ...
1
vote
1answer
173 views

Install latest vlc on centos 5.5

I am using Centos 5.5. When I try, yum install vlc I got vlc version 0.9.9a which is very old with lot of bugs. Is there a way to get the latest version of VLC? I have already tried yum update vlc ...
1
vote
0answers
18 views

How does YUM know of a software update of something I installed from a CD or download

Can YUM update software that I install from a CD? Let's say I install open office, run an installer. How is YUM aware of the location, updates for that software? thanks
2
votes
1answer
462 views

how to stop yum from trying other mirrors

I'm sitting behind a proxy on my CentOS 6.4 box and I can't perform a 'yum update' because yum keeps killing the slow downloads and trying another mirror. The problem is that the way our proxy works ...
0
votes
1answer
4k views

how to rollback/undo yum update on fedora after messing the fedora versions

I want to install texlive on my fedora 16 laptop with the following procedure: # yum remove tex-* texlive-* # cat > /etc/yum.repos.d/texlive.repo <<EOF [texlive] name=texlive ...
1
vote
0answers
377 views

yum epel depsolving problems when installing R

I am trying to install R on an old RHEL5 system. sudo yum install R reveals This system is receiving updates from RHN Classic or RHN Satellite. Setting up Install Process Resolving Dependencies ...
0
votes
1answer
297 views

YUM crashed due to library missing

I tried to remove stock Lua and build my own one, so I tried: yum remove lua But too many dependencies on the package and it does not allow me to remove it so I used rpm instead: rpm -r --nodeps ...
0
votes
0answers
435 views

Yum hangs on setting up package sacks

I'm having trouble with Yum installing postfix. I'm using yum on a trixbox/freepbx system and trying to get voicemail-to-email setup for VOIP Cisco phones in an office environment. Anyways I try ...
0
votes
1answer
248 views

Installing Multitail on RHEL 5.3

I'm trying to install Multitail on a RHEL 5.3 machine, but get the following error as the root user. Should this be accessible from one of the default RPM repositories or do I need to add a new ...
0
votes
1answer
1k views

How to download yum packages on windows (or online in browser)

I am newbie to linux and just started using it at home, but I don't have internet connection at home, and in office I have good internet but using windows, I just want to download yum packages on my ...
0
votes
2answers
133 views

Dealing with conflicts on linux installs

I am trying to run a linux install. I have added a rpm repo. and i am running yum install normalize But i am getting the following error Transaction Check Error: file ...
0
votes
1answer
356 views

Yum's download speed is too slow

My yum download speed is in average less than 5KBps and goes to less than 1KBps but my normal download speed is around 140KBps. I tried installing yum-fastestmirrors but didn't help. any suggestions?
1
vote
1answer
42 views

Package name suggestion in fedora

In Ubuntu when an app is not installed and in Terminal you type for example gvim it says that this app is contained in package vim-gnome and try installing that but in fedora that doesn't happen with ...
0
votes
0answers
120 views

yum install 389-ds (Directory Server) on Redhat Linux not working

I am trying to install 389-ds (Directory Server) on Redhat Linux. $ yum install 389-ds ... Could not retrieve mirrorlist ...
0
votes
1answer
85 views

Fedora bleeding edge Perl repo?

Are there any Fedora YUM repositories that would contain the very latest stable version of Perl (at the time of writing, 5.18.0)? The Fedora site says that won't even be shipped stock until Fedora ...
0
votes
1answer
1k views

How to install particular version (not latest) of software via YUM?

I recently installed CentOS 6.3 on a VPS. The version on PHP that comes with CentOS is 5.3.3, which is not the final, stable PHP 5.3 version. The final version was 5.3.26. Using the default yum ...
1
vote
3answers
5k views

How to downgrade a kernel?

I need to downgrade the kernel from 2.6.32-358.6.2.el6.centos.plus.x86_64 to 2.6.32-220.el6.x86_64 I am unable to install the older version using Yum/rpm as it gives the following error ...